Använd Chat "Line" -protokollet i Pidgin för Linux Mint 17 Qiana

För det första LINJE är ett snabbmeddelandeprogram för mobiltelefoner (bland annat iPhone, Android, Windows Phone, Firefox OS) som också kan installeras på Windows och Mac. Här visar jag dig hur du installerar Lila-Line un plugin från tredje part för pidgin (multiprotocol-meddelandeklient) i Linux Mint 17  (Enligt skaparens sida testades pluginet på Ubuntu och Arch Linux).

Om vi ​​inte har Pidgin installerat, installera det självklart

$ sudo apt-get install pidgin

Innan du laddar ner plugin-programmet från Skapare Vi måste ha tre saker: libpurple (som installeras vid installation av pidgin), apache sparsamhetskompilatorn och filen line_main.thrift (som laddas ner från samma pluginsida)

Installerar sparsamhet

Kompilatorn finns i Ubuntu-arkivet, men författaren föreslår att den kompileras från källkoden, vilket jag empiriskt har verifierat att det är så det måste vara, låt oss därför börja arbeta:

1.- Installera beroenden

$ sudo apt-get install libboost-dev libboost-test-dev libboost-program-options-dev libboost-system-dev libboost-filesystem-dev libevent-dev automake libtool flex bison pkg-config g++ libssl-dev

2. - Ladda ner och packa upp

Vi använder version 0.9.1
$ wget http://www.bizdirusa.com/mirrors/apache/thrift/0.9.1/thrift-0.9.1.tar.gz

$ tar -xvf thrift-0.9.1.tar.gz

3.- Konfigurera och gör installation

Öppna först mappen
$ cd thrift-0.9.1
$ ./configure

Kontrollera att det står vid terminalutgången Byggnad C ++ bibliotek ………: ja, och då

$ make

$ sudo make install

När Thrift har installerats hämtar vi nu pluginet.

Nedladdning och installation av Pidgin-plugin

Varning, detta är oavslutad programvara! Det här pluginet är fortfarande under utveckling och många saker förblir instabila eller inte verkställbara.

Ladda ner härifrån

lila linje

och packa upp den.

Filen laddades ner till mig lila-linje-04279d7.tar.gz I adressboken ~ / Nedladdningar, sedan för att packa upp

$ tar -xvf purple-line-04279d7.tar.gz

Nu kommer vi att ladda ner linjeprotokoll som innehåller filen line_main.thrift vad behöver vi

linjeprotokoll

En gång nedladdad linjeprotokoll, packa upp den och arkivet line_main.thrift kopiera den till mappen lila linje

Gå nu in i mappen lila linje och utföra en make-installation
$ make

$ make install

I teorin borde allt vara OK. Har skapat och kopierat filen libline.so a ~ / .purple / plugins , som vi nu kan lägga till ett konto med LINE-protokollet i Pidgin …… ..

men….

I mitt fall var det inte så, det fanns ett bibliotek med sparsamhetspaketet som inte laddades i systemet (jag insåg detta som felsökningsfönster i pidgin när du laddar plugins) och därför fungerade inte plugin för mig, det var just biblioteket libthrift-0.9.1.so . För att rätta till detta problem är det första vi söker efter biblioteket i fråga med kommandot

$ sudo find / -name libthrift-0.9.1.so

vilket i mitt fall gav 2 resultat:
1.- /usr/local/lib/libthrift-0.9.1.so
2.- ~ / Nedladdningar / sparsamhet-0.9.1 / lib / cpp / .libs / libthrift-0.9.1.so

Den första adressen som den returnerar är platsen för biblioteket som vi behöver eftersom den andra motsvarar filen som vi laddade ner. Att lägga till miljövariabeln permanent i systemet vad vi gör är att lägga till adressen / Usr / local / lib a / Etc / miljö, vi gör detta med kommandot

$ sudo echo 'LD_LIBRARY_PATH="/usr/local/lib/"' >> /etc/environment

Nu laddar vi miljövariabeln.

source /etc/environment

Och med detta kan vi använda LINE-protokollet i Pidgin.

Hälsningar vänner


Innehållet i artikeln följer våra principer om redaktionell etik. Klicka på för att rapportera ett fel här.

27 kommentarer, lämna din

Lämna din kommentar

Din e-postadress kommer inte att publiceras.

*

*

  1. Ansvarig för uppgifterna: Miguel Ángel Gatón
  2. Syftet med uppgifterna: Kontrollera skräppost, kommentarhantering.
  3. Legitimering: Ditt samtycke
  4. Kommunikation av uppgifterna: Uppgifterna kommer inte att kommuniceras till tredje part förutom enligt laglig skyldighet.
  5. Datalagring: databas värd för Occentus Networks (EU)
  6. Rättigheter: När som helst kan du begränsa, återställa och radera din information.

  1.   Mörklila sade

    Låt oss se om de tar ut det för KDE-telepati.

    1.    Jorge sade

      Eller för Kopete. Det tar tillräckligt.

    2.    Herr Boat sade

      Helvete, jag säger er, Pidgin är fantastiskt, men som ett KDE-fan är jag verkligen irriterande att det inte finns något alternativ till det pluginet.

      Känner någon till något alternativ i KDE?

      1.    babel sade

        Jag använder KDE och jag använder Pidgin ändå. Sanningskopeten, telepati eller något annat är väldigt, väldigt långt borta.

  2.   mat1986 sade

    Wow det är en lite mödosam process. Jag skulle vilja prova det, men jag har inga kontakter som använder Line ... jävla whatsapp !! 🙁

    Tack för handledningen 🙂

  3.   ingen sade

    Jag känner inte någon som använder linje eller telegram, det enda som folk vet är facebook och whatsupp 🙁 förresten här är en artikel om hur man ansluter till pidgin och den metoden fungerade igen

  4.   Dva sade

    D-bilder krävs:

  5.   Sergio sade

    Du har varit fantastisk, jag skulle också vilja skriva artiklar och få dem att se bra ut great

  6.   Wisp sade

    Det är verkligen i beta-fas men det är att föredra att sammanställa protokollet än att emulera LINE-applikationen med Wine för Windowslerdos.

    1.    eliotime3000 sade

      Den samma. Eftersom jag hatar att använda Wine på Linux avstår jag från att använda det och göra min partition användbar med Windows.

  7.   anonym sade

    Använd bättre XMPP / Jabber och sluta stödja de stängda silorna.

    1.    eliotime3000 sade

      Huvudproblemet är att protokollet inte har marknadsförts ordentligt för allmänheten, vilket gör den sociala upplevelsen med protokollet outhärdlig.

      Prova som mest Telegram. Jag har redan lagt till mina familjemedlemmar i tjänsten för snabbmeddelanden.

  8.   Robet sade

    mmmm, i widnows 8 finns LINE-applikationen i tunnelbanegränssnittet, och ingen använder det eftersom det är tungt och inte stabilt.

    1.    eliotime3000 sade

      Line finns också i en version för Windows 7 som om det vore ett Windows Live Messenger-fönster. Jag har den här versionen installerad på min partition med Windows 8 som finns i min netbook, som jag använder för att pekapplikationsläget inte fungerar på grund av min netbooks skärmupplösning.

  9.   fernando sade

    Hej alla. Tja, det visar sig att när jag försöker ladda ner den lila linjen säger det mig att nanai från Kina så min glädje i en brunn även om det är sant att få människor använder linjen och om jag använder WhatsApp lite kommer du att berätta för mig detta . Men jag gillar att uppleva alla dessa saker. Sedan klagar jag över att Ubuntu laddar lite långsamt.

    1.    cristian sade

      länken fungerar när du vill: v

  10.   cristian sade

    Jag vill gråta, applådera
    Jag såg fram emot den här lösningen ...

    Jag hade helt enkelt slutat försöka använda linjen på Linux och hade använt det lilla programmet på Windows eller på min smartphone, och vin var aldrig ett giltigt alternativ för mig

  11.   koprotk sade

    Jag är mycket ledsen att inte ha varit med på kommentarerna förut, jag kommer att granska länkarna och fixa dem om de går sönder, men under tiden kan du ladda ner plugin-programmet och LINE-protokollet härifrån: http://altrepo.eu/git/

  12.   Chaparral sade

    Jag har inte haft några problem att följa författarens guide steg för steg, för vilket jag tackar honom. Endast och i det sista kommandot var jag tvungen att göra det som root ($ sudo echo 'LD_LIBRARY_PATH = »/ usr / local / lib /»' >> / etc / miljö) eftersom det inte gav mig tillstånd.
    En hälsning.

  13.   Hugo sade

    Så intressant, tack.

  14.   rotietip sade

    Varje plugin att göra detsamma med kik? Jag har en "vän" som använder den applikationen på sin smartphone, men till skillnad från Line finns det inga PC-klienter och sanningen är att jag är väldigt lat att installera en Android-emulator för något som jag säkert kommer att använda då och då.

  15.   jorge sade

    Hej,
    Jag har installerat plugin-programmet, men nu hur skapar jag kontot i Pidgin?
    I listan över protokoll ser jag inget med Line-identifierare.
    Tack så mycket.

    1.    Koprotk sade

      Om biblioteket har sammanställts i din hemkatalog kanske du inte har laddat biblioteken. Vad du kan göra för att veta vad som händer är att öppna ett felsökningsfönster i pidgin och sedan komma åt pluginsfönstret och kontrollera felen.

  16.   Francis Capote sade

    Något sätt att få det att fungera på Arch Linux ??

    1.    koprotk sade

      Ledsen för förseningen, men om du kan bytte jag nyligen från Mint till ArchLinux och lila-linje och sparsamhet finns i AUR-förvar, eftersom du kan installera båda ännu enklare med yaourt.

      hälsningar

  17.   Edward sade

    Vän, när jag försöker ladda ner den lila linjen ber den mig om ett användarnamn och lösenord. som??

    1.    Koprotk sade

      Konstigt, men du kan googla lila LINE, i den här artikeln hittar du också sidorna där nedladdningarna är.

      hälsningar