Installera Broadcom-drivrutiner på openSUSE

BroadCom-Linux

Hej kompisar. I det här inlägget ger jag dig en snabbguide för att lösa problemen med detta kort. Jag fick informationen från denna sida, Jag har bara sammanfattat det lite och jag delar dem för att det här är det första jag tycker som verkar fungera med denna typ av kort.

Det första vi ska göra är att ta reda på vilken modell vi har så vi kommer att införa följande kod.

sudo /sbin/lspci -nnv | grep Wireless

Vad du kommer att återvända till oss kommer att vara något liknande detta.

0d:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

Det som är markerat med fetstil är din modell.

Med gamla chipsets som BCM430,BCM4306, BCM4309, BCM4311, BCM4312, BCM4318, BCM4322, BCM4331, BCM43224 y BCM43225 Vi kommer bara att införa följande kommandon (anslutna till Internet via kabel).

sudo zypper install b43-fwcutter
sudo /usr/sbin/install_bcm43xx_firmware

Vi startar om och är redo.

Nåväl, med de gamla, nu går vi med de mer moderna chipsetsen. Om du har någon av dessa modeller fungerar det för dig: BCM4311, BCM4312, BCM4313, BCM4321, BCM4322, BCM43224, BCM43225, BCM43227 och BCM43228.

Vi måste installera drivrutinsversionen enligt vår kärna Linux installerad. Om vi ​​har en kärntyp stationär dator vi sätter följande kod:

sudo zypper install broadcom-wl broadcom-wl-kmp-desktop

Att känna till vår kärntyp Linux sätt följande kod:

uname -sr

Den returnerar en kod som liknar den här:

Linux 3.7.10-1.1-desktop

Efter omstart bör Wi-Fi fungera.

Jag hoppas att det har tjänat. Tur.


Innehållet i artikeln följer våra principer om redaktionell etik. Klicka på för att rapportera ett fel här.

14 kommentarer, lämna din

Lämna din kommentar

Din e-postadress kommer inte att publiceras.

*

*

  1. Ansvarig för uppgifterna: Miguel Ángel Gatón
  2. Syftet med uppgifterna: Kontrollera skräppost, kommentarhantering.
  3. Legitimering: Ditt samtycke
  4. Kommunikation av uppgifterna: Uppgifterna kommer inte att kommuniceras till tredje part förutom enligt laglig skyldighet.
  5. Datalagring: databas värd för Occentus Networks (EU)
  6. Rättigheter: När som helst kan du begränsa, återställa och radera din information.

  1.   F3niX sade

    Jag kommer att komma ihåg att OpenSuse inte gav mig problem alls när jag installerade den.

  2.   Rötter87 sade

    0.0 som konstigt för mig inte har gett mig problem med öppet användning när jag installerar det på de moderkort ... kommer det att vara en lycka?

  3.   Snock sade

    Med det enda wifi-kortet som hade problem var en rt61 och för många år sedan. Sedan med nyare versioner var det inga problem.

    1.    Snock sade

      Eftersom ni alla får «archlinux och kde» och inte jag: '(

      1.    pandev92 sade

        Eftersom du inte har konfigurerat användaragenten .., leta efter inlägget som tillät dig att konfigurera det -.-, det har sagts tusen gånger xd

        1.    Källans manual sade

          Yo Jag föreslog månader sedan ett alternativ för att förhindra att folk fortsätter att fråga men du förstår ...

          1.    Snock sade

            Manuel skulle svara dig men inte ens när de ... händer. Pandev92 tack för att du svarade.

  4.   Fernando sade

    Tack för inlägget

  5.   eliotime3000 sade

    Jag har mitt TP-Link trådlösa nätverkskort med Broadcom-chipset i min Debian och nollproblem.
    [Damn Chromium från Ubuntu. Du får mig alltid att se ut som om jag använder Ubuntu på riktigt].

    1.    F3niX sade

      Ändra användaragent och voila - - leta efter Chrome-användare agen Switcher!

  6.   Elp1692 sade

    Mycket bra, om jag en dag råkar migrera till suse tack och hälsningar från Kore Source!

  7.   st0rmt4il sade

    Bra inlägg!

    Skål!

  8.   Kolla på sade

    ARBETAR!!!
    installera openSuse 13.1 på en cpmpaq CQ40-320LA bärbar dator som har Broadcom BCM4312.
    Jag följde stegen och gjorde perfekt.

    Tack så mycket.

  9.   Juan Carlos Gomez sade

    Excellent. Det fungerade perfekt för mig, jag hade 5 dagar på att försöka installera det här kortet i opensuse 13.2. Tack.