Paket för stöd för programvaruutveckling på DEBIAN 10

Paket för stöd för programvaruutveckling på DEBIAN 10

Paket för stöd för programvaruutveckling på DEBIAN 10

Detta inlägg är fortsättningen (tredje delen) av handledning tillägnad DEBIAN GNU / Linux Distro, version 10 (Buster), som fungerar som grund för många andra som MX-Linux 19 (Ugly Duckling).

I denna tredje del kommer vi att visa väsentliga paket (applikationer) rekommenderas för att tillhandahålla det nödvändiga Soporte grundläggande för utveckling, testning och utförande av några programvara (applikationer) om våra vackra och fantastiska Distros DEBIAN 10 och MX-Linux 19.

Uppdatera och optimera MX-Linux 19.0 och DEBIAN 10.2 efter installationen

Uppdatera och optimera MX-Linux 19.0 och DEBIAN 10.2 efter installationen

De två föregående inläggen i denna serie är:

  • Uppdatera och optimera MX-Linux 19.0 och DEBIAN 10.2 efter installationen (Se post)
  • DEBIAN 10: Vilka extra paket är användbara efter installationen? (Se post)
DEBIAN 10: Vilka extra paket är användbara efter installationen?

DEBIAN 10: Vilka extra paket är användbara efter installationen?

Kom ihåg och kom ihåg att:

"Kom ihåg att de åtgärder och paket som rekommenderas här för att köra och installera är just det, "paket rekommenderad", och det är upp till var och en att köra och installera alla eller några av dem, varför är de det? nödvändigt eller användbart på kort eller medellång sikt att känna till och använda dem, genom att ha dem redan körda eller installerade.

Och kom ihåg att dessa åtgärder och / eller paket var tidigare testat på båda Distros, och de ber inte att avinstallera paket som är installerade som standard i dessa. Ytterligare, de ökar inte förbrukningen av minne eller CPU eftersom de inte laddar processer eller demoner (tjänster) i minnet som standard. För att veta i förväg vad varje paket används till, klicka på här."

Uppdatera MX-Linux och DEBIAN: Innehåll

Paket för support för mjukvaruutveckling

Stöd för Java-applikationer

apt install browser-plugin-freshplayer-pepperflash default-jdk icedtea-netx

Objetivo: Installera grundläggande stöd för kompatibilitet med Java-applikationer.

Stöd för QT5-applikationer

apt install libqt5core5a qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools

Objetivo: Installera grundläggande stöd för kompatibilitet med applikationer byggda med QT5.

Stöd för Digital Mining-applikationer

apt install autoconf automake autotools-dev build-essential byobu g++ gcc gcc-7 g++-7 git git-core libboost-dev libboost-all-dev libcrypto++-dev libcurl4 libdb-dev libdb++-dev libevent-dev libgmp-dev libgmp3-dev libhwloc-dev libjansson-dev libmicrohttpd-dev libminiupnpc-dev libncurses5-dev libprotobuf-dev libqrencode-dev libqt5gui5 libqtcore4 libqt5dbus5 libstdc++6 libssl-dev libusb-1.0-0-dev libtool libudev-dev make ocl-icd-opencl-dev openssl pkg-config protobuf-compiler qrencode qttools5-dev qttools5-dev-tools

Objetivo: Installera grundläggande applikationsstöd, drivrutiner och bibliotek som är nödvändiga för installation och hantering av Digital Mining-applikationer.

apt install libdb++-dev libdb5.3++ libdb5.3++-dev

Objetivo: Installera grundläggande biblioteksstöd för program som använder databasbiblioteket Berkeley v5.3, som ofta används av moderna Digital Mining-applikationer som ska kompileras och / eller köras.

Webbapplikationsstöd

Apache

apt install apache2

Objetivo: Installera grundläggande stöd för webbapplikationer optimerade eller kompatibla för Apache2.

nginx

apt install nginx

Objetivo: Installera grundläggande stöd för webbapplikationer optimerade eller kompatibla för Nginx.

PostgreSQL

apt install postgresql

Objetivo: Installera grundläggande kommando- och funktionsstöd för hantering av Postgresql-baserade databaser.

apt install pgadmin3 y phppgadmin

Objetivo: Installera basstödet för applikationer för hantering av databaser baserat på Postgresql.

MySQL

apt install mysql-server mysql-client

Objetivo: Installera grundläggande kommando- och funktionsstöd för hantering av MySQL-baserade databaser.

apt install phpmyadmin y mysql-workbench

Objetivo: Installera grundläggande applikationsstöd för hantering av MySQL-baserade databaser.

mariadb

apt install mariadb-server mariadb-client

Objetivo: Installera det grundläggande kommandot och funktionsstödet för hantering av databaser baserat på MariaDB.

PHP

apt install php

Objetivo: Installera grundläggande kommando- och funktionsstöd för hantering av PHP-baserade applikationer.

apt install php-cas php-cgi php-curl php-gd php-json php-mbstring php-mysql php-xml php-apcu php-cli php-dev php-imap php-ldap php-xmlrpc php-intl php-pgsql php-sqlite3 php-zip phpqrcode

Objetivo: Installera basstödet för inbyggda bibliotek för hantering av PHP-baserade applikationer.

apt install libmagic-dev libapache2-mod-php libcurl4-gnutls-dev

Objetivo: Installera grundläggande icke-native biblioteksstöd för hantering av PHP-baserade applikationer.

PERL

apt install perl

Objetivo: Installera grundläggande kommando- och funktionsstöd för hantering av PERL-baserade applikationer.

apt install libapache2-mod-perl2 y perlbrew

Objetivo: Installera grundläggande biblioteksstöd för hantering av PERL-baserade applikationer.

Python

apt install python-all-dev python-pip

Objetivo: Installera grundläggande kommando- och funktionsstöd för hantering av Python-baserade applikationer.

apt install python3-setuptools python3-pyqt5 python3-pip

Objetivo: Installera grundläggande kommando- och funktionssupport för hantering av Python3-baserade applikationer.

Generisk bild för artikelns slutsatser

Slutsats

Vi hoppas att detta "hjälpsamma lilla inlägg" om vilka viktiga paket som behövs för att ge nödvändigt stöd för en korrekt  «instalación y gestión» vissa programutvecklingar, om Distros «DEBIAN y MX-Linux», vara av stort intresse och nytta för hela tiden «Comunidad de Software Libre y Código Abierto» och med stort bidrag till spridningen av det underbara, gigantiska och växande ekosystemet för applikationer av och för «GNU/Linux».

Och för mer information, tveka inte att besöka någon Online-bibliotek som OpenLibra y jedit att läsa böcker (PDF-filer) om detta ämne eller andra kunskapsområden. För nu, om du gillade det här «publicación», sluta inte dela det med andra, i din Favoritwebbplatser, kanaler, grupper eller grupper av sociala nätverk, helst gratis och öppet som Mastodon, eller säker och privat liknande Telegram.

Eller helt enkelt besöka vår hemsida på Från Linux eller gå med i den officiella kanalen Telegram från FromLinux att läsa och rösta på denna eller andra intressanta publikationer på «Software Libre», «Código Abierto», «GNU/Linux» och andra ämnen relaterade till «Informática y la Computación», Och «Actualidad tecnológica».


Innehållet i artikeln följer våra principer om redaktionell etik. Klicka på för att rapportera ett fel här.

2 kommentarer, lämna din

Lämna din kommentar

Din e-postadress kommer inte att publiceras. Obligatoriska fält är markerade med *

*

*

  1. Ansvarig för uppgifterna: Miguel Ángel Gatón
  2. Syftet med uppgifterna: Kontrollera skräppost, kommentarhantering.
  3. Legitimering: Ditt samtycke
  4. Kommunikation av uppgifterna: Uppgifterna kommer inte att kommuniceras till tredje part förutom enligt laglig skyldighet.
  5. Datalagring: databas värd för Occentus Networks (EU)
  6. Rättigheter: När som helst kan du begränsa, återställa och radera din information.

  1.   Twikzer sade

    Korrigera mig om jag har fel, men ... på debian tog de inte bort phpmyadmin från förvaren?
    och för att installera php behöver du inte ange (till exempel) php7.3 eller php7.3-curl

  2.   Linux-postinstallation sade

    Hälsningar Twikzer! Tack för din kommentar. Visst finns phpmyadmin inte i DEBIAN 10 (stabila) arkiv men det finns i DEBIAN 11 (Testing) Repositories från vad jag antar, att de någon gång kommer att inkludera det som andra paket i de stabila, men du kan eller kan utelämna det utan Men det var därför jag lämnade det där. När det gäller den andra är det inte nödvändigt, eftersom de nuvarande versionerna i förvaret kallas med deras generiska namn.