Synkronisera iPod Nano 6G till Banshee (eller annan spelare)

Hej vänner, tackar den utmärkta mottagningen som min första inlägg, här ger jag dig ett enkelt sätt att kunna synkronisera din iPod Nano 6G (sjätte generationen) med din favoritmusik i Banshee eller någon annan kompatibel spelare med bibliotek libgpod.

Åtgärder för att synkronisera iPod Nano 6G till Banshee

Denna handledning testas för Linux Mint 7, men i princip bör den fungera för alla Ubuntu-härledda distributioner. Det första vi ska göra är att installera biblioteken libgpod från förvaren, om de inte är installerade:

$ sudo apt-get install libgpod4 libgpod-common

Därefter laddar vi ner det modifierade biblioteket libhashab.so av förneka dagar vilket gör att vi kan använda vår iPod Nano 6G: (Jag rekommenderar att du läser biblioteksdokumentationen)

Detta bibliotek är för exklusivt bruk av iPod Nano 6G och bör inte användas med någon annan iPod eller iPhone

$ wget https://github.com/denydias/libhashab/archive/master.zip

$ unzip master.zip

$ cd libhashab-master/

Från och med nu är det mycket viktigt att du vet om ditt system är det 32 bitar eller 64 bitar för det kan du prova följande kommando
$ /bin/uname -m

Om svaret är i686 då är ditt system 32bitstvärtom om svaret är x86_64 då är ditt system 64bits

Om ditt system är det 32bits, så

$ sudo sh install_32bit.sh

Tvärtom, om ditt system är det 64bits, så

$ sudo sh install_64bit.sh

Nu är allt klart för dig att använda din iPod Nano 6G ………….

men….

Om du fortfarande inte kan använda din iPod Nano 6G betyder det att dessa bibliotek av någon anledning inte startar tillsammans med systemet (vilket var mitt fall), så vi måste lägga till katalogen där det modifierade biblioteket är värd för filen / Etc / miljö så att de laddas i systemet så att spelaren kan se dem. För det öppnar vi den här filen med kommandot

$ sudo gedit /etc/environment

Nu när vi har filen öppen kommer en rad att läggas till beroende på arkitekturen:

a) Om ditt system är 64-bitars lägger du till den här kodraden i slutet av filen:
LD_LIBRARY_PATH = »/ usr / lib64 / libgpod /»

b) Men om ditt system är 32bit, lägg sedan till den här kodraden i slutet av filen:
LD_LIBRARY_PATH = »/ usr / lib / libgpod»

Om de redan har en katalog tillagd till variabeln LD_LIBRARY_PATH de lägger helt enkelt till den nya katalogen bredvid den föregående genom att förbereda ett «kolon (:) ». Det ska se ut så här:

LD_LIBRARY_PATH =«/ Usr / lokal / lib /: / usr / lib64 / libgpod /«

Nu med filen / Etc / miljö modifierad måste vi ladda den till systemet för att kunna använda vår spelare (kompatibel med libgpod) för att synkronisera vår iPod 6G, och ber Apple om ursäkt för att de inte använder iTunes

$ source /etc/environment

Och det är allt..


Innehållet i artikeln följer våra principer om redaktionell etik. Klicka på för att rapportera ett fel här.

20 kommentarer, lämna din

Lämna din kommentar

Din e-postadress kommer inte att publiceras.

*

*

  1. Ansvarig för uppgifterna: Miguel Ángel Gatón
  2. Syftet med uppgifterna: Kontrollera skräppost, kommentarhantering.
  3. Legitimering: Ditt samtycke
  4. Kommunikation av uppgifterna: Uppgifterna kommer inte att kommuniceras till tredje part förutom enligt laglig skyldighet.
  5. Datalagring: databas värd för Occentus Networks (EU)
  6. Rättigheter: När som helst kan du begränsa, återställa och radera din information.

  1.   Helena sade

    bra inlägg! av en slump skulle du inte veta hur man ska synkronisera med iPhone4 utan att dö i försöket?

    1.    Koprotk sade

      Jag tror att det beror på vad du vill göra med iPhone, om du vill kopiera musik till den, kanske det kan göras, men om du vill återställa iPhone genom att säkerhetskopiera dina data, installera om iOS och återställa den senare är det mycket troligt att du inte kan, jag kommer Jag rekommenderar att du använder en virtuell maskin för dessa värdar. Skål

      1.    helena_ryuu sade

        ja!!! Det är en iPhone4 och bara musik, podcasts och foton jag vill hantera (det viktigaste är musiken) liksom processen, jag använder Archlinux med kde.

  2.   eliotime3000 sade

    Jag borde hålla mig till iTunes på Windows.

    1.    koprotk sade

      Det är definitivt ett drag som vi inte kan lossa för vissa Apple-enheter. Men om du kan synkronisera en iPod på Linux är den här sååå mycket snabbare, säger jag dig, för i mitt fall kopierar min iPod Nano 6G musik snabbare i Banshee / Linux än iTunes / Windows och till och med iTunes / OSx.

      1.    eliotime3000 sade

        Och vad sägs om att du försöker använda HFS-filsystemet?

      2.    koprotk sade

        Nu använder jag min iTunes-formaterade iPod på Windows. Jag försökte Apple-filformatet och det skulle inte synkroniseras 🙁

  3.   tux sade

    vän jag tror att du menade Linux mint 17

    1.    koprotk sade

      Exakt samma hahahahahahaha

  4.   Matthews sade

    Mycket bra inlägg, var kan jag hitta något liknande för nano 7G?

    1.    Koprotk sade

      Google-vän, men jag tycker att det är svårt för dig att hitta något, eftersom libgpod-biblioteken som är de som hjälper oss med våra iPod-enheter inte når Nano 6G och detta är en modifiering som en användare osjälviskt lanserade för samhället, men om du hittar något, var snäll och berätta inte för oss

  5.   marcos sade

    Det fungerade bra för mig på Fedora 20
    Jag kunde använda min övergivna iPod i ett år igen.
    Libgpod-biblioteket hade redan det installerat så jag var bara tvungen att följa stegen nedan.
    Tack så mycket för bidraget.

  6.   perik sade

    yeeea !! dpm !! ganska en datorutmaning hahahah eftersom jag har en ipod har jag bara kunnat vara i windows för att ha Linux kunde jag inte göra det. nu har jag fått det på min kollegas dator och nu ska jag installera Linux. en rekommendation för mig ... ubuntu eller linux mint? Jag är inte nybörjare i linux Jag har varit många år och äldre i de där linux fortfarande var för sprickor, men jag vet inte vad jag ska sätta.

    kort sagt, att du är en meister; D

    1.    Koprotk sade

      Beklagar förseningen, mynta är bättre för min smak än ubuntu, eftersom personligen ubuntu inte har någon fördel jämfört med mynta och mynta kommer "install-use"

      hälsningar

  7.   Eneritz sade

    Lysande!!! Efter mer än tre år ... .. Snifff, jag kommer att gråta av känslor. Min inte så helt nya iPodNano3G som körs på Linux med gtkpod. Tack så mycket 😀

  8.   saul sade

    Hej god morgon. Jag har problem med min 5: e generationens iPod nano och jag försökte allt även med plaonlinux och det låter mig inte installera iTunes ... Denna handledning kan hjälpa mig med iPod nano eftersom jag inte hittade en lösning på något jag hoppades kan du hjälpa mig tack / ,, /

    1.    Koprotk sade

      läsning http://www.gtkpod.org/wiki/Home Det står att iPod Nano 5th kan synkroniseras utan att göra denna handledning så länge det finns minst en låt försynkroniserad med iTunes. Sammanfattningsvis:
      1.- installera gtkpod-biblioteken om du inte har dem
      2.- synkronisera minst en låt till din iPod Nano 5th med itunes
      3.- nu kan du synkronisera med ditt favoritprogram som kan hantera gtkpod, exempel: rythmbox eller banshee

      1.    Carlota sade

        Tack så mycket för artikeln !!
        Sanningen är att det inte har fungerat för mig. Jag hatar Apples snobberi just nu. Jag har en 5: e generationens Ipod nano och vad gtkpod rekommenderar fungerar inte heller för mig. Jag har gjort allt som finns för forumen.
        Hur som helst ... låt oss se vad som händer.
        Hälsningar!

  9.   Koprotk sade

    Carlota, jag vet verkligen inte hur man hjälper dig, om du testade den här guiden, måste du ta bort alla ändringar, den här guiden är endast för ipod Nano 6G å andra sidan, kom ihåg att inte alla spelare stöder libgpod-bibliotek, Banshee fungerar väldigt bra och rhythmbox också med dessa bibliotek rekommenderar jag också att du formaterar ipod Nano med iTunes i Windows, skickar en låt som finns i båda biblioteken (Windows och Linux) och fortsätter synkroniseringen i Linux. Kontrollerade du om libgpod-versionen är den senaste? Tur.

    hälsningar

  10.   reberamone sade

    Hej, jag har en 7G ipod nano och en Linux Mint 18. Dator kom redan med den inbyggda Banshee och det fungerar bra, förutom när jag kopplade in min ipod och försökte ta bort gamla låtar och spela några nya, kunde jag inte göra det. De jag raderade förblev på ipoden, även om de inte låter. Och de jag försökte sätta in visas helt enkelt inte eller existerar inte. Har du någon aning om hur jag kan lösa det?
    Tack på förhand.