Självstudier: Installera paketen .tar.gz och .tar.bz2

I början när vi startar i Linux och letar efter ett program är det normalt att vi hittar en .deb eller .rpm och i många fall hittar vi program med tillägget .tar.gz y .tar.bz2Dessa filer är komprimerade och innehåller vanligtvis instruktioner för att installera den förutom programmet.

Installationen för dessa två typer av paket är exakt densamma

Först går vi in ​​i mappen där vi har filen, om mappen har flera ord måste vi sätta dem med "" eller om den inte letar efter mappar med varje ord

cd-mapp där filen är cd "mapp där filen är"

Inuti packar vi upp filen

tar -zxvf filnamn.tar.gz tar -jxvf filnamn.tar.bz2

Vi konfigurerar

. / Configure

Vi gör (kompilerar)

göra

Gör nu installationen

make install

Ibland kan det ge oss ett fel i ./configure, i så fall behöver det inte sammanställas och med körning har vi gott, i en terminal gör vi

hur man
Relaterad artikel:
Kommandon för att känna till systemet (identifiera hårdvara och vissa programkonfigurationer)
Program namn

Eller så skapar vi en launcher.


Innehållet i artikeln följer våra principer om redaktionell etik. Klicka på för att rapportera ett fel här.

102 kommentarer, lämna din

Lämna din kommentar

Din e-postadress kommer inte att publiceras.

*

*

  1. Ansvarig för uppgifterna: Miguel Ángel Gatón
  2. Syftet med uppgifterna: Kontrollera skräppost, kommentarhantering.
  3. Legitimering: Ditt samtycke
  4. Kommunikation av uppgifterna: Uppgifterna kommer inte att kommuniceras till tredje part förutom enligt laglig skyldighet.
  5. Datalagring: databas värd för Occentus Networks (EU)
  6. Rättigheter: När som helst kan du begränsa, återställa och radera din information.

  1.   Moskva sade

    wow, +1

  2.   rätt sade

    faktiskt är det rätta att packa upp
    tar -zxvf file.tar.gz
    tar -jxvf file.tar.bz2

    och för att konfigurera finns det ett oändligt antal alternativ (beroende på programvara) för att anpassa installationen

    ./konfigurera –hjälp

    Med det kommer de att se de olika ytterligare alternativen när de installerar ett program.
    Inte alla distributioner använder / usr / local för att installera program, det måste också nämnas.

    Du glömde att nämna hur du avinstallerar ett program som installerats på det sättet. Förutom att definiera optimeringar för varje arkitektur.

    Hur som helst, bra initiativ men du saknade mycket ... för mycket information att dela.

    hälsningar

    1.    Mod sade

      Det är något som jag nästan aldrig har använt, de flesta program jag hittar i de officiella förvaren.

      Sanningen om dekomprimering är att det alltid har varit bra för mig så här.

      Jag skrev det för att alla som säger "när du packar upp den läser instruktionerna" skruvar upp mig.

      Hur som helst ser jag .tar.gz som sista utväg, om det inte finns något i deb / rpm-paketet eller i förvaren

      1.    rätt sade

        "Sanningen är att dekomprimering alltid har varit bra för mig så här."
        vi håller med, jag bestrider inte det, men det betyder inte att det är rätt att göra. Inte alla distros dekomprimerar "intelligent", vissa måste lägga till fler parametrar.

        1.    Mod sade

          Man, det är inte mitt fel att det finns subnormala distros hahahaha

          1.    rätt sade

            KISS man ... KISS

          2.    Mod sade

            Man, KISS är inte idiot, det vet du redan med Slackware hahahaha

          3.    rätt sade

            xD
            Det är därför jag säger dig det

            Enkelt! = Lätt.

  3.   yoyo sade

    +1 för korrekt

    1.    Pepe sade

      Det ena rövhålet än det andra. Dessa "genier" är utanför ämnet.

  4.   Lithos523 sade

    Om du ändrar "make install" till "checkinstall" (du kan installera det med aptitude, det finns i förvaren) kommer programmet att installeras, men också:
    -Skapa en .deb så att du kan installera den vid framtida tillfällen
    -Det installerade programmet visas i Synaptic, så att du enkelt kan avinstallera det därifrån

    1.    Mod sade

      Arch-användare har det involverat med Aptitude ...

  5.   jelpassagerare sade

    Ledsen för min okunnighet, men löser den främmande appen alla dessa problem?

    1.    rätt sade

      nej, eftersom alien fungerar med kompilerade paket och tar.gz eller tar.bz2 är komprimerade filer med källkoden.

  6.   pandev92 sade

    Du kan inte riktigt göra en handledning om detta, för det mesta, åtminstone qt-paketen sammanställs på andra ännu konstigare sätt.

    1.    hypersayan_x sade

      Exakt jag skulle säga samma sak.
      De som använder qmake från Qt är mer eller mindre så här:


      cd CarpetaPrograma
      qmake
      make
      sudo make install

      Och jag lägger till ett annat fall som är cmakes:


      cd CarpetaPrograma
      mkdir build
      cd build
      cmake ..
      make
      sudo make install

      Eller det finns andra som bara måste köra make && sudo make install.
      Det är de vanligaste fallen, men det finns många fler varianter: s

      1.    mcder3 sade

        Det finns tillfällen att vissa applikationer som görs i QT inte tar med sig makefilen. Så det är dags att skapa dem med följande rad:

        qmake -makefile

        hälsningar

  7.   jelpassagerare sade

    Låt oss se om jag kan klargöra när jag måste använda en tar.gz eller en tar.bz2 allt jag gör för att skapa en .deb eller en all.deb med hjälp av alien är att sätta sudo alien install + paketnamn. Är det inte samma sak som att kompilera?

    1.    hypersayan_x sade

      Nej, kompilering omvandlar källkoden till programmet till maskinkod.
      Medan det du gör med utomjording är ompaketering som omvandlar paketformatet för en distribution till paketformatet för en annan distribution.
      För att göra det enklare är det som om du hade en fil komprimerad i RAR och du vill konvertera den till ZIP, du skulle dekomprimera filen i RAR och komprimera den igen i ZIP, det är vad utomjording gör.

  8.   StuMx sade

    Sammanställning görs i fabrikat, inte i konfiguration. Konfigurationsfilen är ett skript som verifierar att systemet uppfyller alla beroenden för att kompilera programmet, sedan genererar den make-filen (som är den som definierar hur den ska kompileras) enligt vårt system.

    1.    Mod sade

      Nu tar jag bort det eftersom den här artikeln redan är lång sedan jag skrev den i april eller maj. Jag kollade inte på det nästan att ta bort något dåligt ord inget annat

  9.   jelpassagerare sade

    Hej:
    Jag tror inte att jag förklarar mig särskilt bra. Alien omvandlar inte bara ett rpm-paket till en .deb, om du tar källkoden till ett program, vare sig det är gz, eller bz2 förvandlar det det till en självinstallationsfelsökare. Därav min fråga. Jag har varit på Linux länge, ha med mig.

  10.   ram sade

    ursäkta min okunnighet, men dessa steg gäller också i Chakra, eller ändras något ???

    1.    KZKG ^ Gaara sade

      Ingen man alls 😀
      Som sådana är dessa steg nästan en standard i alla distributioner, men det är inte 100% säker på att dessa ALLTID är de steg som ska följas. Det är därför jag rekommenderar att du alltid läser instruktionsfilen (LÄS vanligtvis) innan du gör något.

    2.    rätt sade

      som @ KZKG ^ Gaara säger, så är det inte alltid, det är en standard som fungerar för alla distributioner så länge programmet är skrivet i C / C ++

  11.   Carlos-Xfce sade

    När jag står inför en av dessa .tar.gz kommer jag tillbaka till den här artikeln. Hur avskyr jag sådana sådana paket!

    1.    Mod sade

      Fan du är tillräckligt gammal för att installera dessa paket HAHAHAHAHA

  12.   VulkHead sade

    Ursäkta min brist på kunskap, den här installationsmetoden fungerar också för Debian. Eftersom jag försöker och jag försöker och det ger mig ett fel.

  13.   Laura Tejera sade

    Det är därför ingen använder Linux, att göra något dumt är ett trick

    1.    elav sade

      Hur nyfiken, några av de dumma saker som du nämner, de "superbegåvade" användare av Windows och OS X kan inte göra dem, eller de är rädda för dem.

      1.    Laura Tejera sade

        det roliga är hur människor som du kan följa ett sådant stängt operativsystem.

        1.    KZKG ^ Gaara sade

          Har du undvikit att svara på frågan? ... Kan Windows-användare eller OS X-genier göra så många saker med sitt system som vi visar på den här webbplatsen? 🙂

          Förresten, du använder Ubuntu så ... vad pratar vi om?

          1.    Laura Tejera sade

            fortsätt medelmåttig manga

            1.    KZKG ^ Gaara sade

              Är vi mediokra? ... Uff ... LOL!


      2.    Pepe sade

        Vi är år 2015!
        Jag tror att det inte är nödvändigt att slösa bort så mycket tid på att studera för att arbeta från konsolen.
        Varför inte använda automatiska applikationer för detta?
        I vilket fall som helst, de som "gillar" att skriva kommandona från konsolen där, låter dem fortsätta göra det, men parallellt skulle det vara nödvändigt att ha samma automatiserade kommandon. Jag ber dig inte att skicka en raket till månen.

    2.    Santiago Luis Bazan sade

      Anledningarna till att använda fri programvara är moralisk etik. Låt aldrig någon nekas sina mänskliga friheter

      1.    Pepe sade

        Sanningen att sanatan om "frihet" i programmen har fått mig trött. Kunde de inte sluta berömma en icke-existerande gud och vara lite mer ödmjuka?

    3.    Pepe sade

      Du har rätt Laura, dessa killar med sin Linux komplicerar det till benet. I put0 windows är det lättare. Jag förnedrar inte Linux men det kan inte vara så att du installerar några pel0tudes du spenderar timmar och timmar på att undersöka hur tjära fungerar och alla meresunda så att du i slutet av dagen fastnar med den "Linux nybörjaren ..."

      Jag tänker använda ett stabilt operativsystem men inte ta timmar av min produktion eftersom jag måste jobba, jag har ingen önskan att bli en "Linux-examen".

  14.   Thanatos sade

    Något saknas alltid ... när jag ger ./configure får jag: configure: error: Din intltool är för gammal. Du behöver intltool 0.35.0 eller senare.

    Senare returnerar fabriksinstruktionen: Inget mål angavs och ingen makefile hittades. Hög.

    make install: Det finns ingen regel för att bygga `installera målet

    Jag är nybörjare och det är bra att undersöka för att lära mig, men FUCK, kan du inte förklara det med färgade småsten för de av oss som är nya inom Linux?

    1.    ponchu sade

      Thanatos Jag hade ett liknande problem och jag delar mitt resultat:
      (Först och främst för att klargöra att jag också är en neofyt i Linux-världen och mina äventyr i detta sammanhang med "smak" (distro) till Ubuntu är en vecka).
      Förutsatt att den går in i min mapp «Nedladdningar» med kommandot «cd» där mitt paket med programmet «SoulSeek» med slut «.tgz» i terminalen eller konsolen hittades:
      "./Configure" gav mig ett fel att filen eller katalogen inte fanns
      "Make" gav mig samma fel som du ... så jag fortsatte inte med kommandot "sudo make install" (sudo beror på att Ubuntu kräver "Super User och hans lösenord" för att köra detta kommando, med andra ord göra en installation ).
      Efter att ha undersökt den tidigare uppackade filen insåg jag något som kan hända dig och det är att den uppackade filen var av typen "körbar fil" (högerklickegenskaper) och två klick räckte för att utföra den.
      Ditt problem i «./configure» kan lösas med en uppdatering av paketen eller förvaren (dessa termer förvirrar mig lite) installerade i din Distro, eftersom det säger att «intItooI» är gammalt och du behöver en nyare och jag tror att det här paketet kanske är det som kompilerar på din distro. I Ubuntu gör du det i samma terminal genom att skriva "sudo apt-get update" och uppdatera alla paket på systemet.
      Jag hoppas att jag har varit till hjälp.

    2.    Pepe sade

      Som jag sa till Laura tar den här Linux-saken lång tid. Det gav mig samma felmeddelande som ditt och jag går som spöket i Canterville från en plats till en annan och ingenting alls.

      Min chef sa till mig: "du har två dagar på dig att hitta lösningen, om inte, vi går tillbaka till windows."

  15.   Jonathan sade

    tack

  16.   ivan sade

    hej jag har samma problem jag vill installera skype 4.0. I min pclinuxOS hämtade jag tjära, gz2 och dekomprimerade och tills jag fick det, när jag gör det ./configure säger det mig att filen inte existerar .. var gick jag vilse eller vad? berätta för mig, i pclinuxOS (den senast släppta versionen) är skype installerat men det är version 2.2 och jag vill installera 4,
    Finns det något trick jag måste göra för att äntligen installera det här? något synaptiskt som jag inte vet ???
    Jag är ny på detta system, jag har testat andra distros tidigare och hittills är allt bra förutom detta ..

    gäller

    1.    Pepe sade

      Är det jag eller tror jag inte att någon känner till dessa frågor.

    2.    f7eo sade

      Hej, det är länge sedan din fråga.

      Jag rekommenderar att du laddar ner den senaste versionen av Skype för Windows (R)
      och att du använder Wine för att köra det på din GNU-Linux-distro.

  17.   av sade

    Hallå! Jag har samma problem: Jag laddade ner den senaste versionen av centerprogramvaran med enxtension tar.gz och när jag kom till instansen "./configure" fick jag ett fel, precis som i "make". VAD ÄR DET"?? TACK!! Dessutom har mjukvaracentret blockerat möjligheten att installera !!!

  18.   Carlos Rivera sade

    Tack, det hjälpte mig mycket !!!!

  19.   michael sade

    hur man skapar en launcher

  20.   Angi sade

    En fråga, kan du kontrollera beroenden för en tar.gz-fil innan du kör ./configure ???

  21.   JoseLuis sade

    Jag är ny på Linux, det verkar väldigt svårt att installera tar gz gz2-tabletterna och om jag får en deb saknar det beroenden och med varvtalet detsamma om det är i586 eller i686 eller i386 och det värsta är att jag inte har internet i mitt hus. Att se så mycket kommentarer som motsäger en förvirrar dig värre.

  22.   gabriel yamamoto sade

    bra info, men vissa * .tar.bz2-paket är redan kompilerade och för att installera dem måste du bara packa upp dem i valfri mapp (helst / opt så att det är tillgängligt för alla användare) och ge direkt tillgång till binären i / usr / local / bin

  23.   Gonzalo sade

    Mycket bra förklaring av hur tar.gz-filer används. Tack så mycket för informationen. Hälsningar till hela laget

  24.   juancuyo sade

    Det fungerar inte för mig
    cd / home / ju / nedladdningar / icecat-24.0 ——-> Svarar på mig
    bash: cd: home / ju / downloads / icecat-24.0: fil eller katalog finns inte
    Vad gör jag fel??? Operativsystemet är Voyager 14.04 LTS (xubuntu) Xfce desktop Gdebi finns inte i innehållsmenyn och inte heller synaptiska men de är i startmenyn, även om du öppnar dem, känner de inte igen mapparna, det är som om de gjorde inte existera. Jag packade upp den i samma nedladdningsmapp. Är den felaktigt uppackad ????

  25.   Claudio sade

    Denna handledning fungerar också för .tgz?

    1.    joakoej sade

      Nej, .tgz är det format som Slackware använder och de är redan kompilerade, oavsett om du har laddat ner det eller kompilerat det från en slackbuild

    2.    joakoej sade

      För att installera det måste du använda installpkg "paketnamn".

  26.   asdf sade

    Ledsen men det löser inte problemet mycket för mig, när du säger ./configure och vi konfigurerar det, borde du specificera mer, eller hur? om jag bara sätter ./configure så säger det mig
    bash: ./configure: Fil eller katalog finns inte

    då säger du "vi gör"
    Koda:
    Fabrikat
    Mitt resultat:
    make: *** Inget mål angavs och ingen makefile hittades. Hög.

    Gör installationen
    make: *** Det finns ingen regel för att konstruera målet "installera". Hög.

    Och då säger du "vi kör programmet"
    Koda:
    Program namn

    Hur vet jag vilket är namnet eller vilket är körbart? Det är väldigt abstrakt, kanske du tar för givet flera saker som du kommer att veta, men de som kommer för att se en handledning kanske inte vet

    1.    Damian sade

      asdf.

      Jag undersökte och felet som uppstår när jag gav ./configure beror på bristen på kompileringsprogrammet (hur skulle vi kunna kompilera utan att ha ett program som gör det?). kommandot för att installera en kompilator att ange är:

      sudo aptitude installera nödvändigt

      en gång installerad går vi till mappen där filen som ska packas upp och körs:

      tar -zxvf programnamn.tar.gz

      Sedan anger vi den okomprimerade programmappen, och om det körs ./configure och sudo gör installationen

      Jag hoppas att jag har hjälpt!

      Hälsningar.

      1.    Damian sade

        Tyvärr, jag glömde att klargöra, i mitt fall att utföra "make" och "sudo apt-get install-programmet" var jag tvungen att ange "bas" -mappen i den ej packade mappen, precis där tog jag kommandona för att kompilera (gör ) och installationen.

      2.    Carlos sade

        Det ger mig problem när jag använder gör det säger att det inte hittar något att bygga högt

  27.   Brenda sade

    Tyvärr har jag det här problemet, jag kör det här kommandot, det visar mig ett fel och jag kan inte skapa makefilen
    skrivbord: ~ / Nedladdningar $ tar -jxvf iReport-4.1.3.tar.bz2
    tar (underordnad): iReport-4.1.3.tar.bz2: Kan inte öppnas: Fil eller katalog finns inte
    tar (barn): Fel kan inte återställas: avslutar nu
    tjära: Barnet returnerade status 2
    tar: Fel kan inte återställas: avslutar nu
    snälla =)

  28.   Aaron sade

    God dag vänner,
    Jag är ny på Linux, men jag har haft lite besvär när det gäller att känna igen en enhet som är en digital biometrisk läsare, jag googlade bara och uppenbarligen hittade den dock, den laddades ner med en .tar.gz-förlängning, prova packa upp den i en mapp packades flera filer upp men jag vet inte om jag sedan måste köra något annat eller klistra in de packade filerna i en mapp på systemet, jag vet inte, om du hjälper mig snälla, att köra bearbeta bra, jag skulle vara mycket tacksam, jag har Linux Debian 7 installerat på OS. Hälsningar och tack så mycket.

  29.   Rufo Lopez Retortillo sade

    Jag använder både Linex 2011 och Linex 2013 och det största problemet jag hittar när jag installerar applikationer är att de inte laddas i listan över applikationer i sin grupp (grafik, kontor, multimedia etc.) och om jag vill skapa en startprogram vet jag inte var Jag måste gå för att hitta programstartfilen. I vilken mapp skapar du den? Hur man gör det?
    När de installeras från förvaren placeras startarna i sin grupp, kan detta göras genom att installera tar.gz som beskrivs på den här webben?
    Tack för hjälpen

  30.   Carlos sade

    Snälla hjälp att jag har ett annat operativsystem som heter lps 1.5.5 och jag kan inte uppdatera programmet

  31.   Carlos sade

    Snälla berätta igen jag kan inte packa upp en tar.bz2-fil. Jag har ett operativsystem som heter lps 1.5.5 och jag vet inte hur man använder den. Snälla hjälp mig, jag tackar dig ...

  32.   joscastel sade

    efter att ha packat upp bz2-filen fungerar INTE kommandot ./configure INTE eftersom det INTE finns

    1.    joscastel sade

      Jag har ubuntu 14.04LTS

  33.   du vet sade

    Jag förstår det inte, i slax går .tar.gz på bio, men i ubuntu har jag inget sätt att kompilera

  34.   raul sade

    Vad är det bästa operativsystemet? det bästa operativsystemet är att det löser dina problem.

  35.   Juanzito sade

    Linux-folket är fantastiskt. Jag har försökt installera ZinjaI på min nyligen installerade LinuxMint-distro i minst 5 timmar.
    Jag går igenom alla forum som jag hittar och i alla (men alla, inklusive den här) ger de dig hälften av informationen.
    Till exempel har jag redan öppnat terminalen, men jag kan inte ange adressen där den nedladdade filen finns (som är / home / user / Downloads / zinjai).
    Allt jag får är ett fel: "bash: cd: användare: Ingen sådan fil eller katalog.
    Jag förstår att de vill sprida och sprida användningen av ett operativsystem, men att förneka information eller förklara allt i hälften är det enda de kommer att uppnå är att användare som jag, som hade den fasta avsikten att flytta från Windows till Linux, ge upp och håll fast vid min W7, dålig men användbar och hanterbar.

    Skål…

    PS: Vad kostade en eländig installatör med ett grafiskt gränssnitt dem att göra? Varför i dag på XXI-talet ska de fortsätta att använda något som liknar DOS för att installera ett eländigt litet program?. Pojkar ... för att se om de lever upp lite ....

    1.    ocelote sade

      cd ~ / Nedladdnings- / installationsskriptsökväg.

      Ett tips: håll fast med fönster. Varje operativsystem är utformat för en typ av person. Windows är gjort för personer som föredrar att få allt på marken och med minsta möjliga ansträngning och jag ser att det är ditt fall. Det finns människor som inte kan eller inte vill sträva efter något mer än nästa, nästa, nästa ... acceptera. Det är inte dåligt, vi måste helt enkelt känna till våra begränsningar och anpassa oss till dem.

      Ett annat tips: Om du bara visste hur många saker som uppnås med ödmjukhet och använder två ord som "snälla". Det skulle överraska dig. Gör det ofta.

      1.    Knary sade

        Hej Linuxeros.
        Tack så mycket för handledningen, det hjälpte mig att installera drivrutinerna för dwa-131 wifi-adaptern.
        Jag tvivlar lite, jag har gjort allt som de säger ovan.
        Gå till filvägen, gör tar .... och sedan Gör, vänta tills det är klart och gör sedan installationen.
        Fram till det steget gav det mig inga fel.
        Frågan jag har är att veta om jag redan har drivrutinerna installerade eller måste jag göra något annat.
        Juanzito .. muntra upp och ge Linux en chans, oavsett distribution, jag bestämde mig för att lämna windows 7 för en vecka sedan och jag är mer förlorad än fan, hahaha, men att läsa här och där hittar du information som ibland är svår för dig För att förstå beror allt på ansträngningarna hos var och en för att vilja lära sig och komma ut ur monopolet där Windows bäddar in dig (det är min åsikt).
        En sak ... på Linux-terminalen räknas stora bokstäver. 😉

        PS: Jag måste göra något annat efter Kame-installationen. ??

        Tack så mycket.
        Tack så mycket och hälsningar från Kanarieöarna.

      2.    Bågar sade

        Och vem är du som säger till en användare att gå tillbaka till X-systemet? tror du att du är Richard Stallman?

        Jag håller med om vad de säger i vissa kommentarer att det bästa operativsystemet är det som systemet anpassar sig till användaren och INTE tvärtom.

        Jag personligen älskar Windows .exe för som du säger att du inte behöver vara ett datorgeni för att installera något väldigt enkelt som en enkel anteckningsbok; jämfört här i Linux att om det inte finns i dedikerade programvaruapplikationer håller du dig till århundradets trassliga med en surfplatta.

        Jag kom hit för att leta efter och organisera information för att installera program i Linux eftersom jag förbereder mig för att installera mynten på en produktiv maskin och jag vet att om jag inte förbereder kommer jag inte att kunna installera någonting om det inte finns i förvaren.

        Nu "tack" alla frågar problemet är att ingen svarar dem, det är därför som ibland människor måste vara aggressiva så säg inte nonsens.

      3.    pablo sade

        sorry ... men jag har alltid försvarat användningen av gratis och öppen programvara .. Jag har använt datorer i 30 år .. och jag är 37 ..
        problemet är att i allmänhet i Linux är det perfekt att den som vill eller borde "veta" lite mer för något enkelt som att installera ett program, en uppdatering eller vad som helst ... problemet kommer att många behöver arbeta och använda datorn (med vilket operativsystem som helst) för att göra sin specifika arbetsuppgift .. så även om det tar 10 minuter att ladda ner en .gz och installera den .. eller om det som mest händer kommer timmarna att passera .. de är minuter eller timmar att inte vara kan göra ditt jobb och det är där nästan alla tar slut på tålamod ..
        I mitt fall .. på jobbet använder jag bara Ubuntu som är det som är installerat som standard på datorer, eftersom det är ett vetenskapligt centrum, men det får mig att spendera mer timmar på att försöka installera eller till och med riva upp hur man gör en mjuk specifik (till exempel Jag är en geograf) det fungerar .. eller att efter en uppdatering av det .. återställ alla verktyg för att halva slutar arbeta inom ett program ..
        i det här specifika fallet .. Jag behövde se ett webinar / forum på jobbet .. och eftersom de använder java saknar jag tecknet att jag ska uppdatera det .. ok .. gå till java-webbplatsen .. hitta filen för mitt operativsystem, 14.04 .. titta på nedladdning och installation "" instruktioner "" .. ladda ner en .gz och därifrån .. packa upp .. ok, och ... det står "installera" .. och voila .. bara du kunde inte göra någonting med informationen i det här inlägget .. vad gör jag när jag packar upp «jre-blablabla of a lifetime.gz» ??

  36.   Carlos Fabian Ferra sade

    detta fungerade aldrig för mig i någon distro

    1.    yukiteru sade

      Om det inte fungerade för dig är det rent Layer 8.

      1.    Yank Carlos sade

        Genius!

  37.   Ignatius Navarro sade

    Eftersom jag använder det mycket ibland, varje gång jag går in här för att se hur det görs.
    Tack så mycket för att du har skrivit det och för att du inte har tagit bort det efter så länge.

  38.   ramon sade

    som du kan se synaptiskt det nya paketet installerat om det visar dig det äldsta (stabilt enligt distro) ¿?

  39.   jorge sade

    allt går skit när man anländer till ./configure det finns ingen som förklarar bra för när det står att filen inte existerar

    1.    elvis sade

      Jag försöker installera wifi från Broadcom varken ./configure, varken göra eller få installationen att fungera.

      den logiska sekvensen är 1: a exekvera. / konfigurera men uppenbarligen hänvisar denna instruktion bara till en konfigurationskatalog och kör någon fil som läggs där, den ska komma i paketet som laddas ner från Broadcom men i mitt fall är den här katalogen inte där, det är tänkt att utföra konfigurera är en kontroll och skapa Makefile-filen, men när jag packar upp paketet inser jag att Makefile är införlivat, de andra två kommandona gör och gör installationen inte fungerar för mig, det skulle bero på att den senaste versionen av elementära operativsystem inte fungerar stöder inte det freya baserat på ubuntu 14.04

    2.    Alexander TorMar sade

      Sanningen? Denna metod har aldrig fungerat för mig och jag väljer alltid .deb-paket eller kommandon från terminalen ... Synd att det inte finns något klart att installera .tar.gz

  40.   elvis sade

    Jag försöker installera wifi från Broadcom varken ./configure, varken göra eller få installationen att fungera.

    den logiska sekvensen är 1: a exekvera. / konfigurera men uppenbarligen hänvisar denna instruktion bara till en konfigurationskatalog och kör någon fil som läggs där, den ska komma i paketet som laddas ner från Broadcom men i mitt fall är den här katalogen inte där, det är tänkt att utföra konfigurera är en kontroll och skapa Makefile-filen, men när jag packar upp paketet inser jag att Makefile är införlivat, de andra två kommandona gör och gör installationen inte fungerar för mig, det skulle bero på att den senaste versionen av elementära operativsystem inte fungerar stöder inte det freya baserat på ubuntu 14.04

  41.   Alexander TorMar sade

    Sanningen? Denna metod har aldrig hjälpt mig och jag väljer alltid .deb-paket eller kommandon från terminalen ... Synd att det inte finns något klart att installera .tar.gz

  42.   Alexander TorMar sade

    Varför uppdateras inte denna handledning? Eller gör de en ny?
    Alla här klagar över att det inte tjänade dem och det har redan sina år ....

  43.   HECTOR MATOS sade

    Hej, jag vill ha hjälp, med det för att installera paket .. Jag har Ubuntu version 15 .. något .. Jag vill installera adobe flash plugin, för det är mycket användbart att installera det, eftersom jag med adobe flash kan gå in på några webbsidor , där du kan se TV: n och även lyssna på radio .. snälla kan du skicka mig en steg-för-steg-handledning .. Jag har inte mycket erfarenhet av den kommandoraden, det vill säga använda en terminal.

    Hjälp..tack

  44.   Abraham sade

    Hej allihopa !!! Efter att ha läst nästan alla kommentarer letade jag efter en Linux-manual och voila ..
    Vän OCELOTE, acceptera denna kritik, ur min ödmjuka och obetydliga synvinkel som jag delar med miljontals Windows-användare:

    Jag skulle gärna byta till Linux! men många av oss tycker att det är omöjligt, varför? du undrar ... för för mig är datorn det sätt jag måste utföra mitt arbete, det är inte slutet ... Jag vet inte om du förstår vad vi alla vill ha (och JUANZITO har sagt dig bra) det är ett stabilt operativsystem som hjälper oss att för att utföra vårt arbete har jag inte tid att lära mig att göra grundläggande saker som att installera ett program från konsolen, allt borde vara mer intuitivt och lättare ... Som företagare kommer jag att säga att ledningen som du bär med Linux är katastrofal, istället för att hjälpa folket för att göra ändring av operativsystem insisterar du på att människor ljuger med saker som inte intresserar dem och du blockerar förändringen själv ... någon som programmerat i assembler, java, javascript, html, php och xbase säger till dig ... och det rör vid näsan att jag måste öppna konsolen för nästan allt.

    hälsningar

  45.   defcon sade

    Uthållighet DOS 6.22 gammal !!

  46.   erputera sade

    Sätt dig att studera och lämna den skiten av wuendos som fungerar för vissa eftersom de gör putset som nycklar, de betalar inte dem, för att toppa allt, de som gjorde dessa nycklar är linuxgenierna och de borde, det är varför du är som dum att diskutera mamahuevadas, för affärsmän som jag säger till dem, fortsätt att betala deras licens och om det de vill ha är stabilt så vinner de tid vad i helvete de skriver idioter i dessa tutor detta är för oss som som linux idioter ... esset

  47.   GENDA sade

    Det är inte särskilt tydligt för nybörjare. Du säger till exempel:
    «Först går vi till mappen där vi har filen, om mappen har flera ord måste vi sätta dem med" "eller om den inte letar efter mappar med varje ord» ...
    någon användare kommer in i dessa mappar med «explorer» och kommer att byta namn utan att veta namnet på mappen som innehåller den med offerten. Det ur den synvinkel du läser det, «ur den nya användarens synvinkel.

    Sedan sätter du:
    cd-mapp där filen är

    cd "mapp där filen är"
    Från den tidpunkten har användaren redan gått till molnen eller vart som helst, för från och med nu är han förlorad på CD: n med initialerna, du klargör inte hur du kommer dit, ett steg för steg-exempel, börjar med allt det .. öppnar konsolen först.

  48.   GENDA sade

    För HECTOR MATOS: Adobe-plugin, java och andra behöver inte göras manuellt, du behöver bara vara ansluten till internet ett tag och i uppdateringshanteraren visas den automatiskt, därifrån uppdateras den automatiskt, för Firefox till Opera, och resten oberoende ... normalt är startprogrammet bredvid klockan i startfältet, i flera distros såg jag att det som standard var där, jag vet inte om det kommer att vara så i dem alla.

  49.   max sade

    Var snällare, mycket information saknas

  50.   mary sade

    försök att uppdatera python till 3.x och gör installationen när du är klar säger att det finns ett fel:
    zipimport.zipimporterror kan inte dekomprimera data zlib inte tillgängligt gör *** installationsfel

  51.   f_leonar sade

    Efter uppackning för att köra ./configure är det nödvändigt att ange den uppackade katalogen, annars fungerar det inte. Jag använder KDE och jag gick grafiskt in i mappen som jag packade upp och där öppnade jag en terminal för att utföra "make" men det fungerar inte ...

  52.   anonym sade

    Jag har en fråga, jag får den här:
    manolo @ mxlolo-satellit-c655d: ~ / Desktop $ ./konfigurera –hjälp
    bash: ./configure: Ingen sådan fil eller katalog
    vad jag gör…?

  53.   KATSODA sade

    Allt bra tills ./konfigurationen av bollarna kom ut.
    VAD MENAR DU MED DET !? De förklarar inte det, jag vill bara installera det andra jävla livet xddd
    «»»katsoda@katsoda-PC:~/Downloads$ ‘/home/katsoda/Downloads/Second_Life_5_0_4_325124_i686’/configure
    bash: / home / katsoda / Nedladdningar / Second_Life_5_0_4_325124_i686 / configure: Fil eller katalog finns inte »» »
    Jag borde ladda ner Windows 10 och ta röven. (?)
    Tja, nej. Men det här är en av de saker jag hatar om Linux. Att installera och be att dina favoritprogram är kompatibla här är en ganska utmaning.

    1.    Gatoo_ sade

      Det är inte att bry sig, herrar, men skaparen av självstudien förklarar perfekt vad man ska göra om du får ett fel med ./configure. Du måste bara läsa resten av handledningen (som är 4 rader).

      Jag tycker det är otroligt att så många klagar på att det inte förklarar saker när man inte ens har slutat läsa.

  54.   fredag sade

    Tja, jag förklarar mig officiellt inkompetent för denna typ av filer. Jag försöker installera java och det är vad det är;
    javier @ loft: ~ / JAVA / jre1.8.0_151 $ tar -zxvf jre-8u151-linux-x64.tar.gz
    tar (underordnad): jre-8u151-linux-x64.tar.gz: Det går inte att öppna: Fil eller katalog finns inte
    tar (barn): Fel kan inte återställas: avslutar nu
    tjära: Barnet returnerade status 2
    tar: Fel kan inte återställas: avslutar nu

  55.   Roger deku sade

    i Linux ubuntu 18.04.01 lts måste du bara skriva ./namedelprograma i samma mapp efter att du har packat upp den och voila !!!

  56.   jia sade

    Mycket bra, det var till stor hjälp.

  57.   Emerson Gonzalez sade

    i av linux fungerar det inte
    Jag vet inte vad som är konstigt för mig; eller varje gång du installerar en distro börjar du korsets väg
    du ser hur tangentbordet går

  58.   Jose Felix Paisano Morales sade

    Hej alla, jag använder Ubunto 20 och jag konsulterade den här sidan för att installera skannern på en Epson L4150 (jag laddade ner enheterna från http://support.epson.net/linux/en/imagescanv3.php?version=1.3.38#ubuntu).
    Jag följde stegen och använde 'tar -zxvf filename.tar.gz' när jag packade upp den
    '$ cd imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb', vilket är den mapp som skapas.
    Inne i mappen jag använde './install.sh', som är som att använda './configure', frågade systemet mig om mitt lösenord och allt installerat bra.
    Jag försökte min skanner och det var jättebra, tack för att du gav mig anvisningarna, jag kunde använda min skanner