Tips: ¿Cómo cambiar el User Agent de Chromium?

Ya vimos como cambiar el User Agent de Firefox y Opera y ahora le toca el turno a Chromium, el cual estoy usando con regularidad porque Firefox 8 se está comiendo mi memoria RAM.

Existen extensiones que permiten hacer esto, pero por las restricciones que le tiene impuesta Google (los muy hijos de p***) a Cuba no puedo obtenerlas, así que me toca hacer esto a mano.

Para ello editamos el fichero /usr/share/applications/chromium.desktop y buscamos la línea que dice:

Exec=/usr/bin/chromium %U

Y lo ponemos así:

Exec=/usr/bin/chromium --user-agent="Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.1 (KHTML, like Gecko) Debian Chromium/14.0.835.202 Safari/535.1" %U

Si abrimos una pestaña y ponemos:

chrome://version/

Podremos ver el que más o menos en mi caso debe ser así:

--user-agent="Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.835.202 Safari/535.1"

Si lo comparan con la línea que dejé arriba verán que le añadí Debian y sustituí Chrome por Chromium.


117 comentarios

  1.   Oscar dijo

    Tienes conocimiento cual es la extensión de Google, estoy de acuerdo que son unos hijos de mala madre, para simplificar el trabajo, jajajaja, y en que distribución tienes ya Firefox 8?

    1.    elav <° Linux dijo

      Ahora no recuerdo el nombre de la extensión. Y Firefox 8 pues en Debian, con el tar.gz

  2.   Tix dijo

    Con esa ruta ( /usr/share/applications/chromium.desktop) no encuentro nada, se ve que solo sirve para una distribución especifica, lo mismo sirve en LMDE en Mint 12 no y supongo que para Ubuntu y Kubuntu tampoco.

    1.    elav <° Linux dijo

      A lo mejor en Ubuntu cambia el nombre del .desktop, pero por lo general todas las aplicaciones que salen en el menú están ahí. Busca bien, a lo mejor se llama chrome o lago por el estilo.

      1.    Alf dijo

        En ubuntu está en la ruta que se epecifica en el post, sólo que se le da click derecho sobre el ícono y se le a abrir con kwrite (mi caso), y buscas la línea, yo la modifiqué y chromium dejó de funsionar, por eso devolví los valores como los tenía.

  3.   Tix dijo

    Estoy en Mint 12 RC.

    120MB mas 54,9mb mas 46mb mas 41mb mas 33mb hacen un total de 294,9mb con solo 3 pestañas abiertas
    y subiendo según el monitor del sistema. Así que abandono Chromium y voy a probar otro navegador que sea menos vampiro.

    He mirado bien y no encontré nada como chromium.desktop , de todos modos gracias.

    1.    Jamin Samuel dijo

      yo tampoco encontre nada .. estoy en Linux mint 12

  4.   Oscar dijo

    Chromium consume mas RAM que Firefox?

    1.    hipersayan_x dijo

      Consumen lo mismo con la misma cantidad de pestañas, viendo las mismas paginas, con idénticas configuraciones y con los mismos plugins o por lo menos similares.

      1.    Oscar dijo

        @hipersayan_x, gracias por el dato.

      2.    Aliana dijo

        Yo en Kubuntu 11.10, con Firefox 14, con 74 (sí, setenta y cuatro) pestañas abiertas, consumo la misma RAM que Chromium con sólo 20-22… Y si abro más de 25 Chromium ya se vuelve lennnnntísimo.

        Lo mismo en Mint, Firefox gana a Chromium.

        En mi caso al menos NO es cierto que consuman lo mismo con las mismas pestañas abiertas. Si hace falta aporto capturas y datos.

        O sea, me quedo con Firefox y con su inmenso caudal de extensiones. Para cosas puntuales sí uso Chromium.

        Es cierto que navego compulsivamente, no conozco a nadie que abra tantas pestañas. Si sólo necesitas 3 ó 4 pestañitas, quizá te valga Chromium.

        Pero ya eso lo discutimos en otro sitio.

        1.    KZKG^Gaara dijo

          74 pestañas, ok.

          “no conozco a nadie que abra tantas pestañas”… jejeje, yo mejor no digo nada, seguro elav (el otro admin que hasta hace poco trabajó en la misma empresa que yo) dirá algo como: “Sí! éste (refiriéndose a mí) abre tantas pestañas que no me deja ancho de banda para mí” … o algo así JAJAJA.

          Nada, que yo igual abro un montón de pestañas, pues en lo que se van abriendo voy leyendo algunas semi-abiertas ya, y las voy cerrando… mientras que otras tantas aún no terminan de cargar.

        2.    KZKG^Gaara dijo

          Por cierto (qué maleducado soy jaja) … bienvenida al blog 🙂
          Espero encuentres cosas interesantes acá… aunque, siendo user de KDE, te garantizo que encontrarás montón de cosas que te gustarán 😉

          Saludos

          1.    Aliana dijo

            OK, gracias a ti.

            Pero ojo, que soy un tío, aliana son siglas.
            (normalmente cuando aclaro esto no sé por qué cambian el tono amable por otro neutro).

            1.    KZKG^Gaara dijo

              Ups jajajajaja disculpa por el malentendido jajajaja.
              Nada, igualmente un placer tenerte por acá amigo, y repito lo que dije… si gustas de KDE, acá encontrarás montón de cosas interesantes jajaja 🙂

              Saludos y bienvenido al blog 😉


  5. elav aún solo tienes Chromium v14… wow…

    1.    elav <° Linux dijo

      Si ¿Y? A mi Chromium v14 me funciona de maravillas. De hecho, no veo ninguna diferencia con Chrome 15 excepto la pestaña de inicio.

  6.   sdaf2 dijo

    si no te funciona prueba a cambiar el user agent en chrome/chromium con este metodo, rápido y sencillo http://buildall.wordpress.com/2011/05/24/changing-google-chrome-user-agent-string-in-ubuntu-11-04/

    1.    Jamin Samuel dijo

      Verroo no me funciona o no se todavia como hacerlo :S

      1.    Jamin Samuel dijo

  7.   Jamin Samuel dijo

    Her esto puede servir para google chrome tambien ?

    1.    KZKG^Gaara dijo

      Sip 😀

      1.    Jamin Samuel dijo

        ajajaa nunca pude lograr hacer xD

  8.   chino dijo

    Probando 😀

  9.   Jamin Samuel dijo

    sigo probando

    1.    Jamin Samuel dijo

      ….

  10.   Jamin Samuel dijo

    No entiendo que pasa 🙁 puse esto

    /opt/google/chrome/google-chrome %U Exec=/usr/bin/chromium --user-agent="Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Linux Mint 12 Chrome/17.0.963.79 Safari/535.1" %U

    Porfa corrijan me si tengo algo malo 🙁

    1.    KZKG^Gaara dijo

      Con eso no te aparece tan siquiera el logo de Mint en el banner del blog? (esquina superior derecha)

      1.    Jamin Samuel dijo

        no nada 🙁

      2.    Jamin Samuel dijo

        es google chrome el que estoy utilizando .. me vendría bien una ayudita

        1.    KZKG^Gaara dijo

          Uff, lo acabo de probar con Chromium (no tengo Chrome) y me funcionó de perlas O_O… deja investigar un poco a ver qué encuentro.

          1.    Jamin Samuel dijo

            haber antes de investigar .. primero matemos la duda no vaya ser que sea yo que algo este haciendo mal ..

            Donde te metiste para configurar eso ?? abriste chromium y luego que hiciste ?

            1.    KZKG^Gaara dijo

              Abrí una terminal y puse esto:
              chromium --user-agent="Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Linux Mint 12 Chrome/17.0.963.79 Safari/535.1" %U

              Nada más 🙂

              Intenta eso a ver qué resultado te dá 😀


          2.    Jamin Samuel dijo

            no pasa nada .. puse eso en la terminal y luego se me abrio una nueva ventana google chrome .. pero no sale todavia en user agent

            1.    KZKG^Gaara dijo

              Joder con estos de Google … ¬_¬
              Por eso no uso Chrome y sí Chromium …


          3.    Jamin Samuel dijo

            ajajaj lo extraño es que hice el cambio en firefox como lo muestra el otro tutorial .. y quedo bien , me muestra el logo de linux mint y todo pero chromium y chrome nada de nada

          4.    Jamin Samuel dijo

            hey puse esto en la terminal:

            chromium –user-agent=”Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Linux Mint 12 Chrome/17.0.963.79 Safari/535.1″ %U

            y me dice:
            chromium: no se encontró la orden

            1.    KZKG^Gaara dijo

              En vez de Chromium pon /usr/bin/chromium … vaya que, ese Mint ¬_¬ …


          5.    Jamin Samuel dijo

            ajajaja te vas reír un poquito .. mira lo que me dice ahora:

            bash: /usr/bin/chromium: No existe el archivo o el directorio

            1.    KZKG^Gaara dijo

              WTF!!! … intenta con /usr/bin/chromium-browser a ver


          6.    Jamin Samuel dijo

            Ok puse tal cual como me dijiste:

            /usr/bin/chromium-browser –user-agent=”Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Linux Mint 12 Chrome/17.0.963.79 Safari/535.1″ %

            Y mira como me sale el user agent

            1.    KZKG^Gaara dijo

              Ubuntu O_O …. ahora sí que me rindo…
              Ya no sé ni qué distro usas… LOL!!
              Tal vez podrías ponerlo en /etc/chromium/default o algo así… se me están acabando las ideas, en Debian me funciona de perlas 0_0


          7.    Jamin Samuel dijo

            ALELUYA!! \O/ \Ø/ \O/ \Ø/ —> ya lo logre 😀 era que tenia mal escrito chromium ejejeje MIL GRACIAS

          8.    Jamin Samuel dijo

            Ahora solo me falta poner una foto en el avatar .. así como el que tu tienes.

            1.    KZKG^Gaara dijo

              Joder al fin LOL!!!
              Para la foto del avatar, ¿estás registrada ya acá en el sitio?


  11.   Jamin Samuel dijo

    esperame un tantito .. me sale linux mint pero cuando cierro la terminal se me vuelve a poner otravez como si fuece ubuntu :O

    1.    KZKG^Gaara dijo

      Claro, no lo ejecutes en una terminal sino ejecútalo mediante [Alt]+[F2] y listo 🙂

    2.    Jamin Samuel dijo

      mira ;( cerre la terminal y se puso ubuntu .. y yo estoy usando linux mint

  12.   Jamin Samuel dijo

    [Alt] + [F2] luego puse esto:

    /usr/bin/chromium-browser –user-agent=”Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Linux Mint 12 Chromium/17.0.963.79 Safari/535.1″ %

    me abre una nueva ventana de chromium .. abro una pestaña y le pongo esto
    chrome://version/

    y muestra es ubuntu en vez de linux mint AJAJAJAJA .. mi navegador esta satanizado con canonical xD

    1.    KZKG^Gaara dijo

      Cierra todos los Chromium que tengas abierto y haz de nuevo lo del F2

      1.    Jamin Samuel dijo

        sigue sucediendo lo mismo .. me abre con el logo de linux mint .. pero cuando lo cierro y lo vuelvo abrir me aparece otravez con el de ubuntu

      2.    Jamin Samuel dijo

        que debo hacer para que se me quede fijo el user agent ?? ya que si lo abro por F2 o por la terminal me muestra el sistema que estoy usando pero cuando cierro el navegador y lo abro nuevamente me muestra ubuntu

        1.    KZKG^Gaara dijo

          Pues supongo que editar el archivo:
          /usr/share/applications/chromium.desktop

          1.    Jamin Samuel dijo

            ok como lo edito .. ya que por la terminal no hace nada, por F2 tampoco hace nada

  13.   Algabe dijo

    Al fin he podido lograr que funcione con la ayuda de Jhalss y conandoel que me ayudaron con el User Agent 🙂

    1.    KZKG^Gaara dijo

      Uff … joder al fin, ¿cómo lo hiciste al final?

      1.    Algabe dijo

        Muy fácil en la terminal puse:

        [quote]locate chrome.desktop[/quote]
        y edite la siguiente.
        [quote]sudo nano /usr/local/share/applications/google-chrome.desktop[/quote]
        busque la linea “Exec=/opt/google/chrome/google-chrome” y la deje de la siguiente manera.
        [quote]Exec=/opt/google/chrome/google-chrome –user-agent=”Mozilla/5.0 (X11; Linux i686) AppleWebKit/536.5 (KHTML, like Gecko) Fedora Chrome/19.0.1084.52 Safari/536.5″ %U[/quote]
        Reinicio el Chrome y ya funciona el User Agent 🙂

        1.    KZKG^Gaara dijo

          AAHH!! vale vale muchas gracias 😀
          Lo twitteo ahora mismo jajajaja.

  14.   Greenux dijo

    probando

  15.   Greenux dijo

    pruebo de nuevo

  16.   Claudio dijo

    Buenas, tengo Debian LXDE y no me reconoce la distro. Leí los coment anteriores pero no me sale configurarlo! En la terminal sudo nano /usr/local/share/applications/google-chrome.desktop está vacío y no sé cómo configurarlo. Una ayuda o dos?

  17.   a dijo

    test user agent

  18.   Pavloco dijo

    Probando

    1.    Pavloco dijo

      Ya pude, pero le hice diferente.

      1.    Pavloco dijo

        Carajo sigue mal, yo uso Chromium

  19.   Alejandro Mora dijo

    Probando…..

    Muchas gracias!

  20.   Daniel Rojas dijo

    Probando…

  21.   Aliana dijo

    Probando…

  22.   Aliana dijo

    Hola.

    Escribiendo desde Konqueror, Kubuntu 11.10.

    Después de seguir este truco, mi Chromium 18.0.1025.168 no funciona, me dice:

    “KDEInit no pudo lanzar “usr/bin/chromium”.

    En mi caso tuve que editar el archivo

    /usr/share/applications/chromium-browser.desktop

    para seguir el truco.

    No sé si tengo que cambiar algo además en “/usr/bin/chromium-browser”.

    Y a pesar de que he deshecho el truco, sigo sin tener Chromium.

    Espero no tener que reinstalarlo, para no perder las sesiones que había guardado…

    ¿Alguna ayuda para recuperar Chromium?

    1.    KZKG^Gaara dijo

      Hola 🙂
      Si puedes pon el contenido del archivo que modificaste acá -» http://paste.desdelinux.net
      Para poderlo revisar mejor.

      Yo por acá lo compararé con el mío, y veremos qué tiene mal.
      Saludos ^-^

  23.   Aliana dijo

    Eso mismo iba a proponer, que compartieran el archivo a ver…

    El mío ahora (olvidé ponerle título):

    http://paste.desdelinux.net/4518

    Pero creo que ya lo arreglé.

    Cambié la versión del Chromium del truco (Chromium/14.0.835.202) por la mía (Chromium/18.0.1025.168), que menos mal que tuve la precaución de apuntar antes mi versión… Y parece que ya tengo Chromium de nuevo… Creo… Espero que al volverlo a abrir me siga funcionando…

    Pero el truco no me va, me sigue diciendo arriba que tengo Ubuntu, como antes de seguir el truco.

    Igual lo dejo estar, no sea que lo joda de nuevo.

    Consejo a kubunteros, no toquen nada.

    Gracias por atenderme, admin de nombre extraño 🙂

    1.    KZKG^Gaara dijo

      HAHAHAHAHAHA como me he reído con eso final de “admin de nombre extraño” …. LOL!!!!
      En vista de que mi nick no es tan simple como pensé jaja… mucho gusto, me llamo Alejandro 🙂

      En realidad cuando se redactó este post Chromium no daba problemas por indicarle que es una versión diferente, ni idea del por qué ahora sí tiene ese detalle O_O

      Le pusiste Kubuntu en el UserAgent y te dice que usas Ubuntu? Verifica eso, si es así revisaré el code de nuevo para ver algún bug que se me haya pasado.

      Saludos

      1.    Aliana dijo

        ¿Te refieres a cambiar “Debian Chromium/” por “Kubuntu Chromium/”?

        Probaré, pero me da miedo que al reinicar Chromium se fastidie de nuevo.

        Y como dije más arriba, soy un tipo, mi nombre también comienza por A…

      2.    elav <° Linux dijo

        HAHAHAHAHAHA como me he reído con eso final de “admin de nombre extraño” …. LOL!!!!
        En vista de que mi nick no es tan simple como pensé jaja… mucho gusto, me llamo Alejandro

        Deja la “salsa” que Aliana es un tío xD xD

        1.    KZKG^Gaara dijo

          JAJAJA sabes que yo trato bien a todos jaja

  24.   Aliana dijo

    Sugiero: quizá debieras añadir al truco que cambien la v. de Chromium del código por la que tengan instalada…

  25.   Aliana dijo

    Cambiado “Debian Chromium/” por “Kubuntu Chromium/”, y nada. Me sigue diciendo que estoy en Ubuntu.

    Quitado del todo lo de “Debian Chromium/” y “Kubuntu Chromium/”. Nada.

    Ahora sólo puedo abrir Chromium desde consola, aunque eso es un problema de Kubuntu/KDE que ya arreglaré cuando tenga ganas.

    Por lo menos sabe que es Chromium, algo es algo.

    Lo dejamos ya, tampoco nos vamos a volver locos por un detallito.

  26.   bitblu3 dijo

    mmmm, yo soy un buen usuario de firefox, pero le estoy dando un chance a chromium, y la verdad he notado que usa mejor las bondades de nouveau, que firefox. Saludos

  27.   Fega dijo

    probando con chakra

  28.   Fega dijo

    Tengo instalado Chakra con Google Chrome y no puedo hacer funcionar el User Agent alguien que lo ha hecho puede ayudarme por favor? Agradecido desde ya

  29.   Hyuuga_Neji dijo

    testing Debian + Google Chrome 15

    1.    Hyuuga_Neji dijo

      en /usr/share/aplication no esta el google-chrome.desktop
      en realidad ese archivo esta en /opt/google/chrome/google-chrome.desktop

      1.    Hyuuga_Neji dijo

        mi problema esta en poner la linea que lleva para Debian puesto que en http://www.useragentstring.com/pages/Chrome/ solo aparecen las lineas para Ubuntu,Windows y Macosx

  30.   sieg84 dijo

    probando.

    1.    sieg84 dijo

      bueno, en openSUSE funciona sin mover a nada, pero no uso chrome, es chromium

  31.   Daniel dijo

    prueba

  32.   izzyvp dijo

    Good

  33.   Garbage_Killer dijo

    probando

  34.   Garbage_Killer dijo

    prueba 2

  35.   Dcoy dijo

    Test

  36.   Dcoy dijo

    Test2

  37.   x11tete11x dijo

    test

  38.   Brizno dijo

    funciona

  39.   Brizno dijo

    a ver

  40.   Brizno dijo

    viendo

  41.   José dijo

    Probando Maxton

  42.   Brizno dijo

    qqw

  43.   Brizno dijo

    nnmnm

  44.   Brizno dijo

    mgn mh

  45.   mat1986 dijo

    Probando user agent…

  46.   mat1986 dijo

    A ver si ahora xD

  47.   mat1986 dijo

    Probando plan B…

  48.   mat1986 dijo

    Probando el plan C, si reconoce LXQt

  49.   mat1986 dijo

    Probando user agent con maxthon…

  50.   mat1986 dijo

    Luego de la actualización de chromium, se modificó el useragent personalizado, así que estoy probando de nuevo…

  51.   5ull1v4n dijo

    Probando después de una actualización

    1.    5ull1v4n dijo

      Prueba 2 :v

      1.    5ull1v4n dijo

        otra prueba

  52.   mat1986 dijo

    Probando user agent en qupzilla

    1.    mat1986 dijo

      ¿y ahora?

      1.    mat1986 dijo

        ¿y ahora sí?

  53.   mat1986 dijo

    Revisando actualización de useragent en qupzilla

  54.   Brutico dijo

    Ultima prueba

  55.   Brizno dijo

    probando test de user agent

  56.   Brizno dijo

    Test Test Test test test test

  57.   Brizno dijo

    enesima prueba de user agent

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *