Ang kanela para kay Debian ay hindi garantisadong suporta?

Ang tanong na nagsisimula sa post na ito ay naisip, pagkatapos Clem lefebvre Sasagot ako sa isang puna na naiwan ko sa Cinnamon Blog.

Ang problema ay ito: Kahapon sinubukan kong i-install kanela sa aking PC sa trabaho, kung saan mayroon ako Pagsubok sa Debian + Xfce. Gamit ang repository LMDE I-install ko na ito Talukap ng alimango, tulad ng ginawa nito sa ibang mga okasyon, subalit nabigo ang pagtatangka dahil sa isang pagtitiwala. Lumalabas na kanela kailangan ng package libcogl5 (> = 1.7.4), ngunit ang nasabing pakete ay wala sa mga repository ng Debian.

Sinubukan kong i-install ang bersyon na nasa mga repository ng Ubuntu Oneiric, ngunit nagbigay din ito sa akin ng isang error nang hindi ko ma-overlap ang isang file sa aking system. Upang itaas ang lahat, ang package na magagamit sa Debian, ay nasa mga repository ng Sid para sa arkitektura lamang armhf.

Kaya, pupunta ako at talakayin ang sitwasyon kay Clem at ito ang kanyang tugon:

Kaya problema ni Debian iyon sa palagay ko. Kung magbibigay lamang sila ng pinakabagong libcogl at patuloy na palitan ang pangalan nito, dapat mong asahan na ang Cinnamon at Shell ay tuluy-tuloy na masisira. Sa kalaunan ay lilipat tayo patungo sa bersyon na ito, ngunit sa pangmatagalan kakailanganin ni Debian na tugunan ang problemang iyon.

Ano ang naging katulad nito:

Kaya problema ni Debian iyon sa palagay ko. Kung nag-aalok lamang sila ng pinakabagong libcogl at patuloy na binabago ang kanilang pangalan, dapat mong asahan na ang Cinnamon at Shell ay patuloy na masisira. Sa paglipas ng panahon ay lilipat tayo patungo sa bersyon na ito, ngunit sa pangmatagalan ay kailangang tugunan ni Debian ang problemang iyon.

Alam mo Talagang bahagyang tama siya, ngunit medyo may sakit ako sa parehong bagay na laging nangyayari: Pagkakaisa, ElementaryOS, kanela, lahat nakatuon Ubuntu at ang iba pa na nagbibigay sa kanila ng isang sako. Ngunit mayroon pa ring hindi ko maintindihan Paano ito gumagana kanela en Linux Mint 13, kung ang pakete libcogl5 hindi rin ito matatagpuan sa mga repository ng tumpak? Magtatanong ulit ako Clem.

Ang malinaw sa akin ay iyon LMDE, isang pamamahagi na sa akin (marami na) Nasasabik ako dahil ito ay isang ideya lamang, dapat akong mamatay kung hindi nila ito ilalaan sa bersyon ng Linux Mint sa Debian, ang oras na aabutin. Sana at SolusOS punan ang puwang sigurado akong aalis LMDE sa iyong mga gumagamit.

Nakakahiya talaga, kasi bukod sa Xfce, kanela iisa lang ito Talukap ng alimango de Kapaligiran ng Desktop nakakakuha talaga ng atensyon ko.

 


Ang nilalaman ng artikulo ay sumusunod sa aming mga prinsipyo ng etika ng editoryal. Upang mag-ulat ng isang pag-click sa error dito.

25 na puna, iwan mo na ang iyo

Iwanan ang iyong puna

Ang iyong email address ay hindi nai-publish. Mga kinakailangang patlang ay minarkahan ng *

*

*

  1. Responsable para sa data: Miguel Ángel Gatón
  2. Layunin ng data: Kontrolin ang SPAM, pamamahala ng komento.
  3. Legitimation: Ang iyong pahintulot
  4. Komunikasyon ng data: Ang data ay hindi maiparating sa mga third party maliban sa ligal na obligasyon.
  5. Imbakan ng data: Ang database na naka-host ng Occentus Networks (EU)
  6. Mga Karapatan: Sa anumang oras maaari mong limitahan, mabawi at tanggalin ang iyong impormasyon.

  1.   Angelo Gabriel Marquez Maldonado dijo

    Kaya't sinabi ko sa isang kaibigan: "Sa wakas nakita ko ang ilaw, at pumasok ako sa KDE." Mukhang sa Gnome lahat ay may problema, at hindi lamang sa Ubuntu, kung minsan sa Debian maraming mga pagkakamali ang nangyari sa akin. Gayunpaman, umaasa akong ang mga tao sa Mint ay patuloy na nagtatrabaho sa Cinnamon.

    1.    KZKG ^ Gaara dijo

      Iyon ang dahilan kung bakit tulad ng sinabi ko sa isang kaibigan: "Sa wakas nakita ko ang ilaw, at pumasok ako sa KDE". Parang sa Gnome lahat ay isang problema, at hindi lamang sa Ubuntu, minsan sa Debian maraming pagkakamali ang nangyari sa akin

      AMEN !!!!

      1.    Balangkas dijo

        +1000 !!!!

      2.    angkop dijo

        Oo, ang KDE ay isang talagang mahusay na kapaligiran (:

  2.   Xykyz dijo

    Hindi ko maintindihan kung paano ito maaaring maging problema ni debian kung ang software (kanela) ay iyo. Kung magpasya kang magdala ng isang bagay kailangan mong sundin ang pag-unlad nito at iakma ito sa pamamahagi, kung hindi man ano ang punto? Ayoko naman ng Cinnamon ...

    1.    elav <° Linux dijo

      Ang naintindihan ko ay, iyon ang problema ng Debian ay palitan ang pangalan ng package o gamitin ang pinakabagong bersyon ng package, at hindi iyon ang kanilang problema (Linux Mint). Ngunit inuulit ko, kung ang pakete na ito ay wala sa Tiyak na mga imbakan, na kung saan ay ang batayan ng Linux Mint 13, kung gayon paano ito gumagana? 😕

      1.    Xykyz dijo

        Ngunit naiintindihan ko na kung binago ni Debian ang pangalan at ang bersyon at nagdisenyo ka ng software para kay Debian, ang bagay nila ay iakma mo ang software sa pangyayaring iyon, hindi sa sasabihin mong kasalanan ni Debian at manatiling kalmado. Halika, ito ang aking opinyon.

        1.    elav <° Linux dijo

          Sa katunayan, sumulat ulit ako kay Clem at sa totoo lang, napagtanto niya na ang package na kailangan ng Cinnamon ay wala na rin sa Ubuntu. Kaya't tingnan natin kung ano ang nangyayari sa lahat ng ito.

  3.   rogertux dijo

    Hindi ko alam kung kanino ito kasalanan. Ngunit ang alam ko na ito ay nagpapaalala sa akin ng isang tiyak na Pagkakaisa, na hindi matagumpay na na-port sa anumang iba pang pamamahagi.

    Sinabi nito, tila ang bersyon na batay sa Debian ng Linux Mint ay lalong tinatago. At sa palagay ko sa palagay ko ang koponan ng linux mint ay kailangang magpasya sa pagitan ng pagpapabuti ng suporta ng LMDE o pagpatay lamang dito, dahil ang mga proyektong ito ay hindi maiiwan sa kalahati. (Kunin ito o iwanan ito)

    1.    KZKG ^ Gaara dijo

      Sa loob ng ilang taon ay ipagmamalaki ko na palagi akong naging tama, at ang LinuxMint ay hindi mas mahusay o mas masahol pa kaysa sa Canonical, ngunit tulad din ng mga bastard ¬_¬

      1.    TDE dijo

        Para sa akin ang Linux Mint ay tulad ng Guardiola, at ang Ubuntu ay tulad ng Mourinho. Mas gusto ko si Mourinho.

      2.    José Miguel dijo

        Ganito sila magsalita, dalawa na tayo.

        Pagbati.

      3.    Burjans L Garcia D dijo

        Ang problema ay kung sino ang nag-idealize sa kanila, matagal ko na silang nasa kanilang site .. hindi ito dapat sorpresa kay @elav dahil matagal ko nang pinag-uusapan ang problema sa LMDE ... Pakiramdam ko masaya ako kasama si Debian

        1.    elav <° Linux dijo

          Syempre hindi ako nagulat. Huminto ako sa paggamit ng LMDE matagal na ang nakalipas upang magamit ang "puro" Debian, dahil napagtanto ko na ang LMDE ay hindi kukuha ng pansin na dinadala nito.

  4.   Luis dijo

    Elav, lubos na sumasang-ayon sa iyong puna sa LMDE, na parang isang inabandunang proyekto. Ginamit ko ito dati, ngunit ngayon kasama ko ang mga SolusO. Tila nahuhumaling si Clem sa pagpapatuloy na "pagbutihin ang Ubuntu sa Mint", sa kabutihang palad ay ipinagpatuloy ni Ikey Doherty ang proyekto ng SolusOS, na nagbibigay sa iyo ng isang "klasikong" karanasan sa Linux, na may mahusay na mga estetika at na-update na mga application.

  5.   jamin-samuel dijo

    Napakainteresado ng paksa ...

    Napakahusay din ng paglalakad ng kanela sa Fedora.

    Ano sa palagay ko ay ayaw nilang suportahan ang Debian sapagkat hindi talaga makatuwiran na hindi ito gumagana sa Debian ngunit sa UBuntu ito (¬_¬) O ang Ubuntu ay naiiba sa Debian?

    Para sa akin ito ay na si G. Clem ay hindi nais malaman ang tungkol sa Debian ngunit upang makabuo ng higit pa sa Ubuntu.

  6.   shiba87 dijo

    Mula sa nakikita ko, kapwa sa Debian at Ubuntu ang naroroon ay libcogl9, na tumutugma sa bersyon 1.10 ng libcogl, iyon ay, sumusunod ito sa hiniling sa mga dependency ng libcoglX (> = 1.7.4).

    Siguro ako ang nakakakita ng napakadali, ngunit magiging isang bagay ng paglalagay bilang mga dependency:
    libcogl5 (> = 1.7.4)

    Lugar:
    libcogl5 (> = 1.7.4) | libcogl9 (> = 1.7.4)

    At kaunti pa, hindi ang pakete ay hindi, ngunit ang pangalan ay hindi tumutugma sa kasalukuyang ginagamit.

    1.    shiba87 dijo

      Ang ibig niyang sabihin ay "sa halip na maglagay" at hindi "tanong ng paglalagay"

    2.    elav <° Linux dijo

      Sakto Gayunpaman, dahil napansin ng Clem ang problemang iyon, sa palagay ay itatama nila ang error sa ilang sandali.

  7.   Giskard dijo

    Tingnan natin kung ano ang sinasabi ng pahina ng LinuxMint:

    http://www.linuxmint.com/download_lmde.php

    FAQ tungkol sa LMDE
    1. Ang LMDE ay katugma sa mga edisyon ng Linux Mint na batay sa Ubuntu?
    Hindi kaya. Ang LMDE ay katugma sa Debian, na hindi tugma sa Ubuntu.

    Tulad ng nakikita mo, ang pagiging tugma ay pababa. Kung mapapansin nila ito kaagad. Nagdidisenyo sila para sa Ubuntu at sa gayon ay ginagawa itong katugma sa Mint at mga bagay na nagmula sa Ubuntu, ngunit hindi paitaas.

    Tila sa akin ito ay napakalinaw.

    1.    elav <° Linux dijo

      Tandaan na kinukuha ng Ubuntu ang mga pakete nito mula kay Debian, samakatuwid, kung ano ang kasama o hindi kasama mula sa Debian ay nakakaapekto sa kanila, maliban kung ito ay kanilang sariling pakete o nagpasya silang panatilihin ito. Ngunit hindi ito ang kaso, ang libcogl5 ay wala sa Tiyak ...

  8.   Christopher dijo

    Kung nais mong mai-install ang Cinnamon sa pagsubok sa debian ay mag-install mula sa isang lumang imahe ng pagsubok mula 6 na buwan na ang nakakaraan kung saan halos pareho ito sa mga package ng LMDE, idagdag ang mga repositoryang LMDE at i-install ang Cinnamon. Pagkatapos gawin ang ligtas na pag-upgrade hangga't maaari upang hindi ito ma-uninstall dahil lamang sa "Mga pagkakamali sa pagtitiwala"

  9.   auroszx dijo

    Ano ang kakulangan ng suporta mula sa Linux Mint ¬¬

  10.   Vicky dijo

    Ginagawa ng bawat isa ang kaya nila, sa palagay ko ang linux mint o tim ng elementos ay may napakaraming mapagkukunan, hindi lahat ng mga proyekto ay kde. Gusto ko sila bilang mga proyekto, at magiging maganda kung mai-install ang pantheon shell o cinamon sa anumang distro, ngunit sa ngayon ay hindi posible at kung mas gusto ng mga developer na mag-focus sa iba pang mga bagay sa halip na maaaring dalhin, pupunta ako pintasan ito sapagkat upang masabing wala pa talaga akong nagawa para sa kanila, o nag-donate o anumang katulad nito, upang may utang sila sa akin.

  11.   komentarista dijo

    Hindi ko alam, sa palagay ko maraming mga proyekto ang ipinanganak at naging isang pang-amoy sa loob ng maikling panahon, ngunit pagkatapos ay nahulog sila sa limot (Bulaklak ng ilang araw). Iyon ang dahilan kung bakit ginusto ko ang mga proyekto na may mas maraming oras at iyon ay hindi nakasalalay sa pagiging bago.