Pangunahing programa sa pseint (bahagi 3)

Ito ay pagpapatuloy ng tutorial Pangunahing programa sa pseint (bahagi 2), sa oras na ito ay ipapaliwanag ko kung ano ang kinakailangan sa programa.

TAKDANG ARALIN

Ang Takdang Aralin ay isang proseso kung saan ang isang variable ay nilikha at / o binago, na tinutukoy ito sa pamamagitan ng pagkakakilanlan nito kung saan maaari nating ma-access ang memorya ng espasyo.

ang syntax ng takdang-aralin ay:

[variable]<- [expresion];
[variable]=[expresion];

Kung saan ang [variable] ay ang variable na tumatanggap ng halaga ng pagsusuri ng [expression]. Pareho ang wasto kaya't hindi mahalaga kung alin ang ginagamit (kung na-configure nila nang tama ang PSeInt), ngunit sa palagay ko nilikha ko ang una bilang tama.

Kung ang [variable] ay wala pa bago ang takdang-aralin, nilikha ang [variable], kung mayroon ito ang dating halaga ay nawasak at ang bago ay inilalagay sa lugar nito. Para sa kadahilanang ito, ang pagmamapa ay itinuturing na isang mapanirang operasyon.

PAGBASA

Ang pagbabasa ay ang proseso kung saan ang isang data o data ay hiniling mula sa gumagamit upang maiimbak ang nasabing data sa isang variable.

ang syntax nito ay:

Leer variable_1,variable_2,...,variable_n;

kung saan ang [variable_ {1,2, n}] ay ang (mga) variable na tumatanggap ng halagang ibinigay ng gumagamit, kung sakaling mahigit sa isang variable ang hiniling, hihilingin muna nito ang una, pagkatapos ay para sa pangalawa at iba pa hanggang sa natanggap ang lahat ng mga halaga.

Ito rin ay isang mapanirang pag-andar.

PAGSULAT

Ang pagsusulat ay ang proseso kung saan ang isang string ng mga character at / o isa o higit pang mga variable ay nakasulat sa screen

ang syntax ay:

Escribir expresion_1,expresion_2,...,expresion_n;

kung saan ang [expersion_ {1,2, n}] ay ang mga string ng character at / o mga variable na ipapakita.

Ang pagsusulat bilang karagdagan sa pagtanggap ng data na mailalagay sa screen ay tumatanggap din ng tagubilin na "Nang walang paglaktaw" o "Nang hindi bumababa" na maiwasan ang linya na tumalon.

Ang pagsusulat ay hindi nagdaragdag ng mga puwang sa pagitan ng mga argumento, iyon ay, kung inilalagay mo:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

sa kasong ito ipapakita nito ang «olamundo» dahil sa pagitan ng «a» at «b» walang mga string ng mga character na nagsasaad ng puwang sa pagitan ng a at b, upang maipakita nang wasto ito ay nakasulat nang ganito:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

sa kasong ito idagdag »» na kung saan ay isang string ng character na may puwang na puwang sa pagitan ng «alon» at «mundo» at pagkatapos ay ipapakita nito ang «alon ng mundo» sa puwang.

KUNG TAPOS

Ito ay isang pangungusap na sinusuri ang isang naibigay na kundisyon at sinusuri ang katotohanan at / o kasinungalingan ng nasabing kundisyon, iyon ay, kung ang kondisyon ay nakamit o hindi.

Ang syntax nito ay:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Ang sugnay na "Iba Pa" ay hindi sapilitan, sa kasong ito kung ang kondisyon ay maling balewalain ang mga tagubilin at magpatuloy na parang wala ang pangungusap, sa kasong ito mananatili ito:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Kung ang sugnay na "Nabigo" ay inilagay o hindi ay nakasalalay sa mga pangangailangan ng program na iyon.

AYON

Ang pangungusap habang sinusuri nito ang isang mahigpit na variable ng bilang na nagbibigay ng higit sa 2 mga pagpipilian bilang isang pagpipilian, ito ay naiiba mula sa "Kung-Pagkatapos" dahil ang nakaraang isa ay maaari lamang magbigay ng 2 mga pagpipilian.

Ang syntax ay:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Tulad ng nakikita mo pagkatapos ng «number1» mayroong isang «:» at pagkatapos nito ay isasagawa ang mga tagubilin na inilalagay sa kasong «numerical variable = number1», sa pangalawang halimbawa ito ay «number2, number3» nangangahulugan ito na kung ang «numeric variable = number2 o number3" pagkatapos ay "mga tagubilin" ay naisakatuparan, kapaki-pakinabang ito kapag ang 2 posibilidad ay dapat na isagawa ang parehong mga tagubilin.

Mayroon ding sugnay na "In Another Way" na naisakatuparan sa kaganapan na wala sa mga posibilidad na natupad.

HABANG

Ito ay isang paulit-ulit na pagpapaandar na unang sinusuri ang isang kundisyon at pagkatapos kung natupad ito ay nagsasagawa ng isang serye ng mga tagubilin pagkatapos susuriin muli ang kundisyon at kung totoo ito ay nagpapatupad muli ng parehong mga tagubilin at nagpapatuloy na tulad nito hanggang sa ang kondisyon ay mali.

kung ang kundisyon ay hindi totoo mula sa simula hindi na ito naisasakatuparan at kung ito ay laging totoo ay mailalagay ito sa isang walang katapusang loop, upang maiwasan ang huli sa mga tagubilin dapat mayroong isang bagay na sa ilang mga punto ay pinipintasan ang kondisyon na nakatapos ng loop.

ang syntax nito ay:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

ULIT-HANGGANG

Ito ay isang pagpapaandar na halos kapareho ng naunang isa, ngunit hindi katulad ng naunang isa, susuriin ng isang ito ang kalagayan sa dulo, iyon ay, ang utos ay papatayin ng hindi bababa sa 1 oras, din sa halip na ipatupad ang tagubilin kung totoo ito, isinasagawa ito habang Kung ang kalagayan ay hindi natutugunan, ngunit kung nais mong maipatupad habang natutugunan ang kundisyon, gamitin ang "habang" sa halip na "hanggang".

ang syntax nito ay:

Repetir
[Instrucciones] hasta que [condicion]

PARA SA

Ang pahayag na ito ay nagpapatupad ng isang tagubilin sa isang pagtukoy ng bilang ng beses para sa isang variable, hindi katulad ng naunang mga, binago ng siklo na ito ang halaga ng variable na pinag-uusapan nang mag-isa, pati na rin ang pagkakaroon ng isang napakalakas na syntax.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

Ang "Variable" ay ang variable na tumatanggap ng "paunang halaga" at isinasagawa ang mga tagubilin pagkatapos ay nagdaragdag ng "variable" kasama ang "hakbang" at muling isinasagawa ang mga tagubilin hanggang sa ang "variable" ay katumbas ng "pangwakas na halaga".

Kung ang "may [hakbang]" ay tinanggal pagkatapos ay sa default malalaman nito na ang "hakbang" ay katumbas ng 1, gayun din kung ang [hakbang] ay hindi tinukoy at ang "paunang halaga" ay mas malaki kaysa sa "pangwakas na halaga" idadaan ito sa baligtarin ang pagkakasunud-sunod, iyon ay, "Hakbang" ay -1

SUBPROCESS / FUNCTION

Ang isang thread o pagpapaandar ay isang programa sa loob ng iba pa at ang subprogram na ito ay tumatanggap ng isa o higit pang mga halaga, pinapatakbo ang mga ito at nagbabalik ng isa pa. Ang syntax nito ay

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

kung saan ang "return variable" ay ang variable na naglalaman ng halagang ibinalik ng function na "pangalan ng pag-andar" na tumanggap ng mga parameter na "arg_1, arg_2, arg_n" upang maisagawa ito

IBA PANG

Ito ang mga pagpapaandar na komplementaryo lamang sa iba at walang kumplikadong syntax dahil ang mga ito ay mga pantulong na pagpapaandar lamang.

Malinaw na screen

Ang pagpapaandar na ito ay naglilinis ng screen ng anumang bagay sa interpreter

Wait Key

Naghihintay ang pagpapaandar na ito para sa gumagamit na pindutin ang isang key upang magpatuloy sa programa

Maghintay x {Pangalawa, Millisecond}

ang pagpapaandar na ito ay naghihintay ng isang oras sa segundo o milliseconds upang magpatuloy sa programa

PS: Paumanhin sa pagkaantala ngunit abala ako sa iba pang mga bagay kaya't hindi ako nakasulat


Ang nilalaman ng artikulo ay sumusunod sa aming mga prinsipyo ng etika ng editoryal. Upang mag-ulat ng isang pag-click sa error dito.

10 na puna, iwan mo na ang iyo

Iwanan ang iyong puna

Ang iyong email address ay hindi nai-publish. Mga kinakailangang patlang ay minarkahan ng *

*

*

  1. Responsable para sa data: Miguel Ángel Gatón
  2. Layunin ng data: Kontrolin ang SPAM, pamamahala ng komento.
  3. Legitimation: Ang iyong pahintulot
  4. Komunikasyon ng data: Ang data ay hindi maiparating sa mga third party maliban sa ligal na obligasyon.
  5. Imbakan ng data: Ang database na naka-host ng Occentus Networks (EU)
  6. Mga Karapatan: Sa anumang oras maaari mong limitahan, mabawi at tanggalin ang iyong impormasyon.

  1.   Guille dijo

    Walang mga pag-andar upang makuha ang mga key nang hindi hinihinto ang pagpapatupad? Para sa paggawa ng isang bagay na may kilusan na mas nakakaakit sa 9 na taong gulang, kahit na ang isang hangman game ay maaari ding maging masaya na programa.

    Iproseso ang isang bagay_digo
    isang <-1;
    pag-ilid <-30;
    pababa <-5;
    Habang ang isang = 1 Gawin
    Malinaw na screen;
    c <-1;
    linya <- "";
    Ulitin
    linya <-line + "";
    c <-c + 1;
    Hanggang sa c = lateral
    linya <-line + "X";
    c <-1;
    Ulitin
    Magsulat ng " ";
    c <-c + 1;
    Hanggang sa c = down-1
    Sumulat ng linya;
    Ulitin
    Magsulat ng " ";
    c 2 Pagkatapos
    pababa <-down-1;
    Tapusin oo
    "s":
    Kung sa ibaba <15 Kung gayon
    pababa 2 Pagkatapos
    pag-ilid <-lateral-1;
    Tapusin oo
    "d":
    Kung sa pag-ilid <50 Kung gayon
    pag-ilid <-lateral + 1;
    Tapusin oo
    "0":
    isang <-2;
    Pagtatapos ng Segundo
    Tapusin Habang
    Proseso ng pagtatapos

  2.   Guille dijo

    Mabigo kung umakyat ka, mas mabuting baguhin ang mga linya 23 at 28
    -23 Hanggang sa c = 15
    +23 Hanggang sa c = 18
    y
    -28 Kung pababa> 2 Pagkatapos
    +28 Kung pababa> 3 Kung gayon

    1.    xnmm dijo

      Salamat sa kontribusyon ngunit mayroon itong ilang mga problema tulad nito binubuksan mo ang isang pangungusap sa loob ng isa pa ngunit dapat itong magtapos sa loob ng pangungusap kung saan ito nagsimula, ibig kong sabihin, hindi ito mailalagay

      Iproseso ang isang bagay
      isang <- 0;
      basahin sa;
      kung ang a ay hindi katumbas ng 25 pagkatapos
      habang ang a ay hindi katumbas ng 0 gawin
      basahin sa;
      Tapusin oo
      magtapos habang

      tulad ng nakikita mo ang loop habang nagsisimula sa loob ng pahayag na "kung gayon" ngunit nagtatapos sa labas nito, isang bagay na tulad nito ay hindi posible.

      Pinahahalagahan ko pa rin ang kontribusyon
      Proseso ng pagtatapos

      1.    Guille dijo

        Salamat, ngunit sa palagay ko ito ay higit pa sa isang problema sa paglalagay ng code dito, na hindi ko alam kung paano ito ilagay sa uri ng code at lalabas ito nang walang pagkakakuryente.

        Mabuti ang programa. Ang variable na "a" simpleng ginagamit ko upang lumabas sa loop kapag nag-type ang gumagamit ng isang zero. Maaari kang maglagay ng exit () o pahinga; sa kondisyon na tinitingnan ito at nai-save ko ang variable. Ang mga ito ay mga pagpipilian.

        Pagbati.

      2.    Guille dijo

        Susubukan kong palitan ang mga tab para sa mga puwang at mga label por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille dijo

        Puno iyon ng mga error sa pag-import mula sa aking code, susubukan ko ulit sa mga tab:
        Ito ang magiging file na algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille dijo

        Kagiliw-giliw, ang komentong may mga label ng code ay kinakain, tinanggal, anuman ang pumasa, halimbawa sa pagitan ng mga linya
        Ulitin
        Magsulat ng " ";
        c
        pagkatapos ng c mayroong a
        at pagkatapos ay nagpapatuloy ito sa 3 Pagkatapos
        pababa
        Sa pangkalahatan, hindi ito maaasahang ilagay ayon sa kung anong mga code.

  3.   Guille dijo

    Binabago ko ang mga simbolo mula sa pagtatalaga sa = upang makita kung paano.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille dijo

      Patuloy itong kumakain ng bahagi ng code, nabigo ang code tag, dapat iwanan ang pagsulat tulad ng dati.

      1.    xnmm dijo

        Kumusta paumanhin para sa hindi ko nakita na sumagot ka dati ngunit mabuti
        dahil hindi mo mai-publish nang maayos ang code dahil hindi mo ito ipinapadala sa akin sa pamamagitan ng koreo kaya't hindi mo nabibigyan ng maraming liko ang bagay.