Tutorial: I-install ang .tar.gz at .tar.bz2 Packages

Sa una kapag nagsimula kami sa Linux at naghahanap ng isang programa, normal na makahanap kami ng isang .deb o .rpm at sa maraming mga kaso nakakahanap kami ng mga program na may extension .tar.gz y .tar.bz2Ang mga file na ito ay naka-compress at karaniwang naglalaman ng mga tagubilin upang mai-install ito bukod sa programa.

Ang pag-install para sa dalawang uri ng mga pakete ay eksaktong pareho

Pumunta muna kami sa folder kung saan mayroon kaming file, kung ang folder ay may maraming mga salita kailangan naming ilagay ang mga ito sa "" o kung hindi ito naghahanap ng mga folder sa bawat salita

cd folder kung saan matatagpuan ang file na cd "folder kung saan ang file ay"

Sa loob ay tinatanggal namin ang zip file

tar -zxvf filename.tar.gz tar -jxvf filename.tar.bz2

I-configure namin

. / I-configure

Ginagawa namin (pinagsama-sama)

gumawa

Ngayon ay mag-install

gumawa ng i-install

Minsan maaari itong bigyan tayo ng isang error sa ./configure, sa kasong iyon hindi ito kailangan ng compilation at sa pagpapatupad mayroon kaming maraming, sa isang terminal na ginagawa namin

Kaugnay na artikulo:
Nag-uutos na malaman ang system (kilalanin ang hardware at ilang mga pagsasaayos ng software)
pangalan ng programa

O lumilikha kami ng isang launcher.


Ang nilalaman ng artikulo ay sumusunod sa aming mga prinsipyo ng etika ng editoryal. Upang mag-ulat ng isang pag-click sa error dito.

102 na puna, iwan mo na ang iyo

Iwanan ang iyong puna

Ang iyong email address ay hindi nai-publish. Mga kinakailangang patlang ay minarkahan ng *

*

*

  1. Responsable para sa data: Miguel Ángel Gatón
  2. Layunin ng data: Kontrolin ang SPAM, pamamahala ng komento.
  3. Legitimation: Ang iyong pahintulot
  4. Komunikasyon ng data: Ang data ay hindi maiparating sa mga third party maliban sa ligal na obligasyon.
  5. Imbakan ng data: Ang database na naka-host ng Occentus Networks (EU)
  6. Mga Karapatan: Sa anumang oras maaari mong limitahan, mabawi at tanggalin ang iyong impormasyon.

  1.   moscosov dijo

    wena, +1

  2.   angkop dijo

    talagang ang tamang bagay upang i-unzip ay
    tar -zxvf file.tar.gz
    tar -jxvf file.tar.bz2

    at para sa pag-configure mayroong isang infinity ng mga pagpipilian (depende sa software) upang ipasadya ang pag-install

    ./configure -help

    Gamit iyon makikita nila ang iba't ibang mga karagdagang pagpipilian kapag nag-install ng isang programa.
    Hindi lahat ng mga pamamahagi ay gumagamit / usr / lokal upang mag-install ng mga programa, na dapat ding nabanggit din.

    Nakalimutan mong banggitin kung paano mag-uninstall ng isang program na naka-install sa ganoong paraan. Bilang karagdagan sa pagtukoy ng mga pag-optimize para sa bawat arkitektura.

    Gayunpaman, mahusay na pagkukusa ngunit napalampas mo ang maraming… masyadong maraming impormasyon upang ibahagi.

    Regards

    1.    tapang dijo

      Ito ay isang bagay na hindi ko pa nagamit, ang karamihan sa mga program na nakita ko sa mga opisyal na repository.

      Ang katotohanan tungkol sa decompressing ay palaging mabuti para sa akin tulad nito.

      Sinulat ko ito sapagkat nakakaabala sa akin ang lahat ng nagsasabing, "kapag na-unzip mo ito binasa ang mga tagubilin."

      Gayunpaman, nakikita ko ang .tar.gz bilang huling paraan, kung wala sa package ng deb / rpm o sa mga repository

      1.    angkop dijo

        "Ang katotohanan tungkol sa decompressing ay palaging mabuti para sa akin ng ganito."
        sumasang-ayon kami, hindi ko pinagtatalunan iyon, ngunit hindi ito nangangahulugan na ito ang tamang bagay na dapat gawin. Hindi lahat ng mga distrito ay decompress na "matalino", ang ilan ay kailangang magdagdag ng higit pang mga parameter.

        1.    tapang dijo

          Man, hindi ko kasalanan na may mga subnormal distros hahahaha

          1.    angkop dijo

            KISS man ... KISS

          2.    tapang dijo

            Man, hindi moron ang KISS, alam mo na sa Slackware hahahaha

          3.    angkop dijo

            xD
            Iyon ang dahilan kung bakit sinabi ko sa iyo iyan

            Simple! = Madali.

  3.   Yoyo dijo

    +1 para sa nararapat

    1.    Pepe dijo

      Isa pang asshole kaysa sa isa pa. Ang "henyo" na ito ay wala sa paksa.

  4.   Lithos523 dijo

    Kung binago mo ang "make install" sa "checkinstall" (maaari mo itong mai-install nang may kakayahan, ito ay nasa mga repository) i-install nito ang programa, ngunit din:
    -Lumikha ng isang .deb upang mai-install mo ito sa mga darating na okasyon
    -Ang naka-install na programa ay lilitaw sa Synaptic, kaya madali mong mai-uninstall ito mula doon

    1.    tapang dijo

      Ang mga gumagamit ng arko ay nasangkot dito sa Aptitude ...

  5.   jelpasajero dijo

    Paumanhin sa aking kamangmangan, ngunit nalulutas ba ng alien app ang lahat ng mga problemang iyon?

    1.    angkop dijo

      hindi, dahil gumagana ang alien na may naipon na mga package at tar.gz o tar.bz2 ay naka-compress na mga file na may source code.

  6.   pandev92 dijo

    Hindi mo talaga magawa ang isang tutorial dito, madalas, kahit papaano ang mga qt package ay naipon sa iba pang mga mas kakaibang paraan.

    1.    hypersayan_x dijo

      Saktong sasabihin ko ang parehong bagay.
      Ang mga gumagamit ng qmake mula sa Qt ay higit pa o mas kaunti tulad nito:


      cd CarpetaPrograma
      qmake
      make
      sudo make install

      At nagdagdag ako ng isa pang kaso na ang mga cmake:


      cd CarpetaPrograma
      mkdir build
      cd build
      cmake ..
      make
      sudo make install

      O may iba pa na kailangang magpatakbo ng make && sudo make install.
      Iyon ang pinakakaraniwang mga kaso, ngunit maraming iba pa: s

      1.    mcder3 dijo

        May mga oras na ang ilang mga application na ginawa sa QT ay hindi nagdadala ng makefile. Kaya oras na upang likhain ang mga ito sa sumusunod na linya:

        qmake -makefile

        Regards

  7.   jelpasajero dijo

    Tingnan natin kung maaari kong linawin, kapag kailangan kong gumamit ng tar.gz o isang tar.bz2 lahat ng ginagawa ko upang makabuo ng isang .deb o isang all.deb na gumagamit ng alien ay upang ilagay ang sudo alien install + pangalan ng package. Hindi ba pareho iyon sa pag-iipon?

    1.    hypersayan_x dijo

      Hindi, ang pag-iipon ay binabago ang source code ng programa sa machine code.
      Sapagkat kung ano ang gagawin mo sa dayuhan ay muling pag-pack na kung saan ay nagko-convert ang format ng package ng isang pamamahagi sa format ng package ng isa pang pamamahagi.
      Upang gawing mas simple ito, ito ay parang mayroon kang isang file na naka-compress sa RAR at nais mong i-convert ito sa ZIP, i-decompress mo ang file sa RAR at i-compress muli ito sa ZIP, iyon ang ginagawa ng dayuhan.

  8.   StuMx dijo

    Ang pagtitipid ay tapos na sa gumawa, hindi sa pag-configure. Ang configure file ay isang script na nagpapatunay na ang system ay sumusunod sa lahat ng mga dependency upang maipon ang programa, pagkatapos ay bumubuo ito ng make file (na kung saan ay tumutukoy kung paano ito maiipon) ayon sa aming system.

    1.    tapang dijo

      Ngayon tinatanggal ko ito dahil ang artikulong ito ay matagal na mula noong isinulat ko ito noong Abril o Mayo. Hindi ko ito nasuri halos alisin ang ilang masamang salita wala nang iba

  9.   jelpasajero dijo

    Hola:
    Sa palagay ko hindi ko masyadong ipinapaliwanag ang aking sarili. Ang alien ay hindi lamang binabago ang isang rpm package sa isang .deb, kung kukunin mo ang source code ng isang programa, maging gz, o bz2 binago nito ito sa isang pag-install ng debugger. Kaya't ang tanong ko. Nasa isang maikling panahon ako sa Linux, tiisin mo ako.

  10.   Balangkas dijo

    patawarin ang aking kamangmangan, ngunit ang mga hakbang na ito ay may bisa din sa Chakra, o may nagbabago ???

    1.    KZKG ^ Gaara dijo

      Wala namang tao 😀
      Tulad ng naturan, ang mga hakbang na ito ay halos isang pamantayan sa lahat ng mga distrito, ngunit hindi ito 100% sigurado na palaging mga hakbang na ito ang sinusundan. Kaya inirerekumenda ko na palagi mong basahin ang file ng pagtuturo (README karaniwang) bago gumawa ng anumang bagay.

    2.    angkop dijo

      tulad ng @ KZKG ^ Sinabi ni Gaara, hindi ito palaging kaso, ito ay isang pamantayan na gagana para sa lahat ng mga distro hangga't nakasulat ang programa sa C / C ++

  11.   Carlos-Xfce dijo

    Kapag nahaharap ulit ako sa isang .tar.gz ng mga muli, babalik ako sa artikulong ito. Paano ko kinamumuhian ang gayong mga pakete!

    1.    tapang dijo

      Damn ikaw ay may sapat na gulang upang mai-install ang mga package HAHAHAHAHA

  12.   VulkHead dijo

    Ipagpaumanhin ang aking kakulangan ng kaalaman, gumagana rin ang paraan ng pag-install na ito para kay Debian. Sapagkat sinusubukan ko at sinusubukan ko at nagbibigay ito sa akin ng isang error.

  13.   Laura Tejera dijo

    Iyon ang dahilan kung bakit walang gumagamit ng linux, upang gumawa ng anumang hangal ay isang trick

    1.    elav dijo

      Gaano kataka-taka, ang ilan sa mga hangal na bagay na binabanggit mo, ang "sobrang galing" na mga gumagamit ng Windows at OS X ay hindi maaaring gawin ang mga ito, o natatakot sa kanila.

      1.    Laura Tejera dijo

        ang nakakatawa ay kung paano ang mga tao tulad mo ay maaaring sundin ang tulad ng isang saradong OS.

        1.    KZKG ^ Gaara dijo

          Iniwasan mo bang sagutin ang tanong? ... Maaari bang magawa ng mga gumagamit ng Windows o henyo ng OS X ang maraming bagay sa kanilang system tulad ng ipinakita namin sa site na ito? 🙂

          Sa pamamagitan ng paraan, gumagamit ka ng Ubuntu kaya ... ano ang pinag-uusapan natin?

          1.    Laura Tejera dijo

            panatilihin ang katahimikan manga

            1.    KZKG ^ Gaara dijo

              Medyo ba tayo? ... Uff ... LOL!


      2.    Pepe dijo

        Nasa taong 2015 tayo!
        Sa palagay ko hindi kinakailangan na mag-aksaya ng maraming oras sa pag-aaral upang gumana mula sa console.
        Bakit hindi gumamit ng mga awtomatikong aplikasyon para dito?
        Sa anumang kaso, ang mga "nais" na magsulat ng mga utos mula sa console doon, hayaan silang magpatuloy na gawin ito, ngunit sa kahanay ay kinakailangan na magkaroon ng parehong mga awtomatikong utos. Hindi kita hinihiling na magpadala ng isang rocket sa buwan.

    2.    Santiago Luis Bazan dijo

      Ang mga kadahilanan para sa paggamit ng libreng software ay etika sa moralidad. Huwag kailanman payagan ang sinuman na tanggihan ang kanilang kalayaan sa tao

      1.    Pepe dijo

        Ang katotohanan na ang sanata ng "kalayaan" sa mga programa ay nagsawa na ako. Hindi ba nila mapigilan ang pagpuri sa isang di-umiiral na diyos at maging mas mapagpakumbaba?

    3.    Pepe dijo

      Tama ka Laura, ang mga taong ito sa kanilang Linux ay kumplikado ito sa buto. Sa put0 windows mas madali ang mga bagay. Hindi ko pinapahiya ang Linux ngunit hindi ito maaaring mag-install ng anumang pel0tudes na gugugol mo ng oras at oras sa pagsisiyasat kung paano gumagana ang tar at lahat ng meresunda upang sa pagtatapos ng araw ay makaalis ka sa "nagsisimula sa Linux ...".

      Nilalayon kong gumamit ng isang matatag na operating system ngunit hindi kumuha ng maraming oras sa aking produksyon dahil kailangan kong magtrabaho, wala akong pagnanais na maging isang "nagtapos sa Linux".

  14.   Thanatos dijo

    May isang bagay na palaging nawawala ... kapag nagbibigay ako ./configure nakukuha ko: configure: error: Ang iyong intltool ay masyadong luma. Kailangan mo ng intltool 0.35.0 o mas bago.

    Kasunod ay nagbabalik ang tagubilin sa paggawa: Walang tinukoy na target at walang nahanap na makefile. Mataas

    gumawa ng pag-install: Walang patakaran upang mabuo ang target na `i-install

    Ako ay isang newbie at mahusay na magsaliksik upang malaman, ngunit FUCK, hindi mo ba ito maipaliwanag sa mga may kulay na maliliit na bato para sa atin na bago sa Linux?

    1.    Ponchus dijo

      Thanatos Mayroon akong isang katulad na problema at ibinabahagi ko ang aking kinalabasan:
      (Una sa lahat, upang linawin na ako din ay isang neophyte sa mundo ng Linux at ang aking mga pakikipagsapalaran sa kontekstong ito na may "lasa" (distro) sa Ubuntu ay isang linggo).
      Ipagpalagay na pumapasok ito sa aking folder na «Mga Pag-download» gamit ang utos «cd» kung saan ang aking pakete ng programa na «SoulSeek» na nagtatapos «.tgz» ay matatagpuan sa terminal o console:
      Ang "./Configure" ay nagbigay sa akin ng isang error na wala ang file o direktoryo
      Ang "make" ay itinapon sa akin ang parehong error tulad mo ... kaya hindi ako nagpatuloy sa utos na "sudo make install" (sudo ay dahil kinakailangan ng Ubuntu ang "Super User at ang kanyang password" upang patakbuhin ang utos na ito, sa madaling salita gawin ang isang pag-install ).
      Sinisiyasat ang dating hindi naka-zip na file, napagtanto ko ang isang bagay na maaaring mangyari sa iyo at iyon ay ang hindi naka-zip na file ay ng uri ng "maipapatupad na file" (mga tamang pag-click na pag-aari) at 2 pag-click ay sapat upang maisagawa ito.
      Ang iyong problema sa «./configure» ay maaaring malutas sa isang pag-update ng mga pakete o repository (ang mga katagang ito ay malito ako) na naka-install sa iyong Distro, dahil sasabihin nito sa iyo na ang «intItooI» ay luma na at kailangan mo ng isang mas bago at ako isipin na marahil ang package na ito ay ang isa na nag-iipon sa iyong distro. Sa Ubuntu mo ito ginagawa sa parehong terminal sa pamamagitan ng pag-type ng "sudo apt-get update" at i-update ang lahat ng mga pakete sa system.
      Sana naging kapaki-pakinabang ako.

    2.    Pepe dijo

      Tulad ng sinabi ko kay Laura, ang bagay na ito sa Linux ay tumatagal ng mahabang panahon. Binigyan ako nito ng parehong mensahe ng error tulad ng sa iyo at naglalakad ako tulad ng multo ng Canterville mula sa isang lugar patungo sa isa pa at wala talaga.

      Sinabi sa akin ng aking boss: "Mayroon kang 2 araw upang makahanap ng solusyon, kung hindi, babalik kami sa mga bintana."

  15.   Jonathan dijo

    Salamat

  16.   Ivan dijo

    hello mayroon akong parehong problema na nais kong i-install ang skype 4.0. sa aking pclinuxOS, na-download ko ang tar, gz2 at decompressed at hanggang doon ako pumunta, kapag ginawa ko ./configure sinasabi nito sa akin na ang file ay hindi umiiral .. saan ako nawala o ano? sabihin sa akin, sa pclinuxOS (ang huling inilabas na bersyon) na-install ang skype ngunit ito ay bersyon 2.2 at nais kong i-install ang 4,
    Mayroon bang anumang trick na dapat kong gawin upang sa wakas mai-install ito? isang bagay sa synaptic na hindi ko alam ???
    Bago ako sa sistemang ito, sinubukan ko na ang iba pang mga distrito dati at sa ngayon ay maayos ang lahat maliban dito ..

    tungkol

    1.    Pepe dijo

      Ako ba o hindi sa tingin ko may nakakaalam ng mga katanungang ito.

    2.    F7eo dijo

      Kumusta, matagal na ang panahon ng iyong katanungan.

      Inirerekumenda ko na i-download mo ang pinakabagong bersyon ng Skype para sa Windows (R)
      at ginagamit mo ang Alak upang patakbuhin ito sa iyong distro ng GNU-Linux.

  17.   serbesa dijo

    Kamusta! Mayroon akong parehong problema: na-download ko ang pinakabagong bersyon ng center software na may enxtension tar.gz at nang makarating ako sa "./configure" na halimbawa ay nakakuha ako ng isang error, tulad ng sa "make". ANO ITO "?? SALAMAT !! Bukod sa na-block ng software center ang pagpipilian upang mai-install !!!

  18.   Carlos Rivera dijo

    Salamat, malaki ang naitulong nito sa akin !!!!

  19.   Miguel dijo

    kung paano lumikha ng isang launcher

  20.   Angi dijo

    Isang tanong, maaari mo bang suriin ang mga dependency ng isang tar.gz file bago patakbuhin ang ./configure ???

  21.   Joseluis dijo

    Bago ako sa linux, tila napakahirap i-install ang mga tar gz gz2 tablets at kung makakakuha ako ng isang debate wala itong mga dependency at pareho ang rpm kung ito ay i586 o i686 o i386 at ang pinakapangit na bagay ay wala akong internet sa bahay ko. Ang nakakakita ng labis na puna na sumasalungat sa isa ay nakalilito sa iyo ng mas masahol pa.

  22.   gabriel yamamoto dijo

    magandang impormasyon, ngunit ang ilang mga * .tar.bz2 na mga pakete ay naipon at upang mai-install ang mga ito kailangan mo lamang i-unzip ang mga ito sa anumang folder (mas mabuti / opt upang magamit ito sa lahat ng mga gumagamit) at gumawa ng isang direktang pag-access sa binary sa / usr / local / basurahan

  23.   Gonzalo dijo

    Napakagandang paliwanag kung paano gamitin ang mga tar.gz file. Maraming salamat sa impormasyon. Pagbati sa lahat ng koponan

  24.   juancuyo dijo

    Hindi ito gumagana para sa akin
    cd / home / ju / downloads / icecat-24.0 ——-> Tumutugon sa akin
    bash: cd: home / ju / downloads / icecat-24.0: file o direktoryo ay wala
    anong mali kong ginagawa ??? Ang operating system ay Voyager 14.04 LTS (xubuntu) Xfce desktop Gdebi ay wala sa menu ng nilalaman at hindi rin synaptic ngunit ang mga ito ay nasa start menu, kahit na buksan mo ang mga ito, hindi nila makilala ang mga folder, parang ginawa nila wala. Na-unzip ko ito sa parehong folder ng pag-download. Mali ba itong na-unzip ????

  25.   Claudio dijo

    Gumagana din ang tutorial na ito para sa .tgz?

    1.    joakoej dijo

      Hindi, ang .tgz ay ang format na ginagamit ng Slackware at naipon na sila, na-download mo man o naipon ito mula sa isang slackbuild

    2.    joakoej dijo

      Upang mai-install ito kailangan mong gumamit ng installpkg na "pangalan ng package".

  26.   asdf dijo

    Paumanhin ngunit hindi nito masyadong nalulutas ang problema, kapag sinabi mo ./configure at ise-configure namin ito, dapat mong tukuyin ang higit pa, tama ba? kung ilalagay ko lang ./configure sinasabi nito sa akin
    bash: ./configure: Walang file o direktoryo

    pagkatapos sasabihin mong "gumawa kami"
    Code:
    gumawa
    Ang aking resulta:
    gumawa: *** Walang tinukoy na target at walang nahanap na makefile. Mataas

    Gumawa ng pag-install
    gumawa: *** Walang patakaran para sa pagbuo ng target na "i-install". Mataas

    At pagkatapos ay sasabihin mong "pinapatakbo namin ang programa"
    Code:
    Pangalan ng programa

    Paano ko malalaman kung alin ang pangalan o alin ang naisakatuparan? Napaka-abstract, marahil ay binigyan mo ng basta-basta ang maraming mga bagay na malalaman mo, ngunit ang mga darating upang makita ang isang tutorial ay maaaring hindi alam

    1.    Damian dijo

      asdf

      Nag-iimbestiga ako at ang error na lumilitaw kapag nagbibigay ./configure ay dahil sa kakulangan ng compilation program (paano kami makakapagsulat nang walang pagkakaroon ng isang programa na ginagawa ito?). ang utos na mag-install ng isang tagatala upang ipasok ay:

      sudo aptitude install install-mahalaga

      sa sandaling na-install, pumunta kami sa folder kung saan ang file upang i-unzip ay at isagawa:

      tar -zxvf program_name.tar.gz

      Pagkatapos ay ipinasok namin ang hindi naka-zip na folder ng programa, at kung doon namin isinasagawa ./configure at pagkatapos ay sudo gumawa ng pag-install

      Sana nakatulong ako!

      Pagbati.

      1.    Damian dijo

        Paumanhin, nakalimutan kong linawin, sa aking kaso upang maisagawa ang "make" at ang "sudo apt-get install program" kailangan kong ipasok ang folder na "base" sa loob ng unzipped folder, doon ko lang kinuha ang mga utos upang mag-ipon (gumawa ) at ang pag-install.

      2.    Carlos dijo

        Nagbibigay ito sa akin ng mga problema kapag ginamit ko na sinasabi na hindi ito nakakahanap ng anumang maitatayo

  27.   Brenda dijo

    Paumanhin mayroon akong problemang ito pinapatakbo ko ang utos na ito ipinapakita nito sa akin ang isang error at hindi ako makakalikha ng makefile
    desktop: ~ / Nagda-download ng $ tar -jxvf iReport-4.1.3.tar.bz2
    tar (bata): iReport-4.1.3.tar.bz2: Hindi mabuksan: Walang file o direktoryo
    tar (anak): Hindi maibabalik ang error: lumabas ngayon
    alkitran: Ang bata ay bumalik sa katayuan 2
    tar: Hindi maibabalik ang error: lumabas ngayon
    pakiusap =)

  28.   Aaron dijo

    Magandang araw mga kaibigan,
    Bago ako sa linux, gayunpaman, nagkaroon ako ng kaunting abala pagdating sa pagkilala sa isang aparato na isang digital biometric reader, nag-google lang ako at tila nahanap ko subalit, nag-download ito gamit ang isang .tar.gz extension, subukang i-unzip ito sa isang folder, maraming mga file ang na-unzip ngunit hindi ko alam kung pagkatapos nito ay kailangan kong magpatakbo ng ibang bagay o i-paste ang mga hindi naka-zip na file sa isang folder sa system, hindi ko alam, kung tutulungan mo ako, upang patakbuhin ang proseso ng maayos, ako ay magiging napaka nagpapasalamat, mayroon akong naka-install na linux Debian 7 sa OS. Pagbati at maraming salamat.

  29.   Rufo López Retortillo dijo

    Gumagamit ako ng parehong Linex 2011 at Linex 2013 at ang pinakamalaking problema na nakita ko kapag nag-install ng mga application ay hindi sila na-load sa listahan ng mga application sa kanilang pangkat (graphics, office, multimedia, atbp.) At kung nais kong lumikha ng isang launcher hindi alam kung saan ako dapat pumunta upang hanapin ang file ng launcher ng application. Saang folder mo ito nilikha? Paano ito magagawa?
    Kapag na-install ang mga ito mula sa mga repository ang mga launcher ay inilalagay sa kanilang pangkat, magagawa ba ito sa pamamagitan ng pag-install ng tar.gz tulad ng inilarawan sa web na ito
    Salamat sa tulong

  30.   Carlos dijo

    Mangyaring tulungan mayroon akong isa pang operating system na tinatawag na lps 1.5.5 at hindi ko ma-update ang programa

  31.   Carlos dijo

    Mangyaring sabihin sa iyo muli na hindi ko ma-unzip ang isang tar.bz2 file Mayroon akong isang operating system na tinatawag na lps 1.5.5 at hindi ko alam kung paano ito gamitin, mangyaring tulungan ako, salamat ...

  32.   joscastel dijo

    pagkatapos ma-unpack ang bz2 file, ang utos ./configure ay HINDI gumagana dahil HINDI ito umiiral

    1.    joscastel dijo

      Mayroon akong ubuntu 14.04LTS

  33.   alam mo dijo

    Hindi ko maintindihan, sa slax ang .tar.gz ay pumupunta sa sinehan, ngunit sa ubuntu wala akong paraan upang mag-ipon

  34.   Raul dijo

    Ano ang pinakamahusay na OS? ang pinakamahusay na OS ay nalulutas nito ang iyong mga problema.

  35.   Juanzito dijo

    Ang mga taong linux ay kamangha-mangha. Sinusubukan kong mai-install ang ZinjaI sa aking bagong naka-install na distro ng LinuxMint nang hindi bababa sa 5 oras.
    Naglalakad ako sa lahat ng mga forum na nakita ko at sa lahat (ngunit lahat, kabilang ang isang ito), binibigyan ka nila ng kalahati ng impormasyon.
    Halimbawa, binuksan ko na ang terminal, ngunit hindi ko mailagay ang address kung saan matatagpuan ang na-download na file (na kung saan ay / tahanan / gumagamit / Mga Pag-download / zinjai).
    Ang nakukuha ko lang ay isang error: "bash: cd: user: Walang ganoong file o direktoryo.
    Naiintindihan ko na nais nilang ikalat at palaganapin ang paggamit ng isang operating system, ngunit, pagtanggi sa impormasyon o ipaliwanag ang lahat sa kalahating hakbang, ang tanging bagay na makakamit nila ay, ang mga gumagamit na tulad ko, na may matatag na balak na lumipat mula sa Windows patungo sa Linux, sumuko at manatili sa aking W7, masama ngunit kapaki-pakinabang at mapapamahalaan.

    Cheers…

    PS: Ano ang gastos sa kanila ng isang miserable installer na may isang graphic na interface? Bakit ngayon sa siglo XXI, dapat ba silang magpatuloy na gumamit ng isang bagay na katulad sa DOS upang mai-install ang isang malungkot na maliit na programa?. Mga lalaki ... upang makita kung sila ay nabubuhay nang kaunti ....

    1.    Ocelot dijo

      cd ~ / Mga Pag-download / path ng pag-install ng script.

      Isang tip: dumikit sa mga bintana. Ang bawat operating system ay ginawa para sa isang uri ng tao. Ginagawa ang Windows para sa mga taong mas gusto mabigyan ng lahat ng ground at may pinakamaliit na pagsisikap at nakikita ko ang kaso mo. Mayroong mga tao na hindi o hindi nais na maghangad ng isang bagay na higit sa susunod, susunod, susunod ... tanggapin. Hindi iyon masama, kailangan lang nating malaman ang ating mga limitasyon at umangkop sa mga ito.

      Isa pang tip: Kung alam mo lang kung gaano karaming mga bagay ang nakakamit na may kababaang-loob at paggamit ng dalawang salita tulad ng "mangyaring." Sorpresahin ka nito Gawin ito madalas.

      1.    Knario dijo

        Kumusta mga Linuxeros.
        Maraming salamat sa tutorial, nakatulong ito sa akin na mai-install ang mga driver para sa dwa-131 wifi adapter.
        Mayroon akong kaunting pagdududa, nagawa ko na ang lahat ayon sa sinabi nila sa itaas.
        Pumunta sa file path, gawin ang tar .... at pagkatapos ay Gumawa, hintaying matapos ito at pagkatapos ay mag-install.
        Hanggang sa hakbang na iyon, hindi ito nagbigay sa akin ng anumang mga error.
        Ang tanong ko ay upang malaman kung mayroon na akong naka-install na mga driver o kailangan kong gumawa ng iba pa.
        Juanzito .. sige at bigyan ng pagkakataon ang Linux, anuman ang pamamahagi, napagpasyahan kong iwanan ang Windows 7 isang linggo na ang nakakaraan at mas nawala ako kaysa sa impiyerno, hahaha, ngunit sa pagbabasa dito at doon makikita mo ang impormasyon na kung minsan mahirap para sa iyo To maunawaan, ang lahat ay nakasalalay sa pagsisikap ng bawat isa na nais na matuto at makalabas sa monopolyo kung saan binibigyan ka ng Windows (ito ang aking palagay).
        Isang bagay ... sa terminal ng Linux, bilangin ang mga malalaking titik. 😉

        PS: Kailangan kong gumawa ng iba pa pagkatapos ng pag-install ng Kame. ??

        Maraming salamat sa inyo.
        Maraming salamat at pagbati mula sa Canary Islands.

      2.    Mga arko dijo

        At sino ka upang sabihin sa isang gumagamit na bumalik sa X system? Sa tingin mo Richard stallman?

        Sumasang-ayon ako kung ano ang sinasabi nila sa ilang mga puna na ang pinakamahusay na OS ay ang isa na ang sistema ay umaangkop sa gumagamit at HINDI sa kabilang banda.

        Personal kong mahal ang Windows .exe dahil tulad ng sinabi mong hindi mo kailangang maging isang henyo sa computer upang mai-install ang isang bagay na napaka-simple tulad ng isang simpleng notepad; kumpara dito sa linux na kung wala ito sa nakatuon na mga aplikasyon ng software na dumidikit ka sa gusot ng siglo gamit ang isang tablet.

        Nakarating ako dito na naghahanap at nag-oorganisa ng impormasyon upang mag-install ng mga programa sa Linux dahil naghahanda akong mai-install ang mint sa isang produktibong makina at alam ko na kung hindi ako naghahanda hindi ako makakapag-install ng anumang bagay kung wala ito sa mga repository.

        Ngayon ang "pakiusap" na hinihiling ng bawat isa, ang problema ay walang sumasagot sa kanila, kaya nga minsan ang mga tao ay dapat maging agresibo kaya huwag magsabi ng kalokohan.

      3.    Pablo dijo

        sorry .. ngunit palagi kong naipagtanggol ang paggamit ng libre at bukas na software .. Gumagamit ako ng mga computer sa loob ng 30 taon .. at ako ay 37 ..
        ang problema ay sa pangkalahatan sa linux perpekto na ang sinumang nagnanais o dapat na "malaman" nang kaunti pa para sa isang simpleng bagay tulad ng pag-install ng isang programa, isang pag-update o kung ano pa man ... ang problema ay dumating na maraming mga tao ang kailangang gumana at gumamit ang pc (sa anumang OS) upang gawin ang tiyak na gawain sa trabaho .. kaya kahit na tumatagal ng 10 minuto upang i-download ang isang .gz at mai-install ito .. o kung tulad ng nangyayari ang karamihan ay lilipas ang mga oras .. minuto o oras silang hindi kayang gawin ang iyong trabaho at doon halos lahat ng nauubusan ng pasensya ..
        Sa aking kaso .. sa trabaho ay gumagamit lamang ako ng Ubuntu na kung saan ay kung ano ang na-install bilang default sa mga PC, dahil ito ay isang pang-agham na sentro, ngunit ginagawa akong gumugol ng mas maraming oras sa pagsubok na i-install o kahit na malutas kung paano gumawa ng isang malambot na tukoy (halimbawa Ako ay isang geographer) gumagana ito .. o na pagkatapos ng anumang pag-update nito .. bawiin ang lahat ng mga tool dahil ang kalahati ay huminto sa pagtatrabaho sa loob ng isang programa ..
        sa partikular na kaso na ito .. Kailangan kong makita ang isang webinar / forum sa trabaho .. at dahil gumagamit sila ng java miss ko ang pag-sign na dapat kong i-update ito .. ok .. pumunta sa site ng java .. hanapin ang file para sa aking OS , 14.04 .. tingnan ang pag-download at pag-install ng "" mga tagubilin "" .. i-download ang isang .gz at mula doon .. i-unzip .. ok, at… sinasabi nito na "i-install" .. at voila .. tanging hindi mo magawa gumawa ng kahit ano sa impormasyon ng post na ito .. ano ang gagawin ko sa sandaling na-unzip ko ang «jre-blablabla of a habang buhay.gz» ??

  36.   Carlos Fabian Ferra dijo

    hindi ito nagtrabaho para sa akin sa anumang distro

    1.    Yukiteru dijo

      Kung hindi ito gumana para sa iyo, ito ay purong Layer 8.

      1.    Yank Carlos dijo

        Genius!

  37.   Ignacio Navarro dijo

    Habang ginagamit ko ito paminsan-minsan, sa tuwing pumapasok ako dito upang makita kung paano ito ginagawa.
    Maraming salamat sa pagsulat nito at sa hindi pagtanggal nito sa mahabang panahon.

  38.   ramon dijo

    tulad ng nakikita mo sa synaptic na naka-install ang bagong pakete kung ipinapakita nito sa iyo ang pinakaluma (matatag ayon sa distro) ¿?

  39.   Jorge dijo

    ang lahat ay napupunta sa tae pagdating sa ./configure walang sinuman na nagpapaliwanag nang maayos para sa sinabi nitong wala ang file

    1.    Elvis dijo

      Sinusubukan kong mag-install ng wifi mula sa broadcom alinman ./configure, ni gumawa o gumawa ng pag-install na gumagana.

      ang lohikal na pagkakasunud-sunod ay unang pagpapatupad ./configure ngunit tila ang tagubiling ito ay tumutukoy lamang sa isang direktoryo ng pag-configure at pagpapatupad ng ilang file na inilagay doon, dapat itong dumating sa pakete na na-download mula sa broadcom ngunit sa aking kaso ang direktoryong ito ay wala roon, dapat na isagawa ang pag-configure ay isang tseke at likhain ang file ng Makefile, ngunit kapag inaalis ang zip ng package na napagtanto ko na ang Makefile ay isinasama, ang dalawa pang utos na gumawa at gumawa ng pag-install ay hindi gagana para sa akin, ito ay dahil sa pinakabagong bersyon ng elementarya os ay hindi sinusuportahan ito freya batay sa ubuntu 1

    2.    Alejandro TorMar dijo

      Ang katotohanan? Ang pamamaraang ito ay hindi kailanman nagtrabaho para sa akin at palagi akong nag-opt para sa .deb packages o utos mula sa Terminal ... Napakasama walang malinaw na mai-install .tar.gz

  40.   Elvis dijo

    Sinusubukan kong mag-install ng wifi mula sa broadcom alinman ./configure, ni gumawa o gumawa ng pag-install na gumagana.

    ang lohikal na pagkakasunud-sunod ay unang pagpapatupad ./configure ngunit tila ang tagubiling ito ay tumutukoy lamang sa isang direktoryo ng pag-configure at pagpapatupad ng ilang file na inilagay doon, dapat itong dumating sa pakete na na-download mula sa broadcom ngunit sa aking kaso ang direktoryong ito ay wala roon, dapat na isagawa ang pag-configure ay isang tseke at likhain ang file ng Makefile, ngunit kapag inaalis ang zip ng package na napagtanto ko na ang Makefile ay isinasama, ang dalawa pang utos na gumawa at gumawa ng pag-install ay hindi gagana para sa akin, ito ay dahil sa pinakabagong bersyon ng elementarya os ay hindi sinusuportahan ito freya batay sa ubuntu 1

  41.   Alejandro TorMar dijo

    Ang katotohanan? Ang pamamaraang ito ay hindi kailanman nakatulong sa akin at palagi akong nag-opt para sa .deb packages o utos mula sa Terminal ... Napakasama walang malinaw na mai-install .tar.gz

  42.   Alejandro TorMar dijo

    Bakit hindi na-update ang tutorial na ito? O gumawa ba sila ng bago?
    Ang bawat tao'y dito ay nagreklamo na hindi ito nagsilbi sa kanila at mayroon na itong mga taon ....

  43.   HECTOR MATOS dijo

    Kumusta, gusto ko ng tulong, sa pag-install ng mga pakete .. Mayroon akong bersyon ng 15 na Ubuntu .. isang bagay .. Nais kong i-install ang adobe flash plugin, sapagkat napaka kapaki-pakinabang na mai-install ito, dahil sa adobe flash maaari akong magpasok ng ilang mga web page , kung saan maaari mong makita ang TV at makinig din sa radyo .. mangyaring maaari kang magpadala sa akin ng isang sunud-sunod na tutorial .. Wala akong masyadong karanasan sa linya ng utos na sasabihin na gumamit ng isang terminal.

    Tulong..thanks

  44.   Abraham dijo

    Kamusta sa lahat !!! Matapos basahin ang halos lahat ng mga puna ay naghanap ako ng isang manual na linux at iyon lang ..
    Kaibigan OCELOTE, tanggapin ang pintas na ito, mula sa aking mapagpakumbaba at walang gaanong pananaw na ibinabahagi ko sa milyun-milyong mga gumagamit ng Windows:

    Gusto kong lumipat sa linux! ngunit marami sa atin ang nahahanap na imposible, bakit? magtataka ka ... sapagkat para sa akin ang computer ay ang paraan na kailangan kong gawin ang aking gawain, hindi ito ang katapusan ... Hindi ko alam kung naiintindihan mo kung ano ang gusto natin (at sinabi sa iyo ng mabuti ni JUANZITO) ay isang matatag na operating system na makakatulong sa amin upang maisakatuparan ang aming trabaho, wala akong oras upang malaman kung paano gumawa ng mga pangunahing bagay tulad ng pag-install ng isang programa mula sa console, ang lahat ay dapat na mas madaling maunawaan at madali ... Bilang isang negosyante I sasabihin sa iyo na ang pamamahala na dala mo sa Linux ay mapanganib, sa halip na tulungan ang mga tao na gawin ang pagbabago ng operating system ay pinipilit mong magsinungaling ang mga tao sa mga bagay na hindi interesado sa kanila at hinaharangan mo ang pagbabago. Ang isa na nagprograma sa sinasabi sa iyo ng assembler, java, javascript, html, php at xbase ... at hinahawakan nito ang aking ilong na kailangang buksan ang console para sa halos lahat.

    Isang pagbati

  45.   defcon dijo

    Stamina DOS 6.22 old !!

  46.   burahin dijo

    Ilagay ka sa pag-aaral at iwanan ang tae ng wuendos na gumagana para sa ilan dahil ginagawa nila ang mga put bilang mga susi, hindi nila ito binabayaran, upang magdagdag ng insulto sa pinsala ang mga gumawa ng mga susi na iyon ay ang mga henyo ng linux at dapat sila ay Tulad ka ng tanga tinatalakay ang mga mamahuevadas, sa mga negosyante na sinasabi ko sa kanila, panatilihin ang pagbabayad ng kanilang lisensya at kung ang nais nila ay matatag kaya, nanalo sila ng oras kung ano ang ginagawa nilang pagsulat ng mga asshole sa mga tuto na ito para sa atin na gusto ng mga linux assholes…. . daliri po ang ace

  47.   GENNDA dijo

    Hindi ito masyadong malinaw para sa mga gumagamit ng baguhan. Halimbawa sinasabi mong:
    «Una kaming pumunta sa folder kung saan mayroon kaming file, kung ang folder ay may maraming mga salita kailangan naming ilagay ang mga ito sa" "o kung hindi ito tumingin para sa mga folder sa bawat salita» ...
    Ang sinumang gumagamit ay papasok sa mga folder na ito gamit ang «explorer», at papalitan ang pangalan nang hindi alam ang pangalan ng folder na naglalaman nito ng mga marka ng panipi. Na mula sa pananaw na nabasa mo ito, «mula sa pananaw ng gumagamit ng baguhan.

    Pagkatapos ay inilagay mo:
    cd folder kung nasaan ang file

    cd "folder kung saan ang file ay"
    Mula sa puntong iyon, ang gumagamit ay napunta na sa mga ulap o saanman, dahil mula ngayon nawala siya sa CD na may mga inisyal, hindi mo linilinaw kung paano ka makakarating doon, isang sunud-sunod na halimbawa, nagsisimula sa lahat ng iyon .. . ay binubuksan muna ang console.

  48.   GENNDA dijo

    Para sa HECTOR MATOS: Ang plugin ng adobe, java, at iba pa ay hindi kailangang gawin nang manu-mano, kakailanganin mo lamang na konektado sa internet nang ilang sandali, at sa manager ng pag-update lilitaw itong awtomatikong, mula doon awtomatiko itong mag-a-update, para sa Firefox sa Opera, at ang natitira nang nakapag-iisa ... karaniwang ang launcher ay katabi ng orasan sa start bar, sa maraming mga distro nakita ko na bilang default ito ay naroroon, hindi ko alam kung magiging ganun sa lahat sa kanila

  49.   Max dijo

    Mangyaring maging mas malinaw, maraming impormasyon ang nawawala

  50.   Mary dijo

    subukang i-update ang sawa sa 3.x at gawin ang pag-install sa pagkumpleto ay nagsasabi sa akin na mayroong isang error:
    zipimport.zipimporterror ay hindi maaaring decompress data zlib hindi magagamit gumawa *** error sa pag-install

  51.   f_leonar dijo

    Matapos ang pag-unzip upang tumakbo ./configure kinakailangan upang ipasok ang unzipped direktoryo, kung hindi man ay hindi ito gumana. Gumagamit ako ng KDE at graphic na ipinasok ko ang folder na na-unzip ko at doon binuksan ko ang isang terminal upang maisagawa ang "make" ngunit hindi ito gumagana ...

  52.   Hindi kilala dijo

    Mayroon akong isang katanungan, nakukuha ko ito:
    manolo @ mxlolo-satellite-c655d: ~ / Desktop $ ./configure –help
    bash: ./configure: Walang ganoong file o direktoryo
    ano ang ginagawa ko…?

  53.   KATSODA dijo

    Lahat mabuti hanggang sa lumabas ang ./ configure ng mga bola.
    ANONG IBIG MONG SABIHIN !? Hindi nila ito ipinaliwanag, nais ko lamang i-install ang pangalawang buhay na Fucking xddd
    «»»katsoda@katsoda-PC:~/Downloads$ ‘/home/katsoda/Downloads/Second_Life_5_0_4_325124_i686’/configure
    bash: / home / katsoda / Mga Download / Second_Life_5_0_4_325124_i686 / configure: Ang file o direktoryo ay walang »» »
    Mas mahusay kong i-download ang Windows 10 at kunin ang asno. (?)
    Hindi. Ngunit ito ang isa sa mga bagay na kinamumuhian ko tungkol sa Linux. Ang pag-install, at pagdarasal na ang iyong mga paboritong programa ay tugma dito ay isang hamon.

    1.    Gatoo_ dijo

      Hindi mag-abala, mga ginoo, ngunit ang tagalikha ng tutorial na ganap na nagpapaliwanag kung ano ang gagawin kung nakakuha ka ng isang error sa ./configure. Kailangan mo lang tapusin ang pagbabasa ng natitirang tutorial (na 4 na linya).

      Napansin kong hindi kapani-paniwala na maraming mga tao ang nagreklamo na hindi nito ipinapaliwanag ang mga bagay na hindi ka pa tumitigil upang mabasa.

  54.   Biyernes dijo

    Sa gayon, opisyal kong idineklara ang aking sarili na walang kakayahan para sa ganitong uri ng mga file. Sinusubukan kong mag-install ng java at ito ang ano;
    javier @ loft: ~ / JAVA / jre1.8.0_151 $ tar -zxvf jre-8u151-linux-x64.tar.gz
    tar (bata): jre-8u151-linux-x64.tar.gz: Hindi mabuksan: Walang file o direktoryo
    tar (anak): Hindi maibabalik ang error: lumabas ngayon
    alkitran: Ang bata ay bumalik sa katayuan 2
    tar: Hindi maibabalik ang error: lumabas ngayon

  55.   Roger deku dijo

    sa linux ubuntu 18.04.01 lts kailangan mo lamang i-type ./name ng programa sa parehong folder pagkatapos i-unzip ito at voila !!!

  56.   jia dijo

    Napakagandang, ito ay napaka kapaki-pakinabang.

  57.   emerson Goncalez dijo

    sa av linux hindi ito gumagana
    Hindi ko alam kung ano ang kakaiba; o sa tuwing nag-i-install ka ng distro sinisimulan mo ang paraan ng krus
    nakikita mo kung paano pumunta ang keyboard

  58.   Jose Felix Paisano Morales dijo

    Kamusta kayong lahat, gumagamit ako ng Ubunto 20 at kinunsulta ko ang pahinang ito upang mai-install ang scanner ng isang Epson L4150 (na-download ko ang mga drive mula sa http://support.epson.net/linux/en/imagescanv3.php?version=1.3.38#ubuntu).
    Sinunod ko ang mga hakbang at ginamit ang 'tar -zxvf filename.tar.gz', nang ang pag-unzipping ay ginamit ko
    '$ cd photoscan-bundle-ubuntu-20.04-3.63.0.x64.deb', na kung saan ay ang folder na nilikha.
    Sa loob ng folder na ginamit ko ang './install.sh', na tulad ng paggamit ng './configure', tinanong ako ng system para sa aking password at lahat ng naka-install na maayos.
    Sinubukan ko ang aking scanner at ito ay mahusay, salamat sa pagbibigay sa akin ng mga direksyon, nagamit ko ang aking scanner