Eğitim: .tar.gz ve .tar.bz2 Paketlerini Yükleme

Başlangıçta Linux'ta başlayıp bir program aradığımızda, bir .deb veya .rpm bulmamız normaldir ve çoğu durumda uzantıya sahip programlar buluyoruz. .tar.gz y .tar.bz2Bu dosyalar sıkıştırılmıştır ve genellikle programdan ayrı olarak yüklemek için talimatlar içerir.

Bu iki tür paketin kurulumu tamamen aynıdır

İlk önce dosyanın bulunduğu klasöre giriyoruz, eğer klasörde birkaç kelime varsa bunları "" ile koymamız gerekiyor veya her kelimeyle klasör aramıyorsa

dosyanın bulunduğu cd klasörü cd "dosyanın bulunduğu klasör"

İçeride dosyayı açıyoruz

tar -zxvf dosyaadı.tar.gz tar -jxvf dosyaadı.tar.bz2

Yapılandırıyoruz

. / Yapılandırma

Yaparız (derleriz)

yapmak

Şimdi kur

make install

Bazen bize ./configure'da bir hata verebilir, bu durumda derlemeye ihtiyaç duymaz ve yürüttüğümüz bir terminalde bol miktarda sahibiz.

nasıl
İlgili makale:
Sistemi tanıma komutları (donanımı ve bazı yazılım yapılandırmalarını tanımlayın)
program adı

Veya bir fırlatıcı yaratırız.


Makalenin içeriği şu ilkelerimize uygundur editoryal etik. Bir hata bildirmek için tıklayın burada.

102 yorum, sizinkini bırakın

Yorumunuzu bırakın

E-posta hesabınız yayınlanmayacak.

*

*

  1. Verilerden sorumlu: Miguel Ángel Gatón
  2. Verilerin amacı: Kontrol SPAM, yorum yönetimi.
  3. Meşruiyet: Onayınız
  4. Verilerin iletilmesi: Veriler, yasal zorunluluk dışında üçüncü kişilere iletilmeyecektir.
  5. Veri depolama: Occentus Networks (AB) tarafından barındırılan veritabanı
  6. Haklar: Bilgilerinizi istediğiniz zaman sınırlayabilir, kurtarabilir ve silebilirsiniz.

  1.   Moscosov dijo

    wen, +1

  2.   uygun dijo

    aslında açmak için doğru olan şey
    tar -zxvf dosya.tar.gz
    tar -jxvf dosya.tar.bz2

    ve yapılandırma için kurulumu özelleştirmek için sonsuz seçenek (yazılıma bağlı olarak) vardır

    ./configure –help

    Bununla, bir programı kurarken farklı ek seçenekleri görecekler.
    Tüm dağıtımlar program yüklemek için / usr / local kullanmaz, bunun da belirtilmesi gerekir.

    Bu şekilde yüklenen bir programı nasıl kaldıracağınızı söylemeyi unuttunuz. Her mimari için optimizasyonları tanımlamaya ek olarak.

    Her neyse, iyi bir girişim ama çok fazla bilgi kaçırdınız… paylaşmak için çok fazla bilgi.

    selamlar

    1.    cesaret dijo

      Neredeyse hiç kullanmadığım bir şey, resmi depolarda bulduğum programların çoğu.

      Dekompresyonla ilgili gerçek şu ki, benim için her zaman böyle iyi oldu.

      Onu yazdım çünkü "fermuarını açtığınızda talimatları oku" diyenler beni rahatsız ediyor.

      Her neyse, deb / rpm paketinde veya depolarda yoksa son çare olarak .tar.gz'yi görüyorum.

      1.    uygun dijo

        "Dekompresyonla ilgili gerçek şu ki, benim için her zaman böyle iyi olmuştur."
        Katılıyoruz, buna itiraz etmiyorum, ancak bu yapılacak doğru şey olduğu anlamına gelmez. Tüm dağıtımlar sıkıştırmayı "akıllıca" açmaz, bazılarının daha fazla parametre eklemesi gerekir.

        1.    cesaret dijo

          Adamım, normalin altında dağıtımların olması benim hatam değil hahahaha

          1.    uygun dijo

            Öpücük adamım ... öpücük

          2.    cesaret dijo

            Adamım, KISS salak değil, bunu zaten Slackware ile biliyorsun hahahaha

          3.    uygun dijo

            xD
            Bu yüzden sana bunu söylüyorum

            Basit! = Kolay.

  3.   Yoyo dijo

    Uygun için +1

    1.    Pepe dijo

      Diğerinden bir pislik daha. Bu "dahi" konu dışı.

  4.   Lithos523 dijo

    "Make install" seçeneğini "checkinstall" olarak değiştirirseniz (bunu uygun bir şekilde yükleyebilirsiniz, depolarda bulunur), programı da yükleyecektir, ancak:
    -Gelecekte yükleyebilmeniz için bir .deb oluşturun
    -Yüklenen program Synaptic'te görünecek, böylece buradan kolayca kaldırabilirsiniz

    1.    cesaret dijo

      Arch kullanıcıları, Aptitude ile ilgileniyor ...

  5.   Jelpasajero dijo

    Cehaletim için üzgünüm ama uzaylı uygulaması tüm bu sorunları çözüyor mu?

    1.    uygun dijo

      hayır, çünkü alien derlenmiş paketlerle çalışır ve tar.gz veya tar.bz2 kaynak koduyla sıkıştırılmış dosyalardır.

  6.   pandev92 dijo

    Bununla ilgili bir eğitim yapamazsınız, çoğu zaman, en azından qt paketleri başka, hatta daha tuhaf şekillerde derlenir.

    1.    hypersayan_x dijo

      Ben de aynısını söyleyecektim.
      Qt'den qmake kullananlar aşağı yukarı şu şekildedir:


      cd CarpetaPrograma
      qmake
      make
      sudo make install

      Ve cmakes olan başka bir durum ekliyorum:


      cd CarpetaPrograma
      mkdir build
      cd build
      cmake ..
      make
      sudo make install

      Veya make && sudo make install'ı çalıştırması gereken başkaları da var.
      Bunlar en yaygın vakalardır, ancak daha birçok varyant vardır:

      1.    mcder3 dijo

        QT'de yapılan bazı uygulamaların makefile getirmediği zamanlar vardır. Öyleyse bunları aşağıdaki satırla oluşturma zamanı:

        qmake -makefile

        selamlar

  7.   Jelpasajero dijo

    Bakalım, bir tar.gz veya tar.bz2 kullanmam gerektiğinde, alien kullanarak bir .deb veya all.deb oluşturmak için tek yaptığım, sudo alien install + paket adı koymaktır. Bu derlemekle aynı şey değil mi?

    1.    hypersayan_x dijo

      Hayır, derleme, programın kaynak kodunu makine koduna dönüştürmektir.
      Oysa yabancı ile yaptığınız şey, bir dağıtımın paket formatını başka bir dağıtımın paket formatına dönüştüren yeniden paketlemedir.
      Daha basit hale getirmek için, sanki RAR'da sıkıştırılmış bir dosyanız var ve onu ZIP'e dönüştürmek istiyorsunuz, dosyayı RAR'da açıp tekrar ZIP'de sıkıştırmalısınız, uzaylıların yaptığı budur.

  8.   StuMx dijo

    Derleme yapılandırmada değil make'de yapılır. Configure dosyası, sistemin programı derlemek için tüm bağımlılıklarla uyumlu olduğunu doğrulayan bir betiktir, ardından sistemimize göre make dosyasını (nasıl derleneceğini tanımlayan dosya) oluşturur.

    1.    cesaret dijo

      Şimdi onu kaldırıyorum çünkü bu makale, Nisan veya Mayıs aylarında yazdığım zamandan beri zaten uzun bir zaman. Kontrol etmedim neredeyse kötü bir kelimeyi kaldırdım başka hiçbir şey

  9.   Jelpasajero dijo

    Selam
    Kendimi pek iyi açıklamadığımı düşünüyorum. Alien sadece bir rpm paketini .deb'e dönüştürmekle kalmaz, bir programın kaynak kodunu alırsanız, ister gz ister bz2 olsun, onu kendi kendine yüklenen bir hata ayıklayıcıya dönüştürür. Bu yüzden sorum. Uzun zamandır Linux kullanıyorum, bana katlan

  10.   Marco dijo

    cehaletimi affedin, ama bu adımlar Çakra'da da geçerlidir veya bir şey değişir mi ???

    1.    KZKG ^ Gaara dijo

      Hiç erkek yok 😀
      Evet, bu adımlar neredeyse tüm dağıtımlarda standarttır, ancak bunların HER ZAMAN izlenecek adımlar olduğundan% 100 emin değildir. Bu yüzden herhangi bir şey yapmadan önce her zaman talimat dosyasını (genellikle README) okumanızı tavsiye ederim.

    2.    uygun dijo

      @ KZKG ^ Gaara'nın dediği gibi, bu her zaman böyle değildir, program C / C ++ ile yazıldığı sürece tüm dağıtımlar için çalışacak bir standarttır.

  11.   Carlos Xfce dijo

    Yine bunlardan bir .tar.gz ile karşılaştığımda, bu makaleye geri döneceğim. Bu tür paketlerden nasıl nefret ediyorum!

    1.    cesaret dijo

      Kahretsin, bu paketleri kuracak kadar yaşlı mısın HAHAHAHAHA

  12.   VulkKafa dijo

    Bilgi eksikliğim için üzgünüm, bu kurulum yöntemi Debian için de çalışıyor. Çünkü deniyorum ve deniyorum ve bu bana bir hata veriyor.

  13.   Laura Tejera dijo

    Bu yüzden kimse Linux kullanmıyor, aptalca bir şey yapmak bir hile

    1.    ela dijo

      Ne kadar ilginç, bahsettiğiniz bazı aptalca şeyler, "süper yetenekli" Windows ve OS X kullanıcıları bunları yapamıyor veya onlardan korkuyorlar.

      1.    Laura Tejera dijo

        komik olan şey, sizin gibi insanların bu kadar kapalı bir işletim sistemini nasıl takip edebilecekleri.

        1.    KZKG ^ Gaara dijo

          Soruyu cevaplamaktan kaçındınız mı? … Windows kullanıcıları veya OS X dahileri, sistemleriyle bu sitede gösterdiğimiz kadar çok şey yapabilir mi? 🙂

          Bu arada, Ubuntu kullanıyorsun yani… neden bahsediyoruz?

          1.    Laura Tejera dijo

            vasat mangayı sürdürmek

            1.    KZKG ^ Gaara dijo

              Vasat mıyız? … Uff… LOL!


      2.    Pepe dijo

        2015 Yılındayız!
        Konsoldan çalışmak için çok fazla zaman harcamanın gerekli olmadığını düşünüyorum.
        Neden bunun için otomatik uygulamaları kullanmıyorsunuz?
        Her durumda, konsoldan komutları yazmayı "sevenler", yapmaya devam etmelerine izin verir, ancak paralel olarak aynı otomatik komutlara sahip olmak gerekir. Senden aya bir roket göndermeni istemiyorum.

    2.    Santiago Luis Bazan dijo

      Özgür yazılımı kullanmanın nedenleri ahlaki etiktir. Asla kimsenin insan özgürlüklerinden mahrum bırakılmasına izin verme

      1.    Pepe dijo

        Gerçek şu ki, programlardaki "özgürlük" sanata'sı beni bıktırdı. Varolmayan bir tanrıyı övmeyi bırakıp biraz daha alçakgönüllü olamazlar mı?

    3.    Pepe dijo

      Haklısın Laura, Linux'lu bu adamlar işi iyice karmaşıklaştırıyor. Put0 pencerelerde işler daha kolaydır. Linux'u küçümsemiyorum ama herhangi bir pel0tud kurmak için saatlerce ve saatlerinizi tar'ın nasıl çalıştığını araştırmak için harcayacağınız ve tüm meresunda böylece günün sonunda o "Linux acemi ..." ile sıkışıp kalacaksınız.

      Kararlı bir işletim sistemi kullanmak niyetindeyim ama üretimimden saatler almayacağım çünkü çalışmak zorundayım, "Linux mezunu" olma arzum yok.

  14.   Thanatos dijo

    Bir şeyler her zaman eksik ... ./configure verdiğimde şunu alıyorum: configure: error: Intltool çok eski. Intltool 0.35.0 veya sonrasına ihtiyacınız var.

    Daha sonra, make komutu şunu döndürür: Hedef belirtilmedi ve makefile bulunamadı. Yüksek.

    make install: `install hedefini oluşturmak için bir kural yoktur

    Ben bir acemiyim ve öğrenmek için araştırma yapmak güzel, ama FUCK, Linux'ta yeni olan bizler için bunu renkli çakıl taşlarıyla açıklayamaz mısın?

    1.    panço dijo

      Thanatos Benzer bir sorunum vardı ve sonucumu paylaşıyorum:
      (Öncelikle, ben de Linux dünyasında acemi olduğumu ve Ubuntu'ya "lezzet" (dağıtım) ile bu bağlamdaki maceralarımı açıklığa kavuşturmak için bir haftadır).
      Terminal veya konsolda ".tgz" ile biten "SoulSeek" program paketimin bulunduğu "cd" komutuyla "İndirilenler" klasörüme girdiğini varsayarsak:
      "./Configure" bana dosya veya dizinin mevcut olmadığına dair bir hata verdi
      "Make" bana seninle aynı hatayı attı ... bu yüzden "sudo make install" komutuyla devam etmedim (sudo, Ubuntu'nun bu komutu çalıştırmak için "Süper Kullanıcı ve şifresini" gerektirmesi, başka bir deyişle bir kurulum yapmasıdır) .
      Önceden açılmış dosyayı araştırırken, başınıza gelebilecek bir şey fark ettim ve bu, açılan dosyanın "çalıştırılabilir dosya" (sağ tıklama özellikleri) türünde olduğunu ve yürütmek için 2 tıklama aldığını fark ettim.
      "./Configure" daki sorununuz, Distro'nuza yüklenen paketlerin veya depoların (bu terimler beni biraz karıştırır) güncellemesiyle çözülebilir, çünkü size "intItooI" nun eski olduğunu ve daha yenisine ihtiyacınız olduğunu söyler ve bence belki de bu paket sizin dağıtımınızda derlenen pakettir. Ubuntu'da bunu aynı terminalde "sudo apt-get update" yazarak yaparsınız ve sistemdeki tüm paketleri güncellersiniz.
      Umarım yardımcı olmuşumdur.

    2.    Pepe dijo

      Laura'ya da söylediğim gibi, bu Linux işi uzun zaman alıyor. Bana seninki ile aynı hata mesajını verdi ve bir yerden diğerine Canterville'in hayaleti gibi yürüyorum ve hiçbir şey yapmadım.

      Patronum bana "Çözümü bulmak için 2 günün var, yoksa pencerelere geri dönüyoruz" dedi.

  15.   Jonathan dijo

    teşekkürler

  16.   ivan dijo

    merhaba ben de skype 4.0 yüklemek istiyorum aynı sorunu yaşıyorum. PclinuxOS'umda, tar, gz2'yi indirdim ve sıkıştırılmış haldeydim ve oraya ulaşana kadar ./configure yaptığımda dosyanın olmadığını söylüyor .. nerede kayboldum ya da ne? söyle bana, pclinuxOS'ta (son yayınlanan sürüm) skype kurulu ama sürüm 2.2 ve ben 4'ü yüklemek istiyorum
    Bunu nihayet kurmak için yapmam gereken herhangi bir numara var mı? sinaptik bilmediğim bir şey ???
    Bu sistemde yeniyim, daha önce başka dağıtımları denedim ve şu ana kadar bunun dışında her şey yolunda.

    Saygılarımızla

    1.    Pepe dijo

      Ben miyim yoksa kimsenin bu soruları bildiğini sanmıyorum.

    2.    f7eo dijo

      Merhaba, sorunuzun üzerinden uzun zaman geçti.

      Windows (R) için Skype'ın en son sürümünü indirmenizi tavsiye ederim
      ve GNU-Linux dağıtımınızda çalıştırmak için Wine'ı kullandığınızı.

  17.   arasında dijo

    Merhaba! Bende de aynı sorun var: Merkez yazılımının son sürümünü enxtension tar.gz ile indirdim ve "./configure" örneğine geldiğimde "make" de olduğu gibi bir hata aldım. BU NE"?? TEŞEKKÜRLER!! Ayrıca yazılım merkezi yükleme seçeneğini de engelledi !!!

  18.   Carlos Rivera bilgi alanı resmi dijo

    Teşekkür ederim, bana çok yardımcı oldu !!!!

  19.   michael dijo

    başlatıcı nasıl oluşturulur

  20.   Angi dijo

    Bir soru, ./configure dosyasını çalıştırmadan önce tar.gz dosyasının bağımlılıklarını kontrol edebilir misiniz ???

  21.   joseluis dijo

    Linux'ta yeniyim, tar gz gz2 tabletlerini kurmak çok zor görünüyor ve eğer bir deb alırsam bağımlılıkları yok ve rpm ile i586 veya i686 veya i386 ise ve en kötüsü evimde internet olmaması. Biriyle çelişen çok fazla yorum görmek kafanızı daha da karıştırır.

  22.   gabriel yamamoto dijo

    iyi bilgi, ancak bazı * .tar.bz2 paketleri zaten derlenmiştir ve bunları kurmak için bunları herhangi bir klasöre açmanız gerekir (tercihen / opt, böylece tüm kullanıcılar tarafından kullanılabilir) ve / usr / içindeki ikiliye doğrudan erişim sağlamanız gerekir. local / bin

  23.   Gonzalo dijo

    Tar.gz dosyalarının nasıl kullanılacağına dair çok iyi bir açıklama. Bilgilendirme için çok teşekkür ederim. Tüm ekibe selamlar

  24.   Juancuyo dijo

    Benim için çalışmıyor
    cd / home / ju / downloads / icecat-24.0 ——-> Bana yanıt veriyor
    bash: cd: home / ju / downloads / icecat-24.0: dosya veya dizin mevcut değil
    Neyi yanlış yapıyorum??? İşletim sistemi Voyager 14.04 LTS (xubuntu) Xfce masaüstü Gdebi içerik menüsünde değil ve sinaptik değil, ancak başlangıç ​​menüsündeler, açsanız bile klasörleri tanımıyorlar, sanki yokmuş gibi. Aynı indirme klasörüne açtım. Yanlış bir şekilde açılmış mı ????

  25.   Claudio dijo

    Bu öğretici, .tgz için de çalışıyor mu?

    1.    Joakoej dijo

      Hayır, .tgz, Slackware'in kullandığı formattır ve ister indirmiş ister bir slackbuild'den derlemiş olun, zaten derlenmiştir.

    2.    Joakoej dijo

      Yüklemek için installpkg "paket adı" kullanmanız gerekir.

  26.   asdf dijo

    Üzgünüm ama benim için sorunu pek çözmüyor ./configure dediğinizde ve biz onu yapılandırdığımızda daha fazlasını belirtmelisiniz, değil mi? ./configure koyarsam bana söyler
    bash: ./configure: Dosya veya dizin mevcut değil

    sonra "yaparız" diyorsun
    Kod:
    Yapmak
    Benim sonucum:
    make: *** Hedef belirtilmedi ve makefile bulunamadı. Yüksek.

    Kurulum yap
    make: *** "Kurulum" hedefini oluşturmak için bir kural yoktur. Yüksek.

    Ve sonra "programı çalıştırıyoruz" diyorsun
    Kod:
    Program adı

    Hangi adın veya hangisinin çalıştırılabilir olduğunu nasıl bilebilirim? Çok soyut, belki de bileceğiniz birkaç şeyi hafife alırsınız, ancak bir öğretici görmeye gelenler bilmeyebilir

    1.    Damian dijo

      asdf.

      Araştırıyordum ve ./configure verirken ortaya çıkan hata derleme programının eksikliğinden kaynaklanıyor (bunu yapan bir program olmadan nasıl derleyebiliriz?). girilecek bir derleyici kurma komutu şudur:

      sudo yetenek kurulumu inşa-temel

      yüklendikten sonra, açılacak dosyanın bulunduğu klasöre gidip çalıştırıyoruz:

      tar -zxvf program_name.tar.gz

      Daha sonra sıkıştırılmış program klasörüne GİRERİZ ve eğer varsa ./configure komutunu çalıştırır ve ardından sudo make install

      Umarım yardım etmişimdir!

      Selamlar.

      1.    Damian dijo

        Üzgünüm, benim durumumda "make" ve "sudo apt-get install programı" gerçekleştirmek için açıklığa kavuşturmayı unuttum. Sıkıştırılmamış klasörün içindeki "temel" klasöre girmek zorunda kaldım, tam da orada komutları derledim ( make) ve kurulum.

      2.    Carlos dijo

        Yaptığım zaman bana sorun veriyor, yüksek inşa edecek bir şey bulamadığını söylüyor

  27.   brenda dijo

    Maalesef bu sorunu yaşıyorum, bu komutu çalıştırıyorum, bana bir hata gösteriyor ve makefile oluşturamıyorum
    desktop: ~ / İndirilenler $ tar -jxvf iReport-4.1.3.tar.bz2
    tar (alt): iReport-4.1.3.tar.bz2: Açılamıyor: Dosya veya dizin mevcut değil
    tar (alt): Hata düzeltilemez: şimdi çıkılıyor
    tar: Çocuk durumu 2 döndürdü
    tar: Hata düzeltilemez: şimdi çıkılıyor
    lütfen =)

  28.   aaron dijo

    İyi gün dostları,
    Linux'ta yeniyim, ancak dijital biyometrik okuyucu olan bir cihazı tanımaya gelince biraz sıkıntı yaşadım, sadece Google'da araştırdım ve görünüşe göre buldum, ancak bir .tar.gz uzantısıyla indirildi, deneyin Bir klasöre açın, birkaç dosya açıldı, ancak bundan sonra başka bir şey yürütmem veya bu sıkıştırılmamış dosyaları sistemdeki bir klasöre yapıştırmam gerekip gerekmediğini bilmiyorum, bilmiyorum, lütfen bana yardım ederseniz, süreci iyi çalıştırmak için çok minnettarım, şimdiden OS 7'ye Linux Debian XNUMX yükledim, selamlar ve çok teşekkür ederim.

  29.   Rufo Lopez Retortillo dijo

    Hem Linex 2011 hem de Linex 2013 kullanıyorum ve uygulamaları yüklerken bulduğum en büyük sorun, kendi gruplarındaki uygulamalar (grafik, ofis, multimedya vb.) Listesinde yüklenmemiş olmaları ve bir başlatıcı oluşturmak istersem nerede olduğunu bilmiyorum Uygulama başlatıcı dosyasını bulmam gerekiyor. Hangi klasörde oluşturuyorsunuz? Nasıl yapılır?
    Depolardan yüklendiklerinde, başlatıcılar kendi gruplarına yerleştirilir, bu, bu web'de açıklandığı gibi, tar.gz'yi kurarak yapılabilir mi?
    Yardım için teşekkürler

  30.   Carlos dijo

    Lütfen yardım edin lps 1.5.5 adında başka bir işletim sistemim var ve programı güncelleyemiyorum

  31.   Carlos dijo

    Lütfen tekrar söyleyin tar.bz2 dosyasını açamıyorum lps 1.5.5 adında bir işletim sistemim var ve nasıl kullanacağımı bilmiyorum, lütfen bana yardım edin, teşekkür ederim ...

  32.   Joscastel dijo

    bz2 dosyasını açtıktan sonra, mevcut DEĞİLDİR çünkü ./configure komutu çalışmıyor

    1.    Joscastel dijo

      Ubuntu 14.04LTS'ye sahibim

  33.   Sapete dijo

    Anlamıyorum, slax'ta .tar.gz sinemaya gidiyor, ancak ubuntu'da derlemem yok

  34.   Raul dijo

    En iyi işletim sistemi nedir? en iyi işletim sistemi problemlerinizi çözmesidir.

  35.   Juanzito dijo

    Linux insanları harika. ZinjaI'ı yeni yüklediğim LinuxMint dağıtımıma en az 5 saattir yüklemeye çalışıyorum.
    Bulduğum tüm forumlarda dolaşıyorum ve hepsinde (bu dahil hepsi hariç) size bilgilerin yarısını veriyorlar.
    Örneğin, terminali zaten açtım, ancak indirilen dosyanın bulunduğu yeri (/ home / user / Downloads / zinjai) koyamıyorum.
    Tek aldığım bir hata: "bash: cd: user: Böyle bir dosya veya dizin yok.
    Bir işletim sisteminin kullanımını yaymak ve yaymak istediklerini anlıyorum, ancak bilgiyi reddetmek veya her şeyi yarım ölçülerde açıklamak, elde edecekleri tek şey, benim gibi Windows'tan Linux'a geçme kararlılığı olan kullanıcıların pes etmeleri ve W7'ime sadık kaldım, kötü ama kullanışlı ve yönetilebilir.

    Şerefe…

    Not: Grafik arayüzlü sefil bir yükleyicinin yapmasının maliyeti nedir? Neden bugün XXI yüzyılda, sefil küçük bir programı kurmak için DOS'a benzer bir şey kullanmaya devam etsinler? Beyler ... bakalım biraz canlanmışlar mı ...

    1.    Ocelot dijo

      cd ~ / Yüklemeler / kurulum komut dosyası yolu.

      Bir ipucu: pencerelere yapıştırın. Her işletim sistemi tek tip kişi için yapılmıştır. Windows, her şeyin temelden ve mümkün olan en az çabayla verilmesini tercih eden insanlar için yapılmıştır ve görüyorum ki sizin durumunuz. Bir sonraki, sonraki, sonraki ... kabul etmekten daha fazlasını arzu edemeyen veya istemeyen insanlar var. Bu fena değil, sadece sınırlarımızı bilmeli ve onlara uyum sağlamalıyız.

      Başka bir ipucu: Alçakgönüllülükle ve "lütfen" gibi iki kelime kullanarak kaç şey başarıldığını bilseydiniz. Seni şaşırtabilir. Sık sık yapın.

      1.    Knary dijo

        Merhaba Linuxeros.
        Eğitim için çok teşekkür ederim, dwa-131 wifi adaptörünün sürücülerini yüklememe yardımcı oldu.
        Biraz şüphem var, yukarıda söyledikleri gibi her şeyi yaptım.
        Dosya yoluna gidin, tar yapın…. ve sonra Yapın, bitmesini bekleyin ve ardından kurulumu yapın.
        O adıma kadar bana herhangi bir hata vermedi.
        Sahip olduğum soru, sürücüleri önceden kurup kurmadığımı veya başka bir şey yapmam gerekip gerekmediğini bilmek.
        Juanzito .. devam edin ve Linux'a bir şans verin, dağıtım ne olursa olsun, bir hafta önce Windows 7'den ayrılmaya karar verdim ve cehennemden daha fazla kayboldum, hahaha, ama burada ve orada okumak bazen sizin için zor olan bilgileri buluyorsunuz Anlamak için her şey, her birinin öğrenmek ve Windows'un sizi yerleştirdiği tekelden kurtulmak isteme çabasına bağlıdır (bu benim görüşümdür).
        Linux terminalinde bir şey, büyük harfler sayılır. 😉

        Not: Kame kurulumundan sonra başka bir şey yapmam gerekiyor. ??

        Çok teşekkür ederim.
        Kanarya Adaları'ndan çok teşekkür ederim ve selamlar.

      2.    yaylar dijo

        Ve bir kullanıcıya X sistemine geri dönmesini söyleyen kimsin? Richard Stallman'ı düşünüyor musun?

        Bazı yorumlarda, en iyi işletim sisteminin, sistemin kullanıcıya adapte ettiği işletim sistemi olduğu ve bunun tersi DEĞİLDİR.

        Kişisel olarak Windows .exe’yi seviyorum çünkü sizin de söylediğiniz gibi basit bir not defteri gibi çok basit bir şey yüklemek için bir bilgisayar dehası olmanıza gerek yok; burada linux ile karşılaştırıldığında, özel yazılım uygulamalarında değilse, yüzyılın karışıklığına bir tablet ile bağlı kalırsınız.

        Buraya, üretken bir makineye nane kurmaya hazırlandığım için Linux'a program yüklemek için bilgi aradım ve organize ettim ve eğer hazırlamazsam, depolarda yoksa hiçbir şey yükleyemeyeceğimi biliyorum.

        Şimdi herkesin sorduğu "lütfen" sorun, kimsenin onlara cevap vermemesi, bu yüzden bazen insanların saldırgan olması gerekiyor, bu yüzden saçma demeyin.

      3.    pablo dijo

        üzgünüm .. ama özgür ve açık yazılım kullanımını her zaman savundum .. 30 yıldır bilgisayar kullanıyorum .. ve 37 yaşındayım ..
        Sorun şu ki, linux'ta genel olarak, bir program kurmak, bir güncelleme veya her neyse, kim isterse veya biraz daha "bilmesi" gereken mükemmeldir ... sorun, birçok insanın çalışması ve bilgisayarı kullanması gerektiğinden gelir. (herhangi bir işletim sistemi ile) kendi özel görevini yerine getirmelidir .. böylece bir .gz dosyasını indirip kurmak 10 dakika sürse bile .. veya çoğu olduğu gibi saatler geçse bile .. dakikalar veya saatler işini yap ve işte neredeyse herkesin sabrının tükendiği yer ..
        Benim durumumda .. işte, bilimsel bir merkez olduğu için sadece PC'lerde varsayılan olarak kurulu olan Ubuntu'yu kullanıyorum, ancak bu benim kurmaya çalışmak ve hatta nasıl yumuşak yapılacağını çözmek için daha fazla saat harcamama neden oluyor. belirli (örneğin ben bir coğrafyacıyım) işe yarıyor .. ya da herhangi bir güncellemeden sonra .. tüm araçları kurtarın çünkü bir programın yarısı çalışmayı bırakıyor ..
        bu özel durumda .. işte bir web semineri / forum görmem gerekiyordu .. ve java kullandıkları için güncellemem gerektiğini belirten işareti özledim .. tamam .. java sitesine git .. işletim sistemim için dosyayı bul, 14.04 .. indirme ve kurulum "" talimatlarına "" bakın .. bir .gz indirin ve oradan .. unzip .. tamam ve ... "kur" yazıyor .. ve işte .. sadece hiçbir şey yapılamaz Bu yazının bilgileri .. «Bir ömür boyu jre-blablabla'sını» açtıktan sonra ne yapmalıyım ??

  36.   Carlos Fabian Ferra dijo

    bu benim için hiçbir dağıtımda asla işe yaramadı

    1.    yukiteru dijo

      Sizin için işe yaramadıysa, saf Katman 8'dir.

      1.    yank carlos dijo

        Dahi!

  37.   Ignatius Navarro dijo

    Çok nadir kullandığım için, nasıl yapıldığını görmek için buraya her girdiğimde.
    Yazdığınız ve bu kadar uzun süre sonra silmediğiniz için çok teşekkür ederim.

  38.   Ramon dijo

    sinaptikte görebileceğiniz gibi, eğer size en eskisini gösteriyorsa (dağıtıma göre kararlı) kurulan yeni paket ¿?

  39.   Jorge dijo

    ./configure'a vardığınızda her şey boka batıyor, dosyanın var olmadığını söylerken bunu iyi açıklayan kimse yok

    1.    Elvis dijo

      Ne ./configure, ne yap ne de kurmayı çalıştır.

      mantıksal sıra 1. execute ./configure şeklindedir, ancak görünüşe göre bu komut sadece bir configure dizinine atıfta bulunur ve oraya yerleştirilen bazı dosyaları çalıştırır, bu Broadcom'dan indirilen pakette gelmelidir, ancak benim durumumda bu dizin orada değil configure işleminin gerçekleştirilmesi gereken bir kontrol ve Makefile dosyasını oluşturmaktır, ancak paketi açarken Makefile'ın dahil edildiğini, diğer iki komutun make ve make install benim için çalışmadığını fark ettim, çünkü temel işletim sisteminin en son sürümü onu desteklemiyor freya, ubuntu 14.04'e göre

    2.    Alexander TorMar dijo

      Doğrusu? Bu yöntem benim için hiç işe yaramadı ve her zaman .deb paketlerini veya Terminal'den komutları tercih ederim ... Çok kötü .tar.gz'yi yüklemek için net bir şey yok

  40.   Elvis dijo

    Ne ./configure, ne yap ne de kurmayı çalıştır.

    mantıksal sıra 1. execute ./configure şeklindedir, ancak görünüşe göre bu komut sadece bir configure dizinine atıfta bulunur ve oraya yerleştirilen bazı dosyaları çalıştırır, bu Broadcom'dan indirilen pakette gelmelidir, ancak benim durumumda bu dizin orada değil configure işleminin gerçekleştirilmesi gereken bir kontrol ve Makefile dosyasını oluşturmaktır, ancak paketi açarken Makefile'ın dahil edildiğini, diğer iki komutun make ve make install benim için çalışmadığını fark ettim, çünkü temel işletim sisteminin en son sürümü onu desteklemiyor freya, ubuntu 14.04'e göre

  41.   Alexander TorMar dijo

    Doğrusu? Bu yöntem bana hiçbir zaman yardımcı olmadı ve her zaman .deb paketlerini veya Terminal'den komutları tercih ediyorum ... Çok kötü .tar.gz'yi yüklemek için net bir şey yok

  42.   Alexander TorMar dijo

    Bu eğitim neden güncellenmedi? Yoksa yenisini mi yapıyorlar?
    Buradaki herkes, kendilerine hizmet etmediğinden ve zaten yıllarının olduğundan şikayet ediyor….

  43.   HEKTOR MATOS dijo

    Merhaba, bununla ilgili paketleri yüklemek için yardım istiyorum .. Ubuntu sürüm 15'e sahibim .. bir şey .. adobe flash eklentisi kurmak istiyorum, çünkü onu kurmak çok kullanışlı, çünkü adobe flash ile görebileceğiniz bazı web sayfalarına girebilirim. TV ve radyo da dinleyin .. lütfen bana adım adım öğretici gönderir misiniz .. O komut satırında pek tecrübem yok yani terminal kullanın.

    Yardım .. teşekkürler

  44.   İbrahim dijo

    Herkese merhaba !!! Neredeyse tüm yorumları okuduktan sonra bir linux kılavuzu aradım ve bu kadar ..
    Arkadaş OCELOTE, bu eleştiriyi milyonlarca Windows kullanıcısı ile paylaştığım alçakgönüllü ve önemsiz bakış açımdan kabul edin:

    Linux'a geçmeyi çok isterim! ama çoğumuz bunu imkansız buluyoruz, neden? Merak edeceksiniz ... çünkü benim için bilgisayar, işimi yürütmek zorunda olduğum araç, son değil ... Hepimizin ne istediğini anlıyor musunuz bilmiyorum (ve JUANZITO size çok iyi anlattı), bize yardımcı olan kararlı bir işletim sistemi işimizi yürütmek için konsoldan bir program yüklemek gibi temel şeyleri nasıl yapacağımı öğrenecek vaktim yok, her şey daha sezgisel ve daha kolay olmalı ... Bir işadamı olarak Linux ile taşıdığınız yönetimin yardım etmek yerine felaket olduğunu söyleyeceğim insanlar işletim sisteminde değişiklik yapmak için insanların ilgilerini çekmeyen şeylerle yalan söylemeleri konusunda ısrar ediyorsunuz ve değişimi kendiniz engelliyorsunuz ... assembler, java, javascript, html, php ve xbase'de programlanmış biri size şunu söylüyor ... ve neredeyse her şey için konsolu açmak zorunda kalmak burnuma dokunuyor.

    selamlar

  45.   DEFCON dijo

    Stamina DOS 6.22 eski !!

  46.   erput dijo

    Sizi çalışmaya koyun ve bazıları için işe yarayan wuendos bokunu bırakın çünkü anahtar olarak koyuyorlar, onlara para vermiyorlar, her şeyden önce, bu anahtarları yapanlar linux dahileridir ve yapmalılar, bu yüzden Mamahuevada'ları tartışan aptal gibisiniz, işadamlarına, lisanslarını ödemeye devam edin ve eğer istedikleri istikrarlı bir şeyse, bu öğretilere aptal yazarlarsa zaman kazanıyorlar, bu, linux aptallarını sevenler için ... as

  47.   GENDA dijo

    Acemi kullanıcılar için çok net değil. Örneğin şöyle diyorsunuz:
    «Önce, dosyanın bulunduğu klasöre gidiyoruz, eğer klasörde onları koymak zorunda olduğumuz birkaç kelime varsa veya her kelimeyi içeren klasörleri aramıyorsa» ...
    herhangi bir kullanıcı bu klasörlere "gezgin" ile girecek ve tırnak işaretleriyle içeren klasörün adını bilmeden yeniden adlandıracaktır. Bunu okuduğunuz bakış açısından, «acemi kullanıcının bakış açısından.

    Sonra şunu koyarsınız:
    dosyanın olduğu cd klasörü

    cd "dosyanın olduğu klasör"
    Bu noktadan sonra, kullanıcı bulutlara ya da her yere gitmiştir, çünkü artık CD'de baş harfleriyle kaybolmuştur, oraya nasıl ulaşacağınızı netleştiremezsiniz, adım adım bir örnek, tüm bunlardan başlayarak ... önce konsolu açmaktır .

  48.   GENDA dijo

    HECTOR MATOS için: adobe eklentisi, java ve diğerlerinin manuel olarak yapılması gerekmez, sadece bir süre internete bağlanmanız gerekir ve güncelleme yöneticisinde otomatik olarak görünecektir, oradan Firefox için otomatik olarak güncellenecektir. Opera ve geri kalanı bağımsız olarak ... normalde başlatıcı başlangıç ​​çubuğundaki saatin yanında, birkaç dağıtımda varsayılan olarak orada olduğunu gördüm, hepsinde böyle olup olmayacağını bilmiyorum.

  49.   maksimum dijo

    Lütfen daha açık olun, pek çok bilgi eksik

  50.   Mary dijo

    python'u 3.x'e güncellemeyi deneyin ve tamamlandığında make install işlemi yapmak bana bir hata olduğunu söylüyor:
    zipimport.zipimporterror verileri açamıyor zlib mevcut değil yap *** yükleme hatası

  51.   f_leonar dijo

    ./Configure komutunu çalıştırmak için sıkıştırmayı açtıktan sonra sıkıştırılmamış dizine girmek gerekir, aksi takdirde çalışmaz. KDE kullanıyorum ve açtığım klasörü grafiksel olarak girdim ve orada "make" i çalıştırmak için bir terminal açtım ama çalışmıyor ...

  52.   anonim dijo

    Bir sorum var, şunu anlıyorum:
    manolo @ mxlolo-satellite-c655d: ~ / Desktop $ ./configure –help
    bash: ./configure: Böyle bir dosya veya dizin yok
    ne yaptığım…?

  53.   KATSODA dijo

    Topların ./configure ortaya çıkana kadar her şey yolunda.
    BUNUNLA NE DEMEK İSTİYORSUN !? Bunu açıklamıyorlar, sadece ikinci lanet hayatı yüklemek istiyorum xddd
    «»»katsoda@katsoda-PC:~/Downloads$ ‘/home/katsoda/Downloads/Second_Life_5_0_4_325124_i686’/configure
    bash: / home / katsoda / Downloads / Second_Life_5_0_4_325124_i686 / configure: Dosya veya dizin mevcut değil »» »
    Windows 10'u indirip kıçına alsam iyi olur. (?)
    Hayır. Ama bu, Linux hakkında nefret ettiğim şeylerden biri. En sevdiğiniz programları yüklemek ve burada uyumlu olması için dua etmek oldukça zorludur.

    1.    Gatoo_ dijo

      Rahatsız etmeyin beyler, ama öğreticinin yaratıcısı ./configure ile ilgili bir hata alırsanız ne yapmanız gerektiğini mükemmel bir şekilde açıklıyor. Öğreticinin geri kalanını (4 satır) okumayı bitirmeniz yeterli.

      Bunca insanın, okumayı bırakmadığınız halde, bazı şeyleri açıklamadığından şikayet etmesini inanılmaz buluyorum.

  54.   Cuma dijo

    Bu tür dosyalar için kendimi resmen yetersiz ilan ediyorum. Java yüklemeye çalışıyorum ve işte bu;
    javier @ loft: ~ / JAVA / jre1.8.0_151 $ tar -zxvf jre-8u151-linux-x64.tar.gz
    tar (alt): jre-8u151-linux-x64.tar.gz: Açılamıyor: Dosya veya dizin mevcut değil
    tar (alt): Hata düzeltilemez: şimdi çıkılıyor
    tar: Çocuk durumu 2 döndürdü
    tar: Hata düzeltilemez: şimdi çıkılıyor

  55.   Roger deku dijo

    linux ubuntu 18.04.01 lts fermuarını açtıktan sonra aynı klasöre ./namedelprograma yazmanız yeterli ve işte !!!

  56.   jia dijo

    Çok iyi, çok yardımcı oldu.

  57.   Emerson Gonzalez dijo

    av linux'ta bu çalışmıyor
    Neyin tuhaf olduğunu bilmiyorum; ya da her dağıtım kurduğunuzda haç yoluna başlıyorsunuz
    klavyenin nasıl gittiğini görüyorsun

  58.   Jose Felix Paisano Morales dijo

    Herkese merhaba, Ubunto 20 kullanıyorum ve Epson L4150 tarayıcısını kurmak için bu sayfaya başvurdum (sürücüleri http://support.epson.net/linux/en/imagescanv3.php?version=1.3.38#ubuntu).
    Adımları takip ettim ve 'tar -zxvf dosyaadı.tar.gz' kullandım, sıkıştırmayı açarken kullandım
    Oluşturulan klasör olan '$ cd imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb'.
    './Configure' kullanmaya benzeyen './install.sh' kullandığım klasörün içinde, sistem benden parolamı istedi ve her şey düzgün yüklendi.
    Tarayıcımı denedim ve harikaydı, bana talimatları verdiğin için teşekkürler, tarayıcımı kullanabildim