Kernel'i OpenSUSE 13.1'e güncelleyin

Pek çok kişinin bilmesi gerektiği gibi, OpenSUSE'nin yeni sürümü biraz eskimiş bir çekirdekle geliyor, linux-3.11-6, bu yüzden onu depolarla güncellemek için aşağıdaki adımları izlemelisiniz:

Konsolunuza girerler ve süper kullanıcılar olarak oturum açarlar.

Aynı konsolda aşağıdakileri girin
zypper ar -f http://download.opensuse.org/repositories/Kernel:/stable/standard/Kernel:stable.repo

Depoyu yüklemeyi bitirdiklerinde, her şeyi

zypper update

ve bana keyrepo'ya güvenmem, YaSt'a girip Yazılım Yönetimine gitmemi veriyorlar.

yast

Girdikten sonra, her zaman olduğu gibi, arama motorunu kullanarak çekirdeğini bulurlar, birkaç sürüm bulabileceklerini göreceklerdir.

çekirdek 1

vanilya çekirdeği

Vanilya (orijinal çekirdek, kernel.org'dan geliyor), masaüstü (tavsiye edilmiyor, adı her şeyi söylüyor, ancak bilgisayarıma yüklediğimde, tüm USB'yi çalıştırmadan, dolayısıyla fare veya klavye olmadan beni terk etti) ve varsayılan (OpenSUSE tarafından herhangi bir cihaz için oluşturulan ve benim önerdiğim).

Ayrıca bu Xen, zaten kurulu bir sanal makinedeyken kullanabilecekleri her şeyi kapatır ve sistemi yeniden başlatmak için verir.

Sistemi yeniden başlattığınızda, gelişmiş seçeneklere giderseniz, yeni çekirdek seçeneklerine sahip olduğunuzu görebilirsiniz linux_3.12.2-1 ve konsolunuzda uname -r yaptığınızda, yeni çekirdeğinizin gerçekten kurulu olduğunu görebileceksiniz:

uname -r


Makalenin içeriği şu ilkelerimize uygundur editoryal etik. Bir hata bildirmek için tıklayın burada.

16 yorum, sizinkini bırakın

Yorumunuzu bırakın

E-posta hesabınız yayınlanmayacak. Gerekli alanlar ile işaretlenmiştir *

*

*

  1. Verilerden sorumlu: Miguel Ángel Gatón
  2. Verilerin amacı: Kontrol SPAM, yorum yönetimi.
  3. Meşruiyet: Onayınız
  4. Verilerin iletilmesi: Veriler, yasal zorunluluk dışında üçüncü kişilere iletilmeyecektir.
  5. Veri depolama: Occentus Networks (AB) tarafından barındırılan veritabanı
  6. Haklar: Bilgilerinizi istediğiniz zaman sınırlayabilir, kurtarabilir ve silebilirsiniz.

  1.   thorzan dijo

    Bir soru, yeni çekirdek önyükleme sırasında varsayılan olarak ilk seçenek olarak kalır mı?

    1.    Illukki dijo

      Merhaba Thorzan, normalde yeni bir çekirdeğe güncelleme yapılırken grubun ilk açılışında kalır. Saygılarımızla.

      1.    thorzan dijo

        teşekkürler

    2.    freebsddick dijo

      gerçek şu ki, yeni çekirdeği nereye koyarsanız koyun, onu manuel olarak değiştirme seçeneğiniz vardır. o kadar zor bir şey değil gerçek

  2.   tedavi fox dijo

    'OpenSUSE, biraz güncel olmayan bir linux-3.11-6 çekirdeği ile birlikte gelir'
    Beni yanlış anlamayın, ancak bunun modası geçmiş bir çekirdek olduğunu söylemek yanlış.
    Şimdi ortaya çıkıyor ki, fırından çıkan son çekirdeğe sahip değilseniz, modası geçmiş veya başkalarının dediği gibi modası geçmiş.
    Versiyonitin verdiği zarar.

    1.    fega dijo

      Ve Ubuntu veya diğer dağıtımların sürümleri çok daha "modası geçmiş" getirdiğini görmek, çünkü son güncellemeden önce eski ve kararlı olanı seçmek ve sorunlarla karşılaşmak tercih edilir.

    2.    şakacı dijo

      O kadar da kötü değil, suse'nin kararlılığı ve son zamanlarda kernel 3.12'nin getirdiği iyileştirmeler göz önüne alındığında, onu güncellemeyi düşünmek çok çılgınca değil, güncelliyorum ve varsayılan olarak bir cazibe gibi çalışıyor

      1.    eliotime3000 dijo

        Daha iyisi, Arch'ı kullanmanızı tavsiye ederim, böylece şikayette bulunmazsınız. modası geçme.

        1.    şakacı dijo

          sonda kemeri, gerçekten hoşuma gitmedi, 8MB / sn'lik bir bağlantı hızım var ve bu da KDE ortamını yaklaşık 20 dakikada indirmek için fazlasıyla yeterli olmalı ki iki kez test ettiğimde zamanında geldim ve bir buçuk, w $ içinde olduğundan daha fazla ve ayrıca çok hassas, xampp ile bile bir lamba takamayacağımı söylememe gerek yok, phpmyadmin'i başlatmak istediğimde her zaman veritabanına bir hata attım, bunun yanında Eskimeden şikayet ettiğim için, birçok kullanıcı için olduğu gibi benim için de basitçe çekirdeğin güncellenmesi fikrini seviyorum, ancak çekirdekten başka bir şey değil, çünkü bu sistemde daha fazla güvenlik ve istikrar anlamına geliyor çünkü topluluk bunu ödünç veriyor en son kararlı çekirdeğe öncekilerden daha fazla ilgi

          1.    eliotime3000 dijo

            Arch Linux'ta (veya bu blogda), Arch Liinux kurulumuna da göz atabilirsiniz. KDE'de, PC'nize kurmak istediğiniz temel bileşenleri seçmenize izin verdiği için KDE-Meta meta paketini kullanmanız gerekir. Aynısı Debian ve / veya halefleri için de geçerlidir.

            Şimdi, çekirdek şeyiyle, Debian Wheezy'imin 3.2 çekirdeğini kullanıyorum. Mücbir sebep sorunlarının olması durumunda (istismarlar, yeraltı dünyasından kötü amaçlı yazılımlar), onu güncellerdim. LAMP için Debian'ı yönetmek çok daha kolaydır.

          2.    freebsddick dijo

            Gerekli konfigürasyonları yapamazsanız, bunun nedeni arch'de bulunan yazılımın yanlış olması değil, ciddi bir Layer 8 durumu olmasıdır.

          3.    eliotime3000 dijo

            @freebsddick:

            Gerçek hikaye.

  3.   jecale47 dijo

    Teşekkürler PablEitor, mükemmel öğretmen, makinem hazırdı.

  4.   Heribetocha dijo

    Sanal kutum varsa bu durum etkilenir mi?

    1.    Sieg84 dijo

      evet, yeniden yüklemeniz gerekecek.
      NVIDIA / AMD sürücüleriyle aynı

  5.   Ugerjose dijo

    harika gönderi, zaten güncelledim ama yeni çekirdekli wifi beni tanımıyor, orada ne yapabilirim? önceki evet ile