Nasıl Yapılır: Ubuntu888 ve türevlerinde ALC12.04 ile ilgili ses sorunlarını düzeltme

Bu makale bir sorundan kaynaklanmaktadır (bu arada ironik ...) sahip olduğum Ubuntu 12.04 ve tüm dağıtımlar bu özel sürüme dayanmaktadır. Problemin ironisi, bir LTS için kullandığım ilk versiyondu ve bana bu PC'de bir problem verdi. Bu durumda bir ses problemi.

Sorun aslında çok ciddi değil ama günlük kullanımda can sıkıcı hale geliyor. Şunlardan oluşur: PC'yi kulaklık bağlı olarak açıyorum, Ubuntu'ya giriyorum (veya LTS'nin bir türevi) ve biraz müzik dinleyin. Yorulduğumda ve kulaklıkların bağlantısını kestiğimde ve monitör hoparlörlerinden müzik dinlemek istediğimde hiçbir şey çalmıyor. Bilgisayarı kulaklık takılı değilken açarsam, hoparlörlerden duyuyorum ama kulaklıkları takıyorum ve her iki ses çıkışından da ses çıkarıyor.

Aradığım ilk kullanım günleri ve Bunun hakkında bilgi bulamadım, bu yüzden bıraktım. Şimdi elementaryOS Luna Beta 2'yi kurdum (ve tabii ki Ubuntu 12.04'e dayanıyor) ve şaşırtıcı bir şekilde hata hala oradaydı. Tekrar aradım ve sonunda bir çözüm buldum birkaç forumda. İzlenecek adımlar şunlardır:

  1. Mikseri açıyoruz ALSA komutu çalıştırmak: alsamixer Bir kez orada, "Yonga»Sahip olduğumuzdan emin olmak için ALC888. Bu çip genellikle ses sistemlerine entegre edilmiştir Intel HDA.
  2. Karıştırıcıyı anahtarla kapatıyoruz [ESC]. Ardından, bir Intel HDA (Hack'in işe yaraması için bunlardan biri olmalı). Terminalde yazıyoruz: lsmod | grep snd Diyen bazı satırları arıyoruz snd_hda_intel. Bu, gereksinimleri karşıladığımız anlamına gelir.
  3. Şu komutu yerine getiriyoruz: sudo <editor> /etc/modprobe.d/alsa-base.conf Değiştirirler nano, leafpad veya gedit gibi tercih ettiğiniz düzenleyici tarafından.
  4. Dosyanın sonuna şöyle bir kod satırı ekleyeceğiz: options snd-hda-intel model=auto Bu senin için işe yaramazsa, dene options snd-hda-intel model=auto probe_mask=1 Bu, ALSA'ya kesin bir model oluşturmaya çalışmak yerine otomatik olarak ve genel olarak ses kartını tanımlamasını söyler.
  5. Dosyayı kaydedip yeniden başlatıyoruz. Sonra test ederiz.

Sorun olması durumunda ...

Bu adımları izlerken bir sorununuz olabilir, bazılarını çözümünüzle birlikte bırakmam mümkündür:

  • «Düzenlemem gereken dosya yorum yazdığınız yolda değil«. Belki farklı bir yoldadır, mlocate paketini kurmayı ve şunu çalıştırmayı deneyebilirsiniz: cd / sonra dosyayı bulmak için alsa-base.conf'u bulun. Değilse, sıfırdan oluşturmayı deneyin ve kod satırını ekleyin.
  • «Hatlardan birini ekledim, kaydettim, yeniden başlattım ve şimdi sesim yok. Ses paneli bana 'beceriksizce çık' diyor«. Bu kod doğru olmayabilir. Bir başkasıyla değiştirmeyi deneyin veya her durumda silin. Sonra yeniden başlatın ve tamamlayın.
  • «Benim için hiçbir çizgi çalışmadı«. Entegre sesinizin biraz farklı olması mümkündür, her durumda Çipinize göre daha kesin bir model için model = auto değiştirmeyi denemelisiniz.

Hepsi bu, çok basit bir şey, umarım size hizmet etmiştir. Herhangi bir sorunuz veya sorununuz varsa, yorumlar aşağıdadır 🙂


Makalenin içeriği şu ilkelerimize uygundur editoryal etik. Bir hata bildirmek için tıklayın burada.

19 yorum, sizinkini bırakın

Yorumunuzu bırakın

E-posta hesabınız yayınlanmayacak. Gerekli alanlar ile işaretlenmiştir *

*

*

  1. Verilerden sorumlu: Miguel Ángel Gatón
  2. Verilerin amacı: Kontrol SPAM, yorum yönetimi.
  3. Meşruiyet: Onayınız
  4. Verilerin iletilmesi: Veriler, yasal zorunluluk dışında üçüncü kişilere iletilmeyecektir.
  5. Veri depolama: Occentus Networks (AB) tarafından barındırılan veritabanı
  6. Haklar: Bilgilerinizi istediğiniz zaman sınırlayabilir, kurtarabilir ve silebilirsiniz.

  1.   pandev92 dijo

    Aynı hata ALC 887'de de mevcut ve aynı şekilde çözülüyor. (Bende bunlardan bir gerçek var)

    1.    auroszx dijo

      Ciddi anlamda? Şaşırtıcı olan şey, eklenecek tek bir satırsa, bunu pakette veya ALSA kurulumunda düzeltmek istememeleri ...

      1.    st0rmt4il dijo

        ElementaryOS altında nasılsın? - Kararlı mı? Bu dağıtımı kullandığınızda herhangi bir sorun var mı?

        Selamlar!

        1.    auroszx dijo

          Pekala, birkaç uygulama beni kapatmaya veya takılmaya zorladı. Birincisi güncellemeleri yükleyerek düzelttim, ikincisi sanırım eski işlemcimden kaynaklanıyor: / Pantheon, Gala ve uygulamalarının yükünü taşımak kolay değil ...

  2.   Paul dijo

    Amd 780g yongasıyla ilgili başka bir sorunum var. Ses doygun ve bazen düşük kaliteli. Skype, gtalk, mumble ile. vb.
    Mumble'daki seçenekleri ayarlayarak kilidini açabilirim, ancak şu anda kesin bir çözüm bulamadım

  3.   eliotime3000 dijo

    Intel yonga setli HP bilgisayarımdaki sesle, Debian'da olmakta hiçbir sorun yaşamadım çünkü Ardor'u açarken herhangi bir açıklama yapmadan bilgisayarımı otomatik olarak susturdu ve ses sürücüsünü ALSA'ya yerleştirdi.

  4.   pandev92 dijo

    Çekirdek 3.10 ile funtoo içindeyim, ama Intel hattını koydum, ben de ses yok, Ubuntu 13.04'te, bazı pulseaudio parametrelerini düzeltmem gerekiyor, ancak ses korkunç ve o zaman pulsaudio olmalı ... bir felaket ... Benim olayım.

    1.    eliotime3000 dijo

      İyi ki Debian Wheezy'imdeki 3.04 çekirdeğimi güncellemedim.

  5.   st0rmt4il dijo

    Auros bahşiş için teşekkürler 😀

    Selamlar!

  6.   Mauricio dijo

    İnanılmaz arkadaşım, problemden dolayı acı çektim, ancak yalnızca sistemde sesi 5.1 olarak ayarladığımda.

    Sahip olduğum çip bir VIA VT1708S.

    Bu snd-hda-intel çerçevesiyle çalıştığı için test edeyim dedim.

    Artık hem arka hem de ön çıkışı kullanabilirim.

    Bahşiş için teşekkürler.

  7.   Mauricio dijo

    Merhaba, burada önerilen çözümün benim için çok iyi çalıştığını yorumlamaya geldim, ancak web kameramın sesini yakalamadan bıraktım.

    Bu bir Logitech, Inc. Web Kamerası C270
    Araştırırken, çözümün probe_mask = -1 olduğunu gördüm

    Bununla kameranın ses kaydını tanıdım ve hem önden hem de arkadan bağlanmak için de çalışıyor.

    Ben sadece bunu söylemek istedim.

    Bahşiş için tekrar teşekkürler

  8.   yeniden kutu dijo

    Merhaba, nasılsın Öncelikle AurosZx'e çok teşekkür ederim, bu yazının yayınlanmasından bu yana uzun zaman geçmesine rağmen, kulaklık çıkışıyla ilgili bir sorunu çözmem bana çok yardımcı oldu.

    Bir ASUS K14.04A üzerinde Ubuntu 55 kullanıyorum ve bana alsamixer'de görünen yonga Intel PantherPoint HDMI ve ilk seferinde çalıştı. Saygılarımızla.

  9.   Baphomet dijo

    Yeniden başlatmak gerekli değildir: sudo alsa zorla yeniden yükleme