Archlinux'ta Yaourt'un manuel derlemesi

Selamlar. Umarım bu 2015, bu web sitesini sürekli olarak yayınlayan ve ziyaret eden tüm kullanıcılar için öğreticiler, ipuçları ve Geek'in yardımlarıyla dolu olur.

00/00/31 12: 2014'dan hemen önce ile bazı sorunlar yaşadım yoğurt yeni Archlinux kurulumumda.

Merak ediyorsan Neden yeniden kurulum eğer bir Yuvarlanan Gerçeklik? Her zaman yeni şeyler arıyorum ve bunlardan birinde sistemi yükledim. Önemli dosyaları (en önemlilerini bulutta tutma tavsiyesi) kaydettim ve kılavuzu sayesinde Arch'ı yeniden yükledim. Alexander ponce Bu, 2015'te hala yararlıdır, ancak Pacman'ın kendi sürümüne güncellemesinde zorluk yaşadım

 -. Pacman v4.2.0 - libalpm v9.0.0 / _.- '.-. .-. .-. Telif Hakkı (C) 2006-2014 Pacman Geliştirme Ekibi \ '-. '-' '-' '-' Telif Hakkı (C) 2002-2006 Judd Vinet '-' Bu program GNU Genel Kamu Lisansı koşulları altında ücretsiz olarak dağıtılabilir

Görünüşe göre şu anda bağımlılıklardan biri yoğurt dezavantajları var, yani paket sorgu ve daha önce manuel olarak derlemediğim için arama, okuma, sorma ve test etmeye başladım.

Bununla birlikte, en iyi kılavuz her zaman herhangi bir programın ana kaynağıdır ve bu sefer çözüm İngilizcedir, ancak komutlar oldukları için çeviri yoktur, ancak manuel derleme için izlenebilecek bir sıra vardır.

Yaourt derlemesi

Derlemesi paket sorgu

curl -O https://aur.archlinux.org/packages/pa/package-query/package-query.tar.gz tar zxvf paket-query.tar.gz cd paketi-sorgu makepkg -si cd ..

Derlemesi yoğurt

curl -O https://aur.archlinux.org/packages/ya/yaourt/yaourt.tar.gz tar zxvf yaourt.tar.gz cd yaourt makepkg -si cd ..

Sonunda, her şeyin yolunda olup olmadığını kontrol etmek için tüm sistemi güncelleyebilirsiniz:

$ yaourt -Syyau

yaourt -Syyau --noconfirm

Yaourt'un root olarak değil normal bir kullanıcı olarak çalıştırıldığını unutmayın. Başarılar

Resmi Yaourt sitesinden alınmıştır: https://archlinux.fr/yaourt-en


Makalenin içeriği şu ilkelerimize uygundur editoryal etik. Bir hata bildirmek için tıklayın burada.

9 yorum, sizinkini bırakın

Yorumunuzu bırakın

E-posta hesabınız yayınlanmayacak. Gerekli alanlar ile işaretlenmiştir *

*

*

  1. Verilerden sorumlu: Miguel Ángel Gatón
  2. Verilerin amacı: Kontrol SPAM, yorum yönetimi.
  3. Meşruiyet: Onayınız
  4. Verilerin iletilmesi: Veriler, yasal zorunluluk dışında üçüncü kişilere iletilmeyecektir.
  5. Veri depolama: Occentus Networks (AB) tarafından barındırılan veritabanı
  6. Haklar: Bilgilerinizi istediğiniz zaman sınırlayabilir, kurtarabilir ve silebilirsiniz.

  1.   Rodolfo Martinez dijo

    Aynı şey bugün sabah güncelleme yaparken başıma da geldi, internette xD araştırmadan önce yazınızı çok iyi kullanırdım. Mükemmel katkı.

    1.    Statik dijo

      Bu yazıyı yalnızca bir yardım olarak oluşturmanın uygun olduğunu düşünürsem, çünkü güncellemeden sonra kemer kullanıcılarının bu sorunu ortaya çıkardığını gördüm.

      selamlar

  2.   Davidlg dijo

    Bilinmeyen en büyük AUR yardımcılarından biri olan packer'ı kullanıyorum, bir program kurmak istediğimde daha rahat ve çok ağır görünmüyor.
    Kullanıyorum kolay, örneğin neredeyse her zaman kullanıyorum
    $ paketleyici program_adı

  3.   Fernandoagonzalez dijo

    Archlinux'a adanmış bir yazar olması güzel! Parlak.

  4.   Stederr dijo

    Teşekkürler, birkaç ay sonra sistemimi güncellemeye çalıştığımda bu hatayı görünce korktum, neyse ki koyduğunuz talimatlarla çözümü oldukça basit ve hızlıydı.

    Bu arada, HTTPS kullanarak FromLinux'u yüklerken hatalar alıyorum (sanırım güvensiz içeriği engellediği için).

    selamlar

  5.   Roberto dijo

    Aynı sorunu yaşadım, paylaşım için teşekkürler

  6.   jony127 dijo

    Ne acayip bir dağıtım ………

  7.   Francisco dijo

    Ve pacman ve yaourt ile yaşadığınız hata neydi ???, sorunlarım vardı ve bana şu hatayı verdi:

    curl hatası: Sunucuya bağlanılamadı

    Ama düzelttim, dosyayı düzenledim /etc/hosts aşağıdakileri eklemek:

    5.9.250.164 aur.archlinux.org

  8.   jose dijo

    Ahududu için derlemeye çalışıyorum ve bana şu hatayı veriyor:
    / home / viruspi / package-query / PKGBUILD: line 16: make: command not found
    ==> HATA: Derlemede () bir kilitlenme oldu.
    İptal ediliyor ...