Доступний Debian 7.5 "Wheezy" (а також Debian Squeeze LTS)

Debian

Вітаю всіх. З цієї нагоди я повинен вибачитися за велику відсутність, яка довгий час тримала мене подалі від блогу та спільноти. На щастя, я тут, щоб повідомити вам дві хороші новини: по-перше, вийшло п’яте оновлення Debian Wheezy; і по-друге, що Debian Squeeze стане першою версією Debian, що має підтримку LTS.

Debian Wheezy 7.5

На момент написання цього допису я з радістю оновив обидва свої ПК Debian Wheezy до версії 7.5, які постачаються з такими виправленнями (або виправленнями):

пакет Причина
advi Явно передайте latexdir для створення, уникаючи файлів, які потрапляють у каталоги, що не є FHS
базові файли Оновлення для випуску точки
сервер календаря Оновіть інформацію про зону до tzdata 2014a
сом Виправити вразливість ненадійного шляху пошуку [CVE-2014-2093, CVE-2014-2094, CVE-2014-2095, CVE-2014-2096]
посвідчення патруля Заявіть про сумісність із Iceweasel 24
ClamAV Новий випуск вище
конвертор Додайте патчі для сумісності з Iceweasel 24
debian-інсталятор Додайте підтримку для QNAP HS-210
debian-installer-netboot-images Перебудуйте до останньої програми встановлення debian
docx2txt Додайте відсутність залежності від розпакування
ерланг Виправлено введення команд за допомогою CR або LF в імена користувачів, файлів або каталогів у модулі FTP [CVE-2014-1693]
еволюція Виправте показники зайнятості на серверах Exchange 2013
пожежний клоп Новий випуск версії; сумісний з Iceweasel 24
флешблок Новий випуск версії; сумісний з Iceweasel 24
freeciv Виправлено відмову в обслуговуванні [CVE-2012-5645, CVE-2012-6083]
freerdp Виправте libfreerdp-dev, щоб його можна було компілювати
ґларк Примусово використовувати Ruby 1.8, оскільки glark не працює з новішими версіями
gorm.app Виправити помилку збірки
масляна мавпа Новий випуск версії; сумісний з Iceweasel 24
gst-plugins-bad0.10 Виправлено помилку збірки через оновлення libmodplug у DSA 2751
Intel-мікрокод Включіть оновлений мікрокод
ktp-filetransfer-handler Виправте непрацездатний kde-telepathy-filetransfer-handler-dbg на mips
lcms2 Виправлення безпеки
libdatetime-timezone-perl Оновлення до tzdata 2014a
libfinance-quote-perl Оновити URL-адреси Yahoo! Фінансові послуги
libpdf-api2-perl Виправити помилку збірки
libquvi-скрипти Новий випуск вище
2.4 Вирішення проблем із автентифікацією NTLM проти Windows 2012
libxml2 Виправте пошкодження пам'яті при повторному використанні бібліотеки з різьбовими програмами
Linux Оновити до стабільної версії 3.2.57, 3.2.55-rt81, drm / agp 3.4.86; кілька виправлень безпеки; e1000e, igb: бекпорт змінюється до Linux 3.13
ltsp Виправте віддалений звук на тонких клієнтах
міп Припиніть будувати за допомогою -march = native
meep-openmpi Припиніть будувати за допомогою -march = native
mozilla-noscript Новий випуск версії; сумісний з Icweasel 24
mp3gain Виправлено проблеми з відмовою в обслуговуванні та переповненням буфера [CVE-2003-0577, CVE-2004-0805, CVE-2004-0991, CVE-2006-1655]
net-snmp Вирішення проблем субагенту agentx із запитами декількох об’єктів та збільшенням довжини об’єкта [CVE-2014-2310]
новини Виправлено помилку збірки через перехід json з логічного на json_bool
драйвери nvidia-graphics Новий випуск вище
nvidia-графічні модулі Збірка проти nvidia-kernel-source 304.117
openblas Виправте зависання при виклику із програми, що використовує OpenMP
php-getid3 Виправити потенційну проблему безпеки XXE [CVE-2014-2053]
php5 Багато виправлень, отриманих із верхнього потоку
polarssl Виправити помилку збірки через прострочені сертифікати
postgresql-8.4 Новий мікрореліз вищого рівня
postgresql-9.1 Новий мікрореліз вищого рівня
qemu Виправлено вказівник входу для ядер ELF, завантажених опцією -kernel; дозволяти реальному режиму доступ лише до 32-розрядних адрес, якщо тільки не в довгому режимі
qemu-kvm Виправлено вказівник входу для ядер ELF, завантажених опцією -kernel; дозволяти реальному режиму доступ лише до 32-розрядних адрес, якщо тільки не в довгому режимі
квасел Обмежити доступ клієнтів до відставання, що належить іншим користувачам [CVE-2013-6404]
ресурсні агенти Виправте перевірку служби HTTPS за IP-адресою
рубін-пасажирський Виправте небезпечне використання / tmp [CVE-2014-1831, CVE-2014-1832]
шавлія-продовження Новий випуск версії; сумісний з Icewasel 24
самба Виправлено обхід автентифікації та недостатній захист від грубого пригадування пароля [CVE-2012-6150, CVE-2013-4496]
samba4 Видаліть небезпечні та зламані двійкові пакети samba4 та winbind4
спамасин Видалення ххх зі списку поширених підроблених доменів верхнього рівня, оскільки це вже не є підробкою; видалити правила, що посилаються на rfc-ignorant.org та NJABL, які були вимкнені
шипшина Виправити відсутні пропуски; екран оновлення безпеки -
підривна діяльність Виправлено падіння mod_dav_svn під час обробки певних запитів [CVE-2014-0032] та видалення libsvnjavahl-1.a / .la / .so з libsvn-dev
хороший Виправити проблеми автентифікації CAS; виправити виправлення для оновлення SQLite, щоб уникнути помилок з perl <= 5.14; викликати попередження замість помилки, коли файл набору CA неможливо прочитати; вкажіть відсутній шаблон help_suspend.tt2
чутливий Використовуйте Twitter API 1.1 та SSL
тздата Новий випуск вище
wml Видалити тимчасові каталоги (ipp. *)
xine-lib Виправлено помилку збірки через оновлення libmodplug у DSA 2751
xine-lib-1.2 Виправлено помилку збірки через оновлення libmodplug у DSA 2751

Подібним чином існують такі оновлення безпеки:

Консультативний ідентифікатор пакет
DSA-2848 mysql-5.5
DSA-2850 лівіамль
DSA-2852 libgadu
DSA-2854 бурмотіти
DSA-2855 libav
DSA-2856 libcommons-fileupload-java
DSA-2857 libspring-java
DSA-2858 морозиво
DSA-2859 підгін
DSA-2860 парцимонія
DSA-2861 файл
DSA-2862 хром-браузер
DSA-2863 безкоштовно
DSA-2865 postgresql-9.1
DSA-2866 горіхи26
DSA-2867 otrs2
DSA-2868 php5
DSA-2869 горіхи26
DSA-2870 лівіамл-лібіамл-перл
DSA-2871 Wireshark
DSA-2872 удіски
DSA-2873 файл
DSA-2874 бовдур
DSA-2875 чашки-фільтри
DSA-2877 lighttpd
DSA-2878 VirtualBox
DSA-2879 libssh
DSA-2880 python2.7
DSA-2881 морозиво
DSA-2882 extplorer
DSA-2883 хром-браузер
DSA-2884 лівіамль
DSA-2885 лівіамл-лібіамл-перл
DSA-2886 libxalan2-java
DSA-2887 ruby-actionmailer-3.2
DSA-2888 ruby-activesupport-3.2
DSA-2888 ruby-actionpack-3.2
DSA-2889 постфіксадмін
DSA-2890 libspring-java
DSA-2891 mediawiki-розширення
DSA-2891 mediawiki
DSA-2892 a2ps
DSA-2894 OpenSSH
DSA-2895 просодія
DSA-2895 lua-експат
DSA-2896 OpenSSL
DSA-2897 Tomcat7
DSA-2898 ImageMagick
DSA-2899 опенафи
DSA-2900 jbigkit
DSA-2901 WordPress
DSA-2902 витися
DSA-2903 стронгсван
DSA-2904 VirtualBox
DSA-2905 хром-браузер
DSA-2908 OpenSSL
DSA-2909 qemu
DSA-2910 qemu-kvm

А пакети, з якими ми повинні попрощатися:

пакет Причина
hlbr Зламаний
hlbrw Залежить від видалення hlbr

У всякому разі. Залишається лише нагадати вам, що якщо у вас є ПК із подвійним завантаженням, можливо, завантаження Windows не відображається, тому вам доведеться виконати в терміналі наступне:

sudo update-grub

Debian Squeeze LTS

Для тих з вас, хто запускає свої сервери за допомогою Debian Squeeze, це ваш щасливий день. По-перше, ця новина з'явилася в списки розсилки debian, а пізніше, стала офіційною.

Debian Wheezy - це перше видання Debian, яке отримало розширену підтримку (LTS), розроблену таким чином, щоб тривати майже 5 років, починаючи з дати випуску першої версії.

На даний момент відомо, що Debian Squeeze отримає цю підтримку, як тільки вона надійде 31 травня цього року, а закінчення цієї розширеної підтримки буде в лютому 2016 року. Крім того, слід зазначити, що розширена підтримка включатиме платформи X86 з 32-розрядна (i386) та 64-розрядна (amd64). Однак не виключена можливість того, що і Debian Wheezy, і Джессі (яка незабаром стане наступницею поточної стабільної версії) потраплять до категорії LTS.

Для тих, хто хоче знати, хто підтримуватиме Debian 6.X, самі розробники Debian заявили, що відповідальними за LTS будуть треті сторони, які об’єднали зусилля з командою розробників Debian для виправлення помилок та критичних недоліків безпеки.

Як бонус: помилка OpenSSL не вплинула на Debian Squeeze Heartbleed.

debian-7.5

Debian 7.5 "Wheezy" (64-розрядна версія) з XFCE як робочий стіл.


Зміст статті відповідає нашим принципам редакційна етика. Щоб повідомити про помилку, натисніть тут.

26 коментарі, залиште свій

Залиште свій коментар

Ваша електронна адреса не буде опублікований. Обов'язкові для заповнення поля позначені *

*

*

  1. Відповідальний за дані: Мігель Анхель Гатон
  2. Призначення даних: Контроль спаму, управління коментарями.
  3. Легітимація: Ваша згода
  4. Передача даних: Дані не передаватимуться третім особам, за винятком юридичних зобов’язань.
  5. Зберігання даних: База даних, розміщена в мережі Occentus Networks (ЄС)
  6. Права: Ви можете будь-коли обмежити, відновити та видалити свою інформацію.

  1.   калевіто - сказав він

    Еліо, я хотів би встановити debian LXDE на свій ПК. Але, я відчуваю себе складно. У мене були проблеми з Lubuntu, нова версія не читає wifi, я вважаю, це через ПК (Acer Aspire One 0725), чого не сталося б з Debian. Чи є у вас підручник із кроків, які мені слід зробити? Інше питання: Debian не постачається з макетом, наприклад, libreo office. Чи встановлю лише ті, які хочу?

    1.    eliotime3000 - сказав він

      Зазвичай ви можете вибрати, яке середовище робочого столу використовувати в програмі встановлення Debian відразу після завантаження.

      Цей параметр знаходиться в "Додатково >> Альтернативні середовища робочого столу", і ви побачите список середовищ для встановлення на робочому столі.

      Версії Debian для netinstall обов’язково вимагають підключення до кабелю Ethernet для завантаження пакунків, які вимагає програма встановлення відповідно до вибраного робочого столу.

    2.    eliotime3000 - сказав він

      Що стосується WiFi, спершу введіть у термінал «lspci», щоб побачити, яке саме обладнання у вас є, і вставте в Google «сайт: wiki.debian.org {назва обладнання, про яке йде мова}», і ви побачите рішення відповідно до обладнання, яке ви робить життя неможливим.

      1.    калевіто - сказав він

        Дякую, Еліо

    3.    соус - сказав він

      Що стосується libreoffice, ви лише завантажуєте деб з офіційної сторінки та встановлюєте його, а потім деб мови та допомагає тому, що знаходиться у репозиторіях, старий
      У мене є 4.2 на debian jessie kde, і це проходить без проблем

  2.   Ramon - сказав він

    Дурне запитання, як мені перейти до Debian 7.5 LTS, оскільки у мене є Debian 7, чи можна це зробити за допомогою повної модернізації aptitude? Спасибі заздалегідь

    1.    діазепан - сказав він

      Debian 7.5 не є LTS

    2.    петерчеко - сказав він

      Привіт
      Щоб оновити ваш Debian до останньої версії семи версії, потрібно лише:

      apt-get update && apt-get dist-upgrade

      Вітаю 🙂

  3.   петерчеко - сказав він

    Привіт Eliotime3000, чудові новини від команди Debian: D. До речі .. З якого часу ви використовуєте XFCE як середовище? Набридло KDE?

    1.    eliotime3000 - сказав він

      Ні. XFCE - це мій нетбук, який я щойно отримав на день народження. Мій KDE призначений для мого ПК Workstation, який я також оновив до Debian 7.5.

      По правді кажучи, XFCE змусив мене повернутися до часів, коли я був у GNOME 2, і правда полягає в тому, що це як KDE, але для GTK.

      І до речі ... чи вдалося вам налаштувати ваш KDE як eOS + OpenSUSE? Оскільки мені вдалося зробити цей стиль робочого столу, який ви можете побачити у моєму [url = http: //foro.desdelinux.net/viewtopic.php? Pid = 20058 # p20058] коментарі «Показати свій робочий стіл» [/ url] .

      У будь-якому випадку, XFCE - це хороше робоче середовище (ну, у щура є свій шарм), але правда полягає в тому, що KDE набагато перевершує його (він навіть більш універсальний, ніж XFCE і LXDE разом).

  4.   елав - сказав він

    Як і в Ubuntu, випуски Debian мене більше не хвилюють, хоча, звичайно, я ніколи не був схвильований стабільними оновленнями 😀

    1.    петерчеко - сказав він

      Ви кажете це тому, що ви перебуваєте в Arch, оскільки там немає випуску :). Як прокат: D ..

      Потрібно сказати, що я більше не зацікавлений у випусках Debian Stable, оскільки Slackware знаходиться в моєму прицілі, і я дуже задоволений цим: D.

      1.    елав - сказав він

        У Arch немає випусків? Кожен день чоловік: https://www.archlinux.org/packages/?sort=-last_update

        1.    pandev92 - сказав він

          snpashot! = запуск

        2.    eliotime3000 - сказав він

          Цей ритм качки змушує мене кляпатись.

      2.    eliotime3000 - сказав він

        Slackware зробив кращі оновлення, ніж RHEL та Debian разом (наприклад, оновлення OpenSSL та KDE), і Arch я повинен тримати вікі під рукою, тому що без цього я просто гублюся, коли справа доходить до встановлення Arch (розчаровує необхідність використовувати дистрибутив, гострий як бритва, але, в свою чергу, дистрибутив RTFM).

        Тепер, якщо я не можу продати свій старий Pentium IV, я покладу в нього Slackware 14.2 і дам їй цей ПК, щоб моя мати могла навчитися правильно використовувати GNU / Linux (оскільки моя мати ненавидить все, що не працює добре, я маю на увазі встановити його це дистрибутив завдяки надійності та простоті).

    2.    eliotime3000 - сказав він

      Для тих, хто використовує його як сервер та / або має їх встановити на своїх застарілих ПК, так. Крім того, це оновлення усунуло проблему, яку я мав під час оновлення Flash Player за допомогою програми оновлення update-flashplugin-nonfree.

  5.   gasb - сказав він

    Привіт, а як ви переходите на хрип 7.5 з хрипу 7.0? Дякую

    1.    Тесла - сказав він

      Привіт. Ви відкриваєте термінал і ставите:

      оновлення sudo apt-get && оновлення sudo apt-get

      Він запитає пароль вашого користувача та оновиться. Якщо у вас немає активованого sudo, ви можете зробити це за допомогою su.

      Привіт!

      1.    gasb - сказав він

        Дякую за відповідь. У будь-якому випадку, все працювало нормально, але за оновлення системи безпеки ще раз дякую.

  6.   без назви - сказав він

    виправлення: його можна прочитати:

    Debian Wheezy - це перше видання Debian, яке отримало розширену підтримку

    і це неправильно, ви маєте на увазі стискання debian

    що стосується

    1.    eliotime3000 - сказав він

      Дякую за помилку. Подивимось, чи сьогодні вдень вони дадуть мені можливість редагувати статтю.

  7.   Взлана - сказав він

    Доброго дня ... У мене встановлено хрипкий 7.4, як би я перейшов на 7.5? Дякую!!

    1.    eliotime3000 - сказав він

      apt get upgrade
      apt-get update

  8.   Хорхе Варела - сказав він

    Радий прочитати новини, хороша робота від спільноти Debian. З моменту переходу на Ubuntu для Debian кілька років тому, я був цілком задоволений розподілом. Сьогодні я пишу з Ubuntu, бо вирішив спробувати зараз із цим так званим LTS 14.04. Однак Debian завжди буде моїм улюбленим.

  9.   Педро - сказав він

    Встановіть linux debian 7.6.0, і він не завантажиться, а також 7.5.0 і не завантажиться