Станьте віртуальним детективом за допомогою OSRFramework

Приховуйте нашу особистість в Інтернеті Це стає все важче через велику кількість інструментів, алгоритмів та технологій, які були створені для відстеження користувачів та ідентифікації їх поведінки. Майже завжди ці інструменти створюються для того, щоб нападати на злочинців, які приховуються в анонімності мережі, щоб вчинити злочини, а в протилежних випадках шпигувати, порушувати права громадян або красти інформацію.

Одним з тисяч інструментів, створених для відстеження користувачів в Інтернеті, є OSRFramework, що дає нам можливість шукати користувача на тисячах сайтів, включаючи глибоку мережу, викидаючи докладні звіти про їхні сліди в Інтернеті.

За допомогою цього потужного інструменту з відкритим кодом ми можемо стати віртуальними детективами, які на основі різної інформації можуть відслідковувати злочинців, зниклих людей або навіть конкурентів.

Що таке OSRFramework?

Це інструмент з відкритим кодом, розроблений іспанськими Брезо та Рубіо, який об'єднує набір бібліотек, що дозволяють швидко та автоматично виконувати завдання розвідки. Інструмент дозволяє перевіряти імена користувачів у більш ніж 200 веб-сайтах та на деяких прихованих сторінках в Інтернеті, а також здійснює глибокий пошук у службі dns, електронної пошти та іншої інформації кожного профілю. osrframework

Інструмент дає нам можливість відстежувати користувача майже у всіх важливих мережевих послугах, які існують сьогодні. У минулому він використовувався для відстеження сліди терористів, але його використання може бути застосовано до нескінченної кількості цілей, особливо в тих, де ми хочемо згрупувати інформацію користувача або конкуренції.

Цей інструмент виготовлений на python, тому він є міжплатформеним і простим у користуванні, за належної параметризації ми можемо знайти інформацію, що стосується майже будь-якого профілю, тому дослідники можуть використовувати цей інструмент як ідеальне доповнення при відстеженні людей.

Як встановити OSRFramework

Встановлення OSRFramework Це надзвичайно просто, просто встановіть python і виконайте наступну команду: sudo pip install osrframework

Завдяки цьому ми вже маємо всі утиліти, які пропонує нам OSRFramework, якщо ми хочемо знати, в яких соціальних мережах знайдено ім’я користувача, ми можемо використовувати usufy.py наступним чином

usufy.py -n desdelinux -p twitter github instagram badoo facebook

Або якщо це не вдасться, якщо ми хочемо відстежити електронну пошту, ми можемо скористатися нею mailfy.py наступним чином:

mailfy.py -m “i3visio@gmail.com”

 


Зміст статті відповідає нашим принципам редакційна етика. Щоб повідомити про помилку, натисніть тут.

8 коментарі, залиште свій

Залиште свій коментар

Ваша електронна адреса не буде опублікований. Обов'язкові для заповнення поля позначені *

*

*

  1. Відповідальний за дані: Мігель Анхель Гатон
  2. Призначення даних: Контроль спаму, управління коментарями.
  3. Легітимація: Ваша згода
  4. Передача даних: Дані не передаватимуться третім особам, за винятком юридичних зобов’язань.
  5. Зберігання даних: База даних, розміщена в мережі Occentus Networks (ЄС)
  6. Права: Ви можете будь-коли обмежити, відновити та видалити свою інформацію.

  1.   Саймон Мартінес - сказав він

    Я використовую python зовсім недавно, і я не знаю, як вирішити проблему при його встановленні.

    Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "/tmp/pip-build-q1sw7ym_/osrframework/setup.py", line 38
    print "[*] The installation is going to be run as superuser."
    ^

    SyntaxError: відсутні дужки у виклику "print"

    Здається, він використовує синтаксис python 2, і я не знаю, як змусити pip працювати в цій версії, а не в 3
    Якщо ви можете мені допомогти Дякую

    1.    Беніто - сказав він

      Привіт, як справи, замість того, щоб викликати sudo pip install osrframework, зробіть це наступним чином sudo pip2 install osrframework, щоб ви використовували python2, а не python3

      привіт

    2.    ranceis - сказав він

      щось краще, що ви могли б зробити, це встановити virtualenv і створити віртуальне середовище для потрібної вам версії python, так що ви не жертвуєте версією своєї операційної системи, і вам не доведеться конвертувати

  2.   Карлос - сказав він

    Привіт Саймоне:

    Я не фахівець у цих питаннях, але, на мою думку, деякими можливостями, якими ви могли б скористатись, є:

    Використовуйте Python 2.7, і тоді у вас не виникне проблеми.
    Використовуйте утиліту для перетворення Python 2 на 3 (як 2to3). Проблема цього полягає в тому, що воно може генерувати навіть більше помилок, ніж ви вже отримуєте.
    Встановіть pyenv, щоб використовувати різні версії Python у локальному середовищі (не встановлюючи його в системних папках, таких як / bin або / usr [/ local] / bin). У вас буде ізольоване середовище для роботи з потрібною версією Python.

    Сподіваюся, я міг допомогти.

  3.   Андрес - сказав він

    Привіт, я зробив всю процедуру, яка є досить простою, але я не знаю, чи все-таки зробив щось не так, тому що це не працює для мене. Я виконав ці кроки як є, використовую manjaro 17 з kde

  4.   Віктор Бака - сказав він

    чи змогли вони встановити та використовувати нормально?

  5.   мілтон - сказав він

    Це говорить мені про це в калі linux, я міг би встановити його нормально, але коли я запускаю код:
    bash: /usr/local/biin/usufy.py: Дозвіл відмовлено
    Що може бути? Я вже користувач root

  6.   ВЕЛИКИЙ ЧАС - сказав він

    Traceback (останній останній дзвінок):
    Файл "/usr/local/bin/mailfy.py", рядок 11, у
    load_entry_point ('osrframework == 0.18.8', 'console_scripts', 'mailfy.py') ()
    Файл "/usr/local/lib/python2.7/dist-packages/osrframework/mailfy.py", рядок 468, в основному
    парсер = getParser ()
    Файл "/usr/local/lib/python2.7/dist-packages/osrframework/mailfy.py", рядок 433, у getParser
    groupProcessing.add_argument ('- e', '–extension', metavar = », nargs = '+', choices = ['csv', 'gml', 'json', 'ods', 'png', 'txt' , 'xls', 'xlsx'], обов'язково = False, за замовчуванням = DEFAULT_VALUES ["розширення"], action = 'store', help = 'вихідне розширення для файлів зведення. За замовчуванням: xls.')
    KeyError: 'розширення'

    Я пропускаю це, хтось міг мені допомогти.