Cách cài đặt các gói LMDE của chúng tôi trong 3 giây

Tận dụng lợi thế của bài báo gần đây tôi đã đăng gì về MintBackup, Tôi muốn chỉ cho bạn ba cách dễ dàng để cài đặt lại các gói chúng tôi sử dụng khi chúng tôi cài đặt lại LMDE.

Trên thực tế, ngoại trừ dạng đầu tiên, các dạng khác đều có thể được sử dụng trong Debiannhư trong Ubuntu.

Cài đặt trong 3 giây

Về mặt đồ họa.

Đây là cách thích nhất, tất cả đều có đồ họa và không cần phải chạm vào thiết bị đầu cuối. Trong LMDE y LinuxMint, đây là một công cụ tuyệt vời được gọi là MintBackup, trong số những thứ khác, chúng tôi có thể sử dụng để lưu các gói của mình và sau đó, cài đặt lại chúng.

Trong trường hợp của LMDE, nếu chúng tôi cập nhật gói python-apt lên phiên bản 0.8.0, chúng tôi sẽ không thể sử dụng MintBackup do một vấn đề phụ thuộc. Nó sẽ trả về lỗi sau:

Traceback (most recent call last):
File "/usr/lib/linuxmint/mintBackup/mintBackup.py", line 87, in <module>
class MessageDialog(apt.FetchProgress):
AttributeError: 'module' object has no attribute 'FetchProgress'

Hy vọng rằng những người từ Nguyên do sửa nó sớm.

Thông qua thiết bị đầu cuối.

Thông qua giao diện điều khiển, chúng tôi có thể thực hiện theo 2 cách, cuối cùng, đều giống nhau.

Trong 2 bước.

dpkg --get-selections | awk '$2 ~ /^install$/ {print $1}' > lista_de_paquetes.txt

Khi chúng tôi có quyền truy cập vào kho lưu trữ và mọi thứ đã được cấu hình và cập nhật, chúng tôi chỉ cần đặt điều này:

cat lista_de_paquetes.txt | xargs sudo aptitude install -y

Trong 3 bước.

dpkg --get-selections "*" > /home/user/Desktop/lista_de_paquetes.txt

Sau khi cài đặt lại, chúng tôi thực hiện điều này:

dpkg --set-selections  < /home/user/Desktop/lista_de_paquetes.txt

Và sau đó chúng tôi chạy:

apt-get -u dselect-upgrade

Tôi nghĩ rằng không cần thiết phải làm rõ rằng chúng ta phải có các kho lưu trữ được cấu hình chính xác .. Đơn giản phải không?


Nội dung bài viết tuân thủ các nguyên tắc của chúng tôi về đạo đức biên tập. Để báo lỗi, hãy nhấp vào đây.

8 bình luận, để lại của bạn

Để lại bình luận của bạn

địa chỉ email của bạn sẽ không được công bố. Các trường bắt buộc được đánh dấu bằng *

*

*

  1. Chịu trách nhiệm về dữ liệu: Miguel Ángel Gatón
  2. Mục đích của dữ liệu: Kiểm soát SPAM, quản lý bình luận.
  3. Hợp pháp: Sự đồng ý của bạn
  4. Truyền thông dữ liệu: Dữ liệu sẽ không được thông báo cho các bên thứ ba trừ khi có nghĩa vụ pháp lý.
  5. Lưu trữ dữ liệu: Cơ sở dữ liệu do Occentus Networks (EU) lưu trữ
  6. Quyền: Bất cứ lúc nào bạn có thể giới hạn, khôi phục và xóa thông tin của mình.

  1.   SỰ KHÍCH LỆ dijo

    Hoặc bạn cũng viết ra tất cả các chương trình bạn đã có trước đây và làm

    sudo apt-get -y chèn tất cả các gói đã bị xóa

    Tôi thực sự không biết liệu LMDE có cùng mục tiêu với Linux MInt hay không,

    1.    SỰ KHÍCH LỆ dijo

      * Tải về

  2.   Hokasito dijo

    Mặc dù nó hơi "lạc đề", tôi muốn cảnh báo rằng các ứng cử viên phát hành đã xuất hiện trong Linux Mint Debian 201108 cho GNOME và XFCE. Tôi hy vọng một số cải tiến đã được thực hiện… 🙂

    1.    elav <° Linux dijo

      Vâng, vâng, điều gì sẽ xảy ra khi tin tức tuyệt vời này được xuất bản, chúng tôi đã không liên lạc được .. Cảm ơn bạn.

  3.   mitcoes dijo

    Tôi vừa khám phá ra bạn và CẢM ƠN.
    Hôm qua tôi đã cài đặt LMDE 64-bit và tôi thấy ổn, nhưng tôi có 2 điều nhỏ cần khám phá-

    1– Đăng nhập với quyền root ở chế độ đồ họa

    2.- Đặt VLC làm trình phát video mặc định

    Tôi nghĩ rằng tôi sẽ lấy nó từ bảng điều khiển ứng dụng ưa thích hoặc bằng cách mở bằng ứng dụng khác / sử dụng ứng dụng này theo mặc định. Đã đăng nhập với quyền root.

    Tôi đã làm sudo nautilus chỉ trong trường hợp và không có gì cả.

    PS1: Trong 64 bit nếu abckup của các gói hoạt động tốt.
    PS2: Tôi cũng cần cài đặt MAME SDL và wine64 gần đây mà tôi muốn một ppa tồn tại, vì việc cấu hình các chương trình sau này không tự động cập nhật cho bạn.
    PS3: Tôi đang sử dụng trình điều khiển AMD beta AMD_Catalyst_Preview_driver_OpenGL_4.2_beta_support_8.88.8-x86.x86_64.run, Cocoon, https://getcocoon.com/, để xem chuỗi định vị địa lý trong Firefox, Chrome - phải cài đặt -, Firefox hỗ trợ Flash với Flash 64-bit, Zindus, Qbittorrent, Opera, phần mở rộng aletras.oxt và tập lệnh Collectinte để kiểm soát bộ nhớ đệm RAM thừa của tác vụ điều đó cũng xứng đáng nhận được một bình luận từ bạn.

    Tôi mong chờ phần thứ năm của hướng dẫn với những đề xuất này và / hoặc các đề xuất khác

  4.   ĂN VỚI dijo

    Chào bạn
    Một điều, chúng ta nên thay đổi liên kết đầu tiên gửi bài viết MintBackup thành liên kết này: https://blog.desdelinux.net/mintbackup-realiza-un-respaldo-de-tus-paquetes/
    Tôi không biết tại sao, nó liên kết đến một thư mục con "/ wp-content / themes" ...

    1.    KZKG ^ Gaara dijo

      Đã xong, đã sửa 😉

  5.   Nahum dijo

    Xin chào, kể từ phiên bản trước của LMDE amd64, tôi đã gặp sự cố với các gói bị hỏng và lỗi khi tải kho lưu trữ, tôi đã thử nhiều giải pháp và không có giải pháp nào hoạt động… Tôi không biết phải làm gì nữa, tôi muốn cài đặt Gnome-shell và nó đã không cho tôi vì gói bị hỏng. Tôi đã thấy cách giải quyết các gói bị hỏng bằng các lệnh như: sudo dpkg –purge –force-remove-reinstreq

    và tôi gặp lỗi sau:

    dpkg: error: –purge yêu cầu ít nhất một tên gói làm tham số

    Gõ dpkg –help để được trợ giúp cài đặt và gỡ cài đặt gói [*];
    Sử dụng `dselect 'hoặc' aptitude 'để quản lý gói thân thiện hơn;
    Gõ dpkg -Dhelp để biết danh sách cài đặt gỡ lỗi dpkg;
    Nhập dpkg –force-help để biết danh sách các tùy chọn để buộc mọi thứ;
    Gõ dpkg-deb –help để được trợ giúp thao tác với các tệp .deb;

    Các tùy chọn được đánh dấu bằng [*] tạo ra đầu ra rộng rãi,
    Lọc nó với 'less' hoặc 'more'!

    nếu ai đó có thể giúp tôi điều này 🙂