如何在Linux上配置Brother激光打印机

当前的大多数GNU / Linux发行版都对最现代的硬件提供了强大的支持,但是,仍然有一些硬件制造商以某种方式阻碍我们钟爱的操作系统可以与其解决方案兼容。 幸运的是,对于许多使用Brother品牌打印机的人来说,情况并非如此,因为它们具有Linux的本机驱动程序。

我目前有 兄弟DCP-L2550DN激光打印机这并不是说它是一台出色的打印机,但如果它允许我快速打印,高质量并符合成本预期,那么很容易获得便宜的Brother TN2410和TN2420墨盒,这是该设备使用的墨盒。 在Linux Mint中,我做得非常好,尽管当我进行美味佳肴时,使其正常工作要比平常多得多,因此,很好的解释一下使用类似设备的用户应该执行的过程。

拥有该品牌打印机的用户必须做的第一件事是 兄弟linux驱动程序页面 并下载特定打印机型号的驱动程序,它们由公司分发的各种硬件(CUPS,LPR,扫描仪,ADS,激光打印机等)分发。 每种驱动程序类别都为我们提供了与其相关产品的解决方案,这就是为什么例如,同一驱动程序可以用于Brother DCP-L2510D,Brother HL-L2310D和Brother MFC-L2710DN打印机。

Brother在其驱动程序安装页面上为我们提供了一份特定的手册,供您根据所拥有的发行版,硬件模型及其体系结构来使用,以同样的方式,它使我们能够检查打印机的正确操作,配置纸张类型,甚至墨盒状态。

通常,此过程很简单,我们转到Brother驱动程序页面,下载与我们的硬件和发行版兼容的驱动程序,并使用以下命令安装基本软件包:

sudo apt install brother-cups-wrapper-extrabrother-lpr-drivers-extra

然后,我们重新启动计算机,并安装了驱动程序,因为Brother支持页面未显示该信息,在某些情况下,我们必须转至系统/管理/打印机部分(视您的发行版而定),然后选择刚刚安装的打印机,这样,我们将能够在本地使用我们的打印机。


本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

17条评论,留下您的评论

发表您的评论

您的电子邮件地址将不会被发表。 必填字段标有 *

*

*

  1. 负责数据:MiguelÁngelGatón
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。

  1.   匿名

    你好
    我在manjaro gnome中使用了兄弟dcp 7065dn,驱动程序在AUR中。
    这些打印机通常在rpm和deb中有用于archlinux的驱动程序,而派生类通常在AUR中,对于gentoo则有一个兄弟覆盖。
    问候。

    1.    蜥蜴

      其实

  2.   DAC

    驱动程序是否是免费软件-开源?

    1.    蜥蜴

      在这种情况下,它们是Linux的驱动程序,但是不幸的是,源不可用(它们不是开源的)。

  3.   Barbara

    用他们的话说,至少兄弟比理光有更多的支持。 我有一个出色的Ricoh多功能SP310spnw,但是在Linux上使用它时,会遇到很多麻烦,您只能使用打印部分。 理光的支持几乎不存在,尽管据说它具有Linux的驱动程序,但是当要安装它们时会出现错误,因为... CUPS正在运行! 我已经接受了将近一年的时间,尽管我立即向理光发送了一封电子邮件,要求他们找到一种方法来创建合适的驱动程序,但迄今为止,他们甚至还没有确认已收到该电子邮件。 我必须使用其他操作系统才能进行扫描。

  4.   阿尔贝托

    我使用了非常便宜的Brother激光HL-2135W wifi,多年来在Linux上一直很棒。 很高兴。

  5.   Puigdemont 64位

    使用过时的pkgbuild并对其进行了修改来安装1210w,它缺少一些引号,但可以正常工作。

  6.   吉尔

    不要购买Brother,购买HP,我将解释原因:是的,它们具有适用于GNU / Linux的驱动程序,但它们是专有的。 如果X年之后他们停止为新内核更新驱动程序并且停止工作,那么它们将使您无法使用并且因为我们没有代码而无法修改代码。 在工作中,我们使用Brother DCP7065dn。
    还要小心使用HP,因为它也有没有免费驱动程序的打印机,例如HP LaserJet Pro CP1025nw。 仅购买那些具有免费驱动程序的驱动程序,以避免将来被勒索购买新打印机或新的Windows或Mac OS许可证(它们始终具有驱动程序)。
    在任何情况下都不要购买SHARP打印机,我们拥有MX 2310U复印机/打印机:首先是用于Linux的驱动程序安装程序(http://www.sharp.es/cps/rde/xchg/es/hs.xsl/-/html/centro-de-descargas.htm?p=&q=MX-2310U&lang=ES&cat=0&type=1214&type=1215&os=&emu=)有多个文件重命名错误,迫使我们触摸该脚本以使其正常运行,其次,我们将其保存在配置有每个员工用户代码的网络中,事实证明Linux驱动程序无处可放置代码(在Windows中,在“作业管理-用户身份验证-用户”中为是。 因此,我无法在GNU / Linux中使用它,并且尝试了一些更改PPD文件的技巧(https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/),甚至尝试使用反向工程进行加密的驱动程序(https://github.com/benzea/cups-sharp).
    优先顺序:带有免费驱动程序的HP,带有专有驱动程序的HP,带有专有驱动程序的Brother,决不是Sharp。

  7.   费尔南

    你好
    它们需要一个二进制文件才能工作,例如,在兄弟dcp 7065dn的情况下,如果它是自由软件,则我会使用部分驱动程序,但需要一个不是免费的兄弟二进制文件。
    问候。

  8.   吉尔

    避免购买没有免费驱动程序的打印机,否则制造商将无法使用自己的操作系统同时更新驱动程序,这将迫使您购买另一台系统或另一台打印机。
    带有免费驱动程序的HP更好,请注意,有HP带有HP LaserJet CP 1025nw之类的专有驱动程序,在Brother,它们都具有专有驱动程序,但至少它们存在。 更糟糕的是SHARP复印机-打印机,其GNU / Linux驱动程序没有诸如将分配给您的代码放入网络上打印的选项,如果该公司希望控制每个人制作的副本,则这将阻止Linux使用它。例如,我什至没有设法通过修改其PPD来使打印机工作的Sharp MX 2310U(https://linuxsagas.digitaleagle.net/2014/12/05/setting-up-a-sharp-mx-2600n-printer-on-ubuntu/)或采用反向工程驱动程序(https://github.com/benzea/cups-sharp).

  9.   库帕

    下午好。 (白天,晚上等)有人可以指导我为这些网络打印机安装和配置扫描仪吗? 或告诉我在哪里可以找到预先消化的信息。 在我工作的地方,使用了多种兄弟多功能机型,并且在安装驱动程序后,打印机的配置很简单,但是有时系统(通常是zorin os 9 lite)会自动检测网络上的某些扫描仪,但有时却无法。 我想告诉我如何手动添加该扫描仪(如何指示它识别具有特定IP的多功能扫描仪)。 我进行了搜索,最大的收获是,带有ip的扫描程序名称出现在简单扫描列表中,但是没有任何内容被扫描。 三星多功能机也发生同样的事情,但是它们比兄弟功能更频繁地出现在简单扫描列表中。 我碰巧一台PC会检测到扫描仪,而旁边的PC却无法检测到。 它们在同一个网络中

  10.   Nasher_87(ARG)

    一个问题,这很愚蠢,因为我已经发现了,但是很好,我会问,您是否知道Lexmark打印机(Z11 LPT和X75多合一)在Linux中能否正常工作? 从我寻找的内容来看,什么都没有,在Ubuntu 9.10中Z11可以正常工作,使用旧内核可以工作吗?
    问候人

    PS:他们可以侮辱,我应得的😉

    1.    吉尔

      尝试以下操作:在virtualbox中安装Ubuntu 9.10,然后尝试从那里打印到打印机。 如果可行,您可以尝试从该Linux到Linux的网络上共享,以从您的Linux进行打印或以pdf格式进行打印,然后将pdfs打印在两个系统之间的共享文件夹中,以便能够从Ubuntu 9.10中获取它。
      那是专有驱动程序的问题,在Windows中也是如此,您在15年前用Windows XP购买了某些东西,却没有适用于win7或10的驱动程序。
      如果竞争中有免费的驱动程序,请不要使用专有的驱动程序购买任何东西,请选择好。

  11.   匿名

    感谢您提供的信息,如果以后您可以制作一个有关如何通过wifi连接兄弟打印机的教程,就我而言就是MFC9330CDW。 提前致谢

  12.   帕奎托先生

    我有一个Brother HL-L2340DW,并且通过Wifi连接到它。 通过USB连接打印机没有问题,但是Wifi无法正常工作。

    Brother至少为Ubuntu提供了一个称为Driver Install Tool的驱动程序,该驱动程序假定用户独自(或几乎要做某事)需要必要的驱动程序。 问题是您必须知道如何去做。 以我为例,在Google周围走了一圈之后,我看到Brother在这里向您解释了它:

    http://support.brother.com/g/b/downloadhowtobranchprint.aspx?c=es&dlid=dlf006893_000&flang=4&lang=es&os=127&prod=dcpj315w_eu_as&type3=625&printable=true

    问题是知道要在URI中放置什么内容...因此,继续进行搜索,笔者在本文中的某个jose1080i的注释中找到了答案:

    https://www.pedrocarrasco.org/como-configurar-una-impresora-wifi-en-linux/

    没有更好的解释。

    问候。

  13.   威夫主义

    不适用于所有Brother型号,对吗? 我有黑白激光,没有办法

  14.   恩里克·加里戈斯(Enrique Gallegos)

    我使用Linux Mint 19 Cinnamon 64位操作系统,我购买了Brother HL-1110紧凑型单色激光打印机,在加热我的心(通过USB)而不是Wifi之后,它出现在管理系统中,甚至移动了文档,但它们空白了,我必须拥有的“ windols”才能进行打印,并且进展顺利。