安装Ubuntu 12.04 Precise Pangolin后该怎么办

Ubuntu 12.04精确的穿山甲 几天前看到了灯。 就像我们处理此流行发行版的每个版本一样,这里有一些 你应该做的事情 在制作一个 安装 从一开始就对。

1.运行更新管理器

在Ubuntu 12.04发布之后,Canonical分发的ISO映像可能会针对不同的软件包出现新的更新。

因此,建议您在完成安装后再运行 更新管理器。 您可以通过在Dash中搜索它或通过从终端执行以下操作来实现:

sudo apt-get update sudo apt-get upgrade

2.安装西班牙语

在Dash中,我写道 语言 然后您就可以在其中添加您喜欢的语言。

3.安装编解码器,Flash,其他字体,驱动程序等。

由于法律问题,Ubuntu默认情况下不能包含一系列软件包,而这些软件包对于任何用户都是非常必要的:播放MP3,WMV或加密DVD的编解码器,其他资源(在Windows中广泛使用),Flash,驱动程序所有者(以更好地利用3D功能或Wi-Fi)等。

幸运的是,Ubuntu安装程序允许您从头开始安装所有这些程序。 您只需要在安装程序屏幕之一中启用该选项。

如果您尚未安装,请按照以下步骤安装:

显卡驱动

Ubuntu应该自动检测并提醒您3D驱动程序的可用性。 在这种情况下,您将在顶部面板上看到视频卡的图标。 单击该图标,然后按照说明进行操作。

如果Ubuntu未检测到您的卡,则您始终可以通过查找“硬件配置工具”来安装3D驱动程序(nvidia或ati)。

专有编解码器和格式

如果您是不能不听MP3,M4A和其他专有格式的人之一,并且如果您无法以MP4,WMV和其他专有格式播放视频,那么您将无法在这个残酷的世界中生存,这是一个非常简单的解决方案。 您只需要单击下面的按钮:

或在终端上写:

sudo apt-get install ubuntu-restricted-extras

为了增加对加密DVD(所有“原始文件”)的支持,我打开了一个终端并输入以下内容:

sudo apt-get安装libdvdread4 sudo /usr/share/doc/libdvdread4/install-css.sh

4.安装其他存储库

医疗机构

它是软件包的存储库,由于合法版权,许可或专利限制等原因,这些软件包无法包含在Ubuntu发行版中。 包括以下程序:Google Earth,Opera,Win32codecs,Msfonts。

sudo -E wget --output-document = /etc/apt/sources.list.d/medibuntu.list http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list && sudo apt-get --quiet更新&& sudo apt-get --yes --quiet --allow-未经身份验证的安装medibuntu-keyring && sudo apt-get --quiet更新

要在Ubuntu软件中心添加Medibuntu软件包:

须藤apt-get install app-install-data-medibuntu apport-hooks-medibuntu

GetDeb和Playdeb

GetDeb(以前称为Ubuntu Click and Run)是一个网站,在该网站上生产了Deb软件包以及通常的Ubuntu存储库中不提供的更多当前版本的软件包,并提供给最终用户。

Playdeb,Ubuntu的游戏存储库,是由给我们getdeb.net的人创建的,该项目的目的是为Ubuntu用户提供非官方的最新游戏版本库。

5.安装帮助工具以配置Ubuntu

Ubuntu的调整

用于配置Ubuntu的最受欢迎的工具是Ubuntu Tweak。 这个奇迹使您可以“调整” Ubuntu并随心所欲。

要安装Ubuntu Tweak,我打开了一个终端并输入:

sudo add-apt-repository ppa:tualatrix / ppa sudo apt-get更新sudo apt-get安装ubuntu-tweak

我的团结

MyUnity允许您非常轻松地配置Unity。

6.安装压缩应用程序

为了压缩和解压缩某些流行的免费和专有格式,您需要安装以下软件包:

sudo apt-get install rar unace p7zip-full p7zip-rar sharutils mpack lha arj

7.安装其他程序包和配置管理器

突触 -是基于GTK +和APT的软件包管理的图形工具。 Synaptic允许您以通用方式安装,更新或卸载程序包。

默认情况下尚未安装它(如CD上的空格所示)

安装:搜索软件中心:突触。 否则,您可以在终端中输入以下命令...

须藤apt-get install synaptic

能力倾向 -从终端安装应用程序的命令

由于我们可以始终使用“ apt-get”命令,因此没有必要,但是在这里我将其留给需要的人使用:

安装:搜索软件中心:aptitude。 否则,您可以在终端中输入以下命令...

sudo apt-get install aptitude

gdebi -安装.deb软件包

这是没有必要的,因为双击安装.deb会打开软件中心。 对于怀旧:

安装:搜索软件中心:gdebi。 否则,您可以在终端中输入以下命令...

sudo apt-get install gdebi

Dconf编辑器 -在配置Gnome时很有用。

安装:搜索软件中心:dconf编辑器。 否则,您可以在终端中输入以下命令...

须藤apt-get install dconf-tools

要运行它,我打开Dash并键入“ dconf编辑器”。

8.在Ubuntu软件中心中找到更多应用程序

如果找不到应用程序来做您想做的事情,或者Ubuntu中默认出现的应用程序不喜欢您,可以使用Ubuntu软件中心。

从那里,您只需单击几下就可以安装出色的应用程序。 一些受欢迎的选择是:

  • OpenShot, 视频编辑
  • AbiWord的简单,轻巧的文本编辑器
  • 雷鸟,电子邮件
  • ,网络浏览器(Google Chrome的免费版本)
  • 洋泾浜,聊天
  • 洪水,种子
  • VLC, 视频
  • XBMC, 媒体中心
  • FileZilla中,FTP
  • GIMP,图像编辑器(Photoshop类型)

9.更改界面

到传统的GNOME界面
如果您不喜欢Unity,并且想使用传统的GNOME界面,请执行以下操作:

  1. 登出
  2. 点击您的用户名
  3. 在屏幕底部查找会话菜单
  4. 将其从Ubuntu更改为Ubuntu Classic
  5. 单击登录。

如果出于某种奇怪的原因该选项不可用,请尝试首先运行以下命令:

sudo apt安装gnome-session-fallback



GNOME 3 / GNOME外壳
如果要使用Gnome-Shell而不是Unity来尝试Gnome 3.2。

安装:在软件中心中搜索:gnome shell。 否则,您可以在终端中输入以下命令...

sudo apt-get安装gnome-shell

如果您决定安装Gnome Shell,您可能也有兴趣 安装Gnome Shell 3.2扩展.

肉桂
Cinammon是Linux Mint的创建者使用和开发的Gnome 3的一个分支,它使您可以通过经典的“开始”菜单使用较低的任务栏。

sudo add-apt-repository ppa:gwendal-lebihan-dev /肉桂稳定sudo apt-get更新sudo apt-get安装肉桂

10.安装指示器和快速列表

指标 -您可以安装许多指示器,这些指示器将出现在桌面的顶部面板上。 这些指示器可以显示有关许多事物的信息(天气,硬件传感器,ssh,系统监视器,保管箱,虚拟箱等)。

指示器的完整列表及其安装的简要说明可在以下位置获得: 询问Ubuntu.

快速清单 -快速列表使您可以访问常见的应用程序功能。 它们遍历显示在桌面左侧的栏。

快速列表的完整列表及其安装的简要说明可在以下位置获得: 询问Ubuntu.

11.安装Compiz Settings Manager和一些额外的插件

Compiz是使那些令人惊叹的文具令我们所有人无语的人。 不幸的是,Ubuntu没有任何用于配置Compiz的图形界面。 此外,它并没有安装所有插件。

要安装它们,我打开了一个终端并输入:

须藤apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra

12.删除全局菜单

要删除所谓的“全局菜单”(使应用程序菜单出现在桌面的顶部面板上),我只需要打开一个终端并键入以下内容:

sudo apt-get删除appmenu-gtk3 appmenu-gtk appmenu-qt

注销并再次登录。

要还原更改,请打开终端并输入:

sudo apt-get install appmenu-gtk3 appmenu-gtk appmenu-qt

如果您是全球菜单的爱好者,但您不喜欢那样 LibreOffice的 不支持它,我打开了一个终端并写了以下内容:

须藤apt-get install lo-menubar

那应该解决问题。


本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

57条评论,留下您的评论

发表您的评论

您的电子邮件地址将不会被发表。 必填字段标有 *

*

*

  1. 负责数据:MiguelÁngelGatón
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。

  1.   匿名

    这真的很吸引人,您是一个非常专业的博客。 我已加入您的供稿,并期待获得您的精彩帖子。 另外,我已经在我的社交网络中分享了您的网站

    我的主页:: 音乐家

  2.   曼努埃尔

    优秀的先生,让我们使用Linux,我想知道是否可以为PIC单片机安装C编译器。

  3.   何塞

    非常好的内容,我想知道如何安装多维数据集程序,该程序使按alt + tab的屏幕将屏幕移开,而办公桌就像立方体一样移动,我的电子邮件是 jhsantonio@gmail.com

    1.    约翰·杰罗

      该多维数据集称为compiz,可以从synaptics进行安装,要能够很好地使用它,您的视频卡上必须具有opengl 3d效果功能,还必须安装compiz管理器

  4.   卡洛斯·考克斯(Carlos Cox)

    这个页面真的很棒。 谢谢,在这里我找到了很多解决方案。 进一步增加您的丰富知识,

  5.   让我们使用Linux

    它对您有多好!
    一个拥抱! 保罗

    1.    旧金山

      一个有问题的朋友...我正在安装Ubuntu Server,并收到一条消息,指出该程序没有候选安装..就像我想从另一台计算机上安装此链接一样:
      须藤apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra
      并显示以下内容:
      admin目录(/ var / lib / dpkg /)无法锁定,也许其他进程正在使用它?
      你可以告诉我会发生什么,或者你有什么答案..

      1.    让我们使用linux

        安装某些东西时,ubuntu市场可能会意外关闭,然后,不会删除阻止同时安装程序的文件。
        要解决此问题,您只需要打开一个终端并输入:
        sudo rm / var / lib / apt /列表/锁
        sudo rm / var / lib / dpkg /锁定
        让我知道是否解决了。
        干杯! 保罗

  6.   XANDER

    谢谢,一切进展顺利🙂

  7.   Ubuntu的

    是的! 太好了,谢谢。 愿上帝保佑您(提示:在驱动程序中添加Mass-Utils安装)

  8.   埃克·玛特

    感谢您的贡献……非常有建设性

  9.   国王g。 潘达

    谢谢你的朋友,我是LINUX UBUNTU的一位热情用户,来自SAN CARLOS COJEDES委内瑞拉。
    就像他们在盎格鲁-撒克逊语中所说的那样。 继续你出色的工作。

    国王潘达雷斯

  10.   让我们使用Linux

    谢谢卡洛斯!
    拥抱! 保罗

  11.   盖尔曼

    对于我们中那些开始使用Linux的人来说,它是出色的编译,我有一个疑问,那就是,这是否也适用于Kubuntu? 因为我知道它们基本上是相同的发行版,但是唯一改变的是Gnome的KDE桌面。

  12.   Dinamik

    是的,有些事情是不的,很多时候,这些包的调用方式不同,而且特性未得到满足……不做进一步的努力……在kubuntu中不存在统一性

  13.   朱利格罗尼莫

    问候朋友事实是,我想从Ubuntu 12.04版本开始使用tls对新手有效,我想将其安装在整个磁盘上,但保留我的win xp文档是有效的,您知道一些有关它的文档
    问候朱利奥·佩斯·委内瑞拉

  14.   乔纳森·塞缪尔·索托·蒙特斯

    这对我帮助很大 !!! 谢谢

  15.   迭戈

    很好,但是我在ubuntu上有问题,是操作系统没有亮度,我看不到我能提供的解决方案吗?

  16.   安德烈斯·弗洛雷斯(Andres Florez)

    嗨,你看,当我要在终端中安装Flash Player并要求输入密码时,它不会让我写它,该怎么办?

  17.   Echazarret @

    非常感谢。 现在我的Ubuntu只是一分钱,我什至发现Unity更令人愉快。 干杯

  18.   杰米·梅拉拉

    万分感谢

  19.   伊格纳西奥

    感谢您为新手提供免费软件。 难以想象您为该社区提供的巨大服务。 谢谢 !!!

  20.   艾萨克

    简单地宏伟,感谢您的贡献!

  21.   拉法GCG

    你是一个抹胸!
    只是我一直在寻找的东西,我有记忆,不时记得的东西。
    问候。

  22.   莫科莫里森

    谢谢很好!!

  23.   让我们使用Linux

    别客气! 一个拥抱! 保罗

  24.   让我们使用Linux

    别客气! 一个拥抱! 保罗

  25.   ubuntu的12.04的

    具有如此“更新”的存储库会造成不稳定,并且最终将每3个月重新安装一次操作系统。 不适合任何人,

  26.   让我们使用Linux

    谢谢! 干杯! 保罗

  27.   糖浆

    最后是sudo rm -rf /

  28.   柠檬

    感谢您的教程,它进展顺利

  29.   枷锁

    这些是适合胡扯的人的混蛋评论。 对于不认识的人,请不要键入此命令,因为它会清除根系统。 吉尔,给自己买个脑子!

  30.   米格尔

    很大的帮助! 由于编码解码器,我在ubuntu和mint之间犹豫不决,当然是ubuntu,非常感谢

  31.   弘中村2009

    非常好,您解释和展示的内容以及所有提供的信息:我喜欢:...

  32.   赫拉尔

    同事希望您能帮助我...
    事实是,我对Ubuntu 12.04遇到的许多问题感到非常厌倦,我真的不想回到Windows。
    我重新安装了ubuntu 12.04,因为签名中存在一些错误(事实不是很清楚,这意味着什么),发生在我身上的唯一事情是再次安装OS 12.04,希望一切都可以解决,并且我对ubuntu感到很满意。
    现在它又出现了故障,事实是我不知道该怎么办...当我尝试从终端进行更新和升级时遇到了这些错误(1),因为我无法再打开更新管理器,突触和软件中心。
    (1)W:签名验证期间发生错误。 存储库不是最新的,将使用旧的索引文件。 GPG错误是: http://extras.ubuntu.com 精确发布:以下公司无效:BADSIG 16126D3A3E5C1192 Ubuntu Extras存档自动签名密钥

    W:GPG错误: http://ppa.launchpad.net 精确发布:以下公司无效:用于Florian Diesch的BADSIG 5AF549300FEB6DD9 Launchpad PPA
    W:GPG错误: http://ppa.launchpad.net 精确发布:以下公司无效:适用于TualatriX的BADSIG 6AF0E1940624A220 Launchpad PPA
    W:无法得到 http://extras.ubuntu.com/ubuntu/dists/precise/Release
    预先感谢您的支持。

  33.   让我们使用Linux

    正如海报所说的那样,
    文件/etc/apt/sources.list。

    我打开了一个终端,并编写了以下命令以使用管理员特权使用gedit打开文件:

    sudo gedit /etc/apt/sources.list

    然后,您必须启用该选项才能查看行号。 在gedit菜单中查看(我现在尚未安装它,并且记不清自己的名字,但我认为它是Format菜单)。

    对行进行编号后,请查找第57行。

    将其复制并发送到此处,以便我们找出问题所在。 如果您可以告诉我们您使用的发行版和版本,也将非常有用。

    干杯! 保罗

  34.   迭戈·马赫查M

    当我给sudo apt-get update时,我得到了:

    E:源列表/etc/apt/sources.list中的第57行格式错误(dist解析),E:无法读取源列表,E:无法解析或打开软件包列表,或者状态文件。 搜索时,我发现注释掉第57行会起作用,但没有任何效果。

    那可能正在发生?

    谢谢。

    dmahec@yahoo.es

  35.   亚历山大

    终于经过几天的努力。 只需下载Ubuntu 12.04 ISO,从CD引导并加载操作系统,就可以选择卸载有问题的12.04,然后重新安装。 最好的惊喜是,除了纠正所有错误外,它还保留了许多功能,例如受限制的编解码器,Libre Office中的语言以及许多其他使我不必再做的功能!

  36.   亚历山大

    您好,Gumax,我有以下问题……这是整个过程,但是当我在替代版本中强制使用某个版本时,仅出现295.40版本和两个295.53版本,但是没有295.33,并且我找不到如何加载它。 我想知道您是否有解决此问题的想法,因为我在网上搜索了所有内容,却找不到任何东西。
    从已经非常感谢你。

  37.   乔斯珀科

    嗯..认为我在使用Ubuntu时之所以这样做是因为它更易于安装,这就是为什么我建议这样做,因为已经配置了许多东西。 然后我放弃了Ubuntu,转而支持Debian。 他们告诉我,配置它非常麻烦。 再次,Ummmm,对于那些因为安装简单而来的人来说是一个友好的发行版,我认为这不再适用了。 但是,退出并迁移到另一个发行版是一个很好的经验。

  38.   帕布鲁

    谢谢! 我现在要修饰一下。

  39.   库里

    大!

  40.   迭戈坎波斯

    只是…
    一份宏伟的工作

    干杯(:

  41.   埃里克·应付

    谢谢,这是100%可用和功能...

  42.   乌鸦291286

    即使我错过了在自由世界中开始的Ubuntu 10.10,也能获得很好的教程,现在我有了Linux Mint 13,它运行良好,但是我永远不会忘记10.10。

  43.   纪念

    优秀的信息,非常感谢。

  44.   丹尼斯

    很好的教程,非常感谢

  45.   曼努埃尔·费尔南德斯(Manuel Fernandez)

    杰出贡献。 非常感谢

  46.   加布里埃尔·格雷罗(Gabriel Guerrero)

    太好了,真的非常感谢您,您对我有很大帮助,此页面很好。

    洪都拉斯致你们所有人的问候。

  47.   JOSE LUIS

    我想学习,我正在从Windows迁移到linux ubuntu。 谢谢,任何信息对我都很有用

  48.   丹尼尔·维拉托罗

    谢谢,谢谢,该信息对我有很大帮助

  49.   坦率

    非常感谢你,真相是一个黄金帖子。 强烈建议从Ubuntu开始的人

  50.   Sixtus

    您好,早上好,我是在重新启动并运行程序时安装ubuntu的,它要求我提供用户名和密码。
    输入我输入的名字和它的对密码,然后出现 Sixto@ubuntu.com:-$我该怎么办

  51.   卡洛斯

    您好,感谢您的帖子,我告诉您,当我在Ubuntu 12.04中放置智能手机时,它无法识别。

    如果您能提供帮助,我将不胜感激。

    一个拥抱。

    1.    让我们使用linux

      嗨,卡洛斯!

      几天来,我们提供了一种新的问答服务,称为 从Linux询问。 我们建议您在那里进行此类咨询,以便整个社区可以帮助您解决问题。

      拥抱,巴勃罗。

  52.   安娜

    您好保罗,

    我只想说一声谢谢!

    1.    让我们使用linux

      别客气! 干杯! 保罗