DEBIAN 10上的软件开发支持软件包

DEBIAN 10上的软件开发支持软件包

DEBIAN 10上的软件开发支持软件包

这篇文章是续篇 (第三方的) 教程 致力于 DEBIAN GNU / Linux发行版,版本 10(星巴克),它是许多其他基础,例如 MX-Linux 19(丑小鸭).

在第三部分中,我们将展示 基本软件包(应用程序) 建议提供必要的 支持 基本开发,测试和执行 一些 软件(应用程序) 关于我们美丽而伟大的发行版 DEBIAN 10和MX-Linux 19.

安装后更新和优化MX-Linux 19.0和DEBIAN 10.2

安装后更新和优化MX-Linux 19.0和DEBIAN 10.2

本系列的前2个帖子是:

DEBIAN 10:安装后还有哪些额外的软件包有用?

DEBIAN 10:安装后还有哪些其他有用的软件包?

记住并记住:

请记住,此处建议运行和安装的操作和软件包仅仅是这样, “包装 推荐人 并且要由每个人来运行和安装其中的全部或部分内容,为什么 在短期或中期,了解和使用它们是必要或有用的,使它们已经运行或安装。

请记住,这些操作和/或程序包是 先前在两个发行版上都经过测试,并且不要求您卸载其中默认安装的软件包。 进一步, 它们不会增加内存或CPU的消耗 因为它们默认情况下不会在内存中加载进程或守护程序(服务)。 要预先知道每个软件包的用途,请单击 信息.=

更新MX-Linux和DEBIAN:目录

软件开发支持包

对Java应用程序的支持

apt install browser-plugin-freshplayer-pepperflash default-jdk icedtea-netx

目的: 安装基本支持以与Java应用程序兼容。

支持QT5应用

apt install libqt5core5a qt5-default qt5-qmake qtbase5-dev-tools qttools5-dev-tools

目的: 安装基本支持以与使用QT5构建的应用程序兼容。

支持数字采矿应用

apt install autoconf automake autotools-dev build-essential byobu g++ gcc gcc-7 g++-7 git git-core libboost-dev libboost-all-dev libcrypto++-dev libcurl4 libdb-dev libdb++-dev libevent-dev libgmp-dev libgmp3-dev libhwloc-dev libjansson-dev libmicrohttpd-dev libminiupnpc-dev libncurses5-dev libprotobuf-dev libqrencode-dev libqt5gui5 libqtcore4 libqt5dbus5 libstdc++6 libssl-dev libusb-1.0-0-dev libtool libudev-dev make ocl-icd-opencl-dev openssl pkg-config protobuf-compiler qrencode qttools5-dev qttools5-dev-tools

目的: 安装数字采矿应用程序的安装和管理所需的基本应用程序支持,驱动程序和库。

apt install libdb++-dev libdb5.3++ libdb5.3++-dev

目的: 为使用Berkeley v5.3数据库库的程序安装基本库支持,该库被现代Digital Mining应用程序广泛使用以进行编译和/或运行。

Web应用程序支持

阿帕奇

apt install apache2

目的: 为针对Apache2优化或兼容的Web应用程序安装基本支持。

Nginx的

apt install nginx

目的: 为针对Nginx优化或兼容的Web应用程序安装基本支持。

PostgreSQL的

apt install postgresql

目的: 安装基本命令和功能支持以管理基于Postgresql的数据库。

apt install pgadmin3 y phppgadmin

目的: 为基于Postgresql的数据库管理安装基本的应用程序支持。

MySQL的

apt install mysql-server mysql-client

目的: 安装基本命令和功能支持以管理基于MySQL的数据库。

apt install phpmyadmin y mysql-workbench

目的: 安装基本应用程序支持,以管理基于MySQL的数据库。

MariaDB的

apt install mariadb-server mariadb-client

目的: 安装用于管理基于MariaDB的数据库的基本命令和功能支持。

PHP

apt install php

目的: 安装基本命令和功能支持以处理基于PHP的应用程序。

apt install php-cas php-cgi php-curl php-gd php-json php-mbstring php-mysql php-xml php-apcu php-cli php-dev php-imap php-ldap php-xmlrpc php-intl php-pgsql php-sqlite3 php-zip phpqrcode

目的: 安装本机库的基本支持,以处理基于PHP的应用程序。

apt install libmagic-dev libapache2-mod-php libcurl4-gnutls-dev

目的: 安装基本的非本机库支持以处理基于PHP的应用程序。

PERL

apt install perl

目的: 安装基本命令和功能支持以处理基于PERL的应用程序。

apt install libapache2-mod-perl2 y perlbrew

目的: 安装基本库支持以处理基于PERL的应用程序。

蟒蛇

apt install python-all-dev python-pip

目的: 安装基本命令和功能支持以管理基于Python的应用程序。

apt install python3-setuptools python3-pyqt5 python3-pip

目的: 安装基本命令和功能支持以处理基于Python3的应用程序。

文章结论的通用图片

结论

我们希望 有用的小贴子= 关于需要哪些基本软件包才能提供正确支持的必要支持  «instalación y gestión» 某些软件开发,关于发行版 «DEBIAN y MX-Linux»,对于整个 «Comunidad de Software Libre y Código Abierto» 并为传播和应用的奇妙,巨大且不断发展的生态系统做出了巨大贡献 «GNU/Linux».

有关更多信息,请不要总是犹豫访问任何 在线图书馆OpenLibra y 杰迪 读书 书籍(PDF) 关于这个话题或其他 知识领域。 现在,如果你喜欢这个 «publicación», 不要停止分享 与他人,在你的 最喜欢的网站,渠道,团体或社区 社交网络,最好是免费开放的 乳齿象,或者像 Telegram.

或直接访问我们的主页,网址为 来自Linux 或加入官方频道 DesdeLinux的电报 阅读此书或其他有趣的出版物并为其投票 «Software Libre», «Código Abierto», «GNU/Linux» 和其他相关主题 «Informática y la Computación»«Actualidad tecnológica».


本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

2条评论,留下您的评论

发表您的评论

您的电子邮件地址将不会被发表。

*

*

  1. 负责数据:MiguelÁngelGatón
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。

  1.   特威克

    如果我错了,请纠正我,但是..在debian上,他们没有从存储库中删除phpmyadmin?
    并安装php,则无需指定(例如)php7.3或php7.3-curl

  2.   Linux安装后

    问候Twikzer! 谢谢你的评论。 当然,phpmyadmin不在DEBIAN 10(稳定)存储库中,但是在我假设的DEBIAN 11(测试)存储库中,在某些时候它们将像其他软件包一样包含在稳定软件包中,但是您可以或可以忽略它,而无需但是,这就是为什么我把它留在那里的原因。 关于第二个,则没有必要,因为存储库中的当前版本由其通用名称调用。

布尔值(true)