RPi-VK-Drive:具有Vulkan支持的GPU控制器,用于较旧的RPI板

前一段时间,Raspberry Pi基金会与伊加利亚, 揭晓 共同努力或正在开发用于Raspberry Pi板的Vulkan驱动程序 最初,他们说这只能与最新的板子“ Raspberry Pi 4”兼容,这就是他们开始开发初期阶段的方式,并且没有提到准备就绪的具体日期控制器或何时适合启动某些实际应用程序。

他们唯一提到的是在2020年下半年有可能实现这一目标, 在控制器规格范围内 有人提到,这仅限于 VideoCore VI图形加速器支持, 从Raspberry Pi 4模型和 与旧版不兼容,也就是说从3b +模型向后 他们被丢弃了。

他们还提到,与OpenGL相比,使用Vulkan可以提高图形应用程序和游戏的性能。

有了这个消息,许多不是模型4的Raspberry Pi的粉丝和所有者感到失望,因为他们感到自己被搁置了,他们实际上宣布不再值得继续支持这些板中的任何一个。

但是,现在,在最近的新闻中,随着开发人员证明并非如此,情况似乎已经发生了变化。

关于RPi-VK-Driver 1.0

NVIDIA工程师Martin Thomas负责RPi-VK-Driver的开发 用其作者的话来说,这是一个开放的控制器:

“该控制器是由NVIDIA开发的,但是开发是作为个人项目进行的,与NVIDIA无关(该控制器是在业余时间的最近两年开发的)。”

第一个版本 开放式驱动程序RPi-VK-Driver 1.0在MIT许可证下并在 实现了Vulkan图形API支持 适用于Broadcom Videocore IV GPU随附的旧Raspberry Pi板。

控制器 它适用于Raspberry Pi 4之前发布的所有Raspberry Pi板型号。

在受支持的模型中,存储库中提到了以下内容:

  • 零瓦特
  • 1个型号A
  • 1个型号A +
  • 1个B型
  • 1个型号B +
  • 2 B型
  • 3型A +
  • 3 B型
  • 3型B +
  • 计算模块1
  • 计算模块3
  • 计算模块3精简版
  • 计算模块3+
  • 计算模块3+ Lite

由于VideoCore IV GPU功能, 配备了较旧的Raspberry Pi型号, 还不够 为了全面实施Vulkan, 控制器仅实现Vulkan API的子集,它没有涵盖整个标准,但请尝试遵循 在团队允许的范围内。

然而, 可用的功能足以满足许多应用程序和游戏的需要, 由于更高效的内存管理,GPU命令的多线程处理以及对GPU操作的直接控制,因此性能远远领先于OpenGL驱动程序。

该控制器还支持MSAA等功能 (抗锯齿多重采样), 低级着色器和性能计数器。 其中的局限性是,缺少对GLSL着色器的支持,该支持在此开发阶段尚不可用。

至于作者,我们可以强调一点,他也是负责为Raspberry Pi发布Quake 3游戏端口的人,这是新控制器功能的展示。

该游戏基于ioQuake3引擎,并在其中添加了基于Vulkan的模块化渲染后端,该后端最初是由Quake III Arena Kenny Edition项目开发的。 通过在游戏中使用新的控制器,可以在Raspberry Pi 100B +板上以3p输出每秒渲染720帧以上(FPS)。

最后, 关于此控制器的实现 以及知道 有关它的更多信息,您可以在 以下链接。


本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

成为第一个发表评论

发表您的评论

您的电子邮件地址将不会被发表。 必填字段标有 *

*

*

  1. 负责数据:MiguelÁngelGatón
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。