如何用kickthemout殺死入侵者

一些銷售互聯網服務的公司有相當濫用的政策,那就是 他們不將密碼提供給路由器沒有她,我們無法 管理誰可以連接到我們的wifi,請更改密碼以訪問網絡,否則我們將無法管理wifi的廣播

為了大家的利益, 踢出去,這使我們 離開我們的wifi網絡入侵者而無需Internet,我們將能夠決定誰可以消耗網絡帶寬以及誰不能消耗網絡帶寬。

什麼是踢出去?

這是一個開源工具,開發於 蟒蛇 由 尼古拉斯·卡馬里納基斯 y 大衛·舒茨,這使我們可以彈出連接到網絡的設備,並以此方式拒絕消耗帶寬的可能性。

彈出wifi入侵者

此工具使用 ARP中毒方法或ARP欺騙 這 終止連接到局域網的設備的Internet連接,結果是驚人的,使我們能夠快速,輕鬆地享受網絡的所有帶寬。

該工具旨在供網絡管理員用來控制入侵者對帶寬的使用,並且僅在您可以訪問但也沒有訪問權限的那些網絡上工作 防止ARP欺騙攻擊的安全設置.

如何安裝kickthemout?

在安裝kickthemout之前,我們必須確保已安裝 NMAP,在ubuntu和衍生產品中,可以使用以下命令完成:

$ sudo apt-get install nmap

然後安裝 踢出去 非常簡單,我們在終端中執行以下命令就足夠了:

$ git clone https://github.com/k4m4/kickthemout.git $ cd kickthemout / $ sudo -H python -m pip install -r requirements.txt $ sudo python kickthemout.py

如何使用kickthemout將入侵者踢出我的wifi

使用以下方法將入侵者踢出您的wifi 踢出去,只需使用 sudo python kickthemout.py希望它將掃描您的網絡以查找連接的設備,並選擇是否要彈出所有連接的設備(計算機除外),彈出單個設備或我們選擇的多個設備。

該工具直觀行為的Gif如下所示:

航天員

命令運行時,所選設備將無法訪問Internet,因此 這種彈出機制是暫時的,但非常有效。 使用此工具,當入侵者或家庭成員連接到網絡時,我們可以充分利用帶寬,從而使該工具成為所有用戶在必要時都應在其計算機上安裝的工具。


本文內容遵循我們的原則 編輯倫理。 要報告錯誤,請單擊 這裡.

16條評論,留下您的評論

發表您的評論

您的電子郵件地址將不會被發表。 必填字段標有 *

*

*

  1. 負責數據:MiguelÁngelGatón
  2. 數據用途:控制垃圾郵件,註釋管理。
  3. 合法性:您的同意
  4. 數據通訊:除非有法律義務,否則不會將數據傳達給第三方。
  5. 數據存儲:Occentus Networks(EU)託管的數據庫
  6. 權利:您可以隨時限制,恢復和刪除您的信息。

  1.   匿名 他說:

    須藤-H python -m pip install -r requirements.txt
    / usr / bin / python:沒有名為pip的模塊
    在Linux Mint 18中

    1.    拉加托 他說:

      您沒有安裝pip,請使用 sudo apt install python-pip

  2.   托尼 他說:

    很好的蜥蜴..謝謝!

  3.   軟呢帽 他說:

    該程序的描述討論了LAN網絡,它是否也適用於WAN?

    1.    死牛咖啡館 他說:

      不,它使用arp,因此不適用於當前網絡之外的計算機。

  4.   法蘭祖亞 他說:

    我在家庭網絡上進行了一些測試,事實是我沒有發現任何事件,視頻一直在播放以及所有內容,但是與WhatsApp通話的另一個人說他被切斷了幾次,儘管我從未被切斷。

    我不知道,有必要使用Wireshk進行查看並分析其功能。

  5.   Unix根 他說:

    出色的工具,感謝您的發布...我無法停止閱讀此出色的網頁

  6.   納瑪德 他說:

    一切都很好,但是在啟動時仍然停留在“正在掃描您的網絡,請稍候...”,其他人是否也會遇到同樣的事情?

  7.   弗雷德 他說:

    它停留在“正在掃描您的網絡,請稍候...”

    1.    拉加托 他說:

      給它+ c並確認它沒有詢問您路由器的IP。

  8.   又名 他說:

    我離開這個程序,認為它做類似的事情
    https://github.com/aka-kuro/script

  9.   噪聲 他說:

    它不起作用,您早已發布了此帖子。

  10.   索尼婭·梅里尼斯·貝羅特蘭·利爾 他說:

    錯誤:未正確滿足要求。 請查看README文件以獲取配置說明。

    如果您仍然無法解決此錯誤,請在此處提交問題:
    https://github.com/k4m4/kickthemout/issues

    1.    麥酒 他說:

      我也一樣。 可能是哪個?

    2.    約瑟夫· 他說:

      同樣的事情發生在我身上,請幫助我。

  11.   系統用戶 他說:

    它用於kali linux中的無線,如果您有問題,請給我一個頁面,該頁面可能會幫助您:

    https://github.com/k4m4/kickthemout/issues/250