如何在Ubuntu 64位及其衍生版本上安裝DraftSight

您好,這是我的第一篇文章 blog.fromlinux.net 我想分享如何安裝 的DraftSight en Ubuntu的 和64位衍生產品,因為 達索系統 它只會拋出32位的deb軟件包。

在網上,我只能設法找到一個教程,該教程解釋瞭如何解決始終存在的依賴問題。 的DraftSight 在64位系統上安裝該文件時,本教程說您必須修改deb軟件包中的文件,我已按字母順序將其完成,但沒有結果,所以我承擔了自己尋找解決方案的任務,並且基於在控制台中看到的錯誤消息或缺少的庫,我來查找所有缺少的庫。

deb軟件包下載了一些32位庫,但前提是我們在32位系統上運行它,簡而言之,如果我們有32位系統,則我將在稍後向您展示的庫應該已經默認安裝。

現在讓我們談談DraftSight:

對於那些不知道的人 的DraftSight,是該類型的軟件 CAD 類似於(不等於) AutoCAD的它不是開源的,但是它有一個免費版本,該版本符合2D工程圖的創建和編輯的基本要求。值得一提的是,該免費版本不包含程序中的任何廣告類型,這一點在用戶中非常受歡迎。 。

DraftSight可以創建,編輯和查看文件 DWG, DFX 其中,它以多種語言提供,包括西班牙語,它是使用 Qt庫,因此許多KDE用戶將非常高興,我認為這是繼BricsCAD之後在GNU / Linux中的最佳選擇。

草稿

現在該帖子是關於:

創建此文章時的當前版本為V1R5.1,該鏈接將下載最新版本。
此解決方案可在ubuntu及其衍生版本13.10和14.04中使用,我不知道它是否在以前的版本中可用,如果出現任何問題,請告知。

在安裝.deb軟件包之前,我們必須安裝以下庫。

sudo apt-get install libstdc++6:i386 libgtk2.0-0:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386

然後我們以圖形方式或在控制台中安裝.deb軟件包,對於後者,請輸入該軟件包所在的目錄並執行。

sudo dpkg -i DraftSight.deb

我們接受許可條款,我們等待其完成安裝,就是這樣,您可以通過菜單訪問它。

對於那些想使用DraftSight的人,我提供了下載鏈接。

下載DraftSight

本文內容遵循我們的原則 編輯倫理。 要報告錯誤,請單擊 這裡.

23條評論,留下您的評論

發表您的評論

您的電子郵件地址將不會被發表。 必填字段標有 *

*

*

  1. 負責數據:MiguelÁngelGatón
  2. 數據用途:控制垃圾郵件,註釋管理。
  3. 合法性:您的同意
  4. 數據通訊:除非有法律義務,否則不會將數據傳達給第三方。
  5. 數據存儲:Occentus Networks(EU)託管的數據庫
  6. 權利:您可以隨時限制,恢復和刪除您的信息。

  1.   eliotime3000 他說:

    對於Debian Wheezy(64位版本),我不會有任何問題,因為它只需要激活多體系結構模式並解決問題即可。

  2.   基數 他說:

    我只是在Debian Testing(Jessie)64位中安裝了它,之前我已經配置了多體系結構(已經安裝了Skype),並且在安裝時沒有問題,但是正如obedlink所說,您必須安裝庫。 就像我說的那樣,我設法安裝了它,但是應用程序沒有運行,尋找已安裝的軟件包,這讓我感到我只缺少libglu1-mesa:i386,我安裝了它,並且它運行沒有問題。

    謝謝obedlink,它很棒!

  3.   馬努蒂 他說:

    在12.04位的12.10和64中,安裝時會出現問題,您必須強制使用體系結構。 這樣可以安裝,但是在系統更新時,它將卸載應用程序。 這是解決問題的指南:
    http://numeriza.com/informatica/como-instalar-draftsight-v1r3-2-en-ubuntu-64-bits-12-04/
    在這裡您可以看到如果我們不按照先前的指南進行更正,則會出現該錯誤
    http://numeriza.com/informatica/nueva-version-de-daftsight-v1r5-0/

    1.    鏈接 他說:

      我認為從控制台安裝.deb時,即使它是強制體系結構,也不會安裝依賴項,因此您必須手動執行。

      最新版本的.deb中包含的依賴項為:
      xdg-utils,libaudio2

      如果要通過控制台強制體系結構安裝它,則應首先安裝本指南中提到的依賴項以及上面提到的但32bit的依賴項

      須藤apt-get install xdg-utils:i386 libaudio2:i386

  4.   杜比曼 他說:

    太好了,感謝這個TUTO,我設法在Ubuntu 13.10上安裝了草稿! 。

  5.   弗蘭克·加瑪拉 他說:

    尊敬的作者:

    嘗試在ubuntu 14.04上安裝它對我來說不起作用。

    我應該尋找什麼才能能夠毫無問題地安裝它?

    問候

  6.   艾倫 他說:

    非常感謝! 您建議的安裝Draftsight的過程非常完美,並且非常簡單。 恭喜您!

    現在唯一缺少的是,自從我上次嘗試以來,Draftsight Beta已經成熟了,它中仍然存在許多錯誤。 最初的外觀看起來不錯。 再次感謝。

  7.   路易·菲利普 他說:

    傑出貢獻者,我終於可以在64位Lap上安裝它,唯一的問題是,當我安裝它時,要求我接受許可和條件,因為它是通過Ubuntu軟件中心完成的,所以它再次發送給我進行安裝,最後,我剛剛關閉了請求,瞧,我去網上看了一下您的計算機,並以Draftsight和voila的名字尋找了它,它為我工作了100%-

    再次感謝您投入時間來發布此解決方案

    上帝祝福你!!

    您好!

  8.   雀巢 他說:

    你是個天才!!! 我祝賀你的貢獻。 謝謝,謝謝,也非常感謝你!

  9.   阿萊森 他說:

    安裝和工作,感謝您的分享...

  10.   拉斐爾 他說:

    您好,將來使用64個軟件包不會產生問題嗎? 否則係統將僅安裝32個程序?

    謝謝。

  11.   彼得 他說:

    朋友感謝您的貢獻,我得以在Ubuntu 14.04 LTS中安裝它。

  12.   蒂亞戈(Thiago Henrique)(巴西) 他說:

    非常折騰的朋友,deu 100%工作。

  13.   洛倫佐 他說:

    非常感謝,我完全無法安裝它。

  14.   jesusguevarautomotriz 他說:

    我正在嘗試在最近安裝的Debian Whezzy 7.7上安裝DrafSight,我遵循了以下步驟 http://www.espaciolinux.com/foros/software/instalacion-drafsigth-bricscad-debian-wheezy-bits-t51561.html,我在Gnome 3菜單中看到該圖標,並且可以看到二進製文件位於/ opt / dassault-systemes /中。

    但是,當啟動應用程序時,它什麼也沒做,我使用./DrafSight在終端上運行它,並拋出以下錯誤:

    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(./ DraftSight要求)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libTD_Db.so要求)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libTD_DbRoot.so必需)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libTD_Gs.so要求)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libTD_Gi.so要求)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libTD_Ge.so必需)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libTD_Root.so必需)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(由/opt/dassault-systemes/DraftSight/Linux/../Libraries/libAecGeometry.so要求)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libFXExport.so必需。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libFXRenderBase.so必需。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libFXCommandsBase.so必需。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(由/opt/dassault-systemes/DraftSight/Linux/../Libraries/libFxFileDialogs.so要求。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.15”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libDDKERNEL.so必需。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libDDKERNEL.so必需。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libFxImages.so必需。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libFXCrashRpt.so必需。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libFXLISP.so必需。 1)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(由/opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5X11Extras.so要求。 5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(由/opt/dassault-systemes/DraftSight/Linux/../Libraries/libQt5Widgets.so要求。 5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libQt5Xml.so必需。 5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.15”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libQt5Network.so必需。 5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libQt5Network.so必需。 5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libQt5Gui.so要求。 5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.15”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libQt5Core.so必需。 5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libQt5Core.so必需。 5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/libTD_SpatialIndex.so)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/libTD_Dwf7Export.so)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/libQt5Svg.so.5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/libQt5PrintSupport.so.5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/libQt5OpenGL.so.5)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/libDwfCore.so)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libicui18n.so必需。 48)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries / libicuuc.so必需。 48)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/../Libraries/libDwfToolkit.so)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/../Libraries/libW3dTk.so)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/../Libraries/libWhipTk.so)
    ./DraftSight:/lib/x86_64-linux-gnu/libc.so.6:找不到版本“ GLIBC_2.14”(/ opt / dassault-systemes / DraftSight / Linux /../ Libraries /../ Libraries必需/libfreetype.so.6)

    我可以做什麼? 我按照這個程序 https://oscartux.wordpress.com/2014/05/21/como-solucionar-el-problema-de-glibc_2-14-not-found-en-spotify/ 試圖從一個實驗存儲庫安裝libc.so.6,它破壞了我的整個系統,我不得不重新安裝。

  15.   費羅 他說:

    它們已從32位更改為64位,也就是說,不再保留32位。

  16.   卡倫喬 他說:

    在14.04位的Ubuntu 64中,我只是使用gdebi進行安裝。 總之感謝

  17.   安德烈斯 他說:

    我在linux debby中安裝了它,一切都很好,但是當我想打開它時,我得到了過期的許可證標誌,並且它關閉了

  18.   阿德里安·賈西亞 他說:

    HOLA,
    感謝您的線索,在那天它對我非常有用。
    現在我有一個小問題,事實是我已經用Draftsight創建了一些文件,但是我更換了計算機並丟失了.deb軟件包來安裝它,而Draftsight人員停止提供Ubuntu版本,因此我無法安裝並打開這些文件。
    您沒有任何機會獲得此程序的Deb軟件包,可以將其以某種方式傳遞給我嗎?
    我幾天前已經寫信給他們,但我仍然沒有回應。
    謝謝

    1.    阿德里安·賈西亞 他說:

      好吧,我從安德烈斯的先前評論中看到,我什至無法打開它...
      真是一團糟