How To Fedora: Instal·lar còdecs àudio / vídeo i suport per a DVD

Per defecte la nostra estimada distro no instal·la els còdecs d'àudio i vídeo per qüestions de llicències :(, però no desesperin que aquí aquesta la solució:

Instal·lar còdecs d'àudio / vídeo

Per això, només necessitem:

Afegir els repositoris RPM Fusion

posteriorment, vam instal·lar per Gnome (GTK):

sudo yum install gstreamer-plugins-bad gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-ugly gstreamer-ffmpeg libdvdread libdvdnav gstreamer-plugins-good lsdvd libdvbpsi ffmpeg ffmpeg-libs gstreamer-ffmpeg libmatroska xvidcore xine-lib-extras-freeworld

Per KDE seria:

sudo yum install xine-lib-extras xine-lib-extras-freeworld k3b-extras-freeworld

Instal·lar suport per a DVD 's

Accedim com a root:

su -

He instal·lem el paquet acord a la nostra arquitectura.

Per a equips de 32 bits:

rpm -ivh http://rpm.livna.org/repo/17/i386/libdvdcss-1.2.10-1.i386.rpm

Per a equips de 64 bits:

rpm -ivh http://rpm.livna.org/repo/17/x86_64/libdvdcss-1.2.10-1.x86_64.rpm

Ara si, que res no els aturi per escoltar i «veure» una mica de metall XD.


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

23 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   Joan Carles va dir

    Només perquè quedi més bonic el post, tratá d'arreglar això »Per defecte la nostra estimada distro no s'instal·la per defecte» ....

    Salutacions

    1.    Perseu va dir

      XDDD Vagi pleonasme que m'he ventat XDDD, gràcies per la dada, de seguida ho corregeixo;).

      Salutacions :).

  2.   Jamin-samuel va dir

    hey molt bo ... tremend material

    recomano posar com instal·lar «Sublim TEXT2, ArgoUML, XAMPP, UNetbootin, Jdownloader, Skype» a Fedora ...

    si em diuen com instal això en 48 hores m'instal·lo Fedora 17 xD

    1.    Perseu va dir

      XD, UNetbootin es troben en els repos oficials, els altres programes es podrien instal·lar amb els arxius .rpm, seria molt estrany que no es trobessin, pel que fa a Skype, sé que es pot instal·lar amb un script d'instal·lació (no recordo bé si és easylife o un altre), mateix que vaig a tractar en una futura entrada.

      Salutacions;).

      1.    Joan Carles va dir

        Per Sublim TEXT2 es pot afegir el repo per a Fedora; ArgoUML només ho vaig veure per a Debian; XAMPP s'instal·la des de consola després de descomprimir (no és * rpm); el Jdownloader, hi ha un usuari de Linux Music 3.0 que va prendre el * rpm de Mandriva i el va empaquetar per a Fedora; aquí: http://www.mediafire.com/?2xmykn3ayrchtzf (Gràcies Tobal); Skype té un * rpm per a Fedora; però cal instal·lar diverses llibreries perquè funcioni; com ser: libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686 pulseaudio-libs.i686 pulseaudio-libs-glib2.i686 alsa-plugins-pulseaudio.i686.

        Quina bàrbar, com et estrany Fedora!

        Salutacions

    2.    Joan Carles va dir

      Ja t'ho vaig dir més avall, així que podeu anar instal·lant F-17 ....

      1.    Jamin-samuel va dir

        ejejeje ...

  3.   Josue Gomez va dir

    Em va ajudar molt, gràcies per l'aportació, vinc d'ubuntu, s'ha tornat molt inestable: s

    1.    KZKG ^ Gaara va dir

      Ubuntu i inestable, dues paraules cada dia més relacionades 🙁

      1.    Jamin-samuel va dir

        és veritat 🙁

        jo ja m'estic preparant per transitar molt aviat els terrenys de Fedora

        1.    KZKG ^ Gaara va dir

          Aprèn a fer servir a l'papà (literalment) d'Ubuntu ... Debian, no està gens malament 😉
          T'ho diu un que el fa servir ... jaja

          1.    Jamin-samuel va dir

            Jo ja el faci servir ... i em sembla bé .. el que em xoca és la lentitud de l'àvia que fa servir Debian .. Potser potser Solus em acabi saciant però mentrestant provés Fedora que sempre està a el dia amb els paquets (ja és un tema vell que no cal repassar) xD

          2.    krafg va dir

            Aguanti Debian. 😉

  4.   mfcollf77 va dir

    Hola tinc 5 dies d'haver incursions en LINUX i ho vaig fer amb FEDORA 17. creuen que és un bon sistema o per dir-ho així. bastant complet ?,

    clar m'està matant ara mateix com instal·lar programa que corren sota windows i fer-ho en linux tot per un programa de comptabilitat anomenat quickbook i un rypnivil per passar a mp3

    ara mateix el repte és això la instal·lació dels programes i després el so surrond que té el windows media player 11 i 12 o és que en LINUX no té aquests sons i només sons aguts o fins?

    però en termes generals m'agrada FEDORA o sigui LINUX m'agrada el repte de coses noves ja amb windows les versions no trobo moltes coses que em reptin. i aqui si.

  5.   Diego Mayorga va dir

    Disculpa mà fijate que instal i desintale el que esmentes i em va ocasionar problemes ja que no em deixa veure totes les lletres de la manera gràfica i tampoc les imatges, podries si us plau ayudarmen perquè una altra vegada surtin les lletres de la manera gràfica a l'igual que les imatges .

  6.   Jorge va dir

    Moltes gràcies !!! m'ha funcionat perfecte en el meu Fedora 20 per reproduir arxius MP4.

    Salutacions,

    Jorge

  7.   Karina va dir

    molt bon article, però jo tinc Xfce, com ho faig?

  8.   jose montero va dir

    estic instal·lant Fedora 12 en un servidor de 64 bits el qual no ve amb targeta de so, he adquirit una pci sound blaster 5.1 x-f1, el sistema detecta la targeta però quan vull fer-la funcionar amb música per exemple no s'escolta res. ¿He de fer alguna cosa mes per escoltar el so?

  9.   gnacio va dir

    Bones i Santes!

    per mes que intento no puc instal·lar els còdecs de vídeo i àudio privatius

    tinc fedora 20 arq 64 bit

    i des terminal segueixo el tut de l'bloc

    surt aquest missatge

    Error: Paquet: vcdimager-libs-0.7.24-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libiso9660.so.9 () (64bit)
    Error: Paquet: xine-lib-1.2.6-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libcdio.so.15 (CDIO_15) (64 bits)
    Error: Paquet: gstreamer-plugins-ugly-0.10.19-18.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libcdio.so.15 (CDIO_15) (64 bits)
    Error: Paquet: xine-lib-1.2.6-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libmng.so.2 () (64bit)
    Error: Paquet: vcdimager-libs-0.7.24-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libcdio.so.15 (CDIO_15) (64 bits)
    Error: Paquet: vcdimager-0.7.24-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libiso9660.so.9 () (64bit)
    Error: Paquet: xine-lib-1.2.6-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libiso9660.so.9 () (64bit)
    Error: Paquet: gstreamer-plugins-ugly-0.10.19-18.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libcdio.so.15 () (64bit)
    Error: Paquet: vcdimager-libs-0.7.24-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necesita: libiso9660.so.9(ISO9660_9)(64bit)
    Error: Paquet: xine-lib-1.2.6-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libcdio.so.15 () (64bit)
    Error: Paquet: vcdimager-0.7.24-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libcdio.so.15 (CDIO_15) (64 bits)
    Error: Paquete: librtmp-2.4-3.20131205.gitdc76f0a.fc21.x86_64 (rpmfusion-free-rawhide)
    Necessita: libgcrypt.so.20 () (64bit)
    Error: Paquet: vcdimager-0.7.24-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necesita: libiso9660.so.9(ISO9660_9)(64bit)
    Error: Paquet: vcdimager-0.7.24-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libcdio.so.15 () (64bit)
    Error: Paquet: vcdimager-libs-0.7.24-8.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libcdio.so.15 () (64bit)
    Error: Paquet: ffmpeg-libs-2.4.3-2.fc21.x86_64 (rpmfusion-free-Rawhide)
    Necessita: libass.so.5 () (64bit)
    Podria intentar utilitzar la comanda -skip-broken per esquivar el problema
    Podria intentar executar: rpm Va -nofiles -nodigest

    un horror

    com pot ser tan difícil. A el menys per a mi. El mateix de el so de l'hdmi.

    Una pena el tema de les patents.

    Bon Blog. Salutacions des d'Argentina

  10.   Jesús Alfonso Meza va dir

    MI ordinador no reprodueix vídeos de cap format ni pàgina web¿alguien em pot dir què fer per resoldre-ho? Tmb és Fedora. Realment em cal solucionar això ja que aquest ordinador és de la meva feina i m'avorreixo molt de vegades i em guzstaría tenir una mica d'entreteniment de tipus audiovisual. 🙁

  11.   jose ramirez va dir

    Salutacions a tots, instal fedora 21 per provar-me ah agradat la seva interfície i la rapides com està? Però no em funciona el reproductor de vídeo ni els d'àudio a través d'internet si tinc vídeo i àudio ja instal els codecs i res no em instal·la els repositoris rpm fusió surt un error d'instalacion si algien sap una altra manera de fer funcionar els codecs li agrairia publicar ja que sembla una bona distro m'agradaria fer-la servir és bonica i ràpida gràcies.

  12.   jose perez va dir

    Hola, que cal fer per terner suport upnp z DLNA en fedora 20.
    gràcies.

  13.   ED774 va dir

    Hola, tinc dificultats a l'veure vídeos, acabo d'instal·lar Fedora 26 i el meu reproductor per defecte instal·lat és Parole, ja vaig fer les primeres actualitzacions com s'ha de però quan col·loco reproduir vídeo em surt un error que diu ...
    «El reproductor Media Parole no pot descodificar H.264»
    o alguna cosa així
    hi ha manera de istalar o tornar a instal·lar