Tutorial: Instal·lar paquets .tar.gz i .tar.bz2

A el principi quan ens vam iniciar en Linux i busquem un programa el normal és que trobem un .deb o .rpm i en molts casos ens trobem programes amb l'extensió .tar.gz y .tar.bz2, Aquests arxius estan comprimits i en general contenen a part de el programa unes instruccions per instal.

La instal·lació per a aquests dos tipus de paquets és exactament igual

Primer vam entrar a la carpeta on tinguem l'arxiu, si la carpeta té diverses paraules hem de posar-les amb "" o si no ens buscarà carpetes amb cada paraula

cd carpetadondeestéelarchivo cd "carpeta on estigui l'arxiu"

Dins descomprimim l'arxiu

tar -zxvf nombredelarchivo.tar.gz tar -jxvf nombredelarchivo.tar.bz2

configurem

. / Configure

Fem make (compilem)

fer

Ara make install

make install

A vegades ens pot donar un error en ./configure, en aquest cas no necessita compilació i amb executar ens sobra, en una terminal fem

Article relacionat:
Ordres per conèixer el sistema (identificar maquinari i algunes configuracions de programari)
nombredelprograma

O bé vam crear un llançador.


El contingut d'l'article s'adhereix als nostres principis de ètica editorial. Per notificar un error punxa http://secbcaixabank.info/SECB-COVIDXNUMX-DENUNCIA-INSPECCION-PROTOCOLO-.pdf.

102 comentaris, deixa el teu

Deixa el teu comentari

La seva adreça de correu electrònic no es publicarà. Els camps obligatoris estan marcats amb *

*

*

  1. Responsable de les dades: Miguel Ángel Gatón
  2. Finalitat de les dades: Controlar l'SPAM, gestió de comentaris.
  3. Legitimació: El teu consentiment
  4. Comunicació de les dades: No es comunicaran les dades a tercers excepte per obligació legal.
  5. Emmagatzematge de les dades: Base de dades allotjada en Occentus Networks (UE)
  6. Drets: En qualsevol moment pots limitar, recuperar i esborrar la teva informació.

  1.   moscosov va dir

    wena, +1

  2.   correcte va dir

    en realitat el correcte per descomprimir és
    tar -zxvf arxiu.tar.gz
    tar -jxvf arxiu.tar.bz2

    i per al configuri ha una infinitat d'opcions (depenent del programari) per personalitzar la instal·lació

    ./configure -help

    Amb això veuran les diferents opcions addicionals a l'instal·lar un programa.
    No totes les distribucions utilitzen / usr / local per instal·lar els programes, això cal esmentar-també.

    Se't va oblidar esmentar com desinstal·lar un programa instal·lat d'aquesta forma. A més de definir optimitzacions per a cada arquitectura.

    En fi, bona iniciativa però et va faltar molta ... massa informació que donar a conèixer.

    Salutacions

    1.    Valor va dir

      És una cosa que jo no he fet servir gairebé mai, la majoria dels programes els trobo en els repositoris oficials.

      Això de descomprimir la veritat és que sempre m'ha anat bé així.

      Ho he escrit perquè em fot tots aquests que diuen, «quan ho descomprimas llegeix les instruccions».

      De tota manera el .tar.gz el veig com l'últim recurs, si no n'hi ha ni en paquet deb / rpm o en els repositoris

      1.    correcte va dir

        «Això de descomprimir la veritat és que sempre m'ha anat bé així.»
        estem d'acord, això no ho discuteixo, però no vol dir que sigui el correcte. No totes les distros descomprimeixen de manera «intel·ligent», en algunes cal afegir més paràmetres.

        1.    Valor va dir

          Home jo no tinc la culpa que hagi distros subnormals jajajaja

          1.    correcte va dir

            KISS home ... KISS

          2.    Valor va dir

            Home, KISS no és Subnormal, ja ho saps amb Slackware jajajaja

          3.    correcte va dir

            xD
            Per això t'ho dic

            Simple! = Fàcil.

  3.   yoyo va dir

    +1 per Proper

    1.    Pepe va dir

      Un més pelotudo que l'altre. Es van de tema aquests «genius».

  4.   Litos523 va dir

    Si canvies el «make install» per «checkinstall» (el pots instal·lar amb aptitude, aquesta en els repositoris) et instal·la el programa, però a més:
    -Crea XNUMX .deb perquè puguis instal·lar-ho en futures ocasions
    -El programa instal·lat apareixerà en Synaptic, de manera que el pots desinstal·lar fàcilment des d'allà

    1.    Valor va dir

      Els usuaris d'Arch el tenim conmplicadillo amb el Aptitude ...

  5.   jelpasajero va dir

    Perdó per la meva ignorància, però l'aplicació alien, no resol tots aquests problemes?

    1.    correcte va dir

      nope, perquè alien treballa amb paquets compilats i els tar.gz o tar.bz2 són arxius comprimits amb el codi font.

  6.   pandev92 va dir

    Realment no es pot fer un tutorial d'això, la majoria de les vegades, almenys els paquets qt es compilen d'altres maneres encara més estranyes.

    1.    hipersayan_x va dir

      Exacte anava a dir el mateix.
      Els que fan servir qmake de Qt són més o menys així:


      cd CarpetaPrograma
      qmake
      make
      sudo make install

      I afegeixo un altre cas més que són els cmakes:


      cd CarpetaPrograma
      mkdir build
      cd build
      cmake ..
      make
      sudo make install

      O hi ha altres que només cal executar el make && sudo make install.
      Aquests són els casos més comuns, però hi ha moltes més variants: s

      1.    mcder3 va dir

        Hi ha vegades que algunes aplicacions fetes en QT no porten el makefile. Així que toca crearcelos amb la següent línia:

        qmake -makefile

        Salutacions

  7.   jelpasajero va dir

    A veure si m'aclareixo, quan he de fer servir un tar.gz o tar.bz2 l'única cosa que faig per generar un .deb o all.deb usant alien és posar sudo alien install + nom de l'paquet. Això no és el mateix que compilar?

    1.    hipersayan_x va dir

      No, compilar és transformar el codi font de el programa a codi de màquina.
      Mentre que el que fas amb alien és reempaquetar que és convertir el format de paquet d'una distribució a el format de paquet d'una altra distribució.
      Per fer-ho mes simple, és com si tinguessis un arxiu comprimit en RAR i el querés passar a ZIP, vós descomprimirías l'arxiu en RAR i el tornaries a comprimir en ZIP, això mateix és el que fa alien.

  8.   StuMx va dir

    La compilació es fa en el make, no el el configuri. L'arxiu configuri és un script que verifica que el sistema compleixi amb totes les dependències per compilar el programa, després genera l'arxiu make (que és el que defineix com es compilarà) d'acord al nostre sistema.

    1.    Valor va dir

      Ara el trec perquè l'article aquest ja té molt de temps de quan el vaig escriure per abril o maig. Ni ho vaig revisar gairebé traient alguna mala paraula res més

  9.   jelpasajero va dir

    Hola:
    Crec que no m'estic explicant molt bé. Alien no només transforma un paquet rpm en un .deb, si agafes el codi font d'un programa ja sigui gz, o bz2 t'ho transforma en un deb autoinstal·lable. D'aquí la meva pregunta. Porto poc a Linux, tenir paciència amb mi.

  10.   marc va dir

    disculpin la meva ignorància, però aquests passos són vàlids també en Txakra, o alguna cosa canvia ???

    1.    KZKG ^ Gaara va dir

      No home per res 😀
      Com a tal sí, aquests passos són gairebé un estàndard en totes les distros, mes no és 100% segur que SEMPRE aquests siguin els passos a seguir. Per això et recomano que sempre llegeixis l'arxiu d'instruccions (README usualment) abans de fer res.

    2.    correcte va dir

      com diu @ KZKG ^ Gaara, no sempre és així, és un estàndard que funcionarà per a totes les distros sempre que el programa estigui escrit en C / C ++

  11.   Carlos-Xfce va dir

    Quan em torni a enfrontar a un .tar.gz d'aquests, reprendré aquest article. Com detesto aquests tals paquets!

    1.    Valor va dir

      Fotre tens edat suficient com per tenir aquests paquets jajajajaja

  12.   VulkHead va dir

    Disculpeu la meva falta de coneixement, aquest mètode d'instal·lació també funciona per a Debian. Perquè ho intento i ho intento i em dóna un error.

  13.   Laura Tejera va dir

    Per això ningú fa servir linux, per fer qualsevol estupuidez és una asana

    1.    ILAV va dir

      Que curiós, algunes d'aquestes estupideses que esmentes, els «super dotats» usuaris de Windows i OS X no poden fer-les, o els tenen por ..

      1.    Laura Tejera va dir

        el curiós és com gent com tu poden seguir un SO tan tancat.

        1.    KZKG ^ Gaara va dir

          Has evitat respondre la pregunta? ... els usuaris de Windows o els genis de OS X poden fer tantes coses amb el seu sistema com les que mostrem en aquest lloc? 🙂

          Per cert, fas servir Ubuntu de manera que ... de què estem parlant?

          1.    Laura Tejera va dir

            segueixin així màniga de mediocres

            1.    KZKG ^ Gaara va dir

              ¿Mediocres nosaltres? ... uff ... LOL!


      2.    Pepe va dir

        Som a l'any 2015!
        Crec que no cal perdre tant de temps estudiant per treballar des de consola.
        Perquè no fer servir aplicacions automatitzades per a això?
        En tot cas, a què li «agrada» escriure les ordres des de consola ja s'ho faran, que ho segueixin fent però en paral·lel hauria de tenir aquests mateixos ordres automatitzats. No demano que enviïn un coet a la lluna.

    2.    santiago luis Bazan va dir

      les raons per utilitzar programari lliure són ètiques morals. Mai s'ha de permetre que se li negui a ningú els seus libertdes humanes

      1.    Pepe va dir

        La veritat que la Sanata de «llibertat» en els programes em té fart. No podrien deixar de lloar un déu inexistent i ser una mica més humils?

    3.    Pepe va dir

      Tens raó Laura, aquests tipus amb el seu Linux la compliquen fins al hartasgo. Al put0 windows les coses són més fàcils. No desmeresco a Linux però no pot ser que per instal·lar qualsevol pel0tudes et passis hores i hores investigant com merde funciona tar i tota la meresunda perquè a la fi de el dia et quedis bardeado amb això de «principiant Linux ...».

      Jo pretenc fer servir un sistema operatiu estable però que no em tregui hores de la meva producció perquè he de treballar, no tinc desitjos de convertir-me en «llicenciat en Linux".

  14.   Thanatos va dir

    Sempre falta alguna cosa ... a l'hora de donar ./configure em surt: configuri: error: Your intltool is too old. You need intltool 0.35.0 or later.

    Posteriorment la instrucció make llança: No es va especificar cap objectiu i no es va trobar cap makefile. Alt.

    make install: No hi ha cap regla per construir l'objectiu `install

    Sóc novell i és bo investigar per aprendre, però fotre no poden explicar-ho amb pedretes de colors per als ke som nous en Linux?

    1.    Ponchus va dir

      Thanatos jo vaig tenir un problema similar i et comparteixo la meva desenllaç:
      (Primerament aclarir que també sóc un neòfit en el món Linux i la meva peripècia en aquest context amb «gust» (distro) a Ubuntu és d'una setmana).
      Partint que entre bé a la carpeta de «Descàrregues» amb la comanda «cd» on es trobava el meu paquet de el programa «SoulSeek» amb terminació «.tgz» a la terminal o consola:
      «./Configure» em va llançar error que no existia l'arxiu o directori
      «Make» em va llançar el mateix error que a tu ... pel que no vaig prosseguir amb la comanda «sudo make install» (sudo és perquè Ubuntu exigeix ​​«Súper Usuari i la contrasenya» per executar aquesta comanda, en altres paraules fer una instal·lació) .
      Investigant l'arxiu descomprimit anteriorment, em vaig adonar d'una cosa que potser et passi i és que l'arxiu descomprimit era de l'tipus «arxiu executable» (click dret-propietats) i n'hi va haver prou 2 clics per executar-lo.
      El teu problema a «./configure» potser el resolguis amb una actualització dels paquets o repositoris (em confonen una mica aquests termes) instal·lats al teu Distro, ja que et diu que «intItooI» és vell i necessites un més nou i penso que potser aquest paquet és el que compila en el teu distro. En Ubuntu ho fas a la mateixa terminal escrivint «sudo apt-get update» i actualitza tots els paquets de sistema.
      Espero haver estat d'ajuda.

    2.    Pepe va dir

      Com li vaig dir a laura, això de l'Linux et porta molt de temps. A mi em va donar el mateix missatge d'error que el teu i camino com el fantasma de Canterville d'una banda a l'altre i res de res.

      El meu cap em va dir: «tens 2 dies per trobar la solució, sinó, tornem a el windows.»

  15.   Jonathan va dir

    Gràcias

  16.   ivan va dir

    hola, tinc el mateix problema, vull instal·lar Skype 4.0. en el meu PCLinuxOS, descarregui el tar, gz2 ydecomprimi i fins ahi arribi, quan faig ./configure em diu que l'arxiu no existe..en que em vaig perdre o que? diganme, en PCLinuxOS (la darrera versio alliberada) ve instal·lat skype però és la versió 2.2 i vull instal·lar la 4,
    hi ha algun truc que hagi de fer per poder a la fi instal·lar això ?? alguna cosa en el synaptic desconegui ???
    sóc nou en aquest sistema, ja abans havia provat altres distros i fins ara mateix tot va bé excepte per això ..

    salutacions

    1.    Pepe va dir

      Sóc jo o em sembla que ningú sap aquestes preguntes.

    2.    F7eo va dir

      Hola, ja ha passat molt de temps des de la teva pregunta.

      Jo et recomano que et descarreguis la versió ultima versió de Skype per a Windows (R)
      i que facis servir Wine per executar al teu distro de GNU-Linux.

  17.   cervesa anglesa va dir

    Hola! jo tinc el mateix problema: descarregui la darrera versio de el programari center amb enxtension tar.gz i a l'arribar ala instància de «./configure» em salta un error, a l'igual que a «make». QUE ÉS »?? GRÀCIES !! A més de que el centre de softwaretiene bloqqueada l'opció instal·lar !!!

  18.   Carlos Rivera va dir

    Gràcies, em va ajudar moltíssim !!!!

  19.   michael va dir

    com crear un llançador

  20.   Angi va dir

    Una pregunta, es poden comprovar les dependències d'un arxiu tar.gz abans de córrer el ./configure ???

  21.   joseluis va dir

    sóc nou en linux la verad em sembla molt complicat instal·lar els comprimits tar gz gz2 i si amb si un deb li falta dependències i amb els rpm igual si és i586 o i686 o i386 i el pitjor és que no compto amb internet a casa meva. a l'veure tant comentari contradient-se a un li confon pitjor.

  22.   gabriel Yamamoto va dir

    bona info, però alguns paquets * .tar.bz2 ja estan compilats i per instal·lar-los només els rienes de descomprimir en qualsevol carpeta (de preferència / opt perquè aquest disponible per a tots els usuaris) i fer un accés directe a l'binari en / usr / local / bin

  23.   Gonzalo va dir

    Molt bona la explicació de com utilitzar arxius tar.gz. Moltes gràcies per la informació. Salutacions a tot l'equip

  24.   juancuyo va dir

    No em funciona,
    cd / home / jo / descàrregues / Icecat-24.0 ---> Em respon
    bash: cd: home / jo / descàrregues / Icecat-24.0: no existeix el fitxer o directori
    ¡Que estic fent malament ??? el sistema operatiu és Voyager 14.04 LTS (xubuntu) escriptori Xfce Gdebi no està en el menú contectual i el synaptic tampoc però estan en el menú inici, tot i que els obri no reconoicenlas carpetes és com si no existissin. El descomprimi a la mateixa carpeta de descàrregues ¿estara mal descomprimit ????

  25.   claudio va dir

    Aquest tutorial serveix també per .tgz?

    1.    joakoej va dir

      No, els .tgz són el format que utilitza Slackware i ja estan compilats, ja sigui que ho hagis descarregat o compilat a partir d'un slackbuild

    2.    joakoej va dir

      Per instal·lar has de fer servir installpkg «nom de l'paquet».

  26.   asdf va dir

    Ho sentim però no em soluciona molt el problema, quan dius ./configure i el configurem, hauries especificar més no? si simplement poso ./configure em diu
    bash: ./configure: No existeix el fitxer o directori

    després dius «fem make»
    Codi:

    El meu resultat:
    make: *** No es va especificar cap objectiu i no es va trobar cap makefile. Alt.

    make install
    make: *** No hi ha cap regla per construir l'objectiu «install». Alt.

    I després dius «executem el programa»
    codi:
    Nombredelprograma

    Com que sé jo quin és el nom o qual és executable? és molt abstracte potser dónes per fet diverses coses que el teu sabràs però els que vénen a veure un tutorial és molt possible que no sàpiguen

    1.    Damian va dir

      asdf.

      vaig estar investigant i l'error que sorgeix a el donar ./configure es deu a la falta d'el programa d'compilacion (com podriem compilar sense tenir un programa que ho faci?). la comanda per instal·lar un compilador a ingressar és:

      suo aptitude install build-essential

      un cop instal·lat, ens vam dirigir a la carpeta on aquest el fitxer tal com descomprimir i executem:

      tar -zxvf nombre_programa.tar.gz

      Després vam ingressar a la carpeta d'el programa descomprimit, i si ahi executar ./configure i després sudo make install

      espero haver ajudat!

      Salutacions.

      1.    Damian va dir

        perdó, m'oblidi d'aclarir, en el meu cas per realitzar el «make» i el «sudo apt-get install programa» vaig haver de ingressar a la carpeta "base» dins de la carpeta descomprimida, recent ahi em prenc les ordres per compilar ( make) i el install.

      2.    Carlos va dir

        a mi em dóna problemes quan faig servir el make diu que no troba res per construir alt

  27.   Brenda va dir

    Disculpin tinc aquest problema va executar aquesta comanda em mostra error i no puc crear el makefile
    desktop: ~ / Descàrregues $ tar -jxvf iReport-4.1.3.tar.bz2
    tar (child): iReport-4.1.3.tar.bz2: No es pot open: No existeix el fitxer o directori
    tar (child): Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now
    porfa =)

  28.   Aaron va dir

    Bon dia amics,
    Sóc nou en linux, però, he tingut en petit inconvenient a l'hora que reconegui un dispositiu que és un lector biomètric digital, acabo de googlejar i a l'semblar el vaig trobar però, es descàrrec amb una extensió .tar.gz, intenti descomprimir en una carpeta, descomprimits diversos arxius però no sé si després d'això tinc q executar alguna cosa mes o enganxar aquests arxius descomprimits en alguna carpeta del sistema, no ho sé, si m'ajuden si us plau, a executar bé el procés els estaria molt agraït, tinc instal·lat en SO linux Debian 7. des de ja salutacions i moltes gràcies.

  29.   Rufo López Retortillo va dir

    Ús tant Linex 2011 com Linex 2013 i el major problema que trobo a l'instal·lar aplicacions així és que no es em carreguen en el llistat d'aplicacions en el seu grup (gràfics, oficina, multimèdia, etc.) i si vull crear un llançador no sé a on tendo d'anar per trobar l'arxiu llançador de l'aplicació. En quina carpeta ho cregui? Com fer-ho?
    Quan es instaln des dels repositoris es col·loquen els llançadors en el seu grup, es pot fer això instal·lant els, tar.gz com es descriu en aquesta web?
    Gràcies per l'ajuda

  30.   Carlos va dir

    Si us plau ajuda tinc un altre sistema operatiu anomenat lps 1.5.5 i no puc actualitzar el programa

  31.   Carlos va dir

    Si us plau torno a dir-li no puc descomprimir un arxiu tar.bz2 tinc un sistema operatiu anomenat lps 1.5.5 i no es utilitzar-lo si us plau Ajudeu-me se'ls agradesco ...

  32.   joscastel va dir

    després de desempaquetar l'arxiu bz2, la comanda ./configure NO funciona perquè NO existeix

    1.    joscastel va dir

      tinc ubuntu 14.04LTS

  33.   saps va dir

    no ho entenc, en Slax va de cinema el .tar.gz, però en ubuntu no tinc manera que compili

  34.   Raul va dir

    Quin és el millor SO? el millor SO és que et soluciona els problemes.

  35.   Juanzito va dir

    La gent de linux és increïble. Fa, com a mínim 5 hores que estic intentant instal·lar el ZinjaI en el meu recent instal·lada distro de Linux Mint.
    M'estic passejant per tots els fòrums que trobo i en tots (però tots, inclòs aquest), et donen la informació a mitges.
    Per exemple, ja vaig obrir el terminal, però no puc posar l'adreça d'on es troba l'arxiu baixat (que és / home / usuari / Descàrregues / zinjai).
    L'únic que aconsegueixo és un error: «bash: cd: usuari: No such file or directory.
    Entenc que vulguin difondre i propagar l'ús d'un sistema operatiu, però, negant informació o explicant tot a mitges tintes, l'únic que aconseguiran és que, usuaris com jo, que tenia la ferma intenció de passar-me de Windows a Linux, desisteixi i em quedi amb el meu W7, dolent però útil i manejable.

    Salutacions ...

    PD: Què els costava fer un miserable instal·lador amb interfície gràfica? Per què avui en ple segle XXI, han de seguir usant alguna cosa similar a l'DOS per poder instal·lar un miserable programet ?. Nois ... a veure si es revifen una mica ....

    1.    ocelote va dir

      cd ~ / Descàrregues / ruta script d'instal·lació.

      Un consell: segueix amb windows. Cada sistema operatiu està fet per a un tipus de persones. Windows està fet per a les persones que prefereixen que se'ls doni tot mòlt i amb el mínim esforç possible i que veig és el teu cas. Hi ha persones que no poden o no volen aspirar a alguna cosa més que següent, següent, següent ... acceptar. Això no és dolent, simplement hem de saber les nostres limitacions i adaptar-nos a elles.

      Un altre consell: Si sabessis quantes coses s'aconsegueixen amb humilitat i usant dues paraules com «si us plau». Et sorprendria. Fes-ho sovint.

      1.    Knario va dir

        Hola linuxers.
        Moltes gràcies pel tutorial, m'ha ajudat a instal·lar els drivers de l'adaptador wifi DWA-131.
        Tinc un petit dubte, he fet tot com ho diuen a dalt.
        Anar a la ruta de l'arxiu, fer tar .... i després Make, esperar que acabi i després make install.
        Fins a aquest pas no em va donar cap error.
        El dubte que tinc és saber si ja tindria els drivers o he de fer alguna altra cosa.
        A Juanzito .. anima't i dóna-li una oportunitat a linux, sigui la distri que sigui, jo vaig decidir deixar el windows 7 fa una setmana i estic més perdut que el carall, jajajjaja, però llegint aqui i allà trobes informació que et és de vegades difícil d'entendre, tot depèn de l'esforç de cada un a voler aprendre i sortir de l'monopoli en on et s'incrusta Windows (és la meva opinió).
        Una cosa ... al teminal de linux, les majúscules compten. 😉

        Pd: he de fer alguna cosa més després de Kame install. ??

        Moltes gràcies.
        Moltíssimes gràcies i salutacions des de Canàries.

      2.    Arcs va dir

        i qui ets tu per dir a un usuari que torni a X sistema? de cas et creus Richard stallman?

        coincideixo el que diuen per hi ha en alguns comentaris que el millor SO és el que el sistema s'adapti a l'usuari i NO a l'reves.

        personalment m'encanta els .exe del Windows ja que com dius no es necessita ser geni informàtic per instal·lar una cosa molt simple com un simple bloc de notes; comparat aqui en linux que si no aquesta en les aplicacions de programari dedicades et pegues a l'enredada de segle amb un comprimit.

        arribi aquí buscant i organitzant informació per instal·lar programes en linux ja que em preparo a instal·lar en una màquina productiva el mint i es que si no em preparo jo no seré capaç d'instal·lar qualsevol cosa si no està en els repositoris.

        ara ho de l' «si us plau» tothom ho demana el problema és que ningú els contesta, per això algunes vegades la gent ha de ser agressiva així que no diguis bajanades.

      3.    pablo va dir

        perdon .. però des de sempre he defensat l'ús de soft lliure i obert .. ús computadoreas fa 30 anys .. i tinc 37 ..
        el problema és que en general en linux aquesta perfecte que qui vulgui o que haguem de «saber» una mica mes per a alguna cosa simple com instal·lar un programa, una actualització o el que sigui .. el problema ve enque molta gent necessita treballar i usar la pc (amb qualsevol SO) per fer la seva tasca específica de la feina .. pel que fins i tot si demores 10 minuts en baixar una .gz i instalarlo..o si com li passa a la majoria passessin hores ..son minuts o hores de no poder realitzar el teu treball i ahi és on a gairebé tots se'ls acaba la paciència ..
        en el meu cas .. en el treball sol ús ubuntu que és el que s'instal·la per default en les pc, ja que és un centre científic, però això fa que em passi més hores intentant instal·lar o fins i tot desentranyant com fer perquè un soft específic (per exemple jo sóc geografo) funcioni .. o que després de qualsevol actualizacion de el mateix ..recuperar totes les eines perquè la meitat deixa de funcionar dins d'un progama ..
        en aquest cas concret .. necessitava veure un webinar / fòrum de la feina .. i com fan servir java em salt el cartell que havia de actualitzar-lo .. ok .. anar a el lloc de java..buscar l'arxiu per a la meva SO, 14.04 .. mirar les «» instruccions »» de descàrrega i instalacion .. descarregui XNUMX .gz i d'ahi en mes .. descomprimir .. ok, i ... diu el «instal·les» .. i llest .. només que no es va poder fer res amb la info d'aquest post .. que faig una vegada que descomprimo el «jre-blablabla de tota la vida.gz» ??

  36.   carlos fabian ferra va dir

    això no em va servir mai en cap distro

    1.    Yukiteru va dir

      Si no us va servir és per pur Capa 8.

      1.    Yank Carlos va dir

        Geni!

  37.   Ignacio Navarro va dir

    Com l'utilitzo molt de tant en tant, cada vegada entro aquí per poder veure com es fa.
    Moltes gràcies per haver-ho redactat i per no esborrar-a el cap de tant de temps.

  38.   ramon va dir

    com es pot veure en synaptic el paquet nou instal·lat si et mostra el mes vell (estable segons la distro)?

  39.   Jorge va dir

    tot se'n va a la merda a l'arribar a l'./configure no hi ha ningú qui expliqui bé per quan digui que el fitxer no existeix

    1.    Elvis va dir

      estic intentant instal·lar wifi de Broadcom ni ./configure, ni make ni make install resulten.

      la seqüència lògica es 1 ° executar ./configure però a l'sembla aquesta instrucció només fa referència a un directori configuri i executar algun arxiu allà ja, això hauria de venir en el paquet que es baixa de Broadcom però en el meu cas no aquesta aquest directori, el que suposadament hauria de fer configuri és una revisió i crear el fitxer Makefile, però a l'descomprimir el paquet m'adono que Makefile ve incorporat, els altres dos ordres make i make install no em funcionen sera per que no ho suporta l'última versió de elementary us freya basat en ubuntu 14.04

    2.    Alejandro TorMar va dir

      La Veritat? mai m'ha servit aquest mètode i sempre opto per paquets .deb o per ordres des de la Terminal ... Llàstima que no hi hagi res clar per a instal·lar .tar.gz

  40.   Elvis va dir

    estic intentant instal·lar wifi de Broadcom ni ./configure, ni make ni make install resulten.

    la seqüència lògica es 1 ° executar ./configure però a l'sembla aquesta instrucció només fa referència a un directori configuri i executar algun arxiu allà ja, això hauria de venir en el paquet que es baixa de Broadcom però en el meu cas no aquesta aquest directori, el que suposadament hauria de fer configuri és una revisió i crear el fitxer Makefile, però a l'descomprimir el paquet m'adono que Makefile ve incorporat, els altres dos ordres make i make install no em funcionen sera per que no ho suporta l'última versió de elementary us freya basat en ubuntu 14.04

  41.   Alejandro TorMar va dir

    La Veritat? mai m'ha servit aquest mètode i sempre opto per paquets .deb o per ordres des de la Terminal ... Llàstima que no hi hagi res clar per a instal·lar .tar.gz

  42.   Alejandro TorMar va dir

    Per què serà que no actualitzen aquest tutorial? O fan un de nou?
    Tots i totes aquí es queixen que no els va servir i ja té els seus anys ....

  43.   HECTOR MATOS va dir

    Hola, vull ajuda, amb això d'instal·lar paquetes..tengo Ubuntu versió 15 .. algo..deseo instal·lar tova flash plugin, per és molt útil instal·lar-lo, ja que amb tova flash puc entrar a algunes pàgines web, on es pot veure la tele i també escoltar la radio..por favor em poden enviar algun tutorial pas per paso..no tinc molta experiència en això de command line és a dir fer servir alguna terminal.

    Ayuda..gracias

  44.   Abraham va dir

    Hola a tots i totes !!! despres de llegir gairebé tots els comentaris em vaig buscar un manual de linux i llest ..
    Amic ocelot, accepta aquesta crítica, des de la meva humil i insignificant punt de vista que comparteixo amb mmillones d'usuaris de windows:

    M'encantaria passar-me a linux! però a molts ens resulta impossible, perquè? et preguntessis ... perquè per a mi l'ordinador és el mitjà de què disposo per fer la meva feina, no és la fi ... no sé si m'entens el que volem tots (i ben t'ha dit JUANZITO) és un sistema operatiu estable que ens ajudi a desrroyar la nostra feina, no tinc temps per aprendre a fer coses tan bàsiques com instal·lar un programa des de la consola, tot hauria de ser més intuïtiu i més fàcil ... com a empresari et diré que la gestió que porteu amb linux és nefasta, en comptes d'ajudar a la gent a que realitzi el canvi de sistema operatiu us entesteu en què la gent es lie amb coses que no els interessa i vosaltres mateixos bloqueais el canvi ... T'ho diu un que programava en ensamblador, java, javascript, html, php i xBase ... i em toca els nassos haver d'obrir la consola per a gairebé tot.

    una salutació

  45.   DEFCON va dir

    Aguanti DOS 6.22 vella !!

  46.   erput va dir

    Put us a estudiar iaa deixar aquesta merda de wuendos que a alguns li funciona per que es haquean les put as claus, no les paguen, pa sobre de mals qui li haquean aquesta claus són els genis de linux i debian, to això és pa que estigueu com estúpids discutint mamahuevadas, als empresaris això els dic segueixin pagant la seva llicència i si el que volen és un so estables pa guanya temps que cony fan escrivint huevonadas en aquests estatuts això és pa els que ens agrada linux huevones ... .. dit po l'as

  47.   GENNDA va dir

    No està molt clar per a usuaris novells. Per exemple dius:
    «Primer vam entrar a la carpeta on tinguem l'arxiu, si la carpeta té diverses paraules hem de posar-les amb" "o si no ens buscarà carpetes amb cada paraula» ...
    qualsevol usuari entrarà amb el «explorador» a aquestes carpetes, i renombrara sense saber el nom de la carpeta que el conté amb amb les cometes. Això des del punt que ho llegeixes, «des del punt de vista de l'usuari novell.

    Després poses:
    cd carpetadondeestéelarchivo

    cd "carpeta on estigui l'arxiu"
    Des d'aquest punt l'usuari ja es va anar als núvols o on sigui, per que des de ja queda perdut en el amb les sigles CD, no surts com arribes aquí, un exemple pas a pas, començant que tot això ... és obrint la consola primer .

  48.   GENNDA va dir

    Per HECTOR MATOS: El de l'connector de tova, java, i altres no cal que ho facis manualment, només necessites estar connectat a internet un temps, i en el gestor d'actualitzacions t'apareixerà automàticament, des d'aquí s'actualitzarà automàticament, Firefox per opera, i la resta independentment ... normalment el llançador està a la banda de el rellotge a la barra d'inici, en diverses distros vaig veure que per defecte hi era, no sé si en tots serà així.

  49.   Max va dir

    Si us plau es mes explícit falta molta informació

  50.   Maria va dir

    intenti actualitzar python a 3.xi a l'fer make install a l'finalitzar em diu q hi ha error:
    zipimport.zipimporterror can not decompress data zlib no disponibles make *** install error

  51.   f_leonar va dir

    Després de descomprimir per poder executar ./configure cal entrar a directori descomprimit, si no, no funciona. Jo ús KDE i vaig entrar de forma gràfica a la carpeta que descomprimí i aquí vaig obrir un terminal per executar «make» però no funciona ...

  52.   anònim va dir

    tinc un dubte a mi em surt això:
    manolo @ mxlolo-satellite-c655d: ~ / Escriptori $ ./configure -help
    bash: ./configure: No such file or directory
    que faig ...?

  53.   KATSODA va dir

    Tot bé fins que va sortir el ./configure dels collons.
    ¿¡A què es refereixen AMB ESO!?. No ho expliquen, jo només vull instal·lar el second life de merda xDDD
    «»»katsoda@katsoda-PC:~/Downloads$ ‘/home/katsoda/Downloads/Second_Life_5_0_4_325124_i686’/configure
    bash: / home / katsoda / Downloads / Second_Life_5_0_4_325124_i686 / configure: No existeix el fitxer o directori »» »
    Jo millor vaig descarregant el Windows 10 ia prendre pel cul. (?)
    Bé, no. Però això és de les coses que oïdi de Linux. Instal·lar, i pregar que els teus programes preferits siguin compatibles aquí és tot un repte.

    1.    Gatoo_ va dir

      No és per fastiguejar, senyors, però el creador de l'tutorial explica perfectament el que cal fer si surt un error amb ./configure .Només cal acabar de llegir la resta de l'tutorial (que són 4 línies).

      Em sembla increïble que tanta gent es queixi que no explica les coses quan ni tan sols us heu parat a llegir.

  54.   divendres va dir

    Doncs jo em declaro oficialment incompetent per a aquest tipus de fitxers. Estic intentant instal·lar java i això és el que hi ha;
    javier @ golfes: ~ / JAVA / jre1.8.0_151 $ tar -zxvf jre-8u151-linux-x64.tar.gz
    tar (child): jre-8u151-linux-x64.tar.gz: No es pot efectuar open: No existeix el fitxer o directori
    tar (child): Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now

  55.   Roger Deku va dir

    en linux ubuntu 18.04.01 lts només cal teclejar ./nombredelprograma dins de la mateixa carpeta després de descomprimir-lo i llest !!!

  56.   jia va dir

    Molt bé, va ser de molta ajuda.

  57.   emerson Gonçalez va dir

    en av linux això no funciona
    no es que em extra, o cada vegada que instal una distro comences el via crucis
    ja veus com va el teclat

  58.   José Félix Paisà Morales va dir

    Hola a tots ús Ubunto 20 i vaig consultar aquesta pàgina per instal·lar el scaner d'una Epson L4150 (vaig baixar els drives des http://support.epson.net/linux/en/imagescanv3.php?version=1.3.38#ubuntu).
    Vaig seguir els passos i vaig utilitzar 'tar -zxvf nombredelarchivo.tar.gz', a l'descomprimir vaig usar
    '$ Cd imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb', que és la carpeta que es crea.
    Dins de la carpeta vaig usar './install.sh', que és com fer servir './configure', el sistema em va demanar la contrasenya i tot es va instal·lar molt bé.
    Vaig provar el meu escàner i va anar de meravella, gràcies per donar-me les indicacions, ja vaig poder utilitzar el meu escàner