Sådan installeres AceStream på Linux og ikke prøve

De af os, der elsker sport og ikke har adgang til alle nuværende sportskanaler, står generelt over for problemet, at for at kunne nyde det skal vi bruge forskellige sider, der sender online kampe, anmoder de fleste af dem installer AceStream, som har tendens til at være lidt kompleks at installere på Linux.

I denne vejledning lærer vi hvordan installer AceStream på Linux uden at dø i forsøget, levere løsninger på de mest almindelige problemer i dag. Dens anvendelse og det indhold, du får adgang til, er dit samlede ansvar.

Hvad er AceStream?

AceStream er en multimedieplatform ganske innovativt, hvilket har ført gengivelsen af ​​audiovisuelle billeder på Internettet til et højere niveau. For at gøre dette har den implementeret en universel manager til indlæsning af multimediefiler, der bruger de mest avancerede P2P-teknologier, hvilket garanterer en effektiv datalagrings- og transmissionsproces.

Ace Stream-software giver os en række fordele, hvor vi kan fremhæve:

  • Mulighed for at se online udsendelser (TV, brugerdefinerede streams, film, tegnefilm osv.) Med høj lyd- og billedkvalitet.
  • Lyt til musik online i et format, der ikke mister nogen kvalitet.
  • Se torrents online uden at skulle vente på, at den downloades fuldt ud.
  • Se indhold på eksterne enheder (Apple TV, Chromecast osv.) Via kommunikationsprotokoller som AirPlay, Google Cast og andre.
  • Tillader integration med forskellige applikationer. Installer AceStream på Linux

Sådan installeres AceStream på Linux

For at installere AceStream på Linux skal vi følge forskellige trin afhængigt af den distro, du bruger, vi vil fokusere på Arch Linux og Ubuntu, men vi håber i fremtiden at kunne installere det på andre distroer.

Installer AceStream på Arch Linux og derivater

Hovedårsagen til, at jeg har lavet denne artikel, er fordi mange har haft problemer med at installere AceStream på Arch Linux, Antergos, Manjaros og derivater, hovedårsagen er, at pluginets pkgbuild acestream-mozilla-plugin Det giver en fejl under installationen, løsningen er ekstremt enkel.

Vi skal installere acestream-mozilla-plugin som også vil installere os acestream-motor y acestream-spiller-data hvad er pakkerne nødvendige for at reproducere AceStream fra Firefox.

Først og fremmest skal vi åbne en terminal og udføre følgende kommando:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Det løser bekræftelsesproblemet, der forhindrer installation af den afhængighed, der er nødvendig for at installere acestream-mozilla-plugin.

Derefter udfører vi følgende kommando

yaourt -S acestream-mozilla-plugin

Ved gentagne lejligheder bliver vi spurgt, om vi vil installere forskellige afhængigheder, vi skal sige ja til alle.

Installer AceStream på Ubuntu og derivater

Installer AceStream på Ubuntu 14.04 og derivater

For brugere af Ubuntu og derivater op til version 14.04 vil installationen af ​​AceStream være ret enkel, de skal kun udføre følgende kommandoer fra terminalen:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Installer AceStream på Ubuntu 16.04 og derivater

De, der bliver nødt til at kæmpe lidt mere, er brugerne af Ubuntu 16.04 og derivater, da acestream ikke har support til denne version, men takket være dette artiklen, Det lykkedes mig at installere det.

Den første ting, vi skal gøre, er at downloade og installere nogle afhængigheder, som du ikke kan downloade fra de officielle arkiver. Sørg for at installere de relevante til arkitekturen i din distro:

64-bit arkitektur:

  1. Download og installer libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb du kan gøre det fra følgende link: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Download og installer i den rækkefølge, som følgende afhængigheder præsenteres i:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb Du kan downloade hver enkelt fra følgende link: https://drive.google.com/folderview?id= … e_web#list

32-bit arkitektur:

  1. Download og installer libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb du kan gøre det fra følgende link: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Download og installer i den rækkefølge, som følgende afhængigheder præsenteres i: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb Du kan downloade hver enkelt fra følgende link: https://drive.google.com/folderview?id= … e_web#list

Dernæst skal vi fortsætte med den sædvanlige installation af AceStream, som vi gjorde for version 14.04, åbne en terminal og udføre:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

I nogle tilfælde er det nødvendigt at starte tjenesten acestream-engine.service, til dette udfører vi følgende kommandoer fra terminalen:

systemctl start acestream-engine.service systemctl aktiver acestream-engine.service

Med denne vejledning håber vi, at du kan nyde denne fantastiske multimedieoverførselsprotokol, der bruger al kapacitet i P2P-teknologi.


Indholdet af artiklen overholder vores principper for redaktionel etik. Klik på for at rapportere en fejl her.

41 kommentarer, lad dine

Efterlad din kommentar

Din e-mailadresse vil ikke blive offentliggjort.

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Control SPAM, management af kommentarer.
  3. Legitimering: Dit samtykke
  4. Kommunikation af dataene: Dataene vil ikke blive kommunikeret til tredjemand, undtagen ved juridisk forpligtelse.
  5. Datalagring: Database hostet af Occentus Networks (EU)
  6. Rettigheder: Du kan til enhver tid begrænse, gendanne og slette dine oplysninger.

  1.   Julio Cesar Campos sagde han

    Nå posten, men i det mindste i archlinux, og dette var min sag, du har brug for: "systemctl start acestream-engine.service" og "systemctl aktiver acestream-engine.service" for at det skal fungere.

    1.    firben sagde han

      Testede du det fra Firefox, eller brugte du en anden browser?

  2.   UserDebian sagde han

    Ved nogen, hvordan man får det til at arbejde på Debian 9?

  3.   Julio Cesar Campos sagde han

    Firefox på archlinux

  4.   gecoxx sagde han

    Jeg ved ikke, om min tidligere kommentar blev offentliggjort ... Jeg gentager! Det tager jeg ved ikke, hvor mange timer at udføre den forbandede kommando i terminalen, og at jeg lægger –nokonfirm, og til sidst fungerer det ikke !!
    et andet indlæg, der er ubrugeligt!

    installationsforsøg på Manjaro

    1.    firben sagde han

      Kære at det ikke fungerede for dig, det fungerede perfekt for mig, prøv alligevel at udføre disse 2 kommandoer:
      "Systemctl start acestream-engine.service" og "systemctl aktiver acestream-engine.service"

  5.   José sagde han

    god

    Det lykkedes mig at udføre alle trin uden problemer. Men når jeg forsøgte at starte tjenesten fra terminalen, gav det mig to fejl;
    systemctl start acestream-engine.service
    Kunne ikke starte acestream-engine.service: Enhed acestream-engine.service ikke fundet.
    systemctl aktiver acestream-engine.service
    Handlingen kunne ikke udføres: Ingen sådan fil eller mappe

    1.    gustavo sagde han

      Præcis det samme skete med mig. terminalen hopper disse kommandoer til mig med disse fejl.

  6.   Juan M. sagde han

    Mange tak for indlægget! Hvis du bruger Ubuntu 16.10 64 bits, kan du ikke installere "acestream-player-data_3.0.2-1.1_amd64.deb". De skal først downloade og installere disse pakker:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Sandsynligvis er der brug for en anden afhængighed, der findes i repos.
    Greetings!

  7.   Miles sagde han

    Godt.
    Acestream-mozilla-pluginet er stoppet med at fungere i Firefox 52, ligesom mange andre NPAPI-plugins.

  8.   mørk sagde han

    En anden meget god og enkel mulighed er at bruge docker og blive agnostiker for dit operativsystem. Ved hjælp af aceproxy kan du gengive det-

    Jeg har skrevet en lille tutorial og et script for at lette udførelsen.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   David Martin sagde han

    I den del af installationen fra Ubuntu 16.04, når du siger download og installer disse filer, hvordan installerer du dem? Når jeg downloader og udpakker dem, er nogle kun en libreoffice-fil og andre, jeg ved ikke, hvordan man "installerer" dem.
    På forhånd tak og hilsner.
    David.

  10.   wow sagde han

    Enten fungerer tasterne ikke igen, eller der er en eller anden fejl i pakkerne, men i arch og manjaro er det umuligt at installere det.
    Når du prøver at installere en afhængighed (qwebquit) eller noget lignende, går det i en løkke, og der er ingen måde.
    Har nogen fundet løsningen?
    Tak

    1.    Alexander sagde han

      Hej, for installationen i arch linux skal du gøre følgende:
      -Installer pakken 'acestream-launcher' fra yaourt med 'yaourt -S acestream-launcher' (den pakke, som vi vil aktivere næste, downloades automatisk til dig)
      -Aktiver acestream-engine.service, vi går ind i terminalen og i ROOT-tilstand sætter vi følgende
      -systemctl start acestream-engine.service
      -systemctl aktiver acestream-engine.service
      Jeg genstartede computeren efter dette, jeg ved ikke, om det vil være nødvendigt, men bare i tilfælde
      -Dette skal være nok, men i de sidste Arch-opdateringer har de skruet noget sammen, og det virker ikke, så de har ledt efter en midlertidig løsning, som er at downloade en fil, det er følgende:
      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      kilde: https://aur.archlinux.org/packages/acestream-launcher/ (på kommentarerne)
      når den er downloadet, går vi til terminalen og går til den mappe, hvor vi har downloadet den,
      Vi fortsætter med at installere det med 'sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz' og det er det, det skal gå, første gang det aldrig går, så jeg klikker en gang til, første gang altid giver fejl, det er alt

      PS: præciser, at sudo pacman -U og ikke -S, fordi det er en lokal pakke opnået fra makepkg

      1.    wow sagde han

        Mange tak for din interesse.
        Jeg har prøvet så mange gange, at jeg allerede kender afhængighederne og kommentarerne til pakkerne i installationen med yaourt udenad. Jeg vil følge dit råd med launcheren og se om jeg er heldig. Jeg vil fortælle dig.
        Jeg gentager min tak

        Felipe

        1.    wow sagde han

          På en eller anden måde virker det ikke. Jeg har prøvet det link, du har sat i kommentarerne, men det løser det ikke, det genkender linket, det giver mig mulighed for at vælge programmet, jeg vælger acestream-launcher, men VLC åbnes ikke.
          I konsol giver det mig følgende svar.

          Fil «/usr/lib/python3.6/site-packages/psutil/init.py », linje 1231, i _send_signal
          os.kill (self.pid, sig)

          Vi bliver nødt til at vente på nye opdateringer.
          Tak for din hjælp.

  11.   wow sagde han

    Efter den nye opdatering er svaret i konsollen følgende.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Acestream-motor kører.
    2017-07-28 18: 16: 59,615 | MainThread | acestream | fejl under opstart
    Traceback (seneste opkald sidst):
    Fil «core.c», linje 1590, i
    Fil «core.c», linje 144, i
    Fil «core.c», linje 2, i
    ImportError: kan ikke importere navn __m2crypto
    Fejl ved godkendelse til Acestream!
    Media Player kører ikke ...

    Vi forbedrer os, nu genkender det acestream, men libcrypto fortsætter med at kæmpe.

    1.    wow sagde han

      Jeg har prøvet at installere den pakke, som du anbefaler, i det link, du sendte mig.

      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      Og det løser effektivt problemet, vlc åbner og Acestream fungerer.
      Mange tak for din hjælp-

      1.    Alexander sagde han

        Hej, undskyld for forsinkelsen, det var meget mærkeligt, at det ikke fungerede for dig, da det gjorde, jeg er i Arch plasma, jeg er glad for, at det har hjulpet dig, det er det, vi er for

        I den anden distribution, som jeg har, som er Fedora, har jeg vinemulerende acestream til windows xD, hvis du går til en anden distro eller i samme Arch, hvad der overrasker mig er, at ikke engang i Debian har de disse pakker ...

      2.    delikatesse maker01 sagde han

        Hej og filen er, hvordan den er installeret. Jeg er stadig en nybegynder, en hilsen

        1.    wow sagde han

          sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

          Han sætter det i kommentaren ovenfor

  12.   kemabs sagde han

    I går installerede jeg det som en snap-pakke i Kde Neon 5.8, og jeg var forbløffet over, hvor enkelt og hurtigt det fungerede for mig. Det ville være rart, hvis du opdaterer artiklen, fordi der ikke er nogen sammenligning, processen er meget forenklet.

    sudo apt installer snapd → installer snap-pakkehåndteringssystemet (hvis du ikke har det installeret)
    snap find acestream → for at kontrollere, at vi har programmet i arkiverne (alle ubuntu-derivater skal have det)
    sudo snap installere acestreamplayer

    hilsen

    1.    Antonio Manzano sagde han

      Du har ret. Jeg har lige installeret det i kubuntu 17.10, da metoden, der vises her, er fuldstændig umulig. Mange tak

      1.    Far sagde han

        ikke gyldig til i386-arkitektur

    2.    sie9k sagde han

      Det har været den eneste måde at kunne installere det på Lubuntu 16.04.4, men der er ingen måde for mig at gemme konfigurationsfilen, og jeg er nødt til at konfigurere en parameter til at arbejde sammen med Serviio. Nogen ideer til at ordne det?

  13.   José Antonio sagde han

    Meget godt indlæg. En must-read webside til Linux nybegyndere.

  14.   Peter rookie sagde han

    Hvordan ville du installere det til AntiX 16 (det er en Linux-distribution)?

    Jeg har prøvet som Arch Linux og derivater, men jeg er sådan en nybegynder, at jeg må få det forkert

  15.   Alexander sagde han

    Hej, med sna-pakker, som kollegaen ovenfor kommenterer i en kommentar, er det blevet lettere ikke kun for disse distributioner, men for mange. Distributionerne, der er kompatible med disse pakker, er her:
    https://snapcraft.io/

    I Debian ville det være som følger:
    -sudo apt installer snapd
    -sudo snap installere kerne
    -sudo snap installere acestreamplayer
    I Arch og derivater:
    -sudo pacman -S snapd
    -sudo systemctl aktiver - nu snapd.socket
    -sudo snap installere acestreamplayer

    I Arch (plasma) har jeg været nødt til at genstarte, så de installerede pakker vises, hvis det ikke vises ved du allerede, hvad du skal gøre.

    På ubuntu og derivater antager jeg, at det vil være som den partner, der installerede det ovenfor i kommentarerne med KDE neon.

    Det er nysgerrig, at det i Gnome med Debian ser ret grimt ud og ikke integreres godt med GTK, men i Arch plasma integreres det ganske godt, det vigtige er, at det ses uden for æstetik.

    1.    william sagde han

      installerer dette din acestream-motor?
      Ikke mig

      1.    Alexander sagde han

        Hej nej, det installerer det ikke, og det er heller ikke nødvendigt med snappakkerne, som alle dækkede afhængigheder allerede kommer, det skal fungere ja eller ja.

    2.    txuber sagde han

      Hej Alejandro, se om du kan hjælpe mig
      [txuber @ manjaro ~] $ sudo systemctl aktiver - nu snapd.socket
      Enheden kunne ikke aktiveres: Enhedsfil \ xe2 \ x80 \ x93now.service findes ikke.
      på manjaro Manjaro XFCE Edition (17.0.4) x64

      1.    Alexander sagde han

        Hej, Manjaro er, at det ikke er ren Arch, og ting kan ændre sig lidt, det er muligvis allerede aktiveret, og det er ikke nødvendigt at gøre det, jeg antager, at du allerede har forsøgt at springe det trin over ...

  16.   Debian sagde han

    Når du er installeret, hvad skal jeg gøre? Fordi ess-afspilleren ikke er installeret, ved jeg ikke, hvordan jeg får den til at fungere.
    Hjælp mig nogen?

    1.    wow sagde han

      Hvis det du har installeret er acestream-launcher, når du klikker på et link, vil acestream spørge dig med hvilket program du vil åbne linket, fortæller du det med VLC, og dette er det, der vil udføre funktionerne i ace-afspilleren

      1.    Debian sagde han

        Hej. Først og fremmest mange tak for din hjælp. Jeg kommenterer. Jeg har installeret acestream snap-pakken i Debian 9 med gnome. Når jeg er i arenavisión, hvilket er hvad jeg vil have det til, klikker jeg på et acestream-link, og der vises et vindue, der giver mig to muligheder, det første er acestreamengine, at hvis jeg klikker på dette, gør det intet, og det andet er at vælge en anden applikation, jeg giver den for at vælge, men de installerede applikationer ikke åbnes, åbnes min hjemmemappe, så jeg ved ikke, hvordan man vælger vlc.

        En hilsen.

        1.    Alexander sagde han

          Med acestream-launcher går det slet ikke godt, bedre at installere med Snap-pakken, som jeg forklarer i min kommentar ovenfor.

  17.   Peter rookie sagde han

    Jeg prøver at installere snapd-pakken, men det lader mig ikke:

    sudo apt installer snapd
    Læsepakke liste ... Udført
    Oprettelse af afhængighedstræ
    Læsning af statusoplysninger ... Udført
    E: Snapd-pakken kunne ikke findes

    hvad jeg gør?

  18.   Alf sagde han

    Mange tak, det er et af de programmer, jeg brugte i windows, og jeg ville have det i linux

  19.   Oscar sagde han

    Tak Chemabs og Alejandro! Perfekt med Ubuntu 17.10
    sudo apt installer snapd
    snap find acestream
    sudo snap installere acestreamplayer
    Og det er det!
    Den utrolige ting er, at du går til det officielle websted, og de sender dig et indlæg på deres forum fra 2014! Og hvor de kun nævner op til Ubuntu 13.04!

  20.   Marco Barria sagde han

    godt, som de siger i de foregående kommentarer, det fungerer perfekt med snapd in arch:

    sudo pacman -S snapd
    sudo systemctl aktiver snapd.socket
    genstarte
    sudo snap installere acestreamplayer
    genstarte

    og klar:

  21.   mchavez sagde han

    hej, og er der en måde at installere ess-strømmen på uden at være programmerer ... som det gøres med windows