Selvstudie: Installer pakkerne .tar.gz og .tar.bz2

I starten, når vi starter i Linux og leder efter et program, er det normalt, at vi finder en .deb eller .rpm, og i mange tilfælde finder vi programmer med udvidelsen .tar.gz y .tar.bz2Disse filer er komprimeret og indeholder normalt instruktioner til installation af det bortset fra programmet.

Installationen af ​​disse to typer pakker er nøjagtig den samme

Først går vi ind i den mappe, hvor vi har filen, hvis mappen har flere ord, skal vi sætte dem med "" eller hvis den ikke ser efter mapper med hvert ord

cd-mappe hvor filen er cd "mappe hvor filen er"

Inde pakker vi filen ud

tar -zxvf filnavn.tar.gz tar -jxvf filnavn.tar.bz2

Vi konfigurerer

./configure

Vi laver (kompilerer)

lave

Foretag nu installation

make install

Nogle gange kan det give os en fejl i ./configure, i så fald har det ikke brug for kompilering, og med udførelse har vi masser, i en terminal gør vi

relateret artikel:
Kommandoer til at kende systemet (identificer hardware og nogle softwarekonfigurationer)
programnavn

Eller vi opretter en launcher.


Indholdet af artiklen overholder vores principper for redaktionel etik. Klik på for at rapportere en fejl her.

102 kommentarer, lad dine

Efterlad din kommentar

Din e-mailadresse vil ikke blive offentliggjort. Obligatoriske felter er markeret med *

*

*

  1. Ansvarlig for dataene: Miguel Ángel Gatón
  2. Formålet med dataene: Control SPAM, management af kommentarer.
  3. Legitimering: Dit samtykke
  4. Kommunikation af dataene: Dataene vil ikke blive kommunikeret til tredjemand, undtagen ved juridisk forpligtelse.
  5. Datalagring: Database hostet af Occentus Networks (EU)
  6. Rettigheder: Du kan til enhver tid begrænse, gendanne og slette dine oplysninger.

  1.   Moskva sagde han

    wow, +1

  2.   passende sagde han

    faktisk er den rigtige ting at pakke ud
    tar -zxvf file.tar.gz
    tar -jxvf file.tar.bz2

    og til konfiguration er der et uendeligt antal muligheder (afhængigt af softwaren) til at tilpasse installationen

    ./configure -help

    Med det vil de se de forskellige ekstra muligheder, når de installerer et program.
    Ikke alle distributioner bruger / usr / local til at installere programmer, som også skal nævnes.

    Du glemte at nævne, hvordan du afinstallerer et program, der er installeret på den måde. Ud over at definere optimeringer for hver arkitektur.

    Alligevel godt initiativ, men du gik glip af meget ... for meget information til at dele.

    hilsen

    1.    Courage sagde han

      Det er noget, jeg næsten aldrig har brugt, de fleste af de programmer, jeg finder i de officielle arkiver.

      Sandheden om dekomprimering er, at det altid har været godt for mig sådan.

      Jeg skrev det, fordi alle dem, der siger "når du pakker det ud, læser instruktionerne" skruer mig op.

      Under alle omstændigheder ser jeg .tar.gz som sidste udvej, hvis der ikke er nogen i deb / rpm-pakken eller i arkiverne.

      1.    passende sagde han

        "Sandheden om dekomprimering er, at det altid har været godt for mig sådan."
        vi er enige, det bestrider jeg ikke, men det betyder ikke, at det er den rigtige ting at gøre. Ikke alle distroer dekomprimerer "intelligent", nogle er nødt til at tilføje flere parametre.

        1.    Courage sagde han

          Mand, det er ikke min skyld, at der er subnormale distroer hahahaha

          1.    passende sagde han

            KISS mand ... KISS

          2.    Courage sagde han

            Mand, KISS er ikke idiot, det ved du allerede med Slackware hahahaha

          3.    passende sagde han

            xD
            Derfor fortæller jeg dig det

            Enkelt! = Let.

  3.   Yoyo sagde han

    +1 for korrekt

    1.    Pepe sagde han

      Det ene røvhul mere end det andet. Disse "genier" er uden for emnet.

  4.   Lithos523 sagde han

    Hvis du ændrer "make install" til "checkinstall" (du kan installere det med aptitude, det er i arkiverne) vil det installere programmet, men også:
    -Opret en .deb, så du kan installere den ved fremtidige lejligheder
    -Det installerede program vises i Synaptic, så du nemt kan afinstallere det derfra

    1.    Courage sagde han

      Buebrugere har det involveret i Aptitude ...

  5.   jelpassager sagde han

    Undskyld for min uvidenhed, men løser alien-appen alle disse problemer?

    1.    passende sagde han

      nej, fordi alien arbejder med kompilerede pakker, og tar.gz eller tar.bz2 er komprimerede filer med kildekoden.

  6.   pandev92 sagde han

    Du kan ikke rigtig lave en tutorial om dette, det meste af tiden, i det mindste er qt-pakkene samlet på andre endnu mere mærkelige måder.

    1.    hypersayan_x sagde han

      Præcis jeg ville sige det samme.
      Dem, der bruger qmake fra Qt, er noget som dette:


      cd CarpetaPrograma
      qmake
      make
      sudo make install

      Og jeg tilføjer endnu en sag, der er cmakes:


      cd CarpetaPrograma
      mkdir build
      cd build
      cmake ..
      make
      sudo make install

      Eller der er andre, der bare skal køre make && sudo make install.
      Det er de mest almindelige tilfælde, men der er mange flere varianter: s

      1.    mcder3 sagde han

        Der er tidspunkter, hvor nogle applikationer, der er foretaget i QT, ikke bringer makefilen. Så det er tid til at oprette dem med følgende linje:

        qmake -makefile

        hilsen

  7.   jelpassager sagde han

    Lad os se, om jeg præciserer, når jeg skal bruge en tar.gz eller en tar.bz2, alt hvad jeg gør for at generere en .deb eller en all.deb ved hjælp af alien, er at sætte sudo alien install + pakke navn. Er det ikke det samme som at kompilere?

    1.    hypersayan_x sagde han

      Nej, kompilering omdanner programmets kildekode til maskinkode.
      Mens hvad du gør med fremmede er ompakning, som konverterer pakkeformatet for en distribution til pakkeformatet for en anden distribution.
      For at gøre det enklere er det som om du havde en fil komprimeret i RAR, og du vil konvertere den til ZIP, du vil dekomprimere filen i RAR og komprimere den igen i ZIP, det er hvad fremmede gør.

  8.   StuMx sagde han

    Kompilering sker i fabrikat, ikke i konfiguration. Konfigurationsfilen er et script, der verificerer, at systemet overholder alle afhængigheder for at kompilere programmet, så genererer det make-filen (som er den, der definerer, hvordan den skal kompileres) ifølge vores system.

    1.    Courage sagde han

      Nu fjerner jeg det, fordi denne artikel allerede er lang tid fra, da jeg skrev den i april eller maj. Jeg kontrollerede det ikke næsten fjerne noget dårligt ord intet andet

  9.   jelpassager sagde han

    Hej
    Jeg tror ikke, jeg forklarer mig meget godt. Alien omdanner ikke kun en rpm-pakke til en .deb, hvis du tager kildekoden til et program, hvad enten det er gz eller bz2, omdanner det det til en selvinstallerende deb. Derfor mit spørgsmål. Jeg har været på Linux i kort tid, vær med mig.

  10.   Marco sagde han

    undskyld min uvidenhed, men disse trin er også gyldige i Chakra, eller ændrer noget sig ???

    1.    KZKG ^ Gaara sagde han

      Ingen mand overhovedet 😀
      Som sådan er disse trin næsten en standard i alle distroer, men det er ikke 100% sikkert, at disse ALTID er de trin, der skal følges. Derfor anbefaler jeg, at du altid læser instruktionsfilen (LÆS normalt), inden du gør noget.

    2.    passende sagde han

      som @ KZKG ^ Gaara siger, dette er ikke altid tilfældet, det er en standard, der fungerer for alle distroer, så længe programmet er skrevet i C / C ++

  11.   Carlos-Xfce sagde han

    Når jeg igen står over for en .tar.gz af dem, vender jeg tilbage til denne artikel. Hvordan afskyr jeg sådanne pakker!

    1.    Courage sagde han

      Damn du er gammel nok til at installere disse pakker HAHAHAHAHA

  12.   VulkHead sagde han

    Undskyld for min manglende viden, denne installationsmetode fungerer også for Debian. Fordi jeg prøver, og jeg prøver, og det giver mig en fejl.

  13.   Laura Tejera sagde han

    Derfor bruger ingen linux, det er et trick at gøre noget dumt

    1.    elav sagde han

      Hvor nysgerrig, nogle af de dumme ting, du nævner, de "superbegavede" Windows- og OS X-brugere kan ikke gøre dem eller er bange for dem.

      1.    Laura Tejera sagde han

        Det sjove er, hvordan folk som dig kan følge et sådant lukket OS.

        1.    KZKG ^ Gaara sagde han

          Har du undgået at besvare spørgsmålet? ... Kan Windows-brugere eller OS X-genier gøre så mange ting med deres system, som vi viser på dette websted? 🙂

          Forresten bruger du Ubuntu, så ... hvad taler vi om?

          1.    Laura Tejera sagde han

            fortsæt med den middelmådige manga

            1.    KZKG ^ Gaara sagde han

              Er vi middelmådige? ... Uff ... LOL!


      2.    Pepe sagde han

        Vi er i året 2015!
        Jeg tror, ​​det er ikke nødvendigt at spilde så meget tid på at studere for at arbejde fra konsollen.
        Hvorfor ikke bruge automatiserede applikationer til dette?
        Under alle omstændigheder skal de, der "kan lide" at skrive kommandoerne fra konsollen der, lade dem fortsætte med at gøre det, men parallelt ville det være nødvendigt at have de samme automatiserede kommandoer. Jeg beder dig ikke om at sende en raket til månen.

    2.    Santiago Luis Bazan sagde han

      Årsagerne til at bruge gratis software er moralsk etik. Lad aldrig nogen blive nægtet deres menneskelige friheder

      1.    Pepe sagde han

        Sandheden om, at sanataen om "frihed" i programmerne har træt mig. Kunne de ikke stoppe med at rose en ikke-eksisterende gud og være lidt mere ydmyge?

    3.    Pepe sagde han

      Du har ret Laura, disse fyre med deres Linux komplicerer det til benet. I put0 windows er ting lettere. Jeg nedværdiger ikke Linux, men det kan ikke være sådan at installere nogen pel0tudes, du bruger timer og timer på at undersøge, hvordan tjære fungerer, og alle meresunda, så du i slutningen af ​​dagen sidder fast med den "Linux-begynder ..."

      Jeg har til hensigt at bruge et stabilt operativsystem, men ikke at tage timer fra min produktion, fordi jeg er nødt til at arbejde, jeg har ikke noget ønske om at blive en "Linux-kandidat".

  14.   Thanatos sagde han

    Der mangler altid noget ... når jeg giver ./configure får jeg: configure: error: Din intltool er for gammel. Du har brug for intltool 0.35.0 eller nyere.

    Derefter returnerer fabrikationsinstruktionen: Intet mål blev angivet, og der blev ikke fundet nogen makefile. Høj.

    make install: Der er ingen regel til at opbygge `installeringsmålet

    Jeg er nybegynder, og det er godt at undersøge for at lære, men FUCK, kan du ikke forklare det med farvede småsten for de af os, der er nye i Linux?

    1.    ponchu sagde han

      Thanatos Jeg havde et lignende problem, og jeg deler mit resultat:
      (Først og fremmest for at præcisere, at jeg også er en neofyt i Linux-verdenen, og mine eventyr i denne sammenhæng med "smag" (distro) til Ubuntu er en uge).
      Forudsat at den kommer ind i min "Downloads" -mappe med kommandoen "cd", hvor min pakke af programmet "SoulSeek" med slutningen ".tgz" var placeret i terminalen eller konsollen:
      "./Configure" gav mig en fejl om, at filen eller biblioteket ikke eksisterede
      "Make" gav mig den samme fejl som dig ... så jeg fortsatte ikke med kommandoen "sudo make install" (sudo er fordi Ubuntu kræver "Super User og hans adgangskode" for at køre denne kommando, med andre ord udføre en installation ).
      Efter at have undersøgt den tidligere udpakkede fil indså jeg noget, der kan ske for dig, og det er, at den udpakkede fil var af typen "eksekverbar fil" (højreklik-egenskaber), og det tog 2 klik at udføre den.
      Dit problem i «./configure» kan løses med en opdatering af pakkerne eller arkiverne (disse vilkår forvirrer mig lidt) installeret i din Distro, da det fortæller dig, at «intItooI» er gammel, og du har brug for en nyere, og jeg tænk, at måske er denne pakke den, der kompilerer på din distro. I Ubuntu gør du det i samme terminal ved at skrive "sudo apt-get update" og opdatere alle pakkerne på systemet.
      Jeg håber, jeg har været hjælpsom.

    2.    Pepe sagde han

      Som jeg fortalte Laura, tager denne Linux-ting lang tid. Det gav mig den samme fejlmeddelelse som din, og jeg går som spøgelsen fra Canterville fra et sted til et andet og slet ikke noget.

      Min chef fortalte mig: "du har to dage til at finde løsningen, hvis ikke, går vi tilbage til windows."

  15.   Jonathan sagde han

    Tak

  16.   ivan sagde han

    hej jeg har det samme problem, jeg vil installere skype 4.0. på min pclinuxOS downloadede jeg tjæren, gz2 og dekomprimeres, og indtil der kom jeg, når jeg gør ./configure, fortæller det mig, at filen ikke findes .. hvor gik jeg vild eller hvad? fortæl mig, i pclinuxOS (den sidste udgivne version) er skype installeret, men det er version 2.2, og jeg vil installere 4,
    Er der noget trick, jeg skal gøre for endelig at installere dette? noget synaptisk, som jeg ikke kender ???
    Jeg er ny på dette system, jeg har prøvet andre distroer før og indtil nu er alt i orden bortset fra dette ..

    hensyn

    1.    Pepe sagde han

      Er det mig, eller tror jeg ikke nogen kender disse spørgsmål.

    2.    f7eo sagde han

      Hej, det er lang tid siden dit spørgsmål.

      Jeg anbefaler, at du downloader den nyeste version af Skype til Windows (R)
      og at du bruger Wine til at køre det på din GNU-Linux distro.

  17.   af sagde han

    Hej! Jeg har det samme problem: Jeg downloadede den nyeste version af centersoftwaren med enxtension tar.gz, og da jeg kom til "./configure" -instansen, fik jeg en fejl, ligesom i "make". HVAD ER DET"?? TAK!! Derudover har softwarecentret blokeret muligheden for at installere !!!

  18.   Billede af Carlos Rivera sagde han

    Tak, det hjalp mig meget !!!!

  19.   michael sagde han

    hvordan man opretter en launcher

  20.   Angi sagde han

    Et spørgsmål, kan du kontrollere afhængighederne af en tar.gz-fil, før du kører ./configure ???

  21.   joseluis sagde han

    Jeg er ny på linux, det virker meget svært at installere tar gz gz2 tabletterne, og hvis jeg får en deb mangler det afhængigheder og med omdrejningstallet det samme, hvis det er i586 eller i686 eller i386, og det værste er, at jeg ikke har internet derhjemme. At se så mange kommentarer, der modsiger en, forvirrer dig værre.

  22.   gabriel yamamoto sagde han

    god info, men nogle * .tar.bz2-pakker er allerede kompileret, og for at installere dem skal du bare pakke dem ud i enhver mappe (helst / opt, så den er tilgængelig for alle brugere) og give en direkte adgang til binær i / usr / local / bin

  23.   Gonzalo sagde han

    Meget god forklaring på, hvordan man bruger tar.gz filer. Mange tak for informationen. Hilsen til hele holdet

  24.   juancuyo sagde han

    Det virker ikke for mig
    cd / home / ju / downloads / icecat-24.0 ——-> Svarer mig
    bash: cd: home / ju / downloads / icecat-24.0: fil eller bibliotek findes ikke
    hvad laver jeg forkert ??? Operativsystemet er Voyager 14.04 LTS (xubuntu) Xfce desktop Gdebi er ikke i indholdsmenuen og er heller ikke synaptiske, men de er i startmenuen, selvom du åbner dem, genkender de ikke mapperne, det er som om de gjorde ikke-eksisterende. Jeg pakket den ud i den samme downloadmappe. Er den forkert pakket ud ????

  25.   Claudio sagde han

    Denne tutorial fungerer også for .tgz?

    1.    joakoej sagde han

      Nej, .tgz er det format, som Slackware bruger, og de er allerede kompileret, uanset om du har downloadet det eller kompileret det fra en slackbuild

    2.    joakoej sagde han

      For at installere det skal du bruge installpkg "pakke navn".

  26.   asdf sagde han

    Undskyld, men det løser ikke problemet meget for mig, når du siger ./configure, og vi konfigurerer det, skal du angive mere, ikke? hvis jeg bare sætter ./configure, fortæller det mig
    bash: ./configure: Fil eller bibliotek findes ikke

    så siger du "vi laver"
    Kode:
    Lave
    Mit resultat:
    make: *** Intet mål angivet og ingen makefile fundet. Høj.

    Foretag installation
    make: *** Der er ingen regel for konstruktion af "install" -målet. Høj.

    Og så siger du "vi kører programmet"
    Kode:
    Programnavn

    Hvordan ved jeg, hvilket navn eller hvilket eksekverbart? Det er meget abstrakt, måske tager du for givet flere ting, som du vil vide, men de, der kommer for at se en tutorial, ved det måske ikke

    1.    Damian sagde han

      asdf.

      Jeg undersøgte, og den fejl, der vises, når jeg giver ./configure, skyldes manglen på kompileringsprogrammet (hvordan kunne vi kompilere uden at have et program, der gør det?). kommandoen til at installere en compiler, der skal indtastes, er:

      sudo aptitude install build-essential

      når vi er installeret, går vi til den mappe, hvor filen, der skal dekomprimeres, er og udføres:

      tjære -zxvf programnavn.tar.gz

      Så indtaster vi den udpakkede programmappe, og hvis der udføres ./configure og derefter sudo gør installationen

      Jeg håber, jeg har hjulpet!

      Greetings.

      1.    Damian sagde han

        Undskyld, jeg glemte at afklare, i mit tilfælde at udføre "make" og "sudo apt-get install-programmet" måtte jeg indtaste "base" -mappen i den udpakkede mappe, lige der tog jeg kommandoerne til at kompilere (lav ) og installationen.

      2.    Carlos sagde han

        Det giver mig problemer, når jeg bruger, det står, at det ikke finder noget at bygge højt

  27.   brenda sagde han

    Beklager, jeg har dette problem, jeg kører denne kommando, det viser mig en fejl, og jeg kan ikke oprette makefilen
    skrivebord: ~ / Downloads $ tar -jxvf iReport-4.1.3.tar.bz2
    tar (underordnet): iReport-4.1.3.tar.bz2: Kan ikke åbnes: Fil eller bibliotek findes ikke
    tjære (barn): Fejlen kan ikke gendannes: afslutter nu
    tjære: Barn returnerede status 2
    tar: Fejlen kan ikke gendannes: afslutter nu
    venligst =)

  28.   Aaron sagde han

    God dag venner,
    Jeg er ny på linux, men jeg har haft en lille ulempe, når det kommer til at genkende en enhed, der er en digital biometrisk læser, jeg googlede bare og syntes det tilsyneladende, men den blev downloadet med en .tar.gz-udvidelse, prøv at pakke den ud i en mappe blev flere filer udpakket, men jeg ved ikke, om jeg derefter skal udføre noget andet eller indsætte de udpakkede filer i en mappe på systemet, jeg ved ikke, hvis du hjælper mig med at køre behandle det godt, det ville være meget taknemmeligt, jeg har Linux Debian 7 installeret på OS XNUMX. på forhånd, hilsner og mange tak.

  29.   Rufo Lopez Retortillo sagde han

    Jeg bruger både Linex 2011 og Linex 2013, og det største problem, jeg finder, når jeg installerer applikationer, er at de ikke er indlæst på listen over applikationer i deres gruppe (grafik, kontor, multimedie osv.), Og hvis jeg vil oprette en launcher I ved ikke, hvor jeg skal hen for at finde applikationsstarterfilen. I hvilken mappe opretter du den? Hvordan gør man det?
    Når de installeres fra arkiverne, placeres løfteraketterne i deres gruppe, kan dette gøres ved at installere, tar.gz som beskrevet på dette web?
    Tak for hjælpen

  30.   Carlos sagde han

    Hjælp venligst, jeg har et andet operativsystem kaldet lps 1.5.5, og jeg kan ikke opdatere programmet

  31.   Carlos sagde han

    Fortæl dig igen, jeg kan ikke pakke en tar.bz2-fil ud. Jeg har et operativsystem kaldet lps 1.5.5, og jeg ved ikke, hvordan jeg bruger det, vær venlig at hjælpe mig, jeg takker dig ...

  32.   joscastel sagde han

    efter udpakning af bz2-filen fungerer kommandoen ./configure IKKE, fordi den IKKE findes

    1.    joscastel sagde han

      Jeg har ubuntu 14.04LTS

  33.   du ved sagde han

    Jeg forstår det ikke, i slax går .tar.gz i biograf, men i ubuntu har jeg ingen måde at kompilere på.

  34.   Raul sagde han

    Hvad er det bedste operativsystem? det bedste operativsystem er, at det løser dine problemer.

  35.   Juanzito sagde han

    Linux-folk er fantastiske. Jeg har forsøgt at installere ZinjaI på min nyinstallerede LinuxMint distro i mindst 5 timer.
    Jeg går gennem alle de fora, jeg finder, og i alt (men alt inklusive denne) giver de dig halvdelen af ​​informationen.
    For eksempel har jeg allerede åbnet terminalen, men jeg kan ikke placere adressen på, hvor den downloadede fil er placeret (som er / home / user / Downloads / zinjai).
    Alt hvad jeg får er en fejl: "bash: cd: bruger: Ingen sådan fil eller katalog.
    Jeg forstår, at de ønsker at sprede og udbrede brugen af ​​et operativsystem, men hvis de benægter information eller forklarer alt i halve mål, er det eneste, de opnår, at brugere som mig, der havde den faste hensigt at flytte fra Windows til Linux, giv op og hold dig til min W7, dårlig men nyttig og håndterbar.

    Skål ...

    PS: Hvad kostede et elendigt installationsprogram med en grafisk grænseflade dem at gøre? Hvorfor skulle de i det XXI århundrede fortsætte med at bruge noget, der ligner DOS til at installere et elendigt lille program? Drenge ... for at se om de lever lidt op ....

    1.    Ocelot sagde han

      cd ~ / Downloads / installations script sti.

      Et tip: stick med windows. Hvert operativsystem er lavet til en type person. Windows er lavet til folk, der foretrækker at få alt jorden og med mindst mulig indsats, og jeg ser, at det er din sag. Der er mennesker, der ikke kan eller ikke ønsker at stræbe efter noget mere end næste, næste, næste ... accepterer. Det er ikke dårligt, vi skal simpelthen kende vores begrænsninger og tilpasse os dem.

      Et andet tip: Hvis du kun vidste, hvor mange ting der opnås med ydmyghed og ved hjælp af to ord som "tak." Det ville overraske dig. Gør det ofte.

      1.    Knary sagde han

        Hej Linuxeros.
        Mange tak for vejledningen, det hjalp mig med at installere driverne til dwa-131 wifi-adapteren.
        Jeg er lidt i tvivl, jeg har gjort alt, som de siger ovenfor.
        Gå til filstien, tjæ ... og derefter Opret, vent til det er færdigt, og foretag derefter installationen.
        Indtil dette trin gav jeg ingen fejl.
        Det spørgsmål, jeg har, er at vide, om jeg allerede har driverne installeret, eller skal jeg gøre noget andet.
        Juanzito .. gå videre og giv Linux en chance, uanset distributionen, jeg besluttede at forlade Windows 7 for en uge siden, og jeg er mere tabt end helvede, hahaha, men ved at læse her og der finder du oplysninger, der nogle gange er vanskelige for dig at forstå, alt afhænger af hver enkelt indsats for at ønske at lære og komme ud af monopolet, hvor Windows indlejrer dig (det er min mening).
        En ting ... på Linux-terminalen tæller store bogstaver. 😉

        PS: Jeg skal gøre noget andet efter installationen af ​​Kame. ??

        Mange tak.
        Mange tak og hilsner fra De Kanariske Øer.

      2.    buer sagde han

        Og hvem skal du fortælle en bruger at gå tilbage til X-systemet? tror du, du er Richard Stallman?

        Jeg er enig i, hvad de siger i nogle kommentarer, at det bedste operativsystem er det, som systemet tilpasser sig til brugeren og IKKE omvendt.

        Jeg personligt elsker Windows .exe, for som du siger behøver du ikke at være et computergeni for at installere noget meget simpelt som en simpel notesblok; sammenlignet her i linux, at hvis det ikke er i de dedikerede softwareapplikationer, holder du dig til århundredets sammenfiltrede med en tablet.

        Jeg kom her på udkig efter og organiserede information til at installere programmer i Linux, da jeg forbereder mig på at installere mynten på en produktiv maskine, og jeg ved, at hvis jeg ikke forbereder mig, vil jeg ikke være i stand til at installere noget, hvis det ikke er i arkiverne.

        Nu spørger "venligst" alle, problemet er, at ingen svarer dem, det er grunden til, at folk undertiden skal være aggressive, så sig ikke noget vrøvl.

      3.    Pablo sagde han

        undskyld .. men jeg har altid forsvaret brugen af ​​gratis og åben software .. Jeg har brugt computere i 30 år .. og jeg er 37 ..
        problemet er, at det generelt i linux er perfekt, at den, der ønsker eller burde "vide" lidt mere for noget simpelt som at installere et program, en opdatering eller hvad som helst ... problemet kommer i, at mange mennesker har brug for at arbejde og bruge pc (med et hvilket som helst operativsystem) til at udføre sin specifikke arbejdsopgave .. så selvom det tager 10 minutter at downloade en .gz og installere den .. eller hvis som det fleste sker, vil timerne gå .. de er minutter eller timer uden at kunne gør dit job, og det er her næsten alle løber tør for tålmodighed ..
        i mit tilfælde .. på arbejdspladsen bruger jeg kun Ubuntu, som er det der er installeret som standard på pc'er, da det er et videnskabeligt center, men det får mig til at bruge flere timer på at prøve at installere eller endda opklare, hvordan jeg laver en soft specific (for eksempel Jeg er geograf) det virker .. eller det efter en opdatering af det .. gendan alle værktøjerne, fordi halvdelen holder op med at arbejde inden for et program ..
        i dette specifikke tilfælde .. Jeg havde brug for at se et webinar / forum på arbejde .. og da de bruger java, savner jeg tegnet om, at jeg skulle opdatere det .. ok .. gå til java-webstedet .. find filen til mit operativsystem , 14.04 .. se download og installation "" instruktioner "" .. download en .gz og derfra videre .. pakke ud .. ok, og ... den siger "installer" .. og voila .. kun intet kunne gøres med informationen i dette indlæg .. hvad gør jeg, når jeg pakker «jre-blablabla of a lifetime.gz» ud ??

  36.   Carlos Fabian Ferra sagde han

    dette fungerede aldrig for mig i nogen distro

    1.    yukiteru sagde han

      Hvis det ikke fungerede for dig, er det rent Layer 8.

      1.    Yank Carlos sagde han

        Geni!

  37.   Ignatius Navarro sagde han

    Da jeg bruger det meget lejlighedsvis, hver gang jeg kommer ind her for at se, hvordan det gøres.
    Mange tak for at skrive det og for ikke at slette det efter så længe.

  38.   Ramon sagde han

    som du kan se synaptisk den nye pakke installeret, hvis den viser dig den ældste (stabil i henhold til distro) ¿?

  39.   Jorge sagde han

    alt går lort, når du kommer til ./configure, der er ingen, der forklarer godt, når det står, at filen ikke findes

    1.    Elvis sagde han

      Jeg forsøger at installere wifi fra Broadcom hverken ./configure, hverken få eller få installeret til at fungere.

      den logiske sekvens er 1. udfør ./configure men tilsyneladende henviser denne instruktion kun til en konfigurationsmappe og udfør en fil placeret der, dette skal komme i pakken, der downloades fra Broadcom, men i mit tilfælde er denne mappe ikke der, det er formodes at udføre konfiguration er en kontrol og oprette Makefile-filen, men når jeg pakker pakken ud, indser jeg, at Makefile er indarbejdet, de to andre kommandoer gør og gør installationen ikke fungerer for mig, det ville være fordi den nyeste version af elementære os gør understøtter det ikke freya baseret på ubuntu 14.04

    2.    Alexander TorMar sagde han

      Sandheden? Denne metode har aldrig fungeret for mig, og jeg vælger altid .deb-pakker eller kommandoer fra terminalen ... Alt for dårlig, der er intet klart at installere .tar.gz

  40.   Elvis sagde han

    Jeg forsøger at installere wifi fra Broadcom hverken ./configure, hverken få eller få installeret til at fungere.

    den logiske sekvens er 1. udfør ./configure men tilsyneladende henviser denne instruktion kun til en konfigurationsmappe og udfør en fil placeret der, dette skal komme i pakken, der downloades fra Broadcom, men i mit tilfælde er denne mappe ikke der, det er formodes at udføre konfiguration er en kontrol og oprette Makefile-filen, men når jeg pakker pakken ud, indser jeg, at Makefile er indarbejdet, de to andre kommandoer gør og gør installationen ikke fungerer for mig, det ville være fordi den nyeste version af elementære os gør understøtter det ikke freya baseret på ubuntu 14.04

  41.   Alexander TorMar sagde han

    Sandheden? Denne metode har aldrig hjulpet mig, og jeg vælger altid .deb-pakker eller kommandoer fra terminalen ... Alt for dårlig, der er ikke noget klart at installere .tar.gz

  42.   Alexander TorMar sagde han

    Hvorfor opdateres denne tutorial ikke? Eller laver de en ny?
    Alle her klager over, at det ikke tjente dem, og det har allerede sine år….

  43.   HECTOR MATOS sagde han

    Hej, jeg vil have hjælp, med det at installere pakker .. Jeg har Ubuntu version 15 .. noget .. Jeg vil installere adobe flash plugin, for det er meget nyttigt at installere det, da jeg med adobe flash kan indtaste nogle websider , hvor du kan se tv'et og også lytte til radio .. kan du sende mig en trinvis vejledning .. Jeg har ikke meget erfaring med den kommandolinje, det vil sige bruge en terminal.

    Hjælp ... tak

  44.   Abraham sagde han

    Hej alle !!! Efter at have læst næsten alle kommentarerne ledte jeg efter en Linux-manual, og det er det.
    Ven OCELOTE, accepter denne kritik fra mit ydmyge og ubetydelige synspunkt, som jeg deler med millioner af Windows-brugere:

    Jeg ville elske at skifte til linux! men mange af os finder det umuligt, hvorfor? du undrer dig måske ... for for mig er computeren det middel, jeg har til at udføre mit arbejde, det er ikke slutningen ... Jeg ved ikke, om du forstår, hvad vi alle vil have (og JUANZITO har fortalt dig godt) det er et stabilt operativsystem, der hjælper os med at udføre vores arbejde, jeg har ikke tid til at lære at gøre grundlæggende ting som at installere et program fra konsollen, alt skal være mere intuitivt og lettere ... Som forretningsmand vil fortælle dig, at den ledelse, du har med Linux, er katastrofal, i stedet for at hjælpe folket med at foretage ændringen af ​​operativsystemet insisterer du på, at folk lyver med ting, der ikke interesserer dem, og du blokerer selv forandringen ... En, der programmerede i assembler, java, javascript, html, php og xbase fortæller dig det ... og det rører ved min næse at skulle åbne konsollen til næsten alt.

    hilsener

  45.   DEFCON sagde han

    Udholdenhed DOS 6.22 gammel !!

  46.   erput sagde han

    Sæt dig for at studere og efterlade det lort af wuendos, der fungerer for nogle, fordi de laver putten som nøgler, de betaler dem ikke, for at toppe det hele, de, der lavede disse nøgler, er linux-genierne og de burde, til det er hvorfor du er som dum at diskutere mamahuevadas, for forretningsmændene, som jeg fortæller dem, fortsæt med at betale deres licens, og hvis det, de ønsker, er stabilt, vinder de tid, hvad i helvede, de skriver idioter i disse tutoer, det er for os, der ligesom linux idioter ... esset

  47.   GENDA sagde han

    Det er ikke særlig klart for nybegyndere. For eksempel siger du:
    «Først går vi til den mappe, hvor vi har filen, hvis mappen har flere ord, skal vi sætte dem med" "eller hvis den ikke ser efter mapper med hvert ord» ...
    Enhver bruger kommer ind i disse mapper med «opdagelsesrejsende» og omdøber uden at kende navnet på den mappe, der indeholder den med anførselstegn. Det set fra det synspunkt, at du læser det, «fra den uerfarne brugeres synspunkt.

    Så sætter du:
    cd-mappe, hvor filen er

    cd "mappe hvor filen er"
    Fra det tidspunkt er brugeren allerede gået til skyerne eller hvor som helst, for fra nu af går han tabt på cd'en med forkortelsen, du præciserer ikke, hvordan du kommer dertil, et trinvis eksempel, begyndende med alt det ... åbner konsollen først.

  48.   GENDA sagde han

    For HECTOR MATOS: Adobe plugin, java og andre behøver ikke at blive gjort manuelt, du skal kun have forbindelse til internettet i et stykke tid, og i opdateringsadministratoren vises det automatisk, derfra opdateres det automatisk , for Firefox til Opera, og resten uafhængigt ... normalt er launcheren ved siden af ​​uret i startlinjen, i flere distroer så jeg, at det som standard var der, jeg ved ikke, om det vil være sådan i allesammen.

  49.   max sagde han

    Vær mere eksplicit, en masse information mangler

  50.   mary sagde han

    prøv at opdatere python til 3.x og gøre make install efter afslutning fortæller mig, at der er en fejl:
    zipimport.zipimporterror kan ikke dekomprimere data zlib ikke tilgængelig make *** installationsfejl

  51.   f_leonar sagde han

    Efter udpakning for at køre ./configure er det nødvendigt at indtaste den udpakkede bibliotek, ellers fungerer det ikke. Jeg bruger KDE, og jeg trådte grafisk ind i den mappe, jeg pakket ud, og der åbnede jeg en terminal for at udføre "make", men det virker ikke ...

  52.   Anonymous sagde han

    Jeg har et spørgsmål, jeg får dette:
    manolo @ mxlolo-satellit-c655d: ~ / Desktop $ ./konfigurer – hjælp
    bash: ./configure: Ingen sådan fil eller mappe
    hvad jeg gør…?

  53.   KATSODA sagde han

    Alt godt, indtil ./konfigurationen af ​​bolde kom ud.
    HVAD MENER DU MED DET !? De forklarer det ikke, jeg vil bare installere det andet skide liv xddd
    «»»katsoda@katsoda-PC:~/Downloads$ ‘/home/katsoda/Downloads/Second_Life_5_0_4_325124_i686’/configure
    bash: / home / katsoda / Downloads / Second_Life_5_0_4_325124_i686 / configure: Fil eller bibliotek findes ikke »» »
    Jeg må hellere downloade Windows 10 og tage røvet. (?)
    Altså nej. Men dette er en af ​​de ting, jeg hader ved Linux. Installation og bøn om, at dine yndlingsprogrammer er kompatible her, er en ganske udfordring.

    1.    Gatoo_ sagde han

      Det er ikke at gider, mine herrer, men skaberen af ​​vejledningen forklarer perfekt, hvad man skal gøre, hvis du får en fejl med ./configure. Du skal bare afslutte læsningen af ​​resten af ​​selvstudiet (som er 4 linjer).

      Jeg finder det utroligt, at så mange mennesker klager over, at det ikke forklarer ting, når du ikke engang er stoppet for at læse.

  54.   fredag sagde han

    Nå, jeg erklærer mig officielt inkompetent for denne type filer. Jeg prøver at installere java, og det er hvad det er;
    javier @ loft: ~ / JAVA / jre1.8.0_151 $ tar -zxvf jre-8u151-linux-x64.tar.gz
    tar (barn): jre-8u151-linux-x64.tar.gz: Kan ikke åbnes: Fil eller bibliotek findes ikke
    tjære (barn): Fejlen kan ikke gendannes: afslutter nu
    tjære: Barn returnerede status 2
    tar: Fejlen kan ikke gendannes: afslutter nu

  55.   Roger deku sagde han

    i Linux ubuntu 18.04.01 lts skal du bare skrive ./namedelprograma i samme mappe efter at have pakket den ud og voila !!!

  56.   jia sagde han

    Meget god, det var meget nyttigt.

  57.   Emerson Gonzalez sagde han

    i av linux fungerer dette ikke
    Jeg ved ikke, hvad der er mærkeligt for mig; eller hver gang du installerer en distro, starter du vejen for korset
    du ser, hvordan tastaturet går

  58.   Jose Felix Paisano Morales sagde han

    Hej alle sammen, jeg bruger Ubunto 20, og jeg konsulterede denne side for at installere scanneren til en Epson L4150 (jeg downloadede drevene fra http://support.epson.net/linux/en/imagescanv3.php?version=1.3.38#ubuntu).
    Jeg fulgte trinnene og brugte 'tar -zxvf filnavn.tar.gz', da jeg brugte udpakning
    '$ cd imagescan-bundle-ubuntu-20.04-3.63.0.x64.deb', som er den mappe, der oprettes.
    Inde i mappen brugte jeg './install.sh', som er som at bruge './configure', systemet bad mig om min adgangskode og alt installeret fint.
    Jeg prøvede min scanner, og det var dejligt, tak fordi du gav mig anvisningerne, jeg var i stand til at bruge min scanner