Kuinka parantaa pelin suorituskykyä Linuxissa

Oletko yksi niistä, jotka käyttävät Ubuntua ja Unityä? Oletko kyllästynyt Unity + Compizin heikkoon suorituskykyyn, kun on kyse pelien ajamisesta Linuxissa? Kutsun sinut löytämään mielenkiintoisen vaihtoehdon.


FSGamerin taustalla oleva käsite on hyvin yksinkertainen: miksi et aloittaisi erillistä graafista X-palvelinistuntoa erittäin kevyellä ikkunanhallinnalla, kuten openbox, ja suorita sitten kyseinen peli? Oletuksena se käyttää tty8: ta, vaikka tätä asetusta on mahdollista muuttaa. Pelkästään painamalla ctrl-alt-f7 palaat alkuperäiseen istuntoosi. Piditkö ideasta?

Asennus

1.- Lataa tiedosto debytantti kirjoittanut FSGamer.

2.- Asenna ladattu paketti:

sudo dpkg -i Lataukset / fsgamer_0.1.1_all.deb

3.- Muuta määritystiedosto Xwrapper.config niin, että FSGamer voi aloittaa graafisen palvelimen X istunnon (älä unohda vastaavaa varmuuskopiota):

sudo cp /etc/X11/Xwrapper.config /etc/X11/Xwrapper.config.backup sudo gedit /etc/X11/Xwrapper.config

Muuta riviä, joka sanoo sallittu_käyttäjä = konsoli mukaan sallittu_käyttäjä = kukaan.

4.- Ota ääni käyttöön uudessa X Graphics Server -instanssissa seuraavasti:

sudo usermod -a -G audio $ KÄYTTÄJÄ

Sinun on ehkä käynnistettävä kone uudelleen, jotta nämä muutokset tulevat voimaan.

Suorita se suorittamalla seuraava komento:

fsgamer

Lisätietoja: fsgamer


Artikkelin sisältö noudattaa periaatteita toimituksellinen etiikka. Ilmoita virheestä napsauttamalla täällä.

25 kommenttia, jätä omasi

Jätä kommentti

Sähköpostiosoitettasi ei julkaista.

*

*

  1. Vastuussa tiedoista: Miguel Ángel Gatón
  2. Tietojen tarkoitus: Roskapostin hallinta, kommenttien hallinta.
  3. Laillistaminen: Suostumuksesi
  4. Tietojen välittäminen: Tietoja ei luovuteta kolmansille osapuolille muutoin kuin lain nojalla.
  5. Tietojen varastointi: Occentus Networks (EU) isännöi tietokantaa
  6. Oikeudet: Voit milloin tahansa rajoittaa, palauttaa ja poistaa tietojasi.

  1.   Paul Osterdam dijo

    Älä stereotypioi tai yleistä Ubuntu EI OLE LINUX, UBUNTU ON JAKELU, JOLLA KÄYTETÄÄN TÄTÄ YDINTÄ. Jos soitat Ubuntu linuxille, autat saamaan käyttäjät virheisiin, varsinkin monet ihmiset viittaavat .DEB: ään ainoana pakettina, joka Se on olemassa, vaikka tietysti he selvittivät sen täydellisesti.

    Sanon tämän, koska edes Suttleworh ei sano tai sano, että ubuntu on Linux, jota sana ei ole hänelle olemassa, ja myös puhuessasi ubuntuista sinun on viitattava sen johdannaisiin, elleivät aloittelijat sano «tämä toimii Linux mintun kanssa, kun suurin osa asiat ovat yhteensopivia

  2.   guillermoz0009 dijo

    Erinomainen, liian huono käytän Manjaroa!

  3.   Nyctea dijo

    Olemme jo ilmestyneet kolme edellä GNU: n kanssa (otan sen armon ja ironisen XD: n kanssa).

    Loppujen lopuksi kyse on sanojen (vaikka ehkä myös egon) mittaamisesta käyttäjänä, koska jos ymmärrät merkinnän täydellisen sanan etkä ole enää aloitteleva käyttäjä, on ilmeistä, että sinulla on tarpeeksi tietoa harjoitellaksesi Jotkut logiikat tietävät, että jos Ubuntua käytetään, se johtuu siitä, että se on tunnetuin (Jotain kuten Steven Howkinit GNU / Linux-maailmasta. Myös deb-paketit ovat helpoimpia, vähintään vähemmän merkkejä riviä kohden, mikä on parempi käyttäjille uusi tai aloittelija) ja että ollessasi keskimääräinen tai lukutaitoinen käyttäjä, voit oppia menetelmän ja mennä tutkimaan, miten se tehdään mieltymystesi jakautumisessa. Lauseessa »Tiedämme jo, ettet ime sormeasi, miksi sitten näyttää egoa ja olla ylimielinen? » neyson.

  4.   Gaius baltar dijo

    Ja että kaikki nauttivat suosikkijakaumastaan. 😀

  5.   kultainen kettu dijo

    Minulla on ongelma riippuvuuksien kanssa, Ubuntu ei löydä käynnistysalustan integrointivarastoa (joten riippuvuudet eivät täyty)

    Käytän ubuntua gnome-shellin kanssa.
    En tiedä, onko joku repon PPA lisännyt sitä, koska en löytänyt sitä: /

  6.   Gaius baltar dijo

    Oletko tehnyt apt-cache liblaunchpad -integroinnin? Ehkä sinulla on modernin versio käsillä 😉

  7.   sissi7 dijo

    Guillermo, Aurissa on paketti, jota voit käyttää ohjelman asentamiseen, jätän sinulle linkin ja tavan asentaa se:

    https://aur.archlinux.org/packages/fsgamer/

    Päätteessä: »yaourt -S fsgamer«

    Ja sitten sinun on noudatettava viestin vaiheita 3 ja 4

  8.   Gaius baltar dijo

    Jos jokaisessa viestissä meidän on selitettävä, että Ubuntu, Suse tai Fedora ovat Linux, olemme hyviä. Miksi et ole valittanut GNU: n puutteesta? 😉

    Et voi pureskella kaikkia blogikirjoituksia koko käyttäjäryhmälle. Itse asiassa aloitteleva käyttäjä, joka ei pysty erottamaan Ubuntua muista distroista, ei saa edes yrittää kirjoittaa / etc / X11 -kansioon. Älkäämme valittako paheista.

    Tervehdys.

  9.   Nyctea dijo

    Voitit minut, että aioin sanoa "Se ei ole Linux, se on GNU / Linux" (ei vakavalla tavalla, vaan ironisena, koska pyydät olla stereotypioimatta Linuxia, kun stereotypioit koko projektin kutsumalla sitä Linuxiksi, kuinka vanha asia on ja koska historia toistaa itseään näinä aikoina xD), mutta olen samaa mieltä gaiuksen kanssa, sitä ei voida toistaa joka hetki ja vähemmän lauseilla, kuten: «Älä stereotypioi tai yleistä Ubuntu EI OLE LINUX, UBUNTU ON JAKELU, JOKA KÄYTÄÄ TÄTÄ YDINTÄ» .

    En myöskään pidä siitä, että he sanovat, että distro on Linux riippumatta siitä, millainen se on, enkä pidä siitä, että he sanovat Linux mainitsematta GNU: ta, mutta on välttämätöntä, että käyttäjälle annetaan varallisuus, kun Gaius sanoo siirtyvänsä GNU / Linux-maailmaan Tätä tämä sivu tekee (monien ilmaisten ohjelmistojen käyttäjien lisäksi), vai haluatko opettaa aloittelijoille (vai tarkoittaako se lähinnä Windowsista tai vielä pahempaa IOS: sta, joka tarttuu painikkeisiin tietämättä mitä tapahtuu ) ja että hän ei ymmärrä sinua lainkaan ennakkotietojen puuttumisen takia ja että hänellä ei enemmistöllä edes ole aikomusta halua ymmärtää ja tuhlata näin aikaa ja lopulta pahemmaksi päädyt kyllästymään ja putoamaan peliin, jonka Windows ja IOS haluavat sanomalla, että GNU / Linux on tarkoitettu vain tapetuille, Supernerdeille ja / tai ammattilaisille, mikä tuo vettä myllylle, jonka ei pitäisi miellyttää sinua.

  10.   shini kire dijo

    on Yaourtissa (aur)

  11.   Gaius baltar dijo

    Menetämme pohjoista, kaverit. GNU / Linuxissa on paljon tietoa, etkä voi tuhlata aikaa täällä.

    Aloittelijalle on opetettava, että tämä toimii ja että on olemassa ratkaisuja, se on mitä tulee silmiin ja mitä tietokoneen käyttäjä ymmärtää. Kun olet "lapioinut", kasvatat tietämystäsi ja ajattelet "vapauksia".

    Aloitin Ubuntu 8.04: lla, menin Debianiin ja yritin sitten kaikkea, eettiset syyt tulivat myöhemmin (ja ne kiinnostavat minua valtavasti, vaikka lainaukset "Free Software for a Free Society" ovatkin juuttuneet päähänni). Tähän päivään et voi tuhlata aikaa toistamalla tätä jokaisessa opetusohjelmassa, nan?

    En ymmärrä tätä keskustelua täällä ... ainoa STEREOTYPE ja GENERALIZATION, joka on tehty, ovat tämänkaltaiset kommentit. Et voi määritellä vapaata ohjelmistoa, avointa lähdekoodia ja GNU / Linux Distroa jokaisessa blogikirjoituksessa. 😉

  12.   vieras dijo

    Käytän Archia ... ja pystyin asentamaan sen ... sinun on tehtävä joitain tutkimuksia, tällä sivulla ne keskittyvät vain Debian-pohjaisiin distroihin, mutta jos haluat asentaa jakeluosi, sinun on haettava kaikkialta hehehehe ainakin, jos käytät Arch-pohjaista distroa ....

  13.   Gaius baltar dijo

    Projektisivulla on tar.gz, mutta mies ei määritä enempää ...

    Tutkisin, mutta olen ankkuroitu Ubuntuun ja Debianiin. 😀

  14.   Gaius baltar dijo

    Anteeksi, se oli Kubuntu ... ja nykyään en voi seistä KDE xD: ssä

  15.   caesar leijona dijo

    Olen kanssanne samaa mieltä, ja heidän ei pitäisi kutsua sitä vain Linuxiksi, vaan myös GNU / Linuxiksi, koska GNU: lla on myös luottoja, ja täsmentää, että Ubuntu on GNU / Linux-jakelu. Kippis

  16.   danielcb dijo

    Ubuntu on Linux, Linux ei ole vain Ubuntu.

    Se, mitä teet, saa ihmiset tekemään virheen.

  17.   Gaius baltar dijo

    Tietty järjestelmä on määritelty, koska sen avulla voimme tehdä testin. Jos joku muu voi asentaa kaikki distrot määrittelemään tietyt vaiheet, toisin kuin käsillä olevat kirjastot ja arkistot, hänelle on hyvä.

    Jälleen: merkinnän kirjoittaminen kaikentyyppisille käyttäjille on mahdotonta. Kuka tekee sen paremmin tiedät 😉

  18.   nyson dijo

    Katsotaanpa, ohjelmisto on yleensä Linuxille, josta tiedän. tässä artikkelissa he antavat esimerkin asennuksesta ubuntuun ja siinä kaikki. emme tee sade lasista vettä

  19.   nyson dijo

    No, se oli juuri sitä, mitä etsin, ihmiset kertovat minulle, että he kaipaavat turbo-tilaa viritykseen ikkunoissa, sanon heille, että täällä heidän on vain suljettava istunto ja avattava kevyemmällä graafisella ympäristöllä, nyt heillä on se enemmän helppo jopa XD

  20.   Gaius baltar dijo

    Loistava. Meidän on tehtävä testi ja katsottava, saammeko jonkin verran suorituskykyä 😀

  21.   Nelson G.Lombardo dijo

    Erittäin älykäs totuus. Yritetään sitten!

  22.   Robert dijo

    Hän pyytää minulta kaiken tämän ja olen hieman peloissani aloittaa ja pyytää minulta lisää riippuvuuksia riippuvuuksista 🙂

    robert @ solusos1 ~ $ sudo apt-get install fsgamer
    Luetaan pakettiluetteloa ... Valmis
    Luodaan riippuvuuspuu
    Tilatietojen lukeminen ... Valmis
    fsgamer on jo viimeisimmässä versiossaan.
    Voit korjata sen suorittamalla "apt-get -f install":
    Seuraavilla paketeilla on täyttämättömät riippuvuudet:
    fsgamer: Riippuu: dconf-gsettings-backend, mutta ei asennettavissa tai
    gsettings-backend, mutta sitä ei voi asentaa
    Riippuu: python (> = 2.7.1-0ubuntu2), mutta 2.6.6-13 ~ bpo60 + 1 asennetaan
    Riippuu: gir1.2-gtk-3.0, mutta sitä ei voi asentaa
    Riippuu: gir1.2-glib-2.0, mutta sitä ei voi asentaa
    Riippuu: python-xlib, mutta se ei asenna
    Riippuu: gir1.2-gdkpixbuf-2.0, mutta sitä ei voi asentaa
    Riippuu: python-gobject-2, mutta ei asennettavissa
    Riippuu: gir1.2-launchpad -integrointi-3.0, mutta ei asennettavissa
    Riippuu: openbox, mutta se ei asenna
    Se riippuu: espeak, mutta se ei asenna
    E: Riippuvuudet eivät täyty. Kokeile "apt-get -f install" ilman paketteja (tai määritä ratkaisu).

  23.   Robert dijo

    Hyvä käyttö:

    Solus OS 1.3
    ydin 3.3.6-solukset
    GNOME 2.30.2

  24.   villi dijo

    ei toimi minulle asennettaessa pakettia Virhe: Riippuvuutta ei voida tyydyttää: dconf-gsettings-backend | gsettings-backend

  25.   Andrew dijo

    Mitä laiskuutta sen sijaan, että kommentoitaisiin, toimiiko se vai ei, he väittelevät, sanotaanko siinä LINUX vai GNU / LINUX; tai että ubuntu ei ole vain LINUX. Heidän tulisi jättää huomiotta tämäntyyppiset kommentit ja keskittyä viestin tavoitteeseen, eikö?
    loput tulee olemaan toinen.

bool (tosi)