פתרון לבעיית התקנת יישומי 32 סיביות ב- Linux Mint 14 RC 64 סיביות

פשוט פרסמתי את החדשות שאני כבר מכיר Linux Mint 14 RC זמין, וקלם רק הוכרז שבגירסת 64 סיביות יש בעיה שלא מאפשרת להתקין יישומים כמו סקייפ, Google Earth או כל חבילת 32 סיביות אחרת.

היכולת להתקין יישומי 32 סיביות בסביבת 64 סיביות מכונה בדרך כלל "Multiarch". ככל הנראה היה שינוי עם dpkg ב דביאן, אשר ביצע את התצורה מולטיארך להתיישן ב אובונטו. תוכל לראות מידע נוסף אודות בעיה זו כאן: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294

פתרון

כדי להפעיל Multiarch, פתח מסוף והקלד את הפקודות הבאות:

sudo dpkg --add-arquitectura i386
apt update

בעיה זו תתוקן באופן ידני בגרסה היציבה של מנטה לינוקס 14.


תוכן המאמר עומד בעקרונותינו של אתיקה עריכתית. כדי לדווח על שגיאה לחץ כאן.

12 תגובות, השאר את שלך

השאירו את התגובה שלכם

כתובת הדוא"ל שלך לא תפורסם. שדות חובה מסומנים *

*

*

  1. אחראי לנתונים: מיגל אנחל גטון
  2. מטרת הנתונים: בקרת ספאם, ניהול תגובות.
  3. לגיטימציה: הסכמתך
  4. מסירת הנתונים: הנתונים לא יועברו לצדדים שלישיים אלא בהתחייבות חוקית.
  5. אחסון נתונים: מסד נתונים המתארח על ידי Occentus Networks (EU)
  6. זכויות: בכל עת תוכל להגביל, לשחזר ולמחוק את המידע שלך.

  1.   וויליאנס דיג'ו

    @MonitoLinux יותר מדי עבודה שלך. אני לא בטוח שאמצא את זה בספורט האחורי היציב. אבל אני יכול להבטיח לך שבסיד, וכנראה שעד עכשיו בתמונות של וויזי [1] תמצא את זה זמין.

    [1] http://www.debian.org/News/2011/20110726b

    תמיכת ה- Multiarch היא משהו שעורר המון רעש. התנגשתי בו כמו ביוני והוא כבר התגלגל הרבה זמן.

    1.    monitolinux דיג'ו

      @Willians הוא שאני בא מתקופות ישנות יותר, בהן לא היו כל כך הרבה מאגרים עם היישומים שאחד נדרש להם, כאשר אחד המקרים שנמצאו היה קוד המקור.

  2.   RafaGCG דיג'ו

    אני קצת אבוד (וואלה הרבה) עם זה. אני משתמש ב- Xubuntu 12.10 64Bit (זריקה לעומת אובונטו 12.10 שהיא leeeento) וההפתעה שלי כשעברתי להתקין את KompoZer היא שהיא לא הופיעה ... בסופו של דבר הסקתי שמכיוון שהוא לא היה קיים במשך 64bit זה לא היה במאגרים ... אם כי עד כה תמיד מותקן (עם התקנת apt-get להתקין Kompozer) אך הפעם הוא לא הופיע. לאחר הרבה מחשבות מצאתי DeB של 64 ביט והתקנתי אותו. אבל הספק שלי ולבסוף אני מגיע לעניין. אם אני מתקין את זה שאתה מגיב על פוסט זה. האם חבילות 32 ביט יופיעו במאגר להתקנת תוכניות 32 ביט אם 64 ביט אינן זמינות? האם קומפוזר של 32 סיביות היה מופיע בשבילי להתקין במאגרים? האם זה טוב שאני עושה את זה למען תוכניות עתידיות שאני זקוק להם?

  3.   זבל_רוצח דיג'ו

    אלב אמרתי לך, זו לא הסיבה שהייתי בדביאן סיד 😛

    למעשה הבעיה שהמנטה מציגה, דביאן סיד כבר הציגה אותה לפני כחודשיים, אפילו בסינפטית כתוב שלפני התקנת ia2-libs ו- ia32-libs-gtk, היא ממליצה להוסיף dpkg –add-architecture: i32 ואז להריץ עדכן ומוכן.

    1.    אלב דיג'ו

      מתי אמרת לי? אני לא זוכר 😛

      1.    זבל_רוצח דיג'ו

        בדיוק לפני חודשיים, כשהייתה לי בעיה דומה, אך זה היה בגלל שחבילת ia2-libs-gtk הייתה מיושנת, והיא עדיין לא יצאה להשלים את ia32-libs החדשה, עד שאזכור מה אמרת ולמה אני אוסיף dpkg –add- אדריכלות: i32 😛

        1.    אלב דיג'ו

          האהה זה היה דרך IRC נכון?

  4.   MonitoLinux דיג'ו

    הפיתרון הוא להוריד את קוד המקור ולקמפל, ואז ליצור את חבילת deb ולתת אותו לקהילה

  5.   סרחיו עשו ארמבולא דוראן דיג'ו

    נהדר 🙂

  6.   בואו נשתמש בלינוקס דיג'ו

    טוב מאוד! מעניין ...
    נקווה שהם יתקנו את הבעיה לפני שהגרסה הסופית תצא.
    לחיים! פול.

  7.   mfcollf77 דיג'ו

    התקנתי לינוקס מנטה 14 64 ביט ולא הייתה לי שום בעיה להתקין את סקייפ, רק גרסה 4.0 הותקנה

    אראה עם מה עוד יש לי בעיה