Bookworm:Linux用のオープンソースの電子書籍リーダー

ブックワーム

最近 日常生活にテクノロジーを使用することが一般的になりました。 これは、読むのと同じくらい簡単なタスクを新しいテクノロジーに更新する必要がある場合です。

だからこそ 今日は、お気に入りのタイトルを読みやすくする簡単なアプリケーションについて説明します。 そして何よりも、それらは電子形式で利用可能であり、 今日お話しするアプリケーションはBookwormです。

Bookwormについて

ブックワーム シンプルで簡単な電子書籍リーダーです 最新のユーザーインターフェイスで設計されたものを使用します。 epub、pdf、cbr、mobi、cbzなどのさまざまな電子書籍形式をサポートします。 Bookwormの機能のいくつかを以下に示します。

  • epub、pdf、mobi、cbr、cbz形式の電子書籍をサポートします。
  • ユーザーがライブラリのグリッドビューとリストビューを切り替えることができます。
  • フルスクリーンモード、編集、メタデータの並べ替えとフィルタリングをサポートします。
  • 明るい、セピア、暗い読み取りモードで構成されています
  • ブックの複数のページをマークするブックマークオプションがあります。
  • ズームイン、ズームアウト、マージンの設定、線幅の増減などの機能を利用できます。
  • ナイトモードもサポートされています。
  • お気に入りの本のページをブックマークして後で読むことができます。
  • 起動時のライブラリビュー:Bookwormを開いたときに常にライブラリビューを表示する
  • フォント:システムで使用可能なフォントのフォントファミリーと読み取るフォントサイズを選択します

Bookwormではユーザー グリッドビューとリストビューを切り替えることができる機能があります 図書館のために。 書籍のメタデータの編集は、両方のビューで可能です ただし、リストビューでは、メタデータを並べ替えることができます。 ライブラリビューの検索バーを使用してフィルタリングを行うことができます。

LinuxにBookwormをインストールするにはどうすればいいですか?

ライブラリリストビュー

Si このブックリーダーをシステムにインストールしたい 使用しているディストリビューションに応じて、次の手順を実行する必要があります。

このアプリケーションをUbuntuにインストールするには、ターミナルを開く必要があります (Ctrl + Alt + T)そして私たちは 次のコマンドを実行します。

sudo apt-add-repository ppa:bookworm-team/bookworm
sudo apt-get update
sudo apt-get install bookworm

Elementary OSの場合、特別なリポジトリがあります このディストリビューションでは、端末に入力するだけです。

sudo add-apt-repository ppa:elementary-os/stable
sudo apt-get update
sudo apt-get install com.github.babluboy.bookworm

Debianおよびベースのシステムにインストールする一方で、システム上でアプリケーションをコンパイルする必要があります 実行する端末でこれを行うには、次のようにします。

sudo apt-get build-dep granite-demo
sudo apt-get install libgranite-dev
sudo apt-get install valac
sudo apt-get install libwebkit2gtk-4.0-37 libwebkit2gtk-4.0-dev
sudo apt-get install libsqlite3-dev
sudo apt-get install poppler-utils libpoppler-glib-dev
git clone https://github.com/babluboy/bookworm.git
cd bookworm
mkdir build && cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr ../
make
sudo make install

つつ Fedoraおよび派生物の場合、同じケースがこれに当てはまり、コンパイルするには入力する必要があります aplicación:

sudo dnf install cmake gcc-c++ vala
sudo dnf install gtk3-devel libgee-devel granite-devel
sudo dnf install webkitgtk4-devel sqlite-devel poppler-glib-devel
git clone https://github.com/babluboy/bookworm.git
cd bookworm
mkdir build && cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr ../
make
sudo make install

FlatHubからBookwormをインストールするにはどうすればいいですか?

残りのLinuxディストリビューションには、FlatHubからBookwormをインストールする機能があります。システムでこのテクノロジーをサポートするだけで済みます。

ターミナルを開いて、次のコマンドを実行する必要があります:

flatpak install --from https://flathub.org/repo/appstream/com.github.babluboy.bookworm.flatpakref

これで準備が整いました。このアプリケーションをシステムにインストールして、すぐに使用できるようにします。

インストールが完了したら、アプリケーションの実行に進みます。アプリケーションメニューに移動して実行するだけです。

これを行いました 初めてBookwormを開くと、アプリケーションにいくつかの電子書籍を追加するように求められます.

Bookwormに似た他のアプリケーションをご存知の場合は、コメントで遠慮なく共有してください。

 


記事の内容は、次の原則に準拠しています。 編集倫理。 エラーを報告するには、 ここで.

4コメント、あなたのコメントを残してください

コメントを残す

あなたのメールアドレスが公開されることはありません。 必須フィールドには付いています *

*

*

  1. データの責任者:MiguelÁngelGatón
  2. データの目的:SPAMの制御、コメント管理。
  3. 正当化:あなたの同意
  4. データの伝達:法的義務がある場合を除き、データが第三者に伝達されることはありません。
  5. データストレージ:Occentus Networks(EU)がホストするデータベース
  6. 権利:いつでも情報を制限、回復、削除できます。

  1.   チャーリー·ブラウン

    まあ、それはマルチプラットフォームであり、それよりも優れているCalibreよりも完全ではないと思います。Debianリポジトリとその派生物で見つけることができます。 とにかく、試してみる価値はあります...

  2.   イシュタル

    完全に同意します。 挨拶

  3.   ジョタペ

    こんにちは、私はこのコマンドに問題があります:

    cmake -DCMAKE_INSTALL_PREFIX = / usr ../

    それは私には見えます:

    ソースディレクトリ「/ home /」ユーザー「/ bookworm」にCMakeLists.txtが含まれていないようです。
    使用法として–helpを指定するか、CMakeGUIのヘルプボタンを押します。

    何が問題になりますか? ありがとう。

    1.    ジョタペ

      私はDebianバスターを使用しています。 よろしく。