Steam: instalējiet to Debian Wheezy, nemirstot un mēģinot (atjaunināts)

Šis ieraksts, kuru jūs lasīsit tālāk, ir Previous post, kas acīmredzot bija diezgan mulsinošs attiecībā uz Tvaiks, un daudziem, kas vēlējās to instalēt, bija grūti.

Tomēr šeit ir metode, kuru es tikko atklāju pēc tik daudz izmēģināšanas (tas jums atgādinās par instalēšanas metodi Iceweasel no repo Debian Mozilla, bet galu galā tas darbojas):

  1. Mēs savai funkcijai pievienojam multiarha funkciju Debian:sudo apt-get install multiarch-support
  2. Mēs pievienojam repo parakstu, lai instalētu:
    wget -O- -q http://repo.steampowered.com/steam/signature.gpg | gpg --import gpg --check-sigs - pirkstu nospiedums - keyring /usr/share/keyrings/debian-keyring.gpg B05498B7 gpg --export -a B05498B7 | sudo apt-key add -

    Pievienot / Etc / apt / sources.list Nākamais:

    deb http://repo.steampowered.com/steam precise steam

  3. Palaidiet šo:sudo apt-get install -t precise steam steam-launcher
  4. Ja viņi lūdz atkarības:sudo apt-get -f install

Novērst Libc6 problēmu

Steam problēma, kas parādīsies vispirms, būtībā ir atkarība no Libc6 bibliotēkas, kurai nepieciešama vismaz versija 2.15. Lai izvairītos no problēmām, Libc6 bibliotēkas glābsim tikai no Debian Jessie ar veic šādu procedūru (īss, bet funkcionāls):

  1. Mēs pievienojam šādu rindu: / Etc / apt / sources.list:deb http://ftp.us.debian.org/debian/ testing main contrib non-free
  2. Mēs izveidojam direktoriju, kurā tas norāda prioritātes, kas tam ir pingā, lai izvairītos no dist-jaunināšanas, izveidojot failu / etc / apt / preferences ar nano:
    Iepakojums: * Piespraude: origin repo.steampowered.com Piespraudes prioritāte: 400 Iepakojums: * Piespraude: atbrīvojiet a = pārbaudiet Pin prioritāti: -10
  3. Lai instalētu atjaunināto libc6, mēs izpildām šādu komandu:apt-get -t testing install libc6

Un tāpēc mums Steam darbojas bez problēmām

Jebkurā gadījumā es esmu atklājis šo metodi, pateicoties tam, ka esmu iepazinies ar repo direktoriju SteamOS, kuras pamatā ir Debians Sēkšana. Tā kā mēs nevaram zaudēt šādu priekšrocību, es nolēmu veikt šo apmācību, tagad mums vairs nebūs vajadzīgas citas atkarības Ubuntu Nekas tāds.

Jebkurā gadījumā izbaudiet Steam vietnē Debian Wheezy un nākamās versijas (tagad jā).

Tvaiks

Steam uz Debian 7.5 "Wheezy" (64 bitu), ar prieku instalēts manā netbook.

Debian Jessie (un SID) filiālē ir repo non-free a Tvaiks, ja vēlaties uzticēties Debian, ja izmantojat minētā izplatītāja versijas. Turklāt šī apmācība ir arī teksta beigās ielīmējiet no vietnes.

Raksta saturs atbilst mūsu principiem redakcijas ētika. Lai ziņotu par kļūdu, noklikšķiniet uz šeit.

20 komentāri, atstājiet savus

Atstājiet savu komentāru

Jūsu e-pasta adrese netiks publicēta. Obligātie lauki ir atzīmēti ar *

*

*

  1. Atbildīgais par datiem: Migels Ángels Gatóns
  2. Datu mērķis: SPAM kontrole, komentāru pārvaldība.
  3. Legitimācija: jūsu piekrišana
  4. Datu paziņošana: Dati netiks paziņoti trešām personām, izņemot juridiskus pienākumus.
  5. Datu glabāšana: datu bāze, ko mitina Occentus Networks (ES)
  6. Tiesības: jebkurā laikā varat ierobežot, atjaunot un dzēst savu informāciju.

  1.   @Jlcux teica

    Ko jūs zināt par SteamOS?

    1.    3000 teica

      Kas jau ir beta versijā, un kas turklāt nesen ir panācis Debian Wheezy 7.5.

    2.    Cristianhcd teica

      kas būs neveiksme, ja jūs neko nedarīsit ar partneriem un viņu tvaika mašīnām, OS ir vienkārši līdzeklis, lai instalētu virkni pakotņu.

      Uzlabojumi ir redzami AMD / Nvidia draiveru atbalstīšanā, taču joprojām ir tālu no solītā, kas ir nopietna problēma, jo vidusmēra lietotājs tvaiku vai tvaika OS instalēs savā datorā, nevis tvaika mašīnā ar aparatūru « sertifikāts "

  2.   cr0t0 teica

    Debian 7.4 versijā es to biju instalējis atbilstoši https://github.com/GhostSquad57/Steam-Installer-for-Wheezy bet left4dead 2 bija Gamma problēmas, tas bija ļoti reti, un es nevarēju atrast risinājumu. Vietnē Lubuntu 14.04 noklikšķiniet un atskaņojiet. Es atgriezīšos dārgais Sēkšana.

    1.    3000 teica

      Nu, metode, ko es darīju, lai instalētu Steam, tiek iegūta tieši no SteamOS repo, kas bez lielām problēmām ir optimizēta Debian Wheezy.

  3.   bez nosaukuma teica

    tvaika pakete tiek pārbaudīta, ikviens, kam ir stabils, var mainīt repo uz testēšanu, lai to instalētu, un atgriezties stabilā stāvoklī bez papildu sarežģījumiem

    1.    3000 teica

      Nu, es saņēmu šo Steam versiju tieši no SteamOS repo, jo tā ir daudz optimizētāka darbam ar Debian Wheezy un tādējādi ļauj jums palaist lejupielādētās spēles vai jums nav problēmu ar ALSA.

  4.   Alberto villa teica

    Vai ir iespējams, ka viņi veic apmācību par to, kā to instalēt ar GRUB, ja mūsu skaitļos ir dīvaini ar nosaukumu Win7 ar EFI?

    1.    Alberto villa teica

      Es domāju Steam OS. Starp citu, forši .. tas parāda, kur es ievietoju ... (OS) .. bet tas ir darba dators ¬¬

    2.    3000 teica

      SteamOS instalētājs, kas nāk Oficiālais ISOTas nāk ar GRUB, kas atbalsta papildu OS. Arī SteamOS instalētājs ir gandrīz tāds pats kā Debian, tāpēc tai nevajadzētu būt problēmai, ja to instalējat kopā ar Windows.

      UEFI pusē šeit ir pāris vietnes, kurās tiek runāts par UEFI un to, kā instalēt Debian Wheezy ar UEFI (y šeit ir vēl viena metode kas var jums palīdzēt).

  5.   Alfonso teica

    Esmu instalējis Steam Debian 7, problēma ir tāda, ka, mēģinot atvērt programmu, tā man prasa caurlaidi, bet tas nes datora lietotājvārdu, nevis Steam vārdu. Vai ir kāds {fails, kuru jākonfigurē? Tas neļauj man mainīt lietotājvārdu.

    Gracias

    1.    3000 teica

      Kā jums parādās logs Steam? Patīk pieteikšanās veidlapa vai tā, kuru terminālis (vai konsole), kas prasa lietotājam, iziet?

      1.    Alfonso teica

        Parādās terminālis.

  6.   3000 teica

    Ja parādās termināls, palaidiet šīs divas līnijas savā terminālā:

    wget http://dl.dropbox.com/u/29081229/Steam/debian_install.sh

    sh ./debian_install.sh

    Tātad lietotāja paroles problēma vairs neparādās (parasti tas parādās, ja nav instalētas Jockey atkarības, kas ir no Ubuntu repos).

    1.    Alfonso teica

      Es jau esmu veicis soļus un joprojām esmu tajos. Vai būs nepieciešams atinstalēt?

    2.    Alfonso teica

      Tas man lūdz instalēt šādas programmas:

      libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386

      Bet, mēģinot to izdarīt, es saņemu leģendu: "paketēm ir neizpildītas atkarības"

  7.   Šķetere teica

    Hei draugs, tūkstotis pateicības par visvienkāršāko veidu, kā es atradu tvaika uzstādīšanu un lieliski strādāju pie savas Debian Jessie

    Paldies.

  8.   robermgs teica

    Komandā apt-get install -t precīzs tvaika tvaika palaidējs, kuru jūs ievietojāt tvaika rediģēšanai, būtu līdzīgs šim apt-get install -t precīzam tvaika palaišanas ierīces sveicienam

  9.   Nebus teica

    Sveiki, diemžēl es apmaldījos šajā solī:

    «Mēs izveidojam direktoriju, kurā tas norāda prioritātes, kas tam ir pingā, lai izvairītos no dist-jaunināšanas, izveidojot failu / etc / apt / preferences ar nano:»

    Faila saturam man jābūt skaidram, bet vai fails ir jāizveido apakšdirektorijā mapē etc / apt / preferences? Kad es ievietoju "Mēs izveidojam direktoriju ...", es šaubos
    Un kāds nosaukums būtu šim failam? Un kāds pagarinājums?

    ^ ^ ja neskaita tvaiku, kas jau ir, ja man izdosies uzstādīt sasodīto libc6 uz savas sēkšanas, neko neielādējot, tas būtu padarīt jūs par dievu altāri! xP, ka laimīgs lib ir vajadzīgs daudzām audio un video lietotnēm, kuras es vēlos izmēģināt darbam, taču pagaidām es esmu pārstājis riskēt.

    Paldies jau iepriekš!

  10.   Aquadrago teica

    Labdien, palaižot palaišanas programmu, tiek parādīta šāda kļūda:

    Notiek paku saraksta lasīšana ... Gatavs
    E: Vērtība “precīza” nav derīga APT :: Default-Release, jo šāds laidiens avotos nav pieejams

    Kā es to atrisinu?