लिनक्स मिंटमध्ये एएमडी जीपीयू प्रो ड्राइव्हर्स कसे स्थापित करावे?

एएमडी एटीआय

नमस्कार, आज काय चांगला दिवस आहे मी आपल्याबरोबर खाजगी ड्राइव्हर्स स्थापित करण्याची पद्धत सामायिक करण्यासाठी आलो आहे ते आम्हाला काय ऑफर करतात एटीआय कार्डसाठी प्रोसेसरसाठी तसेच यात एकात्मिक GPU देखील आहे.

Yo माझ्याकडे एएमडी प्रोसेसरसह एचपी नोटबुक आहे आर 8 ग्राफिक्ससह ए 5, म्हणून मी एएमडी ड्रायव्हर्सची आवृत्ती 15.7 स्थापित करू शकतो, परंतु दुर्दैवाने माझ्याकडे एक्सॉर्ग आवृत्ती 1.17 असणे आवश्यक आहे, जे मी 1.19 वापरल्यापासून माझ्याकडे नाही.

म्हणून मी एएमडीजीपीयू पीआरओ ड्रायव्हर्स वापरणे निवडू शकतो, माझ्या सिस्टमवर स्थापित करण्यासाठी.

आमची चिपसेट सुसंगत आहे की नाही हे जाणून घेण्यासाठी या ड्रायव्हर्ससह, प्रथम आपल्याला आपले मॉडेल माहित असले पाहिजेत्यासाठी Ctrl + T टर्मिनल उघडून पुढील कमांड कार्यान्वित केली पाहिजे.
lspci | grep VGA

माझ्या बाबतीत मी हे टाकतो:
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R4/R5 Graphics]

आता पुढील चरण म्हणजे अनुकूलता तपासणे, आपण हे येथे करू शकता या दुव्यामध्ये

ते सुसंगत आहे याची पूर्णपणे खात्री असल्याने, पुढील चरण म्हणजे आपल्याकडे कर्नल आवृत्ती 4.13 किंवा उच्च स्थापित आहे हे सत्यापित करणेयापूर्वीच्या आवृत्तीमध्ये, ऑडिओ नसल्याचा दोष आहे एचडीएमआय आउटपुट वापरताना.

आमच्याकडे कर्नलची कोणती आवृत्ती आहे हे जाणून घेणेआपण पुढील आज्ञा कार्यान्वित करणे आवश्यक आहे.
uname -r

हे मला पुढील परिणाम देते:
4.13.0-38-generic

नसल्यास, आपण अधिक वर्तमान कर्नल स्थापित करणे आवश्यक आहे.
आधीच या चरणांसह, आता आम्ही एएमडीजीपीयू पीआरओ ड्रायव्हर्स स्थापित करू आमच्या प्रणाली मध्ये.

एएमडीजीपीयू पीआरओ ड्रायव्हर डाउनलोड करा

ड्रायव्हर डाउनलोड करण्यासाठी आमचा ग्राफ कोणत्या आवृत्तीशी सुसंगत आहे हे आम्हाला माहित असले पाहिजेमागील ड्राइव्हमध्ये 16.40 किंवा 17.40 चालक असल्यास.

माझ्या बाबतीत ते दोघांशी सुसंगत आहे म्हणून मी सर्वात वर्तमान स्थापित करेन, तरीही, दुवा सोडा दोघांसाठी.

लिनक्स मिंटमध्ये एएमडीजीपीयू पीआरओ ड्राइव्हर स्थापित करत आहे

डाउनलोड पूर्ण झाले, आम्ही डाउनलोड केलेली फाईल अनपॅक करणे आवश्यक आहेत्यासाठी आपण टर्मिनल उघडतो आणि फाईल डाउनलोड केलेल्या फोल्डरमध्ये स्वत: ला ठेवतो आणि पुढील आज्ञा कार्यान्वित करतो.
tar -Jxvf amdgpu-pro-amdgpu-pro-17.40-492261.tar.xz

येथे आपण डाउनलोड केलेल्या ड्राइव्हरच्या आवृत्तीसाठी आपण कमांड बदलणे आवश्यक आहे. 

आता इथे आहे आम्ही amdgpu-pro-install फाइल संपादित करणे आवश्यक आहे, जे फाइल अनझिप केल्यावर फोल्डरमध्ये आहे.

आपल्या आवडीचे संपादक वापरा, आपल्याला खालील ओळ सापडली पाहिजे.

आणि ते लिनक्समिंटसाठी उबंटू बदलतात हे असे दिसते:

शेवटी, आपण उच्च आवृत्ती डाउनलोड केली असल्यास, आपण कोडमधून खालील काढणे आवश्यक आहे:

एएमडी जीपीयू स्थापना

आता आपण सर्व ड्राइव्हर्स स्थापित करण्यासाठी सज्ज आहात.

स्थापनेसाठी आम्हाला फक्त खालील टाइप करावे लागेल:

./amdgpu-install -y

नोट: त्यांनी sudo वापरू नयेआवश्यक असल्यास, विशेषाधिकार उन्नत करण्यासाठी प्राधिकृत करण्याची विनंती केली जाते.

आणि आम्ही पुन्हा सुरू करतो, काही प्रकरणांमध्ये दोन रीबूट आवश्यक आहेत.

ते केसवर अवलंबून खालील युक्तिवाद वापरू शकतात.

-h|--help                                        Display this help message
--px                                                  PX platform support
--online                                           Force installation from an online repository
--version=VERSION                       Install the specified driver VERSION
--pro                                                Install "pro" support (legacy OpenGL and Vulkan)
--opencl=legacy                             Install legacy OpenCL support
--opencl=rocm                               Install ROCm OpenCL support
--opencl=legacy,rocm                   Install both legacy and ROCm OpenCL support
--headless                                       Headless installation (only OpenCL support)
--compute                                       (DEPRECATED) Equal to --opencl=legacy –headless

माझ्या बाबतीत मी xpx व्यापतो कारण, मी काही इतर स्थापित केले असल्यास, यामुळे मला ब्लॅकस्क्रीन त्रुटी मिळाली.

ब्लॅकस्क्रीन सोल्यूशन्स

मी नमूद केल्याप्रमाणे, जर योग्य स्थापना केली गेली नसेल तर आपण एक काळा स्क्रीन मिळवू शकता, परंतु घाबरू नका, त्यात एक उपाय आहे.

मी माझ्या बाबतीत नमूद केल्याप्रमाणे, मला –px वितर्क सह स्थापित करावे लागले, म्हणूनच ते आहेजर इंस्टॉलेशन कार्य करत नसेल तर त्यांनी विस्थापित करणे आणि दुसर्‍या वितर्कसह पुन्हा स्थापित करणे आवश्यक आहे, विस्थापित करण्यासाठी, फक्त टाइप करा.
amdgpu-pro-uninstall

आणखी एक उपाय म्हणजे ग्रब एडिट करणे, पद्धत खालील ओळ संपादित करीत आहे, यासाठी आपल्या पसंतीच्या संपादकाचा वापर करा, माझ्या बाबतीत, मी नॅनो वापरतो:
sudo nano /etc/default/grub

त्यांनी खालील ओळीत amdgpu.vm_fraament_size = 9 जोडा, असे दिसते:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.vm_fragment_size=9"

ते बदल जतन करतात आणि ग्रब अद्यतनित करतात.

sudo update-grub

जर ते वापरू शकत नाहीत पुढील, पुढचे.

शेवटी मी लिनक्स मिंट फोरम वरील लोकांचे खूप आभारी आहे कारण त्यांनी माझे प्रेमळ मार्गदर्शन केले पद्धत सामायिक कोण कर्मचारी. पुढच्या वेळेपर्यंत आणखी


लेखाची सामग्री आमच्या तत्त्वांचे पालन करते संपादकीय नीति. त्रुटी नोंदविण्यासाठी क्लिक करा येथे.

एक टिप्पणी, आपले सोडून द्या

आपली टिप्पणी द्या

आपला ई-मेल पत्ता प्रकाशित केला जाणार नाही. आवश्यक फील्ड चिन्हांकित केले आहेत *

*

*

  1. डेटा जबाबदार: मिगुएल Áन्गल गॅटन
  2. डेटाचा उद्देशः नियंत्रण स्पॅम, टिप्पणी व्यवस्थापन.
  3. कायदे: आपली संमती
  4. डेटा संप्रेषण: कायदेशीर बंधन वगळता डेटा तृतीय पक्षास कळविला जाणार नाही.
  5. डेटा संग्रहण: ओकेन्टस नेटवर्क (EU) द्वारा होस्ट केलेला डेटाबेस
  6. अधिकारः कोणत्याही वेळी आपण आपली माहिती मर्यादित, पुनर्प्राप्त आणि हटवू शकता.

  1.   टॉर्मंड 1985 म्हणाले

    आपण तर्क कसे वापरायचे ते समजावून सांगाल का?

    आपण स्थापित करता तेव्हा म्हणता? ./amdgpu-install -y xpx?

    धन्यवाद.