Hoe AceStream op Linux te installeren en niet te sterven terwijl je probeert

Degenen onder ons die van sport houden en geen toegang hebben tot alle huidige sportkanalen, hebben over het algemeen het probleem dat we, om ervan te genieten, gebruik moeten maken van verschillende pagina's die online wedstrijden, de meesten van hen vragen installeer AceStream, die meestal een beetje ingewikkeld is om op Linux te installeren.

In deze gids zullen we leren hoe installeer AceStream op Linux zonder daarbij te sterven en oplossingen te bieden voor de meest voorkomende problemen van vandaag. Het gebruik ervan en de inhoud waartoe u toegang hebt, is uw volledige verantwoordelijkheid.

Wat is AceStream?

AceStream is een multimediaplatform behoorlijk innovatief, waardoor de reproductie van audiovisuals op internet naar een hoger niveau wordt getild. Om dit te doen, heeft het een universele manager geïmplementeerd voor het laden van multimediabestanden, die de meest geavanceerde P2P-technologieën gebruikt en een efficiënt gegevensopslag- en overdrachtsproces garandeert.

Ace Stream-software biedt ons een reeks voordelen die we kunnen benadrukken:

  • Mogelijkheid om online uitzendingen te bekijken (tv, aangepaste streams, films, tekenfilms, enz.), Met hoge audio- en beeldkwaliteit.
  • Luister online naar muziek in een formaat dat geen enkele kwaliteit verliest.
  • Bekijk torrents online, u hoeft niet te wachten tot het volledig is gedownload.
  • Bekijk inhoud op externe apparaten (Apple TV, Chromecast, enz.) Via communicatieprotocollen zoals AirPlay, Google Cast en andere.
  • Maakt integratie met verschillende applicaties mogelijk. Installeer AceStream op Linux

Hoe AceStream op Linux te installeren

Om AceStream op Linux te installeren, moeten we verschillende stappen volgen, afhankelijk van de distro die je gebruikt, we zullen ons concentreren op Arch Linux en Ubuntu, maar we hopen het in de toekomst op andere distributies te kunnen installeren.

Installeer AceStream op Arch Linux en afgeleiden

De belangrijkste reden dat ik dit artikel heb gemaakt, is omdat velen problemen hebben gehad met het installeren van AceStream op Arch Linux, Antergos, Manjaros en derivaten, de belangrijkste oorzaak is dat de pkgbuild van de plug-in acestream-mozilla-plugin Het geeft een foutmelding bij het installeren, de oplossing is uiterst eenvoudig.

We gaan het acestream-mozilla-plugin die ons ook zal installeren acestream-engine y acestream-speler-gegevens wat zijn de pakketten die nodig zijn om te reproduceren AceStream van firefox.

Allereerst moeten we een terminal openen en de volgende opdracht uitvoeren:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Het lost het verificatieprobleem op dat voorkomt dat de afhankelijkheid wordt geïnstalleerd die nodig is om te installeren acestream-mozilla-plug-in.

Vervolgens voeren we het volgende commando uit

yaourt -S acestream-mozilla-plugin

Bij herhaalde gelegenheden zullen we worden gevraagd of we verschillende afhankelijkheden willen installeren, we moeten tegen iedereen ja zeggen.

Installeer AceStream op Ubuntu en derivaten

Installeer AceStream op Ubuntu 14.04 en afgeleiden

Voor gebruikers van ubuntu en afgeleiden tot versie 14.04 zal de installatie van AceStream vrij eenvoudig zijn, ze hoeven alleen de volgende opdrachten uit te voeren vanaf de terminal:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Installeer AceStream op Ubuntu 16.04 en afgeleiden

Degenen die nog wat meer zullen moeten worstelen zijn de gebruikers van Ubuntu 16.04 en afgeleiden aangezien acestream geen ondersteuning heeft voor deze versie, maar dankzij dit artikel, Ik heb het kunnen installeren.

Het eerste dat we gaan doen is een aantal afhankelijkheden downloaden en installeren die je niet kunt downloaden van de officiële repositories, zorg ervoor dat je de juiste installeert voor de architectuur van je distro:

64bit architectuur:

  1. Downloaden en installeren libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb je kunt het doen via de volgende link: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Download en installeer in de volgorde waarin de volgende afhankelijkheden worden weergegeven:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb U kunt ze allemaal downloaden via de volgende link: https://drive.google.com/folderview?id= … e_web#list

32-bits architectuur:

  1. Downloaden en installeren libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb je kunt het doen via de volgende link: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Download en installeer in de volgorde waarin de volgende afhankelijkheden worden weergegeven: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb U kunt ze allemaal downloaden via de volgende link: https://drive.google.com/folderview?id= … e_web#list

Vervolgens moeten we doorgaan met de gebruikelijke installatie van AceStream zoals we deden voor versie 14.04, een terminal openen en uitvoeren:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

In sommige gevallen is het nodig om de service te starten acestream-engine.service, hiervoor voeren we de volgende commando's uit vanaf de terminal:

systemctl start acestream-engine.service systemctl schakel acestream-engine.service in

Met deze tutorial hopen we dat je kunt genieten van dit geweldige multimedia-transmissieprotocol dat alle capaciteit van P2P-technologie gebruikt.


De inhoud van het artikel voldoet aan onze principes van redactionele ethiek. Klik op om een ​​fout te melden hier.

41 reacties, laat de jouwe achter

Laat je reactie achter

Uw e-mailadres wordt niet gepubliceerd. Verplichte velden zijn gemarkeerd met *

*

*

  1. Verantwoordelijk voor de gegevens: Miguel Ángel Gatón
  2. Doel van de gegevens: Controle SPAM, commentaarbeheer.
  3. Legitimatie: uw toestemming
  4. Mededeling van de gegevens: De gegevens worden niet aan derden meegedeeld, behalve op grond van wettelijke verplichting.
  5. Gegevensopslag: database gehost door Occentus Networks (EU)
  6. Rechten: u kunt uw gegevens op elk moment beperken, herstellen en verwijderen.

  1.   Julio Cesar Campos zei

    Nou, de post maar in ieder geval in archlinux en dit was mijn geval heb je nodig: "systemctl start acestream-engine.service" en "systemctl enable acestream-engine.service" om het te laten werken.

    1.    hagedis zei

      Testte u het vanuit firefox of gebruikte u een andere browser?

  2.   UserDebian zei

    Weet iemand hoe hij het op Debian 9 kan laten werken?

  3.   Julio Cesar Campos zei

    Firefox op archlinux

  4.   gecoxx zei

    Ik weet niet of mijn vorige opmerking is gepubliceerd ... ik herhaal! Ik weet niet hoeveel uur het uitvoeren van het verdomde commando in de terminal duurt, en dat heb ik –noconfirm gezet, en uiteindelijk werkt het niet !!
    een ander bericht dat nutteloos is!

    installatiepoging op Manjaro

    1.    hagedis zei

      Beste dat het niet voor jou werkte, het werkte perfect voor mij, probeer in ieder geval deze 2 commando's uit te voeren:
      "Systemctl start acestream-engine.service" en "systemctl enable acestream-engine.service"

  5.   Jose zei

    buenas

    Ik heb alle stappen zonder problemen kunnen doorlopen. Maar toen ik de service vanaf de terminal probeerde te starten, leverde het me twee mislukkingen op;
    systemctl start acestream-engine.service
    Starten van acestream-engine.service is mislukt: eenheid acestream-engine.service niet gevonden.
    systemctl schakel acestream-engine.service in
    Kan bewerking niet uitvoeren: bestand of map bestaat niet

    1.    gustavo zei

      Precies hetzelfde is mij overkomen. de terminal stuitert die opdrachten naar mij met die fouten.

  6.   Juan M zei

    Heel erg bedankt voor de post! Als u Ubuntu 16.10 64 bits gebruikt, kunt u "acestream-player-data_3.0.2-1.1_amd64.deb" niet installeren. Ze moeten deze pakketten eerst downloaden en installeren:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Waarschijnlijk is er een andere afhankelijkheid nodig die zich in de repo's bevindt.
    Groeten!

  7.   Mijlen zei

    Goed.
    De acestream-mozilla-plug-in werkt niet meer in Firefox 52, net als veel andere NPAPI-plug-ins.

  8.   Darco zei

    Een andere zeer goede en eenvoudige optie is om docker te gebruiken en agnostisch te worden van uw besturingssysteem. Met behulp van de aceproxy kunt u deze reproduceren-

    Ik heb een kleine tutorial en een script geschreven om de uitvoering te vergemakkelijken.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   David Martin zei

    Tijdens het installeren vanaf Ubuntu 16.04, als u zegt dat u die bestanden downloadt en installeert, hoe installeert u ze dan? Wanneer ik ze download en extraheer, zijn sommige slechts een libreoffice-bestand en andere, ik weet niet hoe ik ze moet "installeren".
    Bij voorbaat dank en groeten.
    David.

  10.   vafe zei

    Ofwel werken de sleutels niet meer, ofwel zit er een fout in de pakketten, maar in arch en manjaro is het onmogelijk om het te installeren.
    Wanneer je een afhankelijkheid (qwebquit) of iets dergelijks probeert te installeren, gaat het in een lus en is er geen manier.
    Heeft iemand de oplossing gevonden?
    bedankt

    1.    Alexander zei

      Hallo, voor de installatie in arch linux moet je het volgende doen:
      -Installeer het pakket 'acestream-launcher' van yaourt met 'yaourt -S acestream-launcher' (het pakket dat we hierna gaan inschakelen wordt automatisch naar je gedownload)
      -Acestream-engine.service inschakelen, we gaan de terminal binnen en in ROOT-modus plaatsen we het volgende
      -systemctl start acestream-engine.service
      -systemctl schakel acestream-engine.service in
      Ik heb de computer hierna opnieuw opgestart, ik weet niet of het nodig zal zijn, maar voor het geval dat
      -Dit zou genoeg moeten zijn, maar in de laatste Arch-updates hebben ze iets verpest en het werkt niet, dus hebben ze gezocht naar een tijdelijke oplossing, namelijk het downloaden van een bestand, het is de volgende:
      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      bron: https://aur.archlinux.org/packages/acestream-launcher/ (op de commentaren)
      eenmaal gedownload, gaan we naar de terminal en gaan naar de map waar we het hebben gedownload,
      We gaan verder met het installeren met 'sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz' en dat is het, het zou moeten gaan, de eerste keer dat het nooit gaat, dus ik klik een tweede keer, de eerste keer altijd geeft fout, dat is alles

      PS: verduidelijk dat de sudo pacman -U en niet -S omdat het een lokaal pakket is dat is verkregen van makepkg

      1.    vafe zei

        Hartelijk dank voor uw interesse.
        Ik heb het zo vaak geprobeerd dat ik de afhankelijkheden al ken, en de commentaren op de pakketten in de installatie met jou uit mijn hoofd. Ik ga je advies met de draagraket opvolgen en kijken of ik geluk heb. Ik zal het je vertellen.
        Ik herhaal mijn dank

        felipe

        1.    vafe zei

          Op de een of andere manier werkt het niet. Ik heb het geprobeerd met de link die je in de commentaren hebt geplaatst, maar het lost het niet op, het herkent de link, het geeft me de mogelijkheid om het programma te kiezen, ik kies acestream-launcher maar de VLC gaat niet open.
          In console geeft het me het volgende antwoord.

          Bestand «/usr/lib/python3.6/site-packages/psutil/init.py », regel 1231, in _send_signal
          os.kill (self.pid, sig)

          We zullen moeten wachten op nieuwe updates.
          Bedankt voor uw hulp.

  11.   vafe zei

    Na de nieuwe update is het antwoord in console het volgende.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Acestream-motor draait.
    2017-07-28 18: 16: 59,615 | MainThread | acestream | fout tijdens het opstarten
    Hertraceren (meest recente oproep als laatste)
    Bestand «core.c», regel 1590, in
    Bestand «core.c», regel 144, in
    Bestand «core.c», regel 2, in
    ImportError: kan naam __m2crypto niet importeren
    Fout bij authenticatie bij Acestream!
    Mediaspeler werkt niet ...

    We zijn aan het verbeteren, nu herkent het de acestream, maar de libcrypto blijft vechten.

    1.    vafe zei

      Ik heb de installatie geprobeerd van het pakket dat u aanbeveelt in de link die u mij heeft gestuurd.

      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      En het lost effectief het probleem op, vlc wordt geopend en Acestream werkt.
      Heel erg bedankt voor je hulp-

      1.    Alexander zei

        Hallo, sorry voor de vertraging, het was heel vreemd dat het niet voor je werkte toen het wel werkte, ik ben in Arch plasma, ik ben blij dat het je heeft geholpen, daar zijn we voor

        In de andere distributie die ik heb, Fedora, heb ik Wine die acestream emuleert voor Windows xD, voor het geval je naar een andere distro gaat of in dezelfde Arch, wat me verbaast is dat ze deze pakketten zelfs niet in Debian hebben ...

      2.    delicatesse maker01 zei

        Hallo en het bestand is hoe het is geïnstalleerd. Ik ben nog steeds een nieuweling, een groet

        1.    vafe zei

          sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

          Hij plaatst het in de opmerking hierboven

  12.   chemabs zei

    Gisteren heb ik het als een snap-pakket geïnstalleerd in Kde Neon 5.8 en ik was verbaasd over hoe eenvoudig en snel het voor mij werkte. Het zou leuk zijn als je het artikel bijwerkt, want er is geen vergelijking, het proces is veel vereenvoudigd.

    sudo apt install snapd → installeer het snap-pakketbeheersysteem (als je het niet hebt geïnstalleerd)
    snap zoek acestream → om te controleren of we het programma in de repositories hebben (alle ubuntu-derivaten zouden het moeten hebben)
    sudo snap installeer acestreamplayer

    groeten

    1.    Antonio Manzano zei

      Je hebt gelijk. Ik heb het net geïnstalleerd in kubuntu 17.10, aangezien de methode die hier verschijnt totaal onhaalbaar is. Heel erg bedankt

      1.    Papa zei

        niet geldig voor i386-architectuur

    2.    sie9k zei

      Het was de enige manier om het op Lubuntu 16.04.4 te installeren, maar ik kan het configuratiebestand niet opslaan en ik moet een parameter configureren om naast Serviio te werken. Om het even welke ideeën om het te verhelpen?

  13.   Jose Antonio zei

    Zeer goede post, een webpagina die je moet lezen voor Linux-nieuwkomers.

  14.   peter de groentje zei

    Hoe zou je het installeren voor AntiX 16 (het is een Linux-distributie)?

    Ik heb geprobeerd zoals Arch Linux en afgeleiden, maar ik ben zo'n nieuweling dat ik het verkeerd moet hebben

  15.   Alexander zei

    Hallo, met sna-pakketten, die de collega hierboven in een opmerking opmerkt, is het niet alleen gemakkelijker geworden voor deze distributies, maar voor velen. De distributies die compatibel zijn met deze pakketten zijn hier:
    https://snapcraft.io/

    In Debian zou het als volgt zijn:
    -sudo apt installeer snapd
    -sudo snap kern installeren
    -sudo snap installeer acestreamplayer
    In Arch en afgeleiden:
    -sudo pacman -S snapd
    -sudo systemctl enable –nu snapd.socket
    -sudo snap installeer acestreamplayer

    In Arch (plasma) heb ik moeten herstarten zodat de geïnstalleerde pakketten verschijnen, als het niet verschijnt weet je al wat je moet doen.

    Op ubuntu en derivaten denk ik dat het zal zijn zoals de partner die het hierboven heeft geïnstalleerd in de opmerkingen met KDE neon.

    Het is merkwaardig dat het in Gnome met Debian er nogal lelijk uitziet en niet goed integreert met GTK, maar dat het in Arch plasma vrij goed integreert, het belangrijkste is dat het buiten de esthetiek wordt gezien.

    1.    william zei

      installeert dit je een stream-engine?
      Niet ik

      1.    Alexander zei

        Hallo, nee, het installeert het niet, en het hoeft ook niet, met de snap-pakketten zijn alle afhankelijkheden al aanwezig, het moet ja of ja werken.

    2.    txuber zei

      Hallo Alejandro, kijk of je me kunt helpen
      [txuber @ manjaro ~] $ sudo systemctl enable –nu snapd.socket
      Kan eenheid niet inschakelen: eenheidsbestand \ xe2 \ x80 \ x93now.service bestaat niet.
      op manjaro Manjaro XFCE Edition (17.0.4) x64

      1.    Alexander zei

        Hallo, Manjaro is dat het niet pure Arch is en dat dingen een beetje kunnen veranderen, het kan al zijn ingeschakeld en het is niet nodig om dit te doen, ik neem aan dat je al hebt geprobeerd die stap over te slaan ...

  16.   Debian zei

    Eenmaal geïnstalleerd, wat te doen? Omdat de aas-speler niet is geïnstalleerd, weet ik niet hoe ik het moet laten werken.
    Kan iemand me alsjeblieft helpen?

    1.    vafe zei

      Als wat je hebt geïnstalleerd de acestream-launcher is, als je op een link klikt, zal acestream je vragen met welke applicatie je de link wilt openen, je vertelt het dat met VLC, en dit is degene die de functies van de ace-player zal doen

      1.    Debian zei

        Hoi. Allereerst hartelijk dank voor uw hulp. Geef ik commentaar. Ik heb het acestream snap-pakket in Debian 9 met gnome geïnstalleerd. Wanneer ik in arenavisión ben, waarvoor ik het wil, klik ik op een acestream-link en er verschijnt een venster dat me twee opties geeft, de eerste is acestreamengine dat als ik erop klik, het niets doet en de tweede is een andere toepassing kiezen, ik geef het maar de geïnstalleerde applicaties openen niet, mijn thuismap wordt geopend, dus ik weet niet hoe ik de vlc moet selecteren.

        Een groet.

        1.    Alexander zei

          Met de acestream-launcher gaat het helemaal niet goed, beter te installeren met het Snap-pakket zoals ik in mijn opmerking hierboven uitleg.

  17.   peter de groentje zei

    Ik probeer het snapd-pakket te installeren, maar het laat me niet toe:

    sudo apt install snapd
    Pakketlijst lezen ... Klaar
    Afhankelijkheidsboom maken
    De statusinformatie lezen ... Klaar
    E: Het snapd-pakket kon niet worden gevonden

    Wat ik doe?

  18.   Alf zei

    Heel erg bedankt, het is een van de programma's die ik in Windows heb gebruikt en ik wilde het in linux hebben

  19.   Oscar zei

    Bedankt Chemabs en Alejandro! Perfect met Ubuntu 17.10
    sudo apt install snapd
    snap acestream zoeken
    sudo snap installeer acestreamplayer
    En dat is het!
    Het ongelooflijke is dat je naar de officiële website gaat en dat ze je vanaf 2014 een bericht op hun forum sturen! En waarin ze slechts tot Ubuntu 13.04 vermelden!

  20.   Marco Barria zei

    goed, zoals ze in de vorige opmerkingen zeiden, het werkt perfect met snapd in arch:

    sudo pacman -S snapd
    sudo systemctl zet snapd.socket aan
    opnieuw op te starten
    sudo snap installeer acestreamplayer
    opnieuw op te starten

    en klaar :

  21.   mchavez zei

    hallo, en is er een manier om de aasstream te installeren zonder een programmeur te hoeven zijn ... zoals wordt gedaan met Windows