Como instalar AceStream no Linux e não morrer tentando

Aqueles de nós que amamos esportes e não temos acesso a todos os canais de esportes atuais, geralmente enfrentamos o problema de que, para desfrutá-los, devemos utilizar várias páginas que transmitem partidas online, a maioria deles pede instale AceStream, que tende a ser um pouco complexo de instalar no Linux.

Neste guia, vamos ensinar como instalar AceStream no Linux sem morrer na tentativa, fornecendo soluções para os problemas mais comuns hoje. A sua utilização e o conteúdo que acede são da sua total responsabilidade.

O que é AceStream?

acestream é uma plataforma multimídia bastante inovador, que elevou a reprodução de audiovisuais na Internet a um patamar superior. Para isso, implementou um gerenciador universal de upload de arquivos multimídia, que utiliza as mais avançadas tecnologias P2P, garantindo um processo eficiente de armazenamento e transmissão de dados.

O software Ace Stream nos oferece uma série de benefícios nos quais podemos destacar:

  • Possibilidade de visualização de emissões online (TV, streams personalizados, filmes, desenhos animados, etc.), com elevada qualidade de áudio e imagem.
  • Ouça música online em um formato que não perde qualidade.
  • Visualize torrents online, sem ter que esperar o download completo.
  • Visualize o conteúdo em dispositivos remotos (Apple TV, Chromecast, etc.) em protocolos de comunicação como AirPlay, Google Cast e outros.
  • Permite integração com vários aplicativos. Instale AceStream no Linux

Como instalar AceStream no Linux

Para instalar o AceStream no Linux devemos seguir vários passos dependendo da distro que você usa, vamos nos concentrar no Arch Linux e Ubuntu, mas esperamos no futuro poder instalá-lo em outras distros.

Instale AceStream no Arch Linux e derivados

A principal razão pela qual fiz este artigo é porque muitos tiveram problemas para instalar o AceStream no Arch Linux, Antergos, Manjaros e derivados, a principal causa é que o pkgbuild do plugin plugin-acestream-mozilla Dá um erro na hora de instalar, a solução é extremamente simples.

Vamos instalar o plugin-acestream-mozilla que também vai nos instalar motor acestream y acestream-player-data quais são os pacotes necessários para reproduzir AceStream do firefox.

Em primeiro lugar, devemos abrir um terminal e executar o seguinte comando:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Isso corrigirá o problema de verificação que impede a instalação da dependência necessária para instalar plugin do acestream-mozilla.

Em seguida, executamos o seguinte comando

yaourt -S acestream-mozilla-plugin

Em repetidas ocasiões, seremos questionados se queremos instalar várias dependências, devemos dizer sim a todas.

Instale AceStream no Ubuntu e derivados

Instale AceStream no Ubuntu 14.04 e derivados

Para usuários de ubuntu e derivados até a versão 14.04, a instalação do AceStream será bastante simples, bastando executar os seguintes comandos no terminal:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Instale AceStream no Ubuntu 16.04 e derivados

Quem vai ter que se esforçar um pouco mais são os usuários do Ubuntu 16.04 e derivados já que o acestream não tem suporte para essa versão, mas graças a isso artículo, Consegui instalar.

A primeira coisa que faremos é baixar e instalar algumas dependências que você não conseguirá baixar dos repositórios oficiais, certifique-se de instalar os apropriados para a arquitetura de sua distro:

Arquitetura de 64 bits:

  1. Baixar e instalar libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb você pode fazer isso no seguinte link: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Baixe e instale na ordem em que as seguintes dependências são apresentadas:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb Você pode baixar cada um a partir do seguinte link: https://drive.google.com/folderview?id= … e_web#list

Arquitetura de 32 bits:

  1. Baixar e instalar libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb você pode fazer isso no seguinte link: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Baixe e instale na ordem em que as seguintes dependências são apresentadas: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb Você pode baixar cada um a partir do seguinte link: https://drive.google.com/folderview?id= … e_web#list

Em seguida, devemos continuar com a instalação normal do AceStream como fizemos para a versão 14.04, abrir um terminal e executar:

echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get install acestream-full

Em alguns casos é necessário iniciar o serviço acestream-engine.service, para isso executamos os seguintes comandos a partir do terminal:

systemctl start acestream-engine.service systemctl enable acestream-engine.service

Com este tutorial esperamos que você possa desfrutar deste ótimo protocolo de transmissão multimídia que utiliza toda a capacidade da tecnologia P2P.


O conteúdo do artigo segue nossos princípios de Ética editorial. Para relatar um erro, clique Clique aqui.

41 comentários, deixe o seu

Deixe um comentário

Seu endereço de email não será publicado.

*

*

  1. Responsável pelos dados: Miguel Ángel Gatón
  2. Finalidade dos dados: Controle de SPAM, gerenciamento de comentários.
  3. Legitimação: Seu consentimento
  4. Comunicação de dados: Os dados não serão comunicados a terceiros, exceto por obrigação legal.
  5. Armazenamento de dados: banco de dados hospedado pela Occentus Networks (UE)
  6. Direitos: A qualquer momento você pode limitar, recuperar e excluir suas informações.

  1.   Júlio César Campos dito

    Bom o post mas pelo menos no archlinux e esse foi o meu caso você precisa: "systemctl start acestream-engine.service" e "systemctl enable acestream-engine.service" para funcionar.

    1.    Lagarto dito

      Você estava testando no Firefox ou usando outro navegador?

  2.   UserDebian dito

    Alguém sabe como fazê-lo funcionar no Debian 9?

  3.   Júlio César Campos dito

    Firefox em archlinux

  4.   gecoxx dito

    Não sei se o meu comentário anterior foi publicado ... repito! Demoro não sei quantas horas executando o maldito comando no terminal, e isso eu coloquei –noconfirmo, e no final não funciona !!
    outro post que é inútil!

    tentativa de instalação em Manjaro

    1.    Lagarto dito

      Prezado que não funcionou para você, funcionou perfeitamente para mim, de qualquer forma tente executar estes 2 comandos:
      "Systemctl start acestream-engine.service" e "systemctl enable acestream-engine.service"

  5.   Joseph dito

    bom

    Consegui fazer todas as etapas sem nenhum problema. Mas ao tentar iniciar o serviço do terminal, ocorreu-me duas falhas;
    systemctl start acestream-engine.service
    Falha ao iniciar acestream-engine.service: Unidade acestream-engine.service não encontrada.
    systemctl habilitar acestream-engine.service
    Falha ao executar a operação: nenhum arquivo ou diretório.

    1.    gustavo dito

      Exatamente a mesma coisa aconteceu comigo. o terminal devolve esses comandos para mim com essas falhas.

  6.   João M dito

    Muito obrigado pela postagem! Se você usar o Ubuntu 16.10 64 bits, não será possível instalar "acestream-player-data_3.0.2-1.1_amd64.deb". Eles devem primeiro baixar e instalar estes pacotes:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Provavelmente, é necessária alguma outra dependência que esteja nos repositórios.
    Saudações!

  7.   Miles dito

    Bom.
    O plugin acestream-mozilla parou de funcionar no Firefox 52, como muitos outros plug-ins NPAPI.

  8.   Darco dito

    Outra opção muito boa e simples é usar docker e tornar-se agnóstico em relação ao seu sistema operacional. Usando o aceproxy, você pode reproduzi-lo-

    Escrevi um pequeno tutorial e um script, para facilitar a execução.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   David Martin dito

    Na parte de instalação do Ubuntu 16.04, quando você diz para baixar e instalar esses arquivos, como você os instala? Quando faço o download e extraio, alguns são apenas um arquivo libreoffice e outros, não sei como "instalá-los".
    Agradecemos antecipadamente e melhores cumprimentos.
    David.

  10.   Vafe dito

    Ou as chaves não funcionam novamente ou há algum erro nos pacotes, mas no arch e no manjaro é impossível instalá-lo.
    Ao tentar instalar uma dependência (qwebquit) ou algo parecido, ele entra em um loop e não tem como.
    Alguém encontrou a solução?
    obrigado

    1.    Alexander dito

      Olá, para a instalação no arch linux você deve fazer o seguinte:
      -Instale o pacote 'acestream-launcher' de yaourt com 'yaourt -S acestream-launcher' (o pacote que vamos habilitar a seguir é baixado automaticamente para você)
      -Ativar acestream-engine.service, entramos no terminal e no modo ROOT colocamos o seguinte
      -systemctl iniciar acestream-engine.service
      -systemctl habilita acestream-engine.service
      Reiniciei o computador depois disso, não sei se será necessário, mas apenas no caso
      -Isso deve ser suficiente, mas nas últimas atualizações do Arch eles bagunçaram alguma coisa e não deu certo, então eles procuraram uma solução temporária, que é baixar um arquivo, é o seguinte:
      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      fonte: https://aur.archlinux.org/packages/acestream-launcher/ (nos comentários)
      uma vez baixado, vamos para o terminal e vamos para a pasta onde o baixamos,
      Prosseguimos para instalá-lo com 'sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz' e é isso, ele deve ir, na primeira vez nunca passa então eu clico uma segunda vez, a primeira vez sempre dá erro, só isso

      PS: esclareça que o sudo pacman -U e não -S porque é um pacote local obtido do makepkg

      1.    Vafe dito

        Muito obrigado pelo seu interesse.
        Já tentei tantas vezes que já sei de cor as dependências e os comentários dos pacotes ao instalar com yaourt. Vou seguir seu conselho com o lançador e ver se tenho sorte. Eu vou te contar.
        Eu repito meu obrigado

        Felipe

        1.    Vafe dito

          De uma forma ou de outra não funciona. Já tentei com o link que você colocou nos comentários, mas não resolve, reconhece o link, me dá a opção de escolher o programa, escolho o acestream-launcher mas o VLC não abre.
          No console, ele me dá a seguinte resposta.

          Arquivo «/usr/lib/python3.6/site-packages/psutil/o init.py », linha 1231, em _send_signal
          os.kill (self.pid, sig)

          Teremos que esperar por novas atualizações.
          Obrigado por sua ajuda.

  11.   Vafe dito

    Após a nova atualização, a resposta no console é a seguinte.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Motor Acestream funcionando.
    2017-07-28 18: 16: 59,615 | MainThread | acestream | erro durante a inicialização
    Traceback (última chamada mais recente):
    Arquivo «core.c», linha 1590, em
    Arquivo «core.c», linha 144, em
    Arquivo «core.c», linha 2, em
    ImportError: não é possível importar o nome __m2crypto
    Erro ao autenticar no Acestream!
    O Media Player não está funcionando ...

    Estamos melhorando, agora ele reconhece o acestream, mas o libcrypto continua lutando.

    1.    Vafe dito

      Tentei instalar o pacote que você recomenda no link que você me enviou.

      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      E resolve o problema de forma eficaz, o VLC abre e o Acestream funciona.
      Muito obrigado por sua ajuda-

      1.    Alexander dito

        Olá, desculpe pela demora, foi muito estranho que não funcionou para você quando funcionou, estou no plasma Arch, fico feliz que tenha ajudado você, é para isso que somos

        Na outra distribuição que tenho, que é o Fedora, o que eu tenho é o Wine emulando acestream para windows xD, caso você vá para outra distro ou o próprio Arch, o que me surpreende é que nem no Debian eles têm esses pacotes ...

      2.    delicacy maker01 dito

        Olá e o arquivo é como está instalado ainda sou um novato, uma saudação

        1.    Vafe dito

          sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

          Ele coloca no comentário acima

  12.   chemabs dito

    Ontem instalei-o como um pacote instantâneo no Kde Neon 5.8 e fiquei surpreso com o quão simples e rápido funcionou para mim. Seria bom se você atualizasse o artigo porque não há comparação, o processo é muito simplificado.

    sudo apt install snapd → instale o sistema de gerenciamento de pacotes snap (se você não o tiver instalado)
    snap find acestream → para verificar se temos o programa nos repositórios (todos os derivados do ubuntu devem tê-lo)
    sudo snap instalar acestreamplayer

    lembranças

    1.    Antonio Manzano dito

      Tem toda a razão. Acabei de instalá-lo no kubuntu 17.10, já que o método que aparece aqui é totalmente inviável. Muito obrigado

      1.    Papai dito

        não é válido para arquitetura i386

    2.    sie9k dito

      Foi a única forma de poder instalá-lo no Lubuntu 16.04.4, mas não tenho como salvar o arquivo de configuração e preciso configurar um parâmetro para funcionar com o Serviio. Alguma ideia para consertar isso?

  13.   José Antonio dito

    Postagem muito boa. Uma página da web de leitura obrigatória para iniciantes em Linux.

  14.   Peter o novato dito

    Como você o instalaria para o AntiX 16 (é uma distribuição Linux)?

    Eu tentei como o Arch Linux e derivados, mas sou tão novato que devo errar

  15.   Alexander dito

    Olá, com os pacotes sna, que o colega acima comenta em um comentário, ficou mais fácil não apenas para essas distribuições, mas para muitas. As distribuições compatíveis com esses pacotes estão aqui:
    https://snapcraft.io/

    No Debian, seria o seguinte:
    -sudo apt install snapd
    -sudo snap install core
    -sudo snap install um player de stream
    Em Arch e derivados:
    -sudo pacman -S estalou
    -sudo systemctl enable --now snapd.socket
    -sudo snap install um player de stream

    No Arch (plasma) tive que reiniciar para que apareçam os pacotes instalados, se não aparecer você já sabe o que fazer.

    No ubuntu e derivados acho que vai ser como o parceiro que instalou acima nos comentários com o neon do KDE.

    É curioso que no Gnome com Debian parece bastante feio e não se integra bem com GTK, mas no plasma Arch ele se integra muito bem, o importante é que seja visto fora da estética.

    1.    william dito

      isso instala seu motor de transmissão?
      a mim não

      1.    Alexander dito

        Olá, não, ele não instala, nem precisa, com os pacotes snap todas as dependências cobertas já vêm, tem que funcionar sim ou sim.

    2.    txuber dito

      Oi Alejandro, veja se você pode me ajudar
      [txuber @ manjaro ~] $ sudo systemctl enable –now snapd.socket
      Falha ao ativar a unidade: o arquivo de unidade \ xe2 \ x80 \ x93now.service não existe.
      no manjaro Manjaro XFCE Edition (17.0.4) x64

      1.    Alexander dito

        Olá, Manjaro é que não é Arch puro e as coisas podem mudar um pouco, pode já estar habilitado e não é necessário fazer isso, suponho que você já tenha tentado pular essa etapa ...

  16.   Debian dito

    Depois de instalado, o que fazer? Como o ace-player não está instalado, não sei como fazê-lo funcionar.
    Alguém me ajude por favor?

    1.    Vafe dito

      Se o que você instalou é o acestream-launcher, quando você clica em um link acestream vai perguntar com qual aplicativo você quer abrir o link, você diz isso com VLC, e este é o que vai fazer as funções do ace-player

      1.    Debian dito

        Oi. Em primeiro lugar, muito obrigado pela ajuda. Te falo. Instalei o pacote acestream snap no Debian 9 com gnome. Quando estou em arenavisión, que é o que eu quero, clico em um link do acestream e aparece uma janela que me dá duas opções, a primeira é um acestreamengine que se eu clicar aqui não faz nada e a segunda é escolher outro aplicativo, eu dou para escolher mas os aplicativos instalados não abrem, minha pasta pessoal abre, então não sei como selecionar o vlc.

        Uma saudação.

        1.    Alexander dito

          Com o acestream-launcher não está indo nada bem, é melhor instalar com o pacote Snap como explico no meu comentário acima.

  17.   Peter o novato dito

    Tento instalar o pacote snapd, mas não consigo:

    sudo apt instalar snapd
    Lendo lista de pacotes ... Concluído
    Criando árvore de dependências
    Lendo as informações de status ... Concluído
    E: O pacote snapd não pôde ser localizado

    que faço?

  18.   Alf dito

    Muito obrigado, é um dos programas que usei no windows e queria tê-lo no linux

  19.   Oscar dito

    Obrigado Chemabs e Alejandro! Perfeito com Ubuntu 17.10
    sudo apt instalar snapd
    Encontre uma transmissão instantânea
    sudo snap instalar acestreamplayer
    E é isso!
    O incrível é que você vai ao site oficial e eles te mandam um post no fórum de 2014! E no qual eles mencionam apenas até o Ubuntu 13.04!

  20.   Marco Barria dito

    bom, como dizem nos comentários anteriores, funciona perfeitamente com o snapd no arch:

    sudo pacman -S estalou
    sudo systemctl habilita snapd.socket
    reinicialização
    sudo snap instalar acestreamplayer
    reinicialização

    e pronto :

  21.   mchavez dito

    Olá, e há uma maneira de instalar o ace stream sem ter que ser um programador ... como é feito com o Windows