Решение проблемы с установкой 32-битных приложений на Linux Mint 14 RC 64-bit

Я только что опубликовал известную новость Доступен Linux Mint 14 RC, и Клем только что объявил что в 64-битной версии есть проблема, не позволяющая устанавливать такие приложения как Skype, Google Планета Земля или любой другой 32-битный пакет.

Возможность установки 32-битных приложений в 64-битной среде обычно называется «мультиархивом». Видимо в dpkg в Debian, который сделал конфигурацию Мультиархия устареть в Ubuntu. Вы можете увидеть больше информации об этой проблеме здесь: https://bugs.launchpad.net/ubuntu/+source/ia32-libs/+bug/1016294

Решение

Чтобы включить Multiarch, откройте терминал и введите следующие команды:

sudo dpkg --add-arquitectura i386
apt update

Эта проблема будет исправлена ​​вручную в стабильной версии Linux Mint 14.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

12 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Виллианы сказал

    @MonitoLinux слишком много работы твоей. Не уверен, что найду его в бэкпортах стабильной версии. Но я могу гарантировать, что в Sid и, скорее всего, к настоящему времени в репозиториях Wheezy [1] вы найдете его доступным.

    [1] http://www.debian.org/News/2011/20110726b

    Поддержка мультиархитектуры наделала много шума. Я столкнулся с ним как в июне, а он уже давно катался.

    1.    монитолинукс сказал

      @Willians - это то, что я пришел из старых времен, когда не было так много репозиториев с приложениями, которые нужны были, и где одним из самых больших, которые он мог найти, был исходный код.

  2.   Виллианы сказал

    Здесь [1] статья DD по этому поводу.
    И на debian.org [2]

    [1] http://raphaelhertzog.com/2012/02/07/dpkg-with-multiarch-support-available-in-debian-experimental/

    [2] http://wiki.debian.org/Multiarch/HOWTO

  3.   РафаГКГ сказал

    Я немного потерялся (очень много) с этим. Я использую Xubuntu 12.10 64Bit (снимок по сравнению с ubuntu 12.10, который является leeeento), и мое удивление, когда я пошел устанавливать KompoZer, заключается в том, что он не появился ... в конце концов я пришел к выводу, что, поскольку его не существует для 64-битной версии, не было в репозиториях ... хотя до сих пор он всегда устанавливался (с помощью apt-get install Kompozer), но на этот раз он не появился. После долгих раздумий я нашел 64-битный DeB и установил его. Но я сомневаюсь, и наконец я перехожу к делу. Если я установлю это, вы прокомментируете этот пост. Появятся ли в репозитории 32-битные пакеты для установки 32-битных программ, если 64-битные недоступны? Появился бы мне 32-битный Kompozer для установки в репозитории? Хорошо ли, что я делаю это для будущих программ, которые мне нужны?

  4.   Garbage_Killer сказал

    elav Я сказал тебе, что я был в Debian sid

    на самом деле эта проблема, которую представляет mint, Debian sid уже представил ее около 2 месяцев назад, даже в синаптической версии он говорит, что перед установкой ia32-libs и ia32-libs-gtk он рекомендует добавить dpkg –add-architecture: i386, затем запустить обновление и готово.

    1.    Elav сказал

      Когда ты мне сказал? Я не помню 😛

      1.    Garbage_Killer сказал

        ровно 2 месяца назад, когда у меня была аналогичная проблема, но это было из-за того, что пакет ia32-libs-gtk был устаревшим, и он все еще не вышел для завершения новых ia32-libs, пока я не вспомню, как вы сказали, и почему я собираюсь чтобы добавить dpkg -add- architecture: i386 😛

        1.    Elav сказал

          Хахаха, это было через IRC, верно?

  5.   MonitoLinux сказал

    решение - загрузить исходный код и скомпилировать, затем сгенерировать пакет deb и передать его сообществу

  6.   Серхио Эсау Арамбула Дуран сказал

    Отлично

  7.   Давайте использовать Linux сказал

    Очень хорошо! Интересно…
    Будем надеяться, что они исправят проблему до выхода финальной версии.
    Ура! Павел.

  8.   mfcollf77 сказал

    Я установил linux mint 14 64 бит, и у меня не было проблем с установкой Skype, была установлена ​​только версия 4.0

    Я посмотрю, с чем еще у меня проблемы