Устранение неполадок Ubuntu и Mint на Lenovo G480

Я слежу за этим блогом довольно долго, и мне он кажется очень хорошим, поэтому я решил разместить это решение здесь, так как я купил этот ноутбук и обнаружил эти проблемы при установке Ubuntu 12.04 y Linux Mint 14 Я был бы признателен за исправления, так как я новичок в создании учебных пособий.
Далее я покажу вам, как решить проблемы, которые возникают у Lenovo G480 с красным. беспроводной и ethernet и чтобы яркость работала

Решение 1-Ethernet

Первым делом заходим в наш BIOS и вставляем от UEFI. Поскольку мы не подключены ни к какой сети, мы загружаем этот пакет (необходимо для сборки: http://packages.ubuntu.com/precise/build-essential), а затем установите его на наш ноутбук. В Ubuntu 12.04 он запрашивает у нас зависимости dpkg-dev, g ++, gcc, libc6-dev или libc-dev и make. В Linux Mint 14 это не запрашивается после того, как пакет, необходимый для сборки, уже установлен, так как он установлен, мы приступаем к установке следующего пакета

Скачать пакет

Установка проста. Открываем терминал и ставим:

$ cd Desktop
$ tar -xf compat-wireless-3.5.1-1-snpc.tar.bz2
$ cd compat-wireless-3.5.1-1-snpc
$ ./scripts/driver-select alx
$ make
$ sudo make install
$ sudo modprobe alx

уже имея это, мы можем без проблем подключить наш сетевой кабель

Для Linux Mint 14 подключение беспроводной достаточно только войти в Источники программного обеспечения и установить проприетарный драйвер. Для Ubuntu 12.04 мы будем делать это через терминал со следующим:

Проверяем, что наша карта Broadcom 14e4: 4727 для этого вставляем в терминал

lspci -nn | grep 0280

После этого остается сделать следующее:

sudo apt-get install --reinstall bcmwl-kernel-source

и готово, у нас будет беспроводное соединение.

И напоследок яркость, для этого вводим файл нашей личинки

sudo gedit /etc/default/grub
sudo nano /etc/default/grub

С помощью любого из двух введите файл

Ищем строчку, в которой написано:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”

и под ним помещаем следующие

GRUB_CMDLINE_LINUX_DEFAULT="acpi_backlight=vendor"

Обновляем наш Grub

sudo update-grub

А в следующем мы сможем регулировать яркость нашего ноутбука.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

14 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   солидус00 сказал

    Отличный туториал для тех, кто представляет проблему, поздравляю вас.

  2.   Блэр Паскаль сказал

    Спасибо, так-то и так-то иначе. Данте хе-хе. Очень-очень хороший репетитор, продолжайте писать.

  3.   Макова сказал

    Очень хорошо. Если в итоге куплю Леново или нет 😀

  4.   Макова сказал

    Ну да, когда они входят в стандартную комплектацию Debian или Arch

  5.   Элинкс сказал

    Это совсем не плохо!

    Привет!

  6.   Лукас Матиас сказал

    Ваш вклад ценится, сэр, большое спасибо, я продолжал писать 😉

  7.   мешки сказал

    Очень хорошо, но если бы вы проверили пунктуацию, было бы удобнее читать.

  8.   Анхель Карденас сказал

    А с последней версией работать не будет? http://www.orbit-lab.org/kernel/compat-wireless-3.0-stable/v3.6/compat-wireless-3.6.8-1-snpc.tar.bz2

  9.   ловкость сказал

    привет и продолжаем работать с этой машиной, используя ubuntu 12.10 для установки яркости по умолчанию каждый раз, когда они включают 480-битную машину Lenovo G64 с Intel, это выглядит так

    Ubuntu 12.10

    для установки яркости по умолчанию на ноутбуке Lenovo G480 с 64-битной Intel

    войдите как root или superuser и напишите
    sudo gedit /etc/rc.local
    и непосредственно перед выходом 0
    вы ставите следующее
    эхо 652> / sys / class / backlight / intel_backlight / яркость
    652 - это уровень, который я установил, чтобы начать с этого уровня яркости, потому что уровень яркости с Intel идет от 0 до 4437, он установлен перед выходом 0
    сохранить и перезапустить.

    это путь, который я использую на этом ноутбуке с Intel
    sys / класс / подсветка / intel_backlight / яркость

    спасибо gnu / linux

    и мне интересно, а в Fedora как это будет, потому что до сих пор я не мог управлять яркостью экрана с помощью этого же ноутбука, хорошо, если я смогу заставить яркость работать, но после некоторых перезагрузок он больше не работает, и это не так ' t регулировка яркости, помогите пожалуйста в этом вопросе.

  10.   Джебран сказал

    Привет из Linux, как всегда приятно вам писать.

    У меня проблема с моим Thinpad t410.У меня процессор Core i5 vPro первого поколения, 8 оперативной памяти Hyperx с тактовой частотой 1600 ГГц и твердотельный накопитель adata sx900 емкостью 250 ГБ, он работает, это страшно, установите linux mint xfce, и он включается за 4 секунды . Я уже сделал все, что нашел в блогах, от активации обрезки с помощью fstab, использования раздела в ext4, передачи временных файлов в оперативную память и передачи подкачки на 10. но ничто каждый раз не дает мне сбоя в сушилках при проверке в SMART TEST Я получаю недостатки в ECC. Ну, пока я использую только раздел Windows, потому что он не дает мне ошибок.

    1.    ловкость сказал

      Привет, друг Джебран, я не понимаю твоей проблемы, что ты хочешь сделать?

  11.   Хуан Игнасио сказал

    Здравствуйте, большое спасибо за инструкцию. Может быть, вы мне поможете при установке compat-wireless-3.5.1-1-snpc. Я распаковываю папку, запускаю "./scripts/driver-select alx", а затем "make", и вот в чем проблема:

    "Сделайте -C /lib/modules/3.8.0-27-generic/build M = / home / russian / compat-wireless-3.5.1-1-snpc modules
    make [1]: войдите в каталог "/usr/src/linux-headers-3.8.0-27-generic"
    CC [M] /home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.o
    /home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c: В функции 'alx_hw_printk':
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:124:3: error: неявное объявление функции '__netdev_printk' [-Werror = implicit - объявление функции]
    /home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c: На основном уровне:
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:1955:22: ошибка: ожидается '=', ',', ';', 'asm' или '__attribute__' перед 'alx_init_adapter_special'
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:2010:22: error: expected '=', ',', ';', 'asm' или '__attribute__' перед 'alx_init_adapter'
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:3472:22: ошибка: ожидается '=', ',', ';', 'asm' или '__attribute__' перед 'alx_init'
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:3780:23: error: expected '=', ',', ';', 'asm' или '__attribute__' перед 'alx_remove'
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:3903:17: ошибка: здесь не было объявлено 'alx_init' (не в функции)
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:3904:2: error: неявное объявление функции '__devexit_p' [-Werror = implicit - объявление функции]
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:3904:29: ошибка: здесь не было объявлено 'alx_remove' (не в функции)
    /home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:135:12: предупреждение: 'alx_validate_mac_addr' определен, но [-Wunused- не используется функция]
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:210:12: предупреждение: 'alx_init_hw_callbacks' определен, но [-Wunused- не используется функция]
    /home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:1698:12: предупреждение: определите 'alx_alloc_all_rtx_queue', но не используйте [-Wunused- function]
    /home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:1757:13: предупреждение: определите 'alx_free_all_rtx_queue', но не используйте [-Wunused- функция]
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:1773:12: предупреждение: 'alx_set_interrupt_param' определен, но [-Wunused- не используется функция]
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:1824:13: предупреждение: 'alx_reset_interrupt_param' определен, но [-Wunused- не используется - функция]
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:1914:12: предупреждение: 'alx_set_interrupt_mode' определен, но [-Wunused- не используется функция]
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:1941:13: предупреждение: 'alx_reset_interrupt_mode' определен, но [-Wunused- не используется функция]
    /home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:2125:12: предупреждение: 'alx_set_register_info_special' определено, но [-Wunused- не используется функция]
    /home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:3043:13: предупреждение: 'alx_timer_routine' определен, но [-Wunused- не используется функция]
    /home/russian/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.c:3064:13: предупреждение: 'alx_task_routine' определено, но [-Wunused- не используется функция]
    cc1: некоторые предупреждения рассматриваются как ошибки
    make [4]: ​​*** [/home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx/alx_main.o] Ошибка 1
    make [3]: *** [/home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros/alx] Ошибка 2
    make [2]: *** [/home/ruso/compat-wireless-3.5.1-1-snpc/drivers/net/ethernet/atheros] Ошибка 2
    make [1]: *** [_module_ / home / russian / compat-wireless-3.5.1-1-snpc] Ошибка 2
    make [1]: выйти из каталога "/usr/src/linux-headers-3.8.0-27-generic"
    make: *** [модули] Ошибка 2 ″

    Я следовал инструкциям на этих форумах: http://www.forosuse.org/forosuse/showthread.php?t=29916 y http://www.chakra-project.org/bbs/viewtopic.php?id=10514
    Но я действительно не понимаю, как получить доступ к ошибке; Я смотрел файл "alx_main, c", но ничего не понимаю. Простите за незнание, я действительно новичок в Linux. Я использую linux mint 15 на Lenovo G480.

    От уже большое спасибо. С уважением.

    1.    Данте сказал

      Когда я получаю эти ошибки, я даю им разрешения на папку, в которой содержатся файлы.

  12.   анонимный сказал

    как вы устанавливали ubuntu на леново?