I-install ang Pinakabagong Xfce Packages sa Debian Testing

Kamakailan lamang Nagcomment ako sa kanila Na-install ko ang pinakabagong mga bersyon ng ilang mga bahagi ng Xfce sa Archlinux, na unti-unting lumitaw sa ilalim ng pagnunumero 4.9 at ang mga ito ay magiging isang bersyon bago ang kung ano ang mayroon kami sa huling bersyon 4.10

Sa gayon, tulad ng nasa ngayon ako Pagsubok sa Debian Ayokong maiwanan at nag-install na ako:

  • xfce4-panel 4.9.0
  • xfce4-appfinder-4.9.3
  • libxfce4ui-4.9.0

Tingnan natin kung paano.

Pag-install ng kinakailangang mga pakete.

Upang maiipon sa Debian ang mga pakete ng Xfce kailangan naming mag-install ng ilang kinakailangang mga pakete. Nagbubukas kami ng isang terminal at inilalagay:

[code]

build-mahalaga libx11-dev pkg-config libxfce4util-dev libgarcon-1-0-dev libxfce4ui-1-dev exo-utils libexo-1-dev libwnck-dev intltool

[/ code]

Pag-install

Kumuha halimbawa xfce4-appfinder. Xfce4-panel Hindi ko ito kinuha bilang isang halimbawa, dahil pagkatapos ng pag-install, kinailangan kong ibalik ang nakaraang panel dahil binigyan ako nito ng isang error na nasa proseso ng paglutas. Gayunpaman, ang pamamaraan ay pareho para sa iba pang mga application. Upang magawa ito magbubukas kami ng isang terminal at ilagay:

[code]

$ wget -c http://archive.xfce.org/src/xfce/xfce4-appfinder/4.9/xfce4-appfinder-4.9.3.tar.bz2
$ bzip2 -dc xfce4-appfinder-4.9.3.tar.bz2 | tar -xv
$ cd xfce4-appfinder-4.9.3

[/ code]

Ang unang bagay na ginagawa namin ay i-download ang file. Pagkatapos ay i-unzip namin ito at pumunta sa folder kung saan matatagpuan ang mga file na ilalagay namin. Anong susunod?

[code]

$ ./configure
$ gumawa
$ sudo gumawa ng pag-install

[/ code]

Karaniwan ginagawa ko ito sa ganitong paraan:

$ ./configure && make && sudo make install

Ngunit mas mabuting gawin mo ang . / I-configure bago upang makita kung kailangan naming mag-install ng anumang mga pakete. Tama na ito. Ngayon natutuklasan ko kung ano ang nangyayari sa panel, na kapag na-install ko ito binigyan ako ng error na ito kapag sinusubukang ipatupad ito:

xfce4-panel: error sa paghanap ng simbolo: xfce4-panel: hindi natukoy na simbolo: xfce_panel_plugin_mode_get_type


Ang nilalaman ng artikulo ay sumusunod sa aming mga prinsipyo ng etika ng editoryal. Upang mag-ulat ng isang pag-click sa error dito.

2 na puna, iwan mo na ang iyo

Iwanan ang iyong puna

Ang iyong email address ay hindi nai-publish. Mga kinakailangang patlang ay minarkahan ng *

*

*

  1. Responsable para sa data: Miguel Ángel Gatón
  2. Layunin ng data: Kontrolin ang SPAM, pamamahala ng komento.
  3. Legitimation: Ang iyong pahintulot
  4. Komunikasyon ng data: Ang data ay hindi maiparating sa mga third party maliban sa ligal na obligasyon.
  5. Imbakan ng data: Ang database na naka-host ng Occentus Networks (EU)
  6. Mga Karapatan: Sa anumang oras maaari mong limitahan, mabawi at tanggalin ang iyong impormasyon.

  1.   Giskard dijo

    Anong balita ang dala ng mga package na ito? Maaari mo bang ilagay ang isang shot ng screen upang makita kung ano ang hitsura ng isa?
    Salamat sa iyo

  2.   tapang dijo

    Kapareho ng pag-install nito sa Arch heh heh