Linux Kernel 2.6.30及更高版本中存在严重的安全漏洞

Linux内核2.6.30及更高版本包含一个严重的安全漏洞,可以利用该漏洞来 在受攻击的系统上获得超级用户权限.

该漏洞,在Linux的协议实现中 可靠的数据报套接字(RDS)会影响Linux内核的未修补版本,从2.6.30开始,其中首次包含RDS协议。

根据VSR Security,研究小组认为 发现了安全漏洞,只有在内核配置选项下,Linux安装才会受到影响 CONFIG_RDS 启用,并且如果非特权用户没有限制加载模块程序包系列(在大多数发行版中就是这种情况)。

由于负责在内核和用户空间之间复制数据的内核函数无法验证用户提供的地址当前是否位于用户段中,因此本地攻击者可以释放专门准备向内核写入任意值的函数调用套接字记忆。 依靠此功能,非特权用户可以将其特权升级为root特权。

该公司已发布概念证明漏洞,以证明该漏洞的严重性。 H安全男孩 他们尝试了 在Ubuntu 10.04(64位)上进行了漏洞利用,他们成功打开了  如 .

对此事的安排是 已发送 由Linus Torvald撰写。 VSR Secutrity建议用户安装发行版提供的更新或应用已发布的补丁并重新编译其内核(版本2.6.24.2).

数据来源: ZD网 & 关注信息 与计算机世界


本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

2条评论,留下您的评论

发表您的评论

您的电子邮件地址将不会被发表。

*

*

  1. 负责数据:MiguelÁngelGatón
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。

  1.   阿尔瓦罗·奥尔蒂斯(Alvaro Ortiz)

    此漏洞已得到修复。 这则消息已经在Linux博客圈中迅速传播开来,令人震惊。
    http://www.muylinux.com/2010/10/22/vulnerabilidad-critica-en-el-kernel-linux/comment-page-1#comment-36870

  2.   德鲁普

    真的很严重not

    “只有启用了内核配置选项CONFIG_RDS,并且对于非特权用户加载模块软件包系列没有任何限制,它们才会受到影响”

    虽然我不明白您对这哈哈的真正含义!