[Solucionado] Ubuntu se cuelga al inicio: pantalla negra/violeta de la muerte

Artículo de Usemos Linux
Hace años que ya no uso Ubuntu, pero el otro día, tratando de instalar Ubuntu 13.04 en la compu de un amigo volví a tener pesadillas: luego de una instalación aparentemente exitosa el sistema “se cuelga” en el arranque y aparece una pantalla az… perdón, violeta.Después de acordarme de Mark Shuttleworth y de toda su familia di con la solución, que comparto con Uds.


El error suele suceder al utilizar tarjetas de video Nvidia o AMD, o un laptop con Optimus o similar, que permite utilizar 2 tarjetas gráficas intercambiables. Ubuntu, al no venir con los drivers propietarios instalados puede tener problemas para trabajar con ellos.

La solución es arrancar Ubuntu, una vez en el modo nomodeset para omitir la pantalla negra o violeta (según el caso), descargar e instalar los drivers apropiados, y luego reiniciar el sistema para arreglar el problema para siempre.

Pasos a seguir

1.- Iniciá el equipo y presioná la tecla Shift al arrancar, para obtener el menú Grub. Utilizá las flechas del teclado para navegar / resaltar la entrada que corresponda a Ubuntu (generalmente la primera).

2.- Pulsá la tecla e para editar la entrada, lo que mostrará la información detallada del arranque:

3.- Buscá la entrada como se muestra en la captura de arriba. Utilizá las  flechas del teclado para llegar a ella, y luego oprimí la tecla Fin (End) para ir al final de la línea (que puede ser en la siguiente línea, paradójicamente).

Introducí la palabra nomodeset como se muestra en la captura y presioná Ctrl + X para iniciar el sistema.

Si todo va bien, el sistema va a arrancar sin problemas y vas a poder instalar los drivers privativos.


usemoslinux

usemoslinux: Free software advocate. Fundé el blog Usemos Linux en 2010, convirtiéndose rápidamente en uno de los 2 sitios más populares sobre la materia. En 2013 decidí unir esfuerzos y fusionar el blog con Desde Linux.


45 comentarios en “[Solucionado] Ubuntu se cuelga al inicio: pantalla negra/violeta de la muerte

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Current ye@r *

  1. Recien ahora me avisas jaja muy buena la solucion si es que anda, me canse de instalar Ubuntu 12.04, mil drivers privativos bajados de la pagina de AMD para mi tarjeta de video Radeon HD 6550M.. y siempre al reiniciar volvia a la pantalla violeta.. Termine instalando Xubuntu 12.04 y los drivers privativos ahi y funcionan perfecto.. Igual gracias por la solucion!

    1/45
  2. La idea es despues de instalar ubuntu, reiniciar y pasar al modo nomodeset, una vez iniciado en ese modo instalar los drivers y luego reiniciar?

    2/45
  3. UnknownUnknown
    Gaius Baltar

    Es normal cuando tienes gráfica integrada + dedicada, también pasa en Debian y puede provocar que no arranque el monitor. Desactivar la integrada en la BIOS también soluciona casos parecidos. ‘nomodeset’ mola, hay que conocerselo. ^^

    3/45
  4. veo que es ubuntu 12.04 por que el kernel es 3.2, el de raring ringtail es 3.8, a mi me dio problemas 12.04 con la nvidia GT520 pero con las siguientes versiones no deberia pasar, de hecho estoy en 12.10 con los drivers propietarios y tan ricamente cosa en la que la LTS no daba la talla

    4/45
  5. No me funciono :s
    Segui tal cual tu guia y nada… me sigue apareciendo la pantalla negra y despues entra a ubuntu pero sin el decorador de ventanas ni unity ni la barra.
    Tengo una Acer Aspire Z3101 Nvidia Gt520 Ubuntu 13.04

    5/45
  6. UnknownUnknown
    Gaius Baltar

    Si llegas a entrar a Ubuntu es problema del driver. Con los anteriores drivers de mi ATIHD4330 me cascaba la decoración del escritorio, quedándome sin Unity y sin bordes de ventana.

    Si tienes el archivo /etc/X11/xorg.conf, asigna controlador VESA (en vez de nvidia) e intenta instalar el driver de NVIDIA desde la configuración del sistema. También puedes probar con ‘nouveau’ o, directamente, borrar el archivo xorg.conf

    (Puedo equivocarme, estoy frío en el tema de drivers gráficos desde el nuevo amd-legacy, pero antes sufrí mucho con el fokin ‘fglrx’ de ati)

    6/45
  7. Yo mas bien tengo el problema alrevez, el driver libre me funciona bien, pero cuando instalo el privativo se pone la pantalla en negro y usualmente tengo que formatear de nuevo. Esto aplica para cualquier distro de las que he usado (ubuntu 12.10, 13.04, eOS con kernel 3.8, manjaro, chakra, etc), y deberia de funcionar, pues el downgrade al xorg lo suele hacer bien.
    Lo que es cierto es que en mi radeon hd 4200 solo puedo usar el driver libre :( , adios a una mejor experiencia en steam

    7/45
    • Google Chrome 28.0.1500.95Windows 8 x64 EditionMetro
      Juan Antonio

      A mi me paso lo mismo que a ti. Tenia el driver libre y al pasar al privativo me quedo con la pantalla en negro… que puedo hacer?
      Gracias!

      9/45
  8. Firefox 22.0Ubuntu
    hernando sanchez

    Con Mageia sucede algo parecido, serà posible solucionarlo de èsta manera?
    Ojalà, gracias por èsta interesante informaciòn.

    8/45
  9. A mi me ocurría lo mismo luego de instalar una actualización en Ubuntu 12.04, funciona a la perfección gracias.

    10/45
  10. Firefox 24.0Windows 8Metro
    Nilzer Camacho Alvarez

    Buenas a todos, una vez cambiado a NOMODESET y apretar control X. me da da dos opciones de apretar la tecla S y M (el ultimo manual recovery) y ahi que acciones tengo que realizar. Saludos y gracias

    Estoy con ubuntu 13.04

    11/45
  11. Me funciono perfecto, gracias

    12/45
  12. hice eso de nomodeset y no resulta.. muestra un monton de parametros pero sigo sin poder iniciar ubuntu.. me sigue apareciendo y desapareciendo la imagen en negro y con el cursor

    13/45
  13. Normalmente esto es un problema de gestión de energía, yo lo solucioné así: Cambia el parametro “quiet splash” por “nolapic” acuérdate de guardar los cambios. Te puedes ayudar del programa grub customizer, el cual no viene en los repositorios.

    14/45
  14. Hola

    ¿otra forma de llegar al grub?

    El mío, 13.10, presionando shift no va, carga como siempre y vuelve al estado catatónico.

    15/45
    • Firefox 25.0Ubuntu x64
      ALEJANDRO DE ALBA

      Yo estoy en las mismas, la tecla shift no funciona

      16/45
      • Amigos: les dejo este link del wiki oficial de Ubuntu donde dice que el shift debería funcionar. En caso de no ser así, tal vez el GRUB no se instaló correctamente. La única solución que se me ocurre es utilizar un disco de instalación de Ubuntu, arrancar desde ahí y luego volver a instalar o configurar grub desde ahí.

        https://wiki.ubuntu.com/RecoveryMode

        Abrazo! Pablo.

        17/45
  15. Hola a todos mi ubuntu actualizo a 13.04 y ahora al actualizar a 13.10 se me queda colgado al iniciar con la pantalla en negro justo después de pasar por grub. Siendo el único modo de iniciar seleccionando un modo de inicio 3.2

    18/45
  16. ahhh muchas gracias primera ves que me sucede lo de la pantalla negra!!! es KAOTICA!!! JAJAJA me funciono cambiando “quiet splash” por nolapic

    19/45
  17. que vercion de ubuntu es esa lo intente con mi 13.10 y no funciono

    20/45
  18. Muchisimas Gracias!!!

    Habia tenido 2 dias con el mismo problema…

    Saludos desde Mexico!

    21/45
  19. Muchas gracias amigo de mucha ayuda tu post

    23/45
  20. buena tarde veran instale ubuntu 13.04 en mi pc que tenia windows 7 pero ahora en el inicio se me queda trabada no m aparece el grub ni nada decidi sacar el disco duro y eliminar toda particion en fin empesar de 0 pero m sigue tirando la misma pantalla negra y ahi se queda trabada me podrian decir que hacer!!

    24/45
  21. oyes carnala ya intente estoo de tu tutorial y noo pasanada no corre el ubuntu s se cuelga una pantalla negra con un texto prese que esd elnombre de mi targeta mdre jaja nose sipme pudieras hecharlamano cone sto ya me canse de buscar tengo una targeta de video nvidia plis helpmee ya intente muchas cosas y nooo sepuede solucionar el problemaaa aaaaaa

    25/45
  22. Android Webkit 4.0Android 4.0.4
    miguel angel

    Alguien podria ayudarme por favor… instale ubuntu 13.10, actualize y reinicie el equipo… al notar q instalar software privativo puede ocasionar errores, segui los pasos de este post al pie de la letra… pero no funciono… al iniciar ubuntu me pide la contraseña, despues de ingresar la pantalla queda totalmente negra… la grafica q tengo es nvidia, y utilice estos comandos…

    NVIDIA:
    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get install nvidia-319 nvidia-settings-319

    Espero q me puedan ayudar… Gracias de antemano

    26/45
  23. Hola, me pasaba lo mismo de la pantalla negra… pero es cierto es problema del driver de la tarjeta de video… PERO ahora inicia, me pide el usuario, la contraseña y pasando ello aparece un mensaje de ABSOLUTELY NO WARRANTY y luego se queda en “nombreDEusuario@nombrePC:¬$”

    y se queda alli, volví a ingresar datos como mi superusuario, o el usuario y NADA…
    ¿qué hagó? – AYUDAMEeeeeee por favoooor al e-mail ramos.serruto@gmail.com

    27/45
  24. Me sucede algo parecido: actualicé a Ubuntu 13.10 y murio ahí. La solocion de nomodeset no me funcionó. Se puede realizar alguna acción desde el interprete de ordenes del grub? Saludos

    28/45
  25. Pero si tengo instalado windows 7 en una particion y ubuntu en otra, me seguira respetando el boot de windows?

    29/45
  26. hola no soy experto pero y un problema arranco el disco de ubuntu para su instalación aparece la primara pantalla donde aparece si quieres instalar la vercion de prueba y hay queda no ace nada preciono enter y no se inmuta que puedo hacer

    30/45
  27. Gracias.
    Me acaba de solucionar la papeleta al actualizar a Ubuntu 14.04

    31/45
  28. ayuda!! antes al iniciar tenia pocas letras y no me arrancaba pero hice esto y me sigue saliendo lo mismo pero con mas letras me sale appArmor profiles a lo siento la mala explicación pero es lo que me pasa que puedo hacer?

    32/45
  29. Me funcionó. Soy muuuuuuuuy principiante, soluciones como estas me salvan el pellejo. Saludos de Argentina

    33/45
  30. Que grande. Muy buena. Instale Ubuntu en la misma PC que lo tenia instalado en un disco anterior el cual caduco y empezo con este problema. Como no es de mi uso primario no le di mas bola hasta hoy. Que contento volver a usarlo jajaja. Muchas gracias.

    34/45
  31. Te digo que el problema no queda solo en el arranque en mi caso como el de otros amigos cuando están trabajando se pone negra la pantalla no queda otra que reiniciar. Tengo otros amigos que optaron por volver a 12.04 problema resuelto. Te podes imaginar que van a tener que resolver esto pues en ves de ir mejorando con las nuevas versiones terminan empeorando.Hay gente muy desconforme con este tema han perdido tiempo pues al reiniciar hay veces que se pierde el trabajo de algo que se venía haciendo.
    Pero no queda en eso pues se complica al tener que andar haciendo inventos en algo que se supone está mas que probado

    35/45
  32. hola buenas tardes…a me paso algo similar, pero al aparecer la pantalla violeta se colgaba y la reinicie tantas veces que llego un momento que la pantalla se puso negra, solo enciende los bombillitos led del teclado; el ventilador se oye funcionando…que puedo hacer??

    36/45
  33. se me cuelga en [ 0.279060] [firmware bug] : ACPI; BIOS _OSI(linux) query ignored

    como lo puedo solucionar?

    37/45
  34. Yo tengo la versión 14.04 y al momento de ingresar mi contraseña no carga nada.

    38/45
  35. Firefox 28.0Ubuntu x64
    jhoel galeano

    tengo instalado windows 7 he intentado instalar ubuntu 14.04 para trabajar con dos sistemas en una hp mini 110 4100 el problema es q no he podido lograr que inicie.. el se instala bien y cuando reinicio me muestra las opciones para que escoja con cual sistema iniciar, si escojo windows carga bien todo pero si escojo linux se queda colgado en una pantalla violeta…. no he podido hallar la respuesta a mi problema… ayudenme porque soy novato en linux, apenas estoy empezando a conocer e interactuar con este sistema…

    saludes….

    39/45
    • La solución que se recomienda en el post no te funcionó?
      De ser así, volvé a poner quiet splash y reemplazá donde dice $linuxgfxmode por nomodeset.
      La línea debería quedar gfxmode nomodeset
      Recordá guardar los cambios y reiniciar.
      Abrazo! Pablo.

      40/45
  36. Disculpa ¿cuales son los drivers privativos de los que hablas al final, y como los instalo? Soy nuevo en esto agradecere tu respuesta

    41/45
  37. GRacias.

    43/45
  38. Yo utilizo la versión 14.04 y después de introducir mi contraseña para iniciar sección se queda ahí.
    Ya probé todo lo anterior y nada me funcionó, siempre queda en la pantalla morada.

    45/45

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *

Puedes usar las siguientes etiquetas y atributos HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Current ye@r *