Chromium y Firefox Nightly: Sin actualizar en Launchpad o en Debian Backports

Saludos a todos de nuevo. En esta ocasión les vengo a hablar acerca de los navegadores Mozilla Firefox y Chromium, los cuales son Open Source y son usados tanto en Windows y Mac como en la mayor parte de las distros GNU/Linux (tanto las compilaciones oficiales como sus bifurcaciones).

Sin embargo, he notado que, a la hora de descargar el Mozilla Firefox desde el sitio web oficial, me topo con una versión comprimida en BZip en tarball y en el caso de Chromium, en formato ZIP.

Si bien en Mozilla Firefox y Chromium facilitan a los desarrolladores de distros que puedan empaquetar sus versiones estables a su manera, en el caso de Chromium hay un vago o nulo interés en ofrecer una versión por lo menos actual y decente como para poder disfrutarlo a plenitud (en el caso de Google Chrome, se nota que hay un gran interés en tener al día su navegador, pero con su contra-parte en open source hay un interés que deja mucho que desear).

Con Mozilla Firefox no tuve problemas a la hora de mantenerlo al día, puesto que casi todas las distros están al corriente con los lanzamientos que hace la Fundación Mozilla (hasta Debian actualiza con la misma frecuencia que su equivalente oficial su bifurcación), pero Chromium tiene algunas distros que no tienen una versión a la par que las versiones oficiales de Google Chrome, como es el caso de Debian (ni siquiera tiene un backport ni al menos un repo especial como lo tiene Iceweasel).

El caso de Ubuntu (obligatoriamente hay que agregar el repo de seguridad provista por Launchpad para poder así mantener al corriente tus paquetes y al parecer, se quedó en la versión 25 en todas las versiones incluso en Lucid), por lo que me decidí a usar un script hecho específicamente a instalar la versión nightly de Chromium de forma casi automatizada por parte de los usuarios del foro de Debian, ya que oficialmente no encuentro repos ni de Linux Mint que realmente estén actualizados de parte de la familia de Debian (en otras distros, están a la par de la versión estable de Google Chrome).

Si encontrase un repo en el cual mantuviese al día las versiones estables de Chromium (o al menos las nightly builds), le agradecería bastante la ayuda. Por ahora, seguiré usando el script para poder así trabajar con el nightly Build de Chromium (esa costumbre que acabo de importar cuando frecuentaba el uso de Windows).

Comparte para difundir

Si te ha gustado nuestro contenido ahora puedes ayudar a difundirlo en las redes sociales de manera sencilla usando los siguientes botones:

Envía
Pinea
Print

Categorías

Aplicaciones, GNU/Linux

Internauta de Perú que se siente seducido por el software libre y su difusión. Además de ser un entusiasta de distros de GNU/Linux estables como Slackware, Debian y/o CentOS. BOFH de eliotime.com

32 comentarios

  1.   elav dijo

    Pues es normal que no encuentres Firefox en Debian, pues aunque es OpenSource, posee partes (como el logo) con licencias restrictivas que no cumplen con los objetivos de Debian, de ahí que encuentres Iceweasel.

    En Squeeze no sé, pero en Debian Wheezy tenemos la última versión estable de Chromium con bastante prontitud. Ahora mismo está la versión: 26.0.1410.43-1.

    1.    eliotime3000 dijo

      No tengo problemas con Iceweasel en Debian Stable, ya que me funciona de igual forma como lo hace Firefox (su backport de mozilla.debian.net es la que uso para mantener al corriente el Iceweasel y está sincronizada con experimental), pero en Chromium es un problema tener que añadir una repo experimental en una versión estable de Debian (en Testing es como si estuviera añadiendo un backport).

      Ahora, si uno quiere usar la versión nightly build, tendría que hacer la misma hazaña que se usa a la hora de instalar Firefox (hacer un script para instalar/actualizar el navegador) y tener al menos la versión 3 del kernel (ya lo intenté usando la versión del kernel que me vino por defecto en mi PC, pero al parecer, funcionaría en Wheezy sin problemas).

      Con otros programas como LibreOffice, Skype y/o Angry IP Scanner me ha sido fácil la instalación, ya que no tenía que usar nada de script de instalación/actualización, sino tener que usar nada más ni nada menos que el DPKG y/o GDebi.

    2.    Anónimo dijo

      No he investigado motivos, pero me asombra que una versión de Chromium que si no me equivoco apenas fue liberada en Abril ya forme parte de la paquetería de Wheezy, mientras que Iceweasel 17 siendo de noviembre no. Ojalá no traiga problemas por ser tan reciente.

      1.    eliotime3000 dijo

        ¿A qué versión de Iceweasel te refieres? ¿A la rolling Release que está en mozilla.debian.net o a la ESR que se encuentra ya en el backport de Wheezy? Porque el Iceweasel que tengo es el 20 y lo tengo en mi Debian Squeeze: http://i.imgur.com/yavIei5.png (del backport de mozilla.debian.net porque el backport de Squeeze sigue en el 10 ESR).

        1.    Anónimo dijo

          A la versión por defecto para Wheezy que es la 10.0.12 tal y como lo es la 3.5.16 para Squeeze.

          http://packages.debian.org/wheezy/iceweasel

          Siempre pensé que sería bueno aceptar la versión 17.0 al salir pero no lo llegaron a hacer, la dejaron en experimental y en el backport para Squeeze de mozilla.debian.net.

          1.    eliotime3000 dijo

            Es una lástima, pero es válido usar el blackport de Debian Squeeze de mozilla.debian.net si no quieres arriesgarte a usar el repo experimental (de por sí la calidad de las repos es casi la misma, pero no te va a incluír repos de mala calidad).

  2.   sortega dijo

    Hay dos repositorios que mantienen Chromium actualizado, uno estable (versión 25.0.1364.172) y desarrollo (27.0.1453.6), los PPA respectivos son ppa:a-v-shkop/chromium y ppa:a-v-shkop/chromium-dev

    1.    eliotime3000 dijo

      Muchas gracias, pero prefiero agregar los PPA a la antigua (con el keyserver y editando el archivo “sources.list”). Así me evito problemas en los permisos administrativos y con el sudo (como que ya le agarré cariño al “su”, ¿no es así?).

  3.   rama dijo

    En debian la cosa es muy simple, si quieres permanecer en la rama estable, tienes que darte la idea de que los programas no van a estar en su version mas moderna. Ahora si quieres tener las ultimas versiones de los programas (o casi) usa testing o unstable 😉

    1.    eliotime3000 dijo

      Yo estoy contento con Debian Stable, porque apenas uso algunos programas que los mantengo al corriente (los navegadores y el skype, por supuesto). Pero en cuanto a Chromium, no han hecho ni un backport especialmente para la edición estable de Debian como sí lo hacen con Iceweasel (que por cierto, te da a elegir hasta la versión aurora y funciona con total normalidad en Debian Stable).

      En cuanto a la rama experimental, Debian Stable me pide su clave pública para poder usarla para cualquier programa específico.

      1.    tavo dijo

        Es que Debian en su versión estable es irrompible y esa seguridad que te da a través del tiempo hace que te cueste reemplazarlo.Este Debian Squeeze del cual escribo esta instalado desde se lanzó,ya varios años y hoy presentó la primer falla,mejor dicho,la falla fue mía .Resulta que por primera vez no arranca la gráfica por falta de espacio en el disco gdm no podía escribir entradas de registro.Lo solucioné borrando algunos paquetes de íconos y otras boludeces desde una tty ,luego reconfiguré todos los paquetes y arrancó de nuevo sin problemas.Me queda redimensionar el disco donde esta instalado el sistema ya que esta bastante ajustado,fuera de eso no dejo de asombrarme que luego de años sin mantenimiento funcione con la misma fluidez del primer dìa

        1.    eliotime3000 dijo

          Y por eso es que me gusta Debian: tantos años abandonado y un día lo prendes y sigue funcionando con normalidad.

  4.   diazepan dijo

    La versión más nueva de Chromium está en sid. La versión más nueva de Iceweasel está en experimental.

    1.    eliotime3000 dijo

      El problema no es con Iceweasel (menos mal que uso el backport de mozilla.debian.net que está a la par de la repo experimental con las versiones estable, beta y aurora), sino con Chromium, que no puedo agregar el repo experimental de Chromium porque precisamente estoy en stable (en testing se puede agregar sin problemas la repo ésta).

      1.    pandev92 dijo

        no cambia mucho la verdad entre usar la versión 17 o 18 de chromium y la 25…, y más tomando en cuenta que chromium no tiene el flash player pepper por defecto, así que pon el alma en paz, o descarga chrome desde su web

        1.    eliotime3000 dijo

          Ya uso Google Chrome para Linux, pero precisamente trabajo con ambos navegadores porque tengo dos cuentas de GMail.

          Además, en el Google Chrome le desactivé el Pepper Flash Player ya que era mucho menos fluído que el mismo Flash Player 11.2 que ofrece Adobe (menos mal que en los repos oficiales tenía un paquete .deb que tenía un script que bajaba e instalaba automáticamente el flash player).

  5.   rolo dijo

    convengamos que debian squeeze (la actual estable) dentro de tres dias va a pasar a ser oldstable por lo tanto no es logico que hayan actualizaciones de paquetes con nuevas versiones ni siquiera en backports.
    y es mas que probable que termine siendo mucho mas complejo seguir teniendo las versiones mas recientes de los programas como chromium y iceweasel, entre otros mas que nada cuando squeeze pase a los repos de archive.

    1.    eliotime3000 dijo

      Puede ser, pero en el sitio oficial de Debian no han anunciado nada oficial hasta el momento (por ahora son noticias que han sido rumoreadas en las listas de correo), pues tendría que estar publicado de manera oficial en su sección de noticias.

      1.    rolo dijo

        al final squeeze paso a ser oldstable como había comentado antes.
        Era muy evidente que no iban a seguir poniendo versiones mas actuales de los programas cuando estaban a punto de pasar a squeeze a archive.

  6.   Alf dijo

    Personalmente no es de mi interés ir con la última versión de los navegadores, porque los complementos y extensiones que algunos usamos no se desarrollan a la par, y cuando se actualiza el navegador quedan inutilizados los complementos.

    1.    Anónimo dijo

      Que bueno, pensaba que yo era el único loco por acá que prefería una ESR a una Rapid Release.

    2.    pandev92 dijo

      Eso generalmente solo pasa en firefox y su modo de extensiones primitivas.

      1.    eliotime3000 dijo

        Ni me digas, porque en el Chromium 25 que tengo, hay aplicaciones que no me aparecen si no tengo la versión que está a la par de Google Chrome.

      2.    msx dijo

        Firefox como Debian tienen su cuota de primitivismo, sin embargo en el caso particular de Firefox no creo que sea tan así.
        Más bien, pasa algo distinto: las extensiones de Chrome/Chromium son muy similares a las de Opera en cuanto a que permiten un subset muy definido partes del browser al que pueden acceder y están programadas en JS por eso es que pueden activarse y desactivarse al vuelo con tanta facilidad.
        En el caso de Firefox, por el contrario, las extensiones se programan haciendo uso del framework XUL propio de Firefox, por eso es que son tan potentes -de hecho son mini aplicaciones nativas- y al estar tan ligadas al browser, cualquier cambio nuevo en el navegador afecta a las extensiones instaladas.
        Saludos!

        1.    eliotime3000 dijo

          En Firefox/Iceweasel/IceCat van de maravillas si uno prescinde de las extensiones; en Chromium/Google Chrome, se tiene la facilidad de usar las extensiones sin tener que depender necesariamente de un framework en la mayoría de los casos.

    3.    eliotime3000 dijo

      Con Firefox/Iceweasel, se tiene la libertad de poder elegir una versión que te de un soporte extendido (caso de las ESR), pero en Chromium no sucede así.

      Uso Chromium más que todo para poder probar varios componentes que se añaden al HTML5/CSS3 y demás lenguajes web que están innovando. Si logran estandarizar esos lenguajes lo más pronto posible, no sería necesario depender de los rolling releases.

  7.   Jorge dijo

    Debian hace muchos años creo su fork de firefox, me acuerdo que hubo muchas quejas de esto, acusandolos de talibanes por un logo (tanto a los de mozilla como debian). Debian no es muy amigo de estar cambiando versiones “enteras” todos los meses, se hace hincapie en la estabilidad mas que tener lo ultimo. Es masomenos facil instalar y actualizar el paquete tar.bz2 de mozilla en debian y ubuntus descontinuados, solo hay que extraerlo a una carpeta de sistema y crear los accesos. Por si alguno lo necesita, dejo unas listas de comandos aqui http://paste.desdelinux.net/4767 para que lo hagan en una sola orden sin siquiera necesitar repositorios u otro navegador para descargar el paquete, Saludos

    1.    eliotime3000 dijo

      Muchas gracias por el script. De hecho, estoy usando Iceweasel 20 (versión que está a la par de Firefox) que obtuve de mozilla.debian.net y me está yendo de maravillas en mi Debian Stable.

      Además, el rendimiento entre Firefox y Iceweasel es prácticamente el mismo, la diferencia que tiene el Firefox oficial con el Firefox comunitario es que carece del actualizador que aparece en la ventana “Acerca de”, además que las bifurcaciones como Iceweasel y IceCat suelen tener uno que otro parche u otra modificación (el IceCat de GNU bloquea la ejecución del Flash Player y obliga a usar complementos libres como el Gnash, además de ser el IceWeasel original).

  8.   msx dijo

    Más pregunta de foro que post de blog.
    De hecho… ES pregunta de foro.

    1.    eliotime3000 dijo

      Perdóname por redactar en modo [foro][/foro], pero a veces no se hace hincapié en muchos aspectos como lo es la falta de homogeniedad en las versiones de Chromium (ahora casi todas las distros están en la versión 26, que es actualmente la versión oficial de Google Chrome), pero al menos Firefox y bifurcaciones están relativamente todas a la par (en el caso de Iceweasel, el backport de mozilla.debian.net está en la versión 20 en la versión oficial, así como en la 21 en beta y 22 en aurora).

  9.   Alf dijo

    Esto no es con el tema que se trata, pero tiene que ver con firefox

    http://muyseguridad.net/2013/05/03/mozilla-critica-al-productor-del-software-espia-gubernamental-finfisher/

    ¿Grave?

    1.    eliotime3000 dijo

      Al parecer, ésto que menciona va en contra de la filosofía de la Fundación Mozilla: un navegador discreto y respetuoso con tus hábitos de internet.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.