Instalar Shockwave Player nativo en Ubuntu y derivados

Introducción

Adobe Shockwave (o simplemente Shockwave) es un complemento para navegadores web que permite la reproducción de contenidos interactivos como juegos, presentaciones, aplicaciones de formación, etc, anteriormente llamado Macromedia Shockwave.

Al realizar búsquedas en Internet no logré encontrar resultados convincentes que me permitieran tener todo en 1 solo navegador ya que las propuestas era instalar Wine y luego la versión de Firefox para Windows (suena asqueroso lo se, pero así es), así que me tope con algo que no he visto escrito en ningún lado.

¿Como instalarlo?

Sencillo, para realizar la instalación en Ubuntu y derivados se procede desde una terminal a instalar desde repositorios externos un paquete llamado “Pipelight“. Para ello desde una terminal ejecutamos los siguientes comandos:

sudo add-apt-repository ppa:pipelight/stable
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi
sudo pipelight-plugin --update

Habilitar Plugin

Para habilitar Shockwave en los navegadores web, procedemos con los siguientes comandos en una terminal:

sudo pipelight-plugin --unlock shockwave
sudo pipelight-plugin --enable shockwave
sudo pipelight-plugin --create-mozilla-plugins
Ya tenemos Shockwave Player Instalado totalmente funcional

Para checkar que está todo bien hecho… abrimos por ejemplo Firefox y nos vamos al apartado de “Plugins” dentro de Complementos (Add-ons) y nos fijamos si se encuentra Habilitado:

Y si deseamos probar si funciona… nos dirigimos al website oficial donde podemos realizar la prueba. Accediendo a través del siguiente botón:

Probar Shockwave Player

Y para usar Shockwave hacemos click en:


16 comentarios

  1.   Jorgicio dijo

    Es bueno saber eso, pero no seamos discriminatorios con los que tenemos otros navegadores, como Chrome. ¿Cómo sería en este caso? :/

    1.    lozanotux dijo

      Jorge, de por si PIPELIGHT trabaja con Chrome y Chromium la única diferencia es para los que usan Firefox, siempre incluir la linea de “–create-mozilla-plugins” para que se instalen en dicho navegador.

      No tuve posibilidad de probarlo en Chrome, si tenes problemas avisa y hacemos un seguimiento de eso y averiguo como hacerlo andar (que de seguro sea un comando parecido al de Firefox) 🙂

      Gracias y Suerte!

      1.    Jorgicio dijo

        Acabo de averiguar, que el plugin tiene soporte NPAPI, el cual fue descontinuado en Chrome/Chromium desde la release 34. No funcionará, entonces.

        Gracias, igual.

      2.    Roque Jose dijo

        En Chrome usa otro plugin integrado, no es necesario cargar nada. Chromium se quedó sin soporte para Flash,y Firefox lo dejará próximamente también.

  2.   cristian dijo

    hace años que no veo nada que utilice shockwave #elaporte

    1.    anonimo dijo

      Yo no entiendo porque aún insiste la gente y las distros de poner en sus repositorios paquetes binarios cerrados que subren bugs con escalamiento de privilegios dos veces a la semana.
      Todo esto pudiendo instalarlo en el home del usuario sin darle permisos de root al único cancer del que aún (desgraciadamente) necesitamos.

      Se van a la página de descarga de flashplayer:
      https://get.adobe.com/es/flashplayer/
      Descargan el tar.gz para otro Linux, lo descomprimen, crean la carpeta plugins dentro de su carpeta oculta mozilla en su home
      $ mkdir -p .mozilla/plugins
      y copian el archivo libflashplayer.so dentro de la carpeta plugins.
      Eso es todo….sin darle permisos de root a esa sarna.

      1.    anonimo dijo

        Bueno, creo que me he equivocado, no era flashplayer…eso pasa cuando uno va apurado y no lee detenidamente.
        Pero a lo mejor funciona mi forma para este shockwave, tendría que hacer la prueba.
        Disculpen por el ruido y mi confusión entre plugins.

      2.    ZombieAlive dijo

        Eso es lo mas acertado que he escuchado, las distros solo tienen que tener lo básico y lo fundamental que funcione con el sistema. La mejor manera de aplicaciones de usuario es que esten en home. Que existan instaladores como el de Steam o de muchas mas apps que instalan todo en el home.

  3.   joaco dijo

    Nah, genial, al fin existe una forma de instalarlo. Lástima que uso fedora, ¿habrá alguna forma de hacerlo ahí?

    1.    lozanotux dijo

      No me simpatiza este blog… no me deja poner mi comentario porque es teoricamenet “spam” que bronca me generó esto :/

      Bueno, respecto a instalarlo en Fedora… guiate con este link 😉
      http://pipelight.net/cms/install/installation-fedora.html

  4.   sinnerman dijo

    QUÈ BIEN SABERLO!!! 🙂
    …pero alguien usa aun shockwave????

  5.   dmrx912 dijo

    En debian no actualiza ese repositorio. No se puede acceder a el. Hay alguna otra forma de hacerlo.

  6.   UNOWOS dijo

    Soy un incondicional de esta pagina (y de cuando era “usemos linux”).
    Agradezco mucho este tipo de articulos. No soy purista, pero procuro.
    Es cierto que es una historia estar al dia con paquetes cerrados, pero, me parece interesante que se pueda abrir puertas cerradas (como flash y su anticuado 11.2 de linux) y poder tener el 17.0.

    No comento nunca, pero hoy creo que me han motivado a comentar.
    Gracias por vuestro incondicional aporte a la web.

  7.   foton dijo

    hola
    lo instale y no paso nada sigue sin andar el pluguin director.
    tengo instalado el shockwave, libfreshwrapper-pepperflash.so
    sera que lo tengo que desintaslar?

  8.   victor dijo

    no me funciono como hago para deshacer todo lo que instale siguiendo los pasos que me diste gracias

  9.   Camilo dijo

    Hola
    he probado en un portatil acer con xubuntu 14.04 en esta página
    https://www.pixton.com/es/create/comic/pkumvwa7
    y en la de prueba del blog, pero no me ha resultado.
    version de firefox
    ii firefox 49.0.2+build2-0ubuntu0.14.04.1 amd64 Safe and easy web browser from Mozilla
    🙁 lástima estaba interesado en este tema, llevamos un centro educativo y muchos alumnos usan esta web…
    ¿qué mirar?

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

  1. Responsable de los datos: Miguel Ángel Gatón
  2. Finalidad de los datos: Controlar el SPAM, gestión de comentarios.
  3. Legitimación: Tu consentimiento
  4. Comunicación de los datos: No se comunicarán los datos a terceros salvo por obligación legal.
  5. Almacenamiento de los datos: Base de datos alojada en Occentus Networks (UE)
  6. Derechos: En cualquier momento puedes limitar, recuperar y borrar tu información.