FlashPlayer和Firefox 21+有問題嗎? 這裡的解決方案

眾所周知,我使用 Debian的,並安裝 火狐 我出於以下多種原因手動進行操作 這一步.

碰巧隨著 火狐21, Flash播放器 開始出現問題,而不是錯誤,但是瀏覽器找不到它。

通常,您可以按照Firefox中的說明使用FlashPlayer 本文。 但現在不再。

這是因為 火狐21,該文件夾不再使用 〜/ .mozilla /插件/ 對於FlashPlayer,但路徑已更改。 現在文件夾 插件 它位於安裝目錄中 火狐.

例如,就我而言,當我解壓縮 名為.tar.gz,我複製文件夾 火狐 en 〜/ .local / apps /,因此現在要執行的步驟如下:

1-我下載了最新版本的 Flash播放器64位:

cd ~
$ wget http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.202.285/install_flash_player_11_linux.x86_64.tar.gz

2-我解壓縮.tar.gz:

$ tar xfv install_flash_player_11_linux.x86_64.tar.gz

這將提取2個文件和一個文件夾:

  • README.TXT
  • libflashplayer.so
  • 的usr /

4-我們創建文件夾 插件 在安裝Firefox的目錄中,對於我來說是:

$ mkdir ~/.local/apps/firefox/plugins

在某些論壇中,我看到plugins文件夾如果在該路徑下不起作用,則必須位於 〜/ .local / apps / firefox /瀏覽器/插件

為了使這個沒有問題,我們創建一個符號鏈接:

$ ln -s ~/.local/apps/firefox/plugins ~/.local/apps/firefox/browser/plugins

5-我們複製文件 libflashplayer.so:

$ cp libflashplayer.so ~/.local/apps/firefox/plugins

6-我們複製文件夾的內容 在/ usr  到目錄 在/ usr:

$ sudo cp -Rv usr/* /usr

這應該足夠了。 如果由於某種原因它仍然不起作用,我們打開一個新標籤頁,輸入 about:config中 然後尋找參數:

plugins.load_appdir_plugins

如果在 我們把它放進去 .

準備。 按照這些步驟操作,儘管我幾乎不使用它,但我已經讓FlashPlayer再次工作了😛


本文內容遵循我們的原則 編輯倫理。 要報告錯誤,請單擊 這裡.

30條評論,留下您的評論

發表您的評論

您的電子郵件地址將不會被發表。 必填字段標有 *

*

*

  1. 負責數據:MiguelÁngelGatón
  2. 數據用途:控制垃圾郵件,註釋管理。
  3. 合法性:您的同意
  4. 數據通訊:除非有法律義務,否則不會將數據傳達給第三方。
  5. 數據存儲:Occentus Networks(EU)託管的數據庫
  6. 權利:您可以隨時限制,恢復和刪除您的信息。

  1.   其中之一 他說:

    嗯,在flashplayer-nonfree軟件包中使用iceweasel 21有什麼問題?

    歸根結底,它是具有Debian風格的Firefox 21,這樣就沒有問題了。

    1.    eliotime3000 他說:

      您會說flashplugin-nonfree。

      在iceweasel中沒有問題。

      1.    其中之一 他說:

        的確是鍋丟了我哈哈哈。

  2.   eliotime3000 他說:

    Dafuq?!
    我使用Debian在contrib存儲庫中使用的腳本安裝了Flash Player,到目前為止,我對Flash Player沒有任何問題。

    無論如何,借助Iveweasel,Flash Player可以創造奇蹟

  3.   阿努比斯_linux 他說:

    在Chrome中不會發生這種情況,這就是為什麼我非常喜歡

    1.    pandev92 他說:

      鍍鉻閃光燈太可怕了...

      1.    加托 他說:

        我支持

        1.    克洛斯 他說:

          我也同意。

      2.    eliotime3000 他說:

        我也是,這就是為什麼我要去做:插件並停用Pepper Flash Player,並使Flash Player處於活動狀態。

    2.    衣架 他說:

      我使用了chrome,因為閃光燈對我來說要好得多,但是在最近一次更新(我很忙)中,它開始出現故障。
      至少我最終將規模擴大到iceweasel(通過youtube html5測試,我做得很好)

  4.   eliotime3000 他說:

    在YouTube上觀看視頻時,谷歌瀏覽器的胡椒閃光很沉重,因此我更喜歡使用Chromium而不是谷歌瀏覽器使用一千次(它集成的插件本身很沉重,並且會降低瀏覽器的性能)。

  5.   eliotime3000 他說:

    並添加了flashplugin-nonfree只是一個腳本,該腳本根據已安裝的體系結構將adobe.com中的Flash播放器下載到Debian。

    無論如何,最大的好處是如何手動安裝Flash Player(我嘗試使用firefox 21,並且從Debian腳本安裝Flash Player沒問題。

  6.   亞倫 他說:

    奇怪的是,當我從firefox 20更新到21時,在fedora中沒有發生這種情況,但是現在我使用GNOME Web,其3.8版支持flash,所以我沒有這個問題,我邀請您嘗試一下,很快

  7.   像誰 他說:

    那麼這個問題僅適用於Debian嗎? 因為我沒問題

    1.    像誰 他說:

      我使用Chromium,而不是GC x)

      1.    eliotime3000 他說:

        我相信您,因為我也使用Chromium(適用於Windows的每晚版本),而且許多發行版都無需費心修改Chromium User Agent(默認情況下,Chrome用戶代理始終使用chrome,因為它是Google Chrome的實驗版)本身)。

  8.   塔沃 他說:

    即使在此版本21中,我也始終將其安裝在/ usr / lib / mozilla / plugins中……我澄清說我使用iceweasel

    1.    eliotime3000 他說:

      我比較懶惰,因為我使用了Debian倉庫的contrib分支中的“ flashplugin-nonfree”軟件包,而且我直接從Adobe下載了Flash Player,可以在所有瀏覽器中使用。

  9.   Eldebiandepepe 他說:

    如果您使用的是32位計算機,則在/ usr / lib / mozilla / plugins /中復製文件“ libflashplayer.so”應該就足夠了……我想在64位計算機上是相同的,但是如果我沒記錯,在西班牙語的debian列表中,我讀到有人在Wheeze中安裝了Flash與後者有問題……我不知道,這只是看一下問題。

    1.    eliotime3000 他說:

      我通過官方Debian存儲庫中的“ flashplugin-nonfree”軟件包安裝了Adobe Flash Player(特別是在contrib中)。 如果遇到問題,我沒有問題,可能是手動安裝時沒有使用所有瀏覽器(包括Mozilla Firefox)使用的目錄。

      無論如何,我在Iceweasel和Firefox中都沒有安裝Flash Player的問題。

  10.   馬里奧 他說:

    在firefox 21中,對tar.bz2中的文件進行了重新排序。 創建了瀏覽器文件夾,現在«chrome»文件夾(不要與瀏覽器混淆)和諸如mozicon128.png之類的文件將其位置更改為該文件夾中的位置……顯然可能存在問題(我的快捷方式今天早上沒有圖標) :P)。 將可執行文件放入.local仍然很奇怪...我閱讀的教程幾乎總是指向/ opt和ubuntu指向/ usr / lib,這可能是導致錯誤的原因,因為插件始終會通過lib

  11.   sieg84 他說:

    好吧,在Fedora和openSUSE中,我沒有任何問題。

  12.   彼得切科 他說:

    這很有趣,因為我的Firefox 21上的Flash沒有任何問題。
    特別地,我使用Debian倉庫中可用的軟件包:

    衝擊波閃光11.2.202.285
    Icedtea-web插件1.3.2

    Firefox我可以很容易地安裝它:

    我下載了軟件包,解壓縮並將內容複製到/ opt。 然後,我創建從/ opt / firefox / firefox到usr / bin / firefox的符號鏈接,並在KDE菜單中創建啟動器,就是這樣🙂

    1.    eliotime3000 他說:

      我在Debian上安裝“ flashplugin-nonfree”沒有問題,因為使用Flash Player時,使用Iceweasel和Chromium沒問題。

      讓我們看看使用OpenJDK和IcedTea是否可以通過keepvid.com下載視頻有用

      1.    eliotime3000 他說:

        題外話:

        在ZPanel安裝中,我犯了一個嚴重的錯誤,就是沒有激活Web服務器,SQL Server,DNS服務器,文件服務器,郵件服務器和ssh服務器選項,因為如果安裝了這些組件(apache,MariaDB .. 。)並在虛擬機中進行仿真時,必須使用網橋適配器才能進入面板,而不必承受後續的後果(就像我的情況一樣)。

        1.    eliotime3000 他說:

          PS:安裝PHP,否則請下載不帶擴展名的文件。 做吧

  13.   喬尼127 他說:

    好吧,我不太了解,我在wheezy上手動安裝了我的firefox / opt,並且從存儲庫中安裝了flashplugin-nonfree,更新到firefox 21之後,一切都很完美。

  14.   胡安庫約 他說:

    我不知道為什麼這麼頻繁地更新所有東西的狂熱,自7年以來我就安裝了Nero 2006,VLC對我來說作用非凡...直到我對其進行更新,現在時不時地告訴我它無法找到RML(或類似的東西),就不能打開DVD。 每天我都對更新感到憤怒。 Firefox中的Yoono現在是子彈頭了,我不知道為什麼我必須如此頻繁地重新加載用戶。 以防萬一Thunderbird和Firefox無法更新它們或在地獄中。 我期待安裝Debian 7(我必須購買另一台HD)並擁有所有免費軟件,並且多年來不會更新……。

    1.    喬尼127 他說:

      伙計,如果您不總是更新到最新的穩定的debian,它可能派上用場,甚至派上用場。 但是擁有更新的軟件可以為您提供新功能,據稱可以提高性能,支持新功能,並提供錯誤修復,對於我而言,後者對我來說非常重要,無論是在一般情況下還是非常重要。

      例如,您不必在錄製軟件中擁有確切的最新版本,因為對於您來說,對於您而言,該版本對您而言是好事,但對於我來說,甚至對於vlc而言似乎都不重要,但對於其他類型的軟件(例如網絡瀏覽器,這一點很重要。