Basiese programmering met pseint (deel 3)

Dit is 'n voortsetting van die tutoriaal Basiese programmering met pseint (deel 2), hierdie keer sal ek verduidelik wat nodig is om te programmeer.

OPDRAG

Die opdrag is 'n proses waarin 'n veranderlike geskep en / of gewysig word, met verwysing daarna deur middel van die identifiseerder waarmee ons toegang tot die geheuespasie kan kry.

die sintaksis van die opdrag is:

[variable]<- [expresion];
[variable]=[expresion];

Waar [veranderlike] die veranderlike is wat die waarde van evaluering [uitdrukking] ontvang. Albei is geldig, dus dit maak nie saak watter een gebruik word nie (as hulle PSeInt korrek ingestel het), maar volgens my skep ek die eerste een as die regte een.

As [veranderlike] nie voor die opdrag bestaan ​​het nie, is [veranderlike] geskep, indien dit bestaan, word die vorige waarde vernietig en die nuwe op sy plek geplaas. Om hierdie rede word kartering as 'n vernietigende operasie beskou.

LEES

Lees is die proses waarin die gebruiker gevra word vir data of data om genoemde data in 'n veranderlike op te slaan.

die sintaksis daarvan is:

Leer variable_1,variable_2,...,variable_n;

waar [veranderlike_ {1,2, n}] die veranderlike of veranderlikes is wat die waarde ontvang wat deur die gebruiker gegee word, indien meer as een veranderlike gevra word, sal dit eers die eerste vra, dan die tweede, ensovoorts tot al die waardes ontvang het.

Dit is ook 'n vernietigende funksie.

SKRYF

Skryf is die proses waarin 'n string karakters en / of een of meer veranderlikes op die skerm geskryf word

die sintaksis is:

Escribir expresion_1,expresion_2,...,expresion_n;

waar [ekspersie_ {1,2, n}] die karakterstringe en / of veranderlikes is wat vertoon sal word.

Skryfwerk behalwe om die gegewens wat op die skerm geplaas moet word, te ontvang, ontvang ook die opdrag "Sonder om oor te slaan" of "Sonder om af te gaan" wat die lynprong vermy.

Skryf voeg nie spasies tussen die argumente by nie, dit wil sê as u dit stel:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

in hierdie geval sal dit «olamundo» toon, aangesien daar tussen «a» en «b» geen tekenreeks is wat die spasie tussen a en b aandui nie, sodat dit korrek vertoon word, soos volg:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

voeg in hierdie geval »» toe, wat 'n tekenreeks is wat 'n spasie het wat die ruimte tussen «golf» en «wêreld» is en dan sal dit «golfwêreld» met die spasie wys.

AS DAN

Dit is 'n stelling wat 'n gegewe voorwaarde evalueer en die waarheid en / of valsheid van die voorwaarde nagaan, dit wil sê as daar aan die voorwaarde voldoen word of nie.

Die sintaksis is:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Die "anders" -klousule is nie verpligtend nie. In hierdie geval, as die voorwaarde vals is, ignoreer u die instruksies en gaan voort asof die vonnis nie bestaan ​​nie, in hierdie geval sal dit bly:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Of die "mislukking" -klousule geplaas is of nie, hang af van die behoeftes van die program.

VOLGENS

Die sin aangesien dit 'n streng numeriese veranderlike evalueer wat meer as 2 opsies as 'n opsie gee, is dit die verskil van "As-dan", aangesien die vorige slegs 2 opsies kan gee.

Die sintaksis is:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Soos u kan sien na "getal1" is daar 'n ":" en daarna word die instruksies wat uitgevoer moet word, geplaas in die geval dat "numeriese veranderlike = getal1", in die tweede voorbeeld "getal2, getal3" is, beteken dit dat indien " numeriese veranderlike = getal2 of getal3 "dan sal" instruksies "uitgevoer word, dit is handig wanneer twee moontlikhede dieselfde instruksies moet uitvoer.

Daar is ook die klousule "Op 'n ander manier" wat uitgevoer word indien geen van die moontlikhede vervul word nie.

TERWYL

Dit is 'n herhalende funksie wat eers 'n voorwaarde evalueer. As dit dan vervul word, voer dit 'n reeks instruksies uit, dan evalueer dit die voorwaarde, en as dit waar is, voer dit weer dieselfde instruksies uit en gaan dit voort totdat die voorwaarde onwaar is.

as die voorwaarde van die begin af vals is, sal dit nooit uitgevoer word nie en as dit altyd waar is, sal dit in 'n oneindige lus geplaas word. Om die laaste in die instruksies te vermy, moet daar iets wees wat die voorwaarde op een of ander tyd vervals om die lus te kan beëindig.

die sintaksis daarvan is:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

HERHAL-TOT

Dit is 'n funksie wat baie ooreenstem met die vorige, maar in teenstelling met die vorige, kyk hierdie een die toestand aan die einde, dit wil sê dat die opdrag ten minste een keer uitgevoer gaan word, ook in plaas daarvan om die instruksie uit te voer as dit waar is, voer dit uit terwyl dit As daar nie aan die voorwaarde voldoen word nie, maar as u wil hê dit moet uitgevoer word terwyl daar aan die voorwaarde voldoen word, gebruik dan "while" in plaas van "tot".

die sintaksis daarvan is:

Repetir
[Instrucciones] hasta que [condicion]

VIR

Hierdie stelling voer 'n opdrag 'n aantal kere uit vir 'n veranderlike, anders as die vorige, verander hierdie siklus die waarde van die betrokke veranderlike op sigself, sowel as 'n baie kragtige sintaksis.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"Veranderlik" is die veranderlike wat "aanvanklike waarde" ontvang en die instruksies uitvoer, voeg dan "veranderlike" plus "stap" toe en voer die instruksies weer uit totdat "veranderlike" gelyk is aan "finale waarde".

As "met [stap]" verwyder word, sal dit by verstek weet dat "stap" gelyk is aan 1, ook as [stap] nie gespesifiseer word nie en "aanvanklike waarde" groter is as "finale waarde", gaan dit in omgekeerde volgorde, dit wil sê "Stap" is -1

ONDERWERP / FUNKSIE

'N Draad of funksie is 'n program binne 'n ander en dat hierdie subprogram een ​​of meer waardes ontvang, dit gebruik en 'n ander terugstuur. Die sintaksis daarvan is

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

waar "terugkeer veranderlike" die veranderlike is wat die waarde bevat wat teruggestuur word deur die funksie "funksienaam" wat die parameters "arg_1, arg_2, arg_n" ontvang het om dit uit te voer

ANDER

Dit is funksies wat slegs aanvullend is tot die ander en nie 'n ingewikkelde sintaksis het nie, aangesien dit slegs aanvullende funksies is.

Vee skerm uit

Hierdie funksie maak die skerm skoon van enige voorwerp in die tolk

Wag sleutel

Hierdie funksie wag vir die gebruiker om op 'n sleutel te druk om met die program voort te gaan

verwag x {Tweedens, millisekondes}

hierdie funksie wag 'n tyd in sekondes of millisekondes om met die program voort te gaan

PS: jammer vir die vertraging, maar ek was besig met ander sake, so ek kon nie skryf nie


Die inhoud van die artikel voldoen aan ons beginsels van redaksionele etiek. Klik op om 'n fout te rapporteer hier.

10 kommentaar, los joune

Laat u kommentaar

Jou e-posadres sal nie gepubliseer word nie. Verpligte velde gemerk met *

*

*

  1. Verantwoordelik vir die data: Miguel Ángel Gatón
  2. Doel van die data: Beheer SPAM, bestuur van kommentaar.
  3. Wettiging: U toestemming
  4. Kommunikasie van die data: Die data sal nie aan derde partye oorgedra word nie, behalwe deur wettige verpligtinge.
  5. Datastoor: databasis aangebied deur Occentus Networks (EU)
  6. Regte: U kan u inligting te alle tye beperk, herstel en verwyder.

  1.   Guille dijo

    Het u nie funksies om sleutels vas te lê sonder om die uitvoering te stop nie? Om iets te doen met beweging wat meer aantreklik is vir 9-jariges, hoewel 'n hangman-speletjie ook lekker kan wees om te programmeer.

    Verwerk iets_digo
    a <-1;
    laterale <-30;
    af <-5;
    Terwyl a = 1 Doen
    Duidelike skerm;
    c <-1;
    reël <- "";
    herhaling
    reël <-lyn + "";
    c <-c + 1;
    Tot c = lateraal
    lyn <-lyn + "X";
    c <-1;
    herhaling
    Om te skryf " ";
    c <-c + 1;
    Tot c = down-1
    Skryf reël;
    herhaling
    Om te skryf " ";
    c 2 Dan
    af <-af-1;
    Eindig ja
    "s":
    As onder <15 Dan
    af 2 Dan
    laterale <-lateraal-1;
    Eindig ja
    "d":
    As lateraal <50 Dan
    laterale <-laterale + 1;
    Eindig ja
    "0":
    a <-2;
    Einde sekondes
    Einde terwyl
    Eindproses

  2.   Guille dijo

    Wel, misluk as u opgaan, verander lyntjies 23 en 28 beter
    -23 Tot c = 15
    +23 Tot c = 18
    y
    -28 As af> 2 Dan
    +28 As af> 3 Dan

    1.    xnmm dijo

      Dankie vir die bydrae, maar dit het probleme soos dat u die een sin binne die ander oopmaak, maar dit moet eindig binne die sin waar dit begin het, ek bedoel, dit kan nie gestel word nie

      Verwerk iets
      a <- 0;
      voorlees;
      as a nie gelyk is aan 25 nie, dan
      terwyl a nie gelyk is aan 0 doen nie
      voorlees;
      Eindig ja
      eindig terwyl

      terwyl u die lus sien terwyl u in die "as dan" -verklaring begin, maar daarbuite eindig, is so iets nie moontlik nie.

      Ek waardeer steeds die bydrae
      Beëindig proses

      1.    Guille dijo

        Dankie, maar ek dink dit is meer 'n probleem om die kode hier te plaas, ek weet nie hoe om dit in kodetipe te plaas nie en dit kom uit sonder inkeping.

        Die program werk goed. Die veranderlike "a" gebruik ek bloot om die lus te verlaat as die gebruiker 'n nul tik. U kan 'n uitgang () of 'n onderbreking maak; in die voorwaardelike kyk dit en ek stoor die veranderlike. Dit is opsies.

        Groete.

      2.    Guille dijo

        Ek sal probeer om oortjies vir spasies en etikette te verander por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Guille dijo

        Dit is vol invoerfoute uit my kode, ek sal weer probeer met die oortjies:
        Dit is die lêer algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Guille dijo

        Interessant dat die opmerking met kodetikette geëet, uitgevee word, wat ook al tussenin gaan, byvoorbeeld tussen reëls
        herhaling
        Om te skryf " ";
        c
        na die c is daar 'n
        en dan gaan dit voort met 3 Toe
        af
        Oor die algemeen is dit nie betroubaar om volgens watter kodes te stel nie.

  3.   Guille dijo

    Ek verander die simbole van toeken aan = om te sien hoe dit is.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Guille dijo

      Dit hou aan om 'n gedeelte van die kode te eet, die kodetiket mislukking, dit moet die skrif so laat.

      1.    xnmm dijo

        Hallo jammer dat ek nie gesien het dat jy voorheen geantwoord het nie, maar wel
        aangesien u die kode nie goed kan publiseer nie, omdat u dit nie per pos aan my stuur nie, sodat u nie soveel sake aan die saak gee nie.