LXDE-Qt: Unua kontakto

Unue estis PCManFM tiu, kiu portis Qt kaj ŝajne la programistoj de LXDE Ili ŝatis ĉi tiun kadron ĉar ili ĵus prezentis nin LXDE-Qt.

lxde-qt

Uzante la vortojn en la bloga afiŝo de LXDE, ĉe la fundo de la ekrano vi povas vidi lxpanel-qt, la Qt-haveno de lxpanelo kiu funkcias, sed bezonas iom pli poluradon. Ankaŭ ne ekzistas grafikaj agordiloj por agordi ĝin, do ni devos mane tuŝi xml-dosieron. Plej multaj ĉefaj aplikaĵoj jam funkcias.

Vi ankaŭ povas vidi en la bildo PCManFM-Qt, kiu aspektas tre simila al la originala versio de Gtk +. Tapetaj kaj labortablaj ikonoj ankaŭ estas administrataj de PCManFM-Qt.

Ili ankaŭ diras al ni en la blogo, ke la uzo de la memoro pri PCManFM-Qt ĝi estas iomete pli alta ol tiu de la versio 2 GTK +, sed la diferenco ne estas tre signifa. Entuta rendimento similas al la originala versio de Gtk + 2. Nun, kiam ĝi havas la plej multajn el la ecoj de la originalo, kaj preskaŭ pretas por ĉiutaga uzo.

Dekstre de la ekrano vi povas vidi LxImage-Qt, kiu estas konsiderata la posteulo de GPicView ĉar ĝi funkcias multe pli bone kaj estas pli rapide.

Bedaŭrinde ĉio, kion ili povis aprezi, troviĝas nur en la deponejoj LXDE Git, sed ili diras al ni, ke ĉi tio ne estas nur eksperimento, LXDE-Qt ĝi estos realaĵo.

Elfaro

Kiel oni diras al ni en la originala artikolo, la migrado al Qt kaŭzos etan pliiĝon de memora uzado kompare kun la versio Gtk2, sed la migrado al GTK + 3 ankaŭ kaŭzas similan pliiĝon de rimeduzado.

Ĉar Gtk2 ne plu estas subtenata de sia kreinto, kaj nun estas malrekomendata, migri al Qt ne estas malbona ideo nuntempe. Ankaŭ la iom pli alta memora uzado estas ankoraŭ akceptebla por plej multaj ekzistantaj maŝinoj.

La uzo de realaj rimedoj povas multe diferenci inter diversaj Linuksaj distribuoj - oni diras al ni en la eniro - ekzemple tiuj bazitaj sur ubuntu kurante LXDE emas uzi pli da memoro ol tiuj bazitaj sur archlinux.

Vi povas legi pli pri ĝi ĉe ĉi tiu ligilo.


La enhavo de la artikolo aliĝas al niaj principoj de redakcia etiko. Por raporti eraron alklaku Ĉi tie.

65 komentoj, lasu la viajn

Lasu vian komenton

Via retpoŝta adreso ne estos eldonita. Postulita kampojn estas markita per *

*

*

  1. Respondeculo pri la datumoj: Miguel Ángel Gatón
  2. Celo de la datumoj: Kontrola SPAM, administrado de komentoj.
  3. Legitimado: Via konsento
  4. Komunikado de la datumoj: La datumoj ne estos komunikitaj al triaj krom per laŭleĝa devo.
  5. Stokado de datumoj: Datumbazo gastigita de Occentus Networks (EU)
  6. Rajtoj: Iam ajn vi povas limigi, retrovi kaj forigi viajn informojn.

  1.   kronoj diris

    Mi ŝatas la ideon de LXDE-Qt, mi supozas, ke ni devos atendi iomete pli longe por ke la transiro estu tute matura por testi.

  2.   Leprulo_Ivan diris

    Mi pensas, ke LXDE estis inventita kiel pli malpeza alternativo al Gnome kaj KDE. Sed necesus vidi ĝis kiu punkto la konsumo preskaŭ samas kun la versio GTK +. La ideo allogas min .. Mi esperas baldaŭ povi provi ĝin por mi mem.

  3.   Pavloco diris

    Mia malseka sonĝo realiĝis. Se ili vendos ĝin, mi aĉetos ilin, se mi lasos la muson.

    1.    kato diris

      +1

  4.   diazepano diris

    Kompatinda XFCE, li estos sola ... tre soleca.

    1.    socarx diris

      Tiu, kiu restos sola, estas gnomo

  5.   Lolo diris

    Mi ne komprenas.

    Se la prezento estas la sama aŭ iomete pli alta ...

    Kio estas la signifo? Finfine, plej multaj aplikoj estas faritaj en GTK.

    1.    diazepano diris

      La problemo estas GTK2, kiu estas ĉesigita.

    2.    elav diris

      Efikeco estas iomete pli alta .. Sed Gtk2 ne plu estas subtenata, do Qt estas bona eblo, kiu estas konstante disvolvita.

    3.    malluma Purpura diris

      Nu, kun la plimulto de uzantoj uzantaj Qt (Unity, KDE, LXDE) pli da Qt-programoj aperos, tiu tendenco ŝanĝiĝos. Kaj ĉiuokaze vi povas uzi Gtk senprobleme ... Mi uzas Fajrovulpon, LibreOffice kaj iom pli en KDE kaj nenio okazis al mi.

      1.    izzyvp diris

        La ĉakro libreoffice ne havas dependecojn de GTK

        1.    malluma Purpura diris

          Mi scias, sed mi ne uzas Ĉakron.
          Mi uzis ĝin antaŭ kelka tempo kaj, se aferoj ne ŝanĝiĝis, eĉ se ili ne havas dependecojn de GTK, la vida integriĝo estas malbona. La mesaĝoj montrataj kiam vi lasas la kursoron sur butono ne legeblis ĉar ili estas nigraj literoj sur tre malhelgriza ... Jes, mi povus ŝanĝi la fonon sed ĝi tamen estas problemo.

          1.    malluma Purpura diris

            Venu, praktike tio ne supozas plibonigon. Se ili faros version kiu uzas Qt KAJ aspektas tia, tiam ĝi estus io alia.

    4.    vicky diris

      Kio okazas estas, ke gtk2 estas nuligita. Estas vere, ke gtk2 estas pli malpeza ol qt sed Gtk3 ne havas pli bonan rendimenton ol qt4 aŭ qt5, kaj ĉar vi devos fari la migradon ĉiuokaze kaj ke ekzistas kongruaj problemoj inter la malsamaj versioj de gtk3, mi pensas, ke tiuj de lxde ne estos la solaj, kiuj iros de gtk2 al qt (se mi bone memoras, openshot ankaŭ estis portita al qt5)

      Same, la lastan fojon, kiam mi provis pcmanfm-qt kaj lximage-qt ili bezonis gtk2 kiel dependeco (por libfm) se ili ankoraŭ bezonas ĝin, ĝi ne estus pura qt-labortablo.

  6.   kuketo diris

    Ĝi akvigis mian buŝon. Jes, mi forlasas la ronĝulon por ĉi tio.

  7.   kuketo diris

    Alia afero, ĉu ne estus bele, se vi kunigos fortojn kun RazorQT?
    La 2 montras al la sama kampo. Kvankam Razor estas jam tro progresinta por esti faligita de LXDE-QT.

  8.   nano diris

    Ŝajnas al mi sensacia, eble jes, kunigi fortojn kun razor-qt aŭ bone, sekvante ilian apartan vojon sed dividante aplikojn kiel PC-manfm kaj ilia disvolviĝo, longtempe estas afero por ĉiuj ... la vero estas ke kiel ĉi tio realiĝas kaj Lubuntu prenis ĝin, mi havos pli da bazo por uzi retlibron kaj ne devos elspezi tunojn por kajero (kiuj ĉi tie estas tre ŝveligitaj).

    Kialoj por ŝanĝi? jojo Kiom multaj ne? Vi devas vidi, kiel ĉi tiuj sinjoroj progresas kaj vidi kiom longe ili atingas!

    1.    truko22 diris

      Sonas esperiga 😀

  9.   Joj diris

    GTK-reguloj

    1.    KZKG ^ Gaara diris

      BEEEEEPPPP ... trolo detektita! ... LOL!

  10.   klaŭno diris

    Ĝi iomete memorigis min, kio estis KDE 3.1
    Eble kun la paso de la tempo LXDE finos esti tio, kio estis KDE 3.5, tre kompleta labortablo.

  11.   Putras87 diris

    uzi lxde-qt estus simila al uzi razor-qt ĉu ne?

  12.   elruiz1993 diris

    Kaj kial ne aliĝi al Razor? ambaŭ uzas OpenBox, ambaŭ en qt kaj ambaŭ faras simplan kaj tre malpezan labortablon

  13.   vicky diris

    La lxinput kaj lxrandr-aplikoj ankaŭ estas en qt. Ili troviĝas en la ĉakro ccr 😉

    1.    vicky diris

      Ekrankopioj
      lxinput:
      http://s8.postimg.org/zbavfb93p/input.png

      lxrandr:
      http://s11.postimg.org/4tullqscj/monitosettings.png

      lxbildo
      http://s22.postimg.org/fvjs6nppd/input4.png

      Ili aspektas preskaŭ samaj kiel iliaj versioj de gtk.

      1.    nano diris

        Ili aspektas belaj xD

      2.    x11tete11x diris

        Mi eniras la lambastonon, kiel mi lamas (?

      3.    kato diris

        Kun ĉi tio, mi volas ŝanĝi XFCE al LXDE, mi pli ŝatas Qt (ekzistas programoj tre agrablaj kiel VLC) ol GTK3, kiu konstante rompas iujn musajn problemojn.

  14.   Nomo (bezonata) diris

    Sed kiel ili faris ĝin? Ĉu en QT4? Mi diras al vi, ke ĝi ankaŭ ne disvolviĝas.

  15.   ferchmetal diris

    Ĉi tiu unua specimeno aspektas interesa, mi persone amas kio estas Razor-QT kaj mi eĉ uzas ĝin en Lubuntu ...

  16.   rokenrolo diris

    Laŭ mia scio, LXDE ne intencas lasi sian evoluon en gtk, do qt estus varianto. Ĉu ĉi tiel?
    Aliflanke, ĉu iu scias certe, ĉu ekzistas intencoj de tiuj ĉe LXDE porti gtk2 al gtk3?
    Salutojn.

  17.   rokenrolo diris

    Laŭ mia scio, LXDE ne intencas lasi sian evoluon en gtk, do qt estus varianto. Ĉu ĉi tiel?
    Aliflanke, ĉu iu scias certe, ĉu ekzistas intencoj de la LXDE-teamo porti la labortablon de gtk2 al gtk3? Se ne, estas fakto, ke la varianto qt baldaŭ estus la sola vere farebla.
    Salutojn.

  18.   Xunlilinux diris

    Bone por LXDE, ĝi estis io, kion mi pensis lastatempe, porti LXDE al QT estas la plej bona afero !!!
    Malpeza medio skribita en qT mankis, kvankam KDE ankoraŭ povas "malpezigi" xD je sufiĉe altaj niveloj. Mia KDE, ekzemple, komence konsumas nur 192MB kaj mi havas kompletan medion kaj kun iuj efikoj, nenio mankas xD
    Mi deziras, ke XFCE faru same, sed ili portos ĝin al gtk3, doloras 🙁
    Kompatinda gnomo kaj gtk ... ili restas solaj xD
    Por mi (kaj ankaŭ por multaj aliaj) Qt estas la estonteco.

  19.   eliotime3000 diris

    Mi provis LXDE ĉe Debian Stable, kaj tiu decido kliniĝi al QT ŝajnis ĝusta (mi laciĝis vidi VLC kvazaŭ ĝi estus klasika Vindozo).

    Ĉiuokaze, mi esperas, ke la QT plibonigas LXDE, kaj se vi volas ekzekuti GTK + -aplikojn ĝuste kun la LXDE-QT, vi povas apliki la kongruan pakon GTK + por QT.

    1.    pandev92 diris

      Se ĝi aspektis malbone, estas ĉar vi ne ĝuste aplikis la temon XD

      1.    eliotime3000 diris

        Bedaŭrinde, sur la DVD1, kiun mi instalis Debian Wheezy, la VLC venis kun QT kiel dependeco, do ne diru al mi, ke mi malĝuste aplikis la temon, ĉar Debian aŭtomate agordas multajn dependecojn por vi kaj plejofte funkcias tre bone.

  20.   Federico A. Valdes Toujague diris

    @ eliotime3000 Salutojn !!!. En la repo Wheezy, eĉ post ĝisdatigo, la versio de lxde-common estas 0.5.5.6, kaj ĝi reflektas:

    * Bonaspekta, internaciigita uzantinterfaco GTK + 2.

    Mi demandas vin, ĉu ili poste ŝanĝiĝis al Qt4

  21.   diazepano diris

    Pliaj informoj pri ĝi:

    1) Ĉi tiu versio de LXDE uzas QT 4, kaj ĝi atendos la alvenon de QT 5.1. Diras 5 forigitaj kelkaj apis rilataj al X11

    2) Jam ekzistas iu kunlaboro kun Razor-qt. Pliaj informoj en ĉi tiu gugla grupo
    https://groups.google.com/forum/?fromgroups=#!forum/razor-qt

  22.   kike diris

    @diazepan, @Son Link, @elav, mi lasas al vi la lastajn eldonaĵojn de GTK2 kaj GTK3:

    GTK2: Versio 2.24.19 - 2013-06-16
    GTK 3: Versio 3.6.4 - 2013-01-07

    Kial vi diras, ke GTK2 estas ĉesigita? Estas klare, ke tion vi ŝatus, sed ĝi ne estas la realaĵo, multaj aplikoj estas en GTK2 kaj ne planas ŝanĝi, do ĝi ankoraŭ subtenos longan tempon.

    1.    vicky diris

      Kiel mi komprenas, Gtk2 ankoraŭ subtenas, sed ĝia disvolviĝo haltas en la senco, ke apenaŭ novaj aferoj aldoniĝas al ĝi.

      1.    kike diris

        Efektive ili poluras la cimojn sed sen aldoni ion novan.

    2.    www.archlinux.org diris

      »Estas klare, ke tion vi ŝatus« haha. Ke kde estas bela, tio ne signifas, ke estas pli facile aŭ pli bone uzi qt-bibliotekojn. Ankaŭ nun, kiam Py-Side aperis, PyQT probable estos trafita, miaflanke mi ne uzos kampon ...

      1.    kike diris

        Vidu, mi ŝatus, ke ili migru XFCE al Qt, ĉar mi pli ŝatas ĝin, sed tio ne signifas, ke GTK estas malbona, kaj estas homoj ĉi tie, kiuj ĉiam "malamis" GTK. Kaj memore, kvankam mi pli ŝatas Qt-bibliotekojn, la KDE-medio abomenas ĝin, mi eĉ trovas ĝin malbela.

        1.    kato diris

          +1 (Mi ŝatas Qt sed ne KDE)

        2.    vicky diris

          La defaŭlta medio ŝajnos al vi malbela, sed KDE estas tre agordebla. Estas tre bonaj temoj de bespin kaj qtcurve. Bespin estas ideala se vi ŝatas mac-stilon kaj qtcurve se vi ŝatas gtk-temojn aŭ minimalismon.
          Kaj se ĝi estas Plasmo, vi ne ŝatas ĝin, vi povas uzi BE :: Shell

          -Ekrankopioj de BE :: Shell
          http://th3r0b.deviantart.com/art/a-screenshot-365407705

          http://fc02.deviantart.net/fs70/f/2012/279/6/6/66f7fc93cd02e8f1bad995e1d20e2e0b-d5gylvw.png

          -Qtkurbo imitante la elementan stilon
          http://th03.deviantart.net/fs71/PRE/f/2012/333/5/8/elementary_qtcurve_1_2_by_lgsalvati-d5idlwi.png

          -Qtkurva minimuma temo:
          http://fc05.deviantart.net/fs71/i/2012/236/c/b/droid_1_0_by_lgsalvati-d5bmxk2.png

          Kvankam ankaŭ povas esti, ke la labortabla medio kaj la sperto, kiujn ĝi ofertas al vi, ne plaĉas al vi kaj negrave kiel ĝi aspektas, ke ĝi aspektos malbela. Ekzemple, mi ne ŝatas XFCE (tre malmulte ekscita laŭ mia gusto) kaj Cinamon (mi eĉ ne scias kial mi ne ŝatas XD).

  23.   Kakashi diris

    ekster temo
    debian 7 wheezy alportas kernon pae? Ĉu ĝi povus esti instalita sur tekkomputilo kun intel "dothan" cpu?

    1.    eliotime3000 diris

      La Pae venas kun plej multaj procesoroj, kiel la NX, do tiu problemo estas solvita.

      Estus problemo, se vi instalus Slackware sur ĉeftabulo de Foxconn, kurioze, kerna paniko ĵetas min, kiam mi provas instali / kopii tiun distro sur tiuj ĉeftabuloj.

  24.   leo diris

    Mi ne scias, ĉu mi eraras, sed mi pensas, ke openbox havas gtk2-dependecojn, ĉu ne estos multaj antaŭŝargitaj bibliotekoj?
    Sed ankaŭ laŭ konsumo, ili ne tro zorgu, ĉar en la plej malbona kazo oni uzus malfermkeston "senŝeligita"

    1.    vicky diris

      Openbox ne dependas de iu ilaro. Mi kompilis ĝin en ĉakro sen gtk instalita.
      Kvankam pcmanfm dependas de libfm ĝi ja dependas de gtk2 (kvankam mi supozas ke poste tio ankaŭ estos portita)

  25.   St0rmt4il diris

    Mi ĝojas, ke ili elektis migri al QT, mi esperas, ke kun ĉi tio estos pli da programistoj, kiuj helpas ĉi tiun medion kaj daŭre karakterizas sin per malalta konsumo laŭ RAM.

    Dankon!

  26.   atzx diris

    Mi amas la ideon !!, mi vere rekomendas ruliĝan eldonan distribuon, por ke ili havu la plej novan de la plej novaj kaj kun la cimoj riparitaj de antaŭaj versioj, persone mi grimpas por tiel diri en linuksaj distribuoj de la plej facila al la plej malfacila. , Mi komencis kun ubuntu, sed antaŭ ol mankis manjaro, mi rekomendas ĝin 100% pro ĝia tre simpla maniero instali ubuntu-tipon, la ŝanĝo estis ĉar ubuntu griziĝis pro kiom malrapida ĝi estas kaj ke vi ne povas havi la lastan la lasta, mi nuntempe uzas manjaron kaj mia sekva paŝo estos archlinux, pro tempo mi ne povis ŝanĝi, sed mi faros.
    Por tiuj, kiuj koleras pri Ubuntu, la malstabileco en latpops, estis pli bona delikateco, se vi volas ion agrablan, instalu la grafikan interfacon KDE, aŭ ion rapide la grafikan interfacon LXDE (Havebla en GTK aŭ Qt, mi rekomendas Qt).
    Mia lasta paŝo estas movi mian aparataron al tute senpaga, mi serĉis tekkomputilon kaj mi trovis ĝin, jen la adreso.

    1.    atzx diris

      pardonu, ke mia fingro foriris, jen la adreso:
      http://www.crowdsupply.com/kosagi/novena-open-laptop