Litte wy Synaptic moetsje yn LMDE <° Linux

Ien fan 'e meast foarkommende fragen ûnder brûkers dy't yn begjinne GNU / Linux, is hoe't jo programma's ynstallearje of ferwiderje en hokker soarte pakketten kinne ynstalleare wurde. Wy sille jo ien fan 'e maklikste manieren sjen litte om dizze taak te dwaan, mei Synaptysk, en ek sille wy jo koart fertelle wat it is en hoe't wy it kinne brûke.

Normaal yn Windows, om in programma in bestân te ynstallearjen mei de tafoeging .exe en wy gewoan moatte brûke de Folgjende »Folgjende mei it ûneven searjenûmer en foar it reverse proses (ferwiderjen) gean wy nei Control Panel »Programma's tafoegje / ferwiderje.

Yn it gefal fan GNU / Linux, d'r binne ek wat wy ús soene kinne neame .exe mar fansels, se hawwe in oare namme en struktuer. Meastentiids binne de measte pakketten yn GNU / Linux Se wurde ûnderbrocht yn repositories, en ferskate ark wurde brûkt om se te behearjen. Miskien binne de populêrste as bekendste de .deb en de .rpm en beide kinne wurde beheard troch Synaptysk, dat earst in ynterface foar wie APT.

Synaptic: ynterface foar APT

Wurkje mei Synaptysk it is heul ienfâldich. De ynterface is net yngewikkeld en selden moat in nije brûker al har opsjes brûke of oanpasse. Yn 't algemien kinne jo, as it standert komt, de meast foarkommende taken útfiere.

Synaptysk hat lykas hy west Programma's tafoegje / ferwiderje de Windows, Foar de wurking moatte wy hawwe ynsteld (yn it gefal fan Debian en har derivaten) de paden nei de repositories wêr't de te ynstallearjen pakketten binne, yn it bestân /etc/apt/sources.list, Ut dat bestân, Synaptysk krijt it paad dat nedich is om tagong te krijen ta de pakketten.

De ynterface wite.

It is goed om ta te foegjen dat de ynterface fan Synaptysk en linuxmint, is oars as Debian, Foar guon reden yn linuxmint, knop net opnommen Kontrolearje alle updates, Mar litte wy weromgean nei de ynterface.

Oan de top hawwe wy de Menu balke wêrfan sille wy letter wat opsjes sjen. In bytsje fierderop, de folgjende knoppen:

  • Opladen: Update de pakketlist.
  • Tapasse: As wy in pakket markearje om te ynstallearjen of te ferwiderjen, brûke wy dizze knop om de feroaring ta te passen.
  • Eigenskippen: It toant de skaaimerken fan it pakket, de beskriuwing en ôfhinklikens.
  • Search: It toant in dialooch mei ferskate opsjes om nei pakketten te sykjen neffens bepaalde parameters.

Knoppen foar flugge tagong

Hjirûnder hawwe wy de interface ferdield yn twa kolommen. Links binne de opsjes neffens de seksje dy't wy selektearje. Rop de seksje knoppen: Seksjes, status, oarsprong, filters en sykresultaten.

  • Seksjes: Toant pakketten organisearre troch kategoryen. As wy wolle sykje nei in pakket yn ferbân mei de Gnome buroblêdomjouwing, bygelyks, moatte wy gewoan nei de seksje gean gnome.
  • steat: Yn dizze paragraaf sille wy fine hokker de upgradearbere, ferâldere, ynstalleare as oerbleaune pakketten binne.
  • Origin: Toant de oarsprong (repositories) fan 'e pakketten. Mei oare wurden, wêr't se weikomme.
  • Filters: Yn dizze paragraaf kinne jo beskate filters tapasse om ferskate soarten ynformaasje te krijen. It is wichtich om te witten dat de brutsen pakketten hjir ferskine.
  • Sykresultaten: Krekt wat it docht is lykas de namme oanjout, toant it sykresultaten yn Synaptysk.

Synaptyske seksjes

Oan 'e oare kant hawwe wy de list mei pakketten dy't wy fia Synaptic kinne ynstallearje. As wy ien fan har selektearje en rjochts klikke, kinne wy ​​bepaalde opsjes kieze, lykas:

  • Untselektearje: Untselektearje it pakket as wy it earder hawwe selekteare.
  • Kontrolearje om te ynstallearjen: Kontrolearje it pakket om te ynstallearjen.
  • Markearje om opnij te ynstallearjen: No dat, selektearje en ynstallearje it pakket opnij.
  • Markearje om te aktualisearjen: As it pakket in update hat, selektearje wy it mei dizze opsje.
  • Markearje om te wiskjen: Ferwiderje allinich it selekteare pakket.
  • Kontrolearje om folslein te ferwiderjen: Ferwiderje it selekteare pakket mei de oanbefellende ôfhinklikens. De foarstelde ôfhinklikens gean nei restkonfiguraasje.
  • Propiedades: Docht itselde as de knop boppe.
  • Mark oanrikkemandearre foar ynstallaasje: Selektearje de oanbefellende ôfhinklikens fan it te ynstallearjen pakket.
  • Mark foarsteld foar ynstallaasje: Selektearje de foarstelde ôfhinklikens fan it te ynstallearjen pakket.

List mei beskikbere pakketten

Oare opsjes.

Dit wite kinne wy ​​al mei wurkje Synaptysk, mar wy kinne oare dingen dwaan, lykas bygelyks de boarnen fan 'e repositories feroarje. Iets nuttichs as de spegels dy't wy brûke stadich of stadich binne. Hjirfoar sille wy Konfiguraasje »Repository.

Yn it opsjesfinster dat wy krije, hoege wy allinich 3 ljepblêden te witten om ús repositories te behearjen. Yn 'e earste krije wy de tûken dy't wy brûke linuxmint (Main, Upstream, Import, Backport en Romeo). Bewurkje it bestân gewoan kontrolearje / ûntsiferje /etc/apt/sources.list.

Untstean fan 'e software

Yn 'e twadde ljepper omfetsje wy de repositories dy't net binne mint, dat is de Pakketten fan tredden as fan Debiande PPA de ubuntu as elke boarne kompatibel mei LMDE.

Tredde partij software

En yn 'e tredde ljepper kinne wy ​​de automatyske updates aktivearje en elke kear as wy wolle dat se rinne.

Automatyske fernijings

Noch mear?

As jo ​​it nedich binne, Synaptysk moat ek ynstelle de Netwurk proxy en de Distribúsje dat wy standert wolle brûke. Hjirfoar sille wy Ynstellings »Foarkarren.

Om in bytsje út te lizzen oer de Distribúsje, as wy nei it bestân sjogge /etc/apt/sources.list, wy hawwe twa lay-outs om te brûken (let op de kleurde tekst):

deb http://packages.linuxmint.com/ debian wichtichste streamop ymport
deb http://ftp.debian.org/debian testing haadbydrage net-fergees
deb http://security.debian.org/ testing/ updates haadbydrage net-fergees
deb http://www.debian-multimedia.org testing wichtichste net-frij

Standert, Synaptysk nimt altyd de heechste ferdieling, wat betsjut dat as it pakket ynkomt Pidgin 2.8 yn 'e repo's fan Munt (debian) en ferzje 2.9 yn Debian (testing), sil it programma suggerearje om ferzje 2.9 te ynstallearjen.

Fansels kin dit feroare wurde as wy de ferdieling dy't wy wolle brûke mei de hân kieze mei de opsje: Foarkarferzjes fan:

Kies ferdieling
En goed, as wy in proxy brûke om te ferbinen fia http, hawwe wy ek de opsje om it mei de hân yn te stellen:

Netwurk proxy

D'r binne oare ark om ús pakketten te behearjen, te aktualisearjen en te ynstallearjen. ubuntu bygelyks befettet no jo Software Center, y LMDE hat in heul ferlykbere, mar op in bepaalde manier Synaptysk It is mear folslein.


De ynhâld fan it artikel hâldt him oan ús prinsipes fan redaksje etyk, Om in flater te melden klikje hjir.

2 opmerkingen, lit jo

Lit jo reaksje efter

Jo e-mailadres wurdt net publisearre.

*

*

  1. Ferantwurdlik foar de gegevens: Miguel Ángel Gatón
  2. Doel fan 'e gegevens: Control SPAM, kommentaarbehear.
  3. Legitimaasje: jo tastimming
  4. Kommunikaasje fan 'e gegevens: De gegevens wurde net oan tredden kommunisearre, útsein troch wetlike ferplichting.
  5. Gegevensopslach: Databank hoste troch Occentus Networks (EU)
  6. Rjochten: Op elk momint kinne jo jo ynformaasje beheine, herstelle en wiskje.

  1.   jonathan sei

    Tige tank, de wierheid is dat ik gewoan mei Linux begjin en dit ark is wichtich. It is goed om har better te kennen

  2.   claro sei

    Ik moat wite hoe't Linux mint 17 Quiana foarkomme kin om de repo te aktualisearjen fanôf har offisjele side
    En opnommen yn myn sources.list in nij update-adres dat al is test yn Ubuntu 14.04 en kompatibel mei Mint, mar as (apt-get update) it folgjende wurdt werjûn:

    Err http://ubuntu.mes.edu.cu fertroude foarstelde InRelease

    Err http://packages.linuxmint.com Qiana InRelease

    Err http://archive.ubuntu.com fertroude InRelease

    Err http://archive.ubuntu.com trust-updates InRelease

    Err http://security.ubuntu.com fertroude-feiligens InRelease

    Err http://ubuntu.mes.edu.cu fertroude-feiligens InRelease

    Err http://ubuntu.mes.edu.cu trust-updates InRelease

    Err http://ubuntu.mes.edu.cu fertroude InRelease

    Err http://archive.ubuntu.com fertroude Release.gpg
    Koe "archive.ubuntu.com" net oplosse
    Err http://security.ubuntu.com trusty-security Release.gpg
    Koe "security.ubuntu.com" net oplosse
    Err http://ubuntu.mes.edu.cu fertroude-foarstelde Release.gpg
    Koe "ubuntu.mes.edu.cu" net oplosse
    Err http://packages.linuxmint.com qiana Release.gpg
    Koe "packages.linuxmint.com" net oplosse
    Err http://ubuntu.mes.edu.cu trusty-security Release.gpg
    Koe "ubuntu.mes.edu.cu" net oplosse
    Err http://ubuntu.mes.edu.cu trusty-updates Release.gpg
    Koe "ubuntu.mes.edu.cu" net oplosse
    Err http://archive.ubuntu.com trusty-updates Release.gpg
    Koe "archive.ubuntu.com" net oplosse
    Err http://ubuntu.mes.edu.cu fertroude Release.gpg
    Koe "ubuntu.mes.edu.cu" net oplosse
    Err http://extra.linuxmint.com Qiana InRelease

    Err http://extra.linuxmint.com qiana Release.gpg
    Koe "extra.linuxmint.com" net oplosse
    Err http://archive.canonical.com fertroude InRelease

    Err http://archive.canonical.com fertroude Release.gpg
    Koe "archive.canonical.com" net oplosse
    W: Net mooglik te krijen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-proposed/InRelease

    W: Net mooglik te krijen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-security/InRelease

    W: Net mooglik te krijen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-updates/InRelease

    W: Net mooglik te krijen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty/InRelease

    W: Net mooglik te krijen http://packages.linuxmint.com/dists/qiana/InRelease

    W: Net mooglik te krijen http://extra.linuxmint.com/dists/qiana/InRelease

    W: Net mooglik te krijen http://archive.ubuntu.com/ubuntu/dists/trusty/InRelease

    W: Net mooglik te krijen http://archive.ubuntu.com/ubuntu/dists/trusty-updates/InRelease

    W: Net mooglik te krijen http://security.ubuntu.com/ubuntu/dists/trusty-security/InRelease

    W: Net mooglik te krijen http://archive.canonical.com/ubuntu/dists/trusty/InRelease

    W: Net mooglik te krijen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-proposed/Release.gpg Koe "ubuntu.mes.edu.cu" net oplosse

    W: Net mooglik te krijen http://packages.linuxmint.com/dists/qiana/Release.gpg Koe "packages.linuxmint.com" net oplosse

    W: Net mooglik te krijen http://archive.ubuntu.com/ubuntu/dists/trusty/Release.gpg Koe "archive.ubuntu.com" net oplosse

    W: Net mooglik te krijen http://archive.ubuntu.com/ubuntu/dists/trusty-updates/Release.gpg Koe "archive.ubuntu.com" net oplosse

    W: Net mooglik te krijen http://security.ubuntu.com/ubuntu/dists/trusty-security/Release.gpg Koe "security.ubuntu.com" net oplosse

    W: Net mooglik te krijen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-security/Release.gpg Koe "ubuntu.mes.edu.cu" net oplosse

    W: Net mooglik te krijen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty-updates/Release.gpg Koe "ubuntu.mes.edu.cu" net oplosse

    W: Net mooglik te krijen http://ubuntu.mes.edu.cu/UBUNTU/ubuntu/dists/trusty/Release.gpg Koe "ubuntu.mes.edu.cu" net oplosse

    W: Net mooglik te krijen http://extra.linuxmint.com/dists/qiana/Release.gpg Koe "extra.linuxmint.com" net oplosse

    W: Net mooglik te krijen http://archive.canonical.com/ubuntu/dists/trusty/Release.gpg Koe "archive.canonical.com" net oplosse

    W: Guon yndeksbestannen kinne net downloade. Se binne negeare, of ynstee brûkt âlde.
    E: Koe / var / lib / dpkg / lock net beskoattelje - iepen (11: Boarne tydlik net beskikber)
    E: Koe de admin-map (/ var / lib / dpkg /) net beskoattelje, miskien brûkt d'r in oar proses?

    *************** Hoe kinne jo dit probleem oplosse? **************************
    Ik smeekje jo my asjebleaft te helpen