ძირითადი პროგრამირება ფსევდონიმით (ნაწილი 3)

ეს არის სახელმძღვანელოს გაგრძელება ძირითადი პროგრამირება ფსევდონიმით (ნაწილი 2), ამჯერად მე აგიხსნით რა არის საჭირო პროგრამირებისთვის.

დავალება

დავალება არის პროცესი, როდესაც ცვლადი იქმნება და / ან მოდიფიცირდება, მისი მითითება ხდება მისი იდენტიფიკატორის საშუალებით, რომლითაც ჩვენ შეგვიძლია მის მეხსიერებაზე წვდომა.

დავალების სინტაქსია:

[variable]<- [expresion];
[variable]=[expresion];

სადაც [ცვლადი] არის ცვლადი, რომელიც იღებს შეფასების მნიშვნელობას. ორივე მოქმედებს, ამიტომ არ აქვს მნიშვნელობა რომელი იქნება გამოყენებული (თუ ისინი PSeInt– ს სწორად აქვთ კონფიგურირებული), მაგრამ ჩემი აზრით მე პირველს ვქმნი როგორც სწორს.

თუ [ცვლადი] დავალებამდე არ არსებობდა, შეიქმნა [ცვლადი], თუ ის არსებობდა, წინა მნიშვნელობა განადგურებულია და ახალი მოთავსებულია მის ადგილზე. ამ მიზეზით, რუკების შედგენა ითვლება დესტრუქციულ ოპერაციად.

ᲙᲘᲗᲮᲕᲐ

კითხვა არის პროცესი, რომლის დროსაც მომხმარებელი ითხოვს მონაცემებს ან მონაცემებს აღნიშნული მონაცემების ცვლადში შესანახად.

მისი სინტაქსია:

Leer variable_1,variable_2,...,variable_n;

სადაც [ცვლადი_ {1,2, n}] არის ცვლადი ან ცვლადები, რომლებიც მიიღებენ მომხმარებლის მიერ მოცემულ მნიშვნელობას, ერთზე მეტი ცვლადის მოთხოვნის შემთხვევაში, იგი ჯერ ითხოვს პირველს, შემდეგ მეორეს და ასე შემდეგ მიღებული აქვს ყველა მნიშვნელობა.

ეს ასევე არის დესტრუქციული ფუნქცია.

ᲬᲔᲠᲐ

წერა არის პროცესი, რომელშიც ეკრანზე იწერება სიმბოლოების სიმებიანი და / ან ერთი ან მეტი ცვლადი

სინტაქსია:

Escribir expresion_1,expresion_2,...,expresion_n;

სადაც [expersion_ {1,2, n}] არის სიმბოლოების სიმები და / ან ცვლადები, რომლებიც გამოჩნდება.

წერა, ნაჩვენები მონაცემების მიღების გარდა, იღებს ინსტრუქციას "გამოტოვების გარეშე" ან "ჩამოტვირთვის გარეშე", რაც ხაზის წყვეტს არიდებს თავს.

წერა არ მატებს არგუმენტებს შორის მანძილს, ანუ თუ დააყენებთ:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

ამ შემთხვევაში იგი აჩვენებს «olamundo» - ს, რადგან «a» - სა და «b» - ს შორის არ არსებობს სიმბოლოების სიმებიანი, რომლებიც მიუთითებს a და b ადგილს შორის, ისე რომ სწორად იყოს ნაჩვენები, ასე იწერება:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

ამ შემთხვევაში დაამატეთ »», რომელიც წარმოადგენს სიმბოლოების სიმებს, რომელსაც აქვს სივრცე, რომელიც არის სივრცე „ტალღასა“ და «სამყაროს» შორის და შემდეგ ის აჩვენებს «ტალღის სამყაროს» სივრცესთან ერთად.

თუ შემდეგ

ეს არის განცხადება, რომელიც აფასებს მოცემულ პირობას და ამოწმებს მოცემული პირობის სიმართლეს და / ან სიცრუეს, ანუ პირობითობა დაკმაყოფილებულია თუ არა.

მისი სინტაქსია:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

პუნქტი "სხვა" არ არის სავალდებულო, ამ შემთხვევაში, თუ პირობა ცრუა, უგულებელყოფს მითითებებს და გაგრძელდება ისე, თითქოს წინადადება არ არსებობს, ამ შემთხვევაში ის დარჩება:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

დაიდო თუ არა ”წარუმატებლობის” პუნქტი, ეს დამოკიდებულია ამ პროგრამის საჭიროებებზე.

შესაბამისად

წინადადება, რადგან იგი აფასებს მკაცრად რიცხობრივ ცვლადს, რომელიც 2-ზე მეტ ვარიანტს იძლევა, ეს არის განსხვავება "თუ-მაშინ" -სგან, ვინაიდან წინა მხოლოდ 2 ვარიანტს იძლევა.

სინტაქსია:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

როგორც ხედავთ "რიცხვი 1" -ის შემდეგ არის ":" და ამის შემდეგ უნდა შესრულდეს მითითებები იმ შემთხვევაში, თუ "რიცხვითი ცვლადი = ნომერი 1", მეორე მაგალითში ეს არის "ნომერი 2, ნომერი 3", ეს ნიშნავს, რომ თუ " რიცხვითი ცვლადი = number2 ან number3 "მაშინ შესრულდება" ინსტრუქციები ", ეს გამოდგება მაშინ, როდესაც 2 შესაძლებლობამ უნდა შეასრულოს იგივე ინსტრუქცია.

ასევე არსებობს პუნქტი "სხვა გზით", რომელიც შესრულებულია იმ შემთხვევაში, თუ არცერთი შესაძლებლობა არ შესრულდება.

ხოლო

ეს არის განმეორებადი ფუნქცია, რომელიც ჯერ აფასებს პირობას, შემდეგ კი, თუ იგი შესრულებულია, ასრულებს ინსტრუქციების სერიას, შემდეგ ხელახლა აფასებს პირობას და თუ ეს სიმართლეა, იგი ისევ ახორციელებს იმავე მითითებებს და ასე გრძელდება მანამ, სანამ მდგომარეობა არ არის ცრუ.

თუ მდგომარეობა თავიდანვე მცდარია, იგი არასოდეს შესრულდება და თუ ის ყოველთვის სიმართლეა, იგი მოთავსდება უსასრულო მარყუჟში, ინსტრუქციებში უკანასკნელის თავიდან ასაცილებლად უნდა არსებობდეს ისეთი რამ, რაც გარკვეულ მომენტში გაყალბებს პირობას, რომ შესაძლებელი გახდეს ციკლის დასრულება.

მისი სინტაქსია:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

გამეორება-მანამ

ეს არის ფუნქციის ძალიან მსგავსი წინა, მაგრამ განსხვავებით წინა, ეს ამოწმებს პირობას ბოლოს, ანუ ბრძანება შესრულდება მინიმუმ 1 ჯერ, ასევე ინსტრუქციის შესრულების ნაცვლად, როდესაც ის მართალია, იგი ასრულებს თუ პირობა არ არის შესრულებული, მაგრამ თუ გსურთ მისი შესრულება პირობის დაკმაყოფილებისას გამოიყენეთ "სანამ" ნაცვლად "სანამ".

მისი სინტაქსია:

Repetir
[Instrucciones] hasta que [condicion]

FOR

ეს განცხადება ასრულებს ინსტრუქციას ცვლადისთვის რამდენჯერმე განმსაზღვრელი, განსხვავებით წინა, ეს ციკლი თავისთავად ცვლის სადავო ცვლადის მნიშვნელობას, ასევე აქვს ძალიან ძლიერი სინტაქსი.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"ცვლადი" არის ცვლადი, რომელიც იღებს "საწყის მნიშვნელობას" და ასრულებს ინსტრუქციებს, შემდეგ ემატება "ცვლადი" პლუს "ნაბიჯი" და კვლავ ასრულებს ინსტრუქციებს, სანამ "ცვლადი" არ იქნება "საბოლოო მნიშვნელობა".

თუ „[ნაბიჯით]“ წაიშალა, მაშინ სტანდარტულად იცის, რომ „ნაბიჯი“ უდრის 1 – ს, ასევე თუ [ნაბიჯი] არ არის მითითებული და „საწყისი მნიშვნელობა“ აღემატება „საბოლოო მნიშვნელობას“, ის გაივლის საპირისპირო თანმიმდევრობით, ანუ "ნაბიჯი" არის -1

ქვეპროცესი / ფუნქციონირება

ძაფი ან ფუნქცია არის პროგრამა სხვაში და რომ ეს ქვეპროგრამა იღებს ერთ ან მეტ მნიშვნელობას, მოქმედებს მათ და უბრუნებს სხვას. მისი სინტაქსია

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

სადაც "დაბრუნების ცვლადი" არის ცვლადი, რომელიც შეიცავს ფუნქციის "ფუნქციის სახელი" დაბრუნებულ მნიშვნელობას, რომელმაც მიიღო პარამეტრები "arg_1, arg_2, arg_n" ამის შესასრულებლად

სხვები

ეს არის ფუნქციები, რომლებიც მხოლოდ დანარჩენებს ავსებენ და არ აქვთ რთული სინტაქსი, რადგან ისინი მხოლოდ დამატებითი ფუნქციებია.

ეკრანის გასუფთავება

ეს ფუნქცია ხსნის ეკრანს ნებისმიერი ობიექტის თარჯიმანში

დაველოდოთ გასაღებს

ეს ფუნქცია ელოდება მომხმარებელს, რომ დააჭიროს კლავიშს პროგრამის გასაგრძელებლად

დაელოდე x {მეორე, მილიწამები}

ეს ფუნქცია წამში ან მილიწამებში ელოდება პროგრამის გასაგრძელებლად

პ.ს: ბოდიში დაგვიანებისთვის, მაგრამ სხვა საკითხებით ვიყავი დაკავებული, ამიტომ წერა არ შემეძლო


სტატიის შინაარსი იცავს ჩვენს პრინციპებს სარედაქციო ეთიკა. შეცდომის შესატყობინებლად დააჭირეთ ღილაკს აქ.

10 კომენტარი დატოვე შენი

დატოვე კომენტარი

თქვენი ელფოსტის მისამართი გამოქვეყნებული არ იყო.

*

*

  1. მონაცემებზე პასუხისმგებელი: მიგელ ანგელ გატონი
  2. მონაცემთა მიზანი: სპამის კონტროლი, კომენტარების მართვა.
  3. ლეგიტიმაცია: თქვენი თანხმობა
  4. მონაცემთა კომუნიკაცია: მონაცემები არ გადაეცემა მესამე პირებს, გარდა სამართლებრივი ვალდებულებისა.
  5. მონაცემთა შენახვა: მონაცემთა ბაზა, რომელსაც უმასპინძლა Occentus Networks (EU)
  6. უფლებები: ნებისმიერ დროს შეგიძლიათ შეზღუდოთ, აღადგინოთ და წაშალოთ თქვენი ინფორმაცია.

  1.   გილი დიჯო

    არ გაქვთ გასაღებების აღების ფუნქციები შესრულების შეჩერების გარეშე? მოძრაობისთვის ისეთი საქმის გაკეთებისთვის, რაც უფრო მიმზიდველია 9 წლის ბავშვებისთვის, თუმცა ჩამოხრჩობანას თამაში ასევე შეიძლება იყოს სახალისო.

    დაამუშავე რაღაც_დიგო
    a <-1;
    გვერდითი <-30;
    ქვემოთ <-5;
    ხოლო a = 1 Do
    ეკრანის გასუფთავება;
    გ <-1;
    ხაზი <- "";
    გამეორება
    ხაზი <-ხაზი + "";
    c <-c + 1;
    სანამ c = გვერდითი
    ხაზი <-ხაზი + "X";
    გ <-1;
    გამეორება
    Წერა " ";
    c <-c + 1;
    სანამ c = ქვემოთ -1
    სტრიქონის წერა;
    გამეორება
    Წერა " ";
    c 2 შემდეგ
    ქვემოთ <-down-1;
    დასრულდა დიახ
    "s":
    თუ ქვემოთ <15 მაშინ
    ქვემოთ 2 შემდეგ
    გვერდითი <-გარემ -1;
    დასრულდა დიახ
    "დ":
    თუ გვერდითი <50 მაშინ
    გვერდითი <-გვერდი + 1;
    დასრულდა დიახ
    "0":
    a <-2;
    წამით დასრულება
    სანამ დასრულდება
    EndProcess

  2.   გილი დიჯო

    კარგით, თუ ვერ ახვიდებით, უკეთესად შეცვალეთ 23 და 28 სტრიქონები
    -23 წლამდე c = 15
    +23 წლამდე c = 18
    y
    -28 თუ ქვემოთ> 2 შემდეგ
    +28 თუ ქვემოთ> 3 შემდეგ

    1.    xnmm დიჯო

      გმადლობთ შენატანით, მაგრამ მას აქვს გარკვეული პრობლემები, მაგალითად, თქვენ გახსნით ერთ წინადადებას მეორეში, მაგრამ ის უნდა დასრულდეს იმ წინადადებაში, სადაც დაიწყო, ვგულისხმობ, რომ არ შეიძლება მისი დადება

      დაამუშავე რამე
      a <- 0;
      წაიკითხავს;
      თუ a არ არის 25-ის ტოლი, მაშინ
      ხოლო a ტოლი არ არის 0 do
      წაიკითხავს;
      დასრულდა დიახ
      დასრულება ხოლო

      როგორც ხედავთ მარყუჟს "თუ მაშინ" განცხადების შიგნით დაწყებისას, მაგრამ მის გარეთ მთავრდება, მსგავსი რამ შეუძლებელია.

      მე მაინც ვაფასებ შენატანს
      დასრულების პროცესი

      1.    გილი დიჯო

        მადლობა, მაგრამ ვფიქრობ, ეს უფრო პრობლემაა კოდის აქ განთავსებაში, რომ არ ვიცი როგორ უნდა ჩავსვა კოდის ტიპით და ის ჩაღრმავების გარეშე გამოდის.

        პროგრამა კარგად მუშაობს. ცვლადი "ა" მე გამოვიყენებ მარყუჟს გასასვლელად, როდესაც მომხმარებელი ნულს აკრეფს. თქვენ შეგიძლიათ განათავსოთ გასასვლელი () ან შესვენება; პირობითად უყურებს მას და მე ვინახავ ცვლადს. ისინი ვარიანტებია.

        ულოცავენ.

      2.    გილი დიჯო

        შევეცდები ჩანართების შეცვლას სივრცეებისა და ეტიკეტებისთვის por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    გილი დიჯო

        ეს სავსეა ჩემი კოდის იმპორტის შეცდომებით, მე კვლავ შევეცდები ჩანართებით:
        ეს იქნება ფაილი algo.psc

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    გილი დიჯო

        საინტერესოა, რომ კოდის ეტიკეტით კომენტარი მიირთმევს, წაიშლება, რაც არ უნდა შედის, მაგალითად ხაზებს შორის
        გამეორება
        Წერა " ";
        c
        გ-ს შემდეგ არის ა
        და შემდეგ ის გრძელდება 3 შემდეგ
        ძირს
        საერთო ჯამში, ეს არ არის საიმედო, თუ რომელი კოდების მიხედვით უნდა დადგინდეს.

  3.   გილი დიჯო

    მე ვცვლი სიმბოლოებს მინიჭებიდან = რომ ვნახო როგორ არის ეს.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    გილი დიჯო

      ის განაგრძობს კოდის ნაწილის ჭამას, კოდის ტეგი ვერ ხერხდება, მან უნდა დატოვოს წერა ისე, როგორც არის.

      1.    xnmm დიჯო

        გამარჯობა, ბოდიში, რომ მანამდე ვერ გიპასუხე, მაგრამ კარგად
        რადგან კოდს კარგად ვერ გამოაქვეყნებთ, რადგან არ გამომიგზავნით ფოსტით, ასე რომ ამდენ რიგრიგობას არ მისცემთ საკითხს.