Барномасозии асосӣ бо псейнт (қисми 3)

Ин идомаи ёдгирӣ аст Барномасозии асосӣ бо псейнт (қисми 2), ин дафъа ман мефаҳмонам, ки барои барнома чӣ зарур аст.

СУПОРИШ

Таъинкунӣ ин равандест, ки дар он тағирёбанда сохта ва / ё тағир дода мешавад ва ба воситаи идентификатори худ ба он ишора мекунад, ки мо метавонем ба фазои хотираи он дастрасӣ пайдо кунем.

синтаксиси супориш чунин аст:

[variable]<- [expresion];
[variable]=[expresion];

Дар куҷо [тағйирёбанда] тағирёбандае мебошад, ки арзиши баҳогузорӣ [ифода] мегирад. Ҳардуи онҳо эътибор доранд, бинобар ин муҳим нест, ки кадоме аз он истифода мешавад (агар онҳо PSeInt-ро дуруст танзим карда бошанд), аммо ба назари ман, ман аввалинашро ҳамчун дуруст эҷод мекунам.

Агар [тағирёбанда] пеш аз таъинот вуҷуд надошта бошад, [тағирёбанда] сохта шудааст, агар он вуҷуд дошта бошад, арзиши қаблӣ нест карда мешавад ва нав ба ҷои худ гузошта мешавад. Аз ин сабаб, харитасозӣ амалиёти харобиовар ҳисобида мешавад.

ХОНДАН

Хондан ин равандест, ки дар он аз корбар маълумот ё маълумот барои дар тағирёбанда нигоҳ доштани маълумотҳои зикршуда талаб карда мешавад.

синтаксиси он чунин аст:

Leer variable_1,variable_2,...,variable_n;

ки дар он [тағйирёбанда_ {1,2, n}] тағирёбанда ё тағирёбандае мебошанд, ки арзиши додаи корбарро мегиранд, дар ҳолате ки агар аз як тағирёбанда зиёдтар тағирот талаб карда шавад, аввал аввал талаб мекунад, баъд дуюм ва ғ. тамоми арзишҳоро ба даст овардаанд.

Ин ҳам вазифаи харобкор аст.

Навиштан

Навиштан ин равандест, ки дар экран сатри аломатҳо ва / ё як ё якчанд тағирёбанда навишта мешавад

синтаксис чунин аст:

Escribir expresion_1,expresion_2,...,expresion_n;

ки дар он [expersion_ {1,2, n}] сатрҳои аломатҳо ва / ё тағирёбандаҳо нишон дода мешаванд.

Навиштан ба ғайр аз гирифтани маълумоте, ки ба экран гузошта мешавад, инчунин дастурҳои "Бе паридан" ё "Бе зеркашӣ" -ро мегирад, ки ҷаҳиши хатро пешгирӣ мекунанд.

Навиштан байни далелҳо фосила илова намекунад, яъне агар шумо чунин гузоред:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,b;
FinProceso

дар ин ҳолат он «olamundo» -ро нишон медиҳад, зеро дар байни «a» ва «b» сатри аломате вуҷуд надорад, ки фосилаи байни a ва b-ро нишон диҳад, то он дуруст нишон дода шавад, чунин навишта шудааст:

Proceso SinTitulo
a<- "ola";
b<- "mundo";
Escribir a,"",b;
FinProceso

дар ин ҳолат илова кунед »», ки сатри аломатест, ки фосилае дорад, ки фосилаи байни «мавҷ» ва «ҷаҳон» аст ва он гоҳ он «ҷаҳони мавҷ» -ро бо фосила нишон медиҳад.

АГАР ПАС

Ин ҷумлаест, ки шарти додашударо арзёбӣ мекунад ва дурустӣ ва / ё дурӯғии ин шартро месанҷад, яъне агар шарт иҷро шавад ё не.

Синтаксиси он чунин аст:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] Sino
[instrucciones por falso] FinSi

Банди "Дигар" ҳатмӣ нест, дар ин ҳолат, агар шарт бардурӯғ бошад, дастурҳоро нодида гиред ва гӯё ҳукм вуҷуд надошта бошед, дар ин ҳолат чунин хоҳад буд:

Si [condición a evaluar] Entonces
[instrucciones por verdadero] FinSi

Ҷойгир карда шудани банди "Нокомӣ" аз ниёзҳои он барнома вобаста аст.

Мувофиқи

Ҳукме, ки тағирёбандаи қатъии ададиро арзёбӣ мекунад, ки зиёда аз 2 вариантро ҳамчун вариант медиҳад, ин фарқият аз "If-then" мебошад, зеро пештар танҳо 2 вариант дода метавонад.

Синтаксис чунин аст:

Segun [variable numérica] Hacer
[número1]: [instrucciones] [número2],[número3]: [instrucciones] [...] De Otro Modo: [instrucciones] FinSegun

Тавре ки шумо мебинед, пас аз «рақами 1» «:» вуҷуд дорад ва пас аз он дастурҳои иҷрошаванда дар ҳолате гузошта мешаванд, ки «тағирёбандаи ададӣ = рақами1», дар мисоли дуюм он «рақами2, рақами3» бошад, ин маънои онро дорад, ки агар « тағирёбандаи ададӣ = number2 or number3 "пас" дастурҳо "иҷро мешаванд, ин муфид аст, вақте ки 2 имкон бояд ҳамон дастурҳоро иҷро кунанд.

Инчунин банди "Бо роҳи дигар" мавҷуд аст, ки дар сурати иҷро нашудани ягон имконот иҷро карда мешавад.

ҲАНГОМИ

Ин функсияи такрориест, ки аввал шартро арзёбӣ мекунад ва пас аз иҷро шуданаш як силсила дастурҳоро иҷро мекунад, пас шартро дубора арзёбӣ мекунад ва агар дуруст бошад, ҳамон дастурҳоро дубора иҷро мекунад ва то даме ки шарт нодуруст аст, идома меёбад.

агар шарт аз аввал дурӯғ бошад, ҳеҷ гоҳ иҷро намешавад ва агар он ҳамеша дуруст бошад, он дар ҳалқаи бепоён ҷойгир карда мешавад, барои пешгирӣ кардани охирин дар дастурҳо бояд чизе бошад, ки дар ягон лаҳза шартро таҳриф мекунад, то битавонад битавонад даврро ба анҷом расонад.

синтаксиси он чунин аст:

Mientras [condición a evaluar] Hacer
[instrucciones] FinMientras

ТАКРОР-то

Ин функсия ба функсияи пешина хеле монанд аст, аммо бар хилофи вазифаи пешина, ин шартро дар охир месанҷад, яъне фармон ҳадди аққал 1 маротиба иҷро мешавад, инчунин ба ҷои иҷрои дастур ҳангоми ҳақиқӣ, онро дар ҳоле иҷро мекунад Агар шарт иҷро нашуда бошад, аммо агар шумо хоҳед, ки он ҳангоми иҷрои шарт иҷро карда шавад, ба ҷои "то" "while" -ро истифода баред.

синтаксиси он чунин аст:

Repetir
[Instrucciones] hasta que [condicion]

ПАРА

Ин изҳорот дастуреро иҷро мекунад, ки миқдори муайяни тағирёбандаро фарқ мекунад, бар хилофи тағйироти қаблӣ, ин давра илова бар доштани синтаксиси хеле қавӣ, арзиши тағирёбандаро мавриди баҳо тағир медиҳад.

Para [variable] Desde [valor inicial] Hasta [valor Final] Con [paso] Hacer
[instruciones] FinPara

"Тағирёбанда" тағирёбандае мебошад, ки "арзиши ибтидоӣ" мегирад ва дастурҳоро иҷро мекунад ва сипас "тағйирёбанда" илова "қадам" -ро илова мекунад ва дастурҳоро дубора иҷро мекунад, то вақте ки "тағирёбанда" ба "арзиши ниҳоӣ" баробар шавад.

Агар "with [step]" хориҷ карда шавад, пас бо нобаёнӣ ӯ мефаҳмад, ки "қадам" ба 1 баробар аст, инчунин агар [қадам] мушаххас нашуда бошад ва «арзиши ибтидоӣ» аз «арзиши ниҳоӣ» зиёдтар бошад, он бо тартиби баръакс мегузарад, яъне, "Қадам" -1 аст

СУПРОЦЕСС / ФУНКЦИЯ

Ришта ё функсия барномаест дар дохили дигар, ки ин зерпрограмма як ё якчанд арзишҳоро қабул мекунад, онҳоро амалӣ мекунад ва дигарашро бар мегардонад. Синтаксиси он аст

SubProceso [variable_de_retorno]<- [nombre de la funcion] ([arg_1],[arg_2],...,[arg_n])

acción 1;
acción 2;
.
.
.
acción n;
FinSubproceso

ки дар он "тағирёбандаи баргард" тағирёбандаест, ки арзиши баргаштаи функсияи "номи функсия" -ро дорад, ки параметрҳои "arg_1, arg_2, arg_n" -ро барои иҷрои ин қабул кардааст

ДИГАР

Инҳо функсияҳое мебошанд, ки барои дигарон танҳо якдигарро пурра мекунанд ва синтаксиси мураккаб надоранд, зеро онҳо танҳо функсияҳои иловагӣ мебошанд.

Экранро тоза кунед

Ин функсия экранро аз ҳама гуна ашё дар тарҷумон тоза мекунад

Калидро интизор шавед

Ин функсия интизор мешавад, ки корбар барои идома додан бо барнома тугмаеро пахш мекунад

Интизор шавед х {Дуюм, Милисекундҳо}

ин функсия барои идомаи барнома вақтро дар сонияҳо ё миллисекундҳо интизор мешавад

PS: Узр барои таъхир, аммо ман бо масъалаҳои дигар банд будам, бинобар ин навишта наметавонистам


Мазмуни мақола ба принсипҳои мо риоя мекунад ахлоқи таҳрирӣ. Барои гузориш додани хато клик кунед ин ҷо.

10 шарҳ, аз они шумо

Назари худро бинависед

Суроғаи почтаи электронии шумо нест, нашр карда мешавад.

*

*

  1. Масъул барои маълумот: Мигел Анхел Гатан
  2. Мақсади маълумот: Назорати СПАМ, идоракунии шарҳҳо.
  3. Қонунӣ: Розигии шумо
  4. Иртиботи маълумот: Маълумот ба шахсони сеюм расонида намешавад, ба истиснои ӯҳдадориҳои қонунӣ.
  5. Нигоҳдории маълумот: Пойгоҳи додаҳо аз ҷониби Occentus Networks (ИА) ҷойгир карда шудааст
  6. Ҳуқуқҳо: Ҳар лаҳза шумо метавонед маълумоти худро маҳдуд, барқарор ва нест кунед.

  1.   Гилле Диго

    Оё шумо функсияҳои гирифтани калидҳоро бидуни қатъ кардани иҷро надоред? Барои коре бо ҳаракате, ки барои кӯдакони 9-сола ҷолибтар аст, гарчанде ки бозии овезон низ метавонад барои барнома шавқовар бошад.

    Коркарди чизе_digo
    a <-1;
    паҳлуӣ <-30;
    поён <-5;
    Дар ҳоле ки a = 1 Do
    Тоза кардани экран;
    c <-1;
    сатри <- "";
    Такрор кунед
    сатри <-хат + "";
    c <-c + 1;
    То в = паҳлуӣ
    хати <-хат + "X";
    c <-1;
    Такрор кунед
    Навиштан " ";
    c <-c + 1;
    То в = поён-1
    Хат нависед;
    Такрор кунед
    Навиштан " ";
    в 2 Пас
    поён <-паён-1;
    Ҳа бале
    "s":
    Агар дар зери <15 Баъд
    поён 2 Пас
    паҳлуӣ <-паҳлӯ-1;
    Ҳа бале
    "d":
    Агар паҳлуӣ <50 Баъд
    паҳлуӣ <-паҳлӯ + 1;
    Ҳа бале
    "0":
    a <-2;
    Анҷоми сония
    Дар ҳоле ки хотима меёбад
    Раванди хотимавӣ

  2.   Гилле Диго

    Хуб, агар ба боло бароед, сатрҳои 23 ва 28 -ро беҳтар кунед
    -23 То в = 15
    +23 То в = 18
    y
    -28 Агар поён> 2 Пас
    +28 Агар поён> 3 Пас

    1.    хнм Диго

      Ташаккур барои саҳм, аммо он баъзе мушкилот дорад, ба монанди он ки шумо як ҷумларо дар дохили дигар мекушоед, аммо он бояд дар дохили ҷумлае оғоз шавад, ки гуфтан мумкин аст

      Коркарди чизе
      а <- 0;
      хондан ба;
      агар a ба 25 баробар набошад
      дар ҳоле ки a ба 0 кардан баробар нест
      хондан ба;
      Ҳа бале
      дар ҳоле анҷом меёбад

      вақте ки шумо давраро мебинед, дар дохили изҳороти "if then" сар мешавад, аммо берун аз он ба поён мерасад, чизе монанди ин ғайриимкон аст.

      Ман ҳоло ҳам саҳмро қадр мекунам
      Раванди хотимавӣ

      1.    Гилле Диго

        Ташаккур, аммо ман фикр мекунам, ки ин ҷо гузоштани код бештар аз мушкилот аст, зеро ман намедонам чӣ гуна онро дар навъи рамз ҷойгир кунам ва он бидуни дохилшавӣ мебарояд.

        Барнома хуб кор мекунад. Тағирёбандаи "а" -ро ман барои баромадан аз ҳалқа истифода мекунам, вақте ки корбар сифрро менависад. Шумо метавонед баромад () ё танаффус гузоред; дар шартӣ ба он менигарад ва ман тағирёбандаро сабт мекунам. Онҳо имконот мебошанд.

        Ташаккур.

      2.    Гилле Диго

        Ман кӯшиш мекунам ҷадвалбандиҳоро барои ҷойҳо ва барчаспҳо иваз кунам por si funciona algo:

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      3.    Гилле Диго

        Ин пур аз хатогиҳои воридотӣ аз кодекси ман аст, ман бори дигар бо ҷадвалбандиҳо кӯшиш мекунам:
        Ин файли algo.psc хоҳад буд

        Proceso algo_digo
        a<-1;
        lateral<-30;
        abajo<-5;
        Mientras a=1 Hacer
        Borrar Pantalla;
        c<-1;
        linea<-"";
        Repetir
        linea<-linea+" ";
        c<-c+1;
        Hasta Que c=lateral
        linea<-linea+"X";
        c<-1;
        Repetir
        Escribir " ";
        c<-c+1;
        Hasta Que c=abajo-1
        Escribir linea;
        Repetir
        Escribir " ";
        c 3 Entonces
        abajo<-abajo-1;
        Fin Si
        "s":
        Si abajo < 15 Entonces
        abajo 2 Entonces
        lateral<-lateral-1;
        Fin Si
        "d":
        Si lateral < 50 Entonces
        lateral<-lateral+1;
        Fin Si
        "0":
        a<-2;
        Fin Segun
        Fin Mientras
        FinProceso

      4.    Гилле Диго

        Ҷолиб аст, ки тавзеҳ бо нишони рамзӣ хӯрда, нест карда мешавад, ҳар чӣ дар байни он бошад, масалан байни сатрҳо
        Такрор кунед
        Навиштан " ";
        c
        пас аз в вуҷуд дорад а
        ва он гоҳ бо 3 Баъд идома меёбад
        поён
        Умуман, ин мувофиқи кадом рамзҳо гузоштан боэътимод нест.

  3.   Гилле Диго

    Ман нишонаҳоро аз таъин кардан ба = иваз мекунам, то бубинам, ки чӣ гуна аст.

    Proceso algo_digo
    a=1;
    lateral=30;
    abajo=5;
    Mientras a=1 Hacer
    Borrar Pantalla;
    c=1;
    linea="";
    Repetir
    linea=linea+" ";
    c=c+1;
    Hasta Que c=lateral
    linea=linea+"X";
    c=1;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=abajo-1
    Escribir linea;
    Repetir
    Escribir " ";
    c=c+1;
    Hasta Que c=18
    Escribir "Dibujo una X (w,a,s,d y 0 para salir)";
    Leer mueve;
    Segun mueve Hacer
    "w":
    Si abajo > 3 Entonces
    abajo=abajo-1;
    Fin Si
    "s":
    Si abajo 2 Entonces
    lateral=lateral-1;
    Fin Si
    "d":
    Si lateral < 50 Entonces
    lateral=lateral+1;
    Fin Si
    "0":
    a=2;
    Fin Segun
    Fin Mientras
    FinProceso

    1.    Гилле Диго

      Он як қисми рамзро мехӯрад, теги рамз ноком мешавад, ва он бояд навиштаҷотро ҳамон тавре тарк кунад.

      1.    хнм Диго

        Салом пушаймонам, ки шумо пештар ҷавоб надидаед, аммо хуб
        азбаски шумо рамзро хуб нашр карда наметавонед, зеро онро ба воситаи почта ба ман намефиристед, то ин қадар гардиш ба ин масъала надиҳед.

bool (ҳақиқӣ)