DEBIAN 10: What extra packages are useful after installing?

DEBIAN 10: What extra packages are useful after installing?

DEBIAN 10: What extra packages are useful after installing?

This article is the continuation (second part) of the Tutorials dedicated to DEBIAN GNU / Linux Distro, version 10 (Buster), which serves as the basis for many others such as MX-Linux 19 (Ugly Duckling).

This second part we will show that other extra or additional packages (applications) are recomendados to follow optimizing (complementing) our beautiful and great Distros DEBIAN 10 and MX-Linux 19.

Update and optimize MX-Linux 19.0 and DEBIAN 10.2 after installing

Update and optimize MX-Linux 19.0 and DEBIAN 10.2 after installing

Since, the first part of this tutorial series, called "Update and optimize MX-Linux 19.0 and DEBIAN 10.2 after installing" was focused on essential basic actions and packages necessary for a first update, customization and optimization of them, that is, the first post-installation steps once installed.

And citing the previous article, remember the following:

"Remember that the actions and packages recommended here to run and install are just that, "packages recomendados", and it is up to each one to execute and install all or some of them, why are they necessary or useful, in the short or medium term, to know and use them, by having them already run or installed.

And keep in mind that these actions and / or packages were previously tested on both Distros, and do not ask to uninstall packages installed by default in these. Further, they do not increase the consumption of memory or CPU since, they do not load processes or daemons (services) in memory by default. To know in advance what each package is used for, click here!."

Debian 10 Buster

DEBIAN 10: Useful extra packages to install

Native Games Applications

apt install games-adventure games-arcade games-board games-card games-chess games-console games-education games-emulator games-fps games-java-dev games-mud games-platform games-programming games-puzzle games-racing games-rogue games-rpg games-shootemup games-simulation games-sport games-strategy games-tasks games-toys games-typing

Objective: Install specific game packages by defined categories

apt install atari800 cen64 cen64-qt desmume dolphin-emu dosbox fs-uae fs-uae-arcade fs-uae-launcher fs-uae-netplay-server games-emulator gbsplay gngb gnome-nds-thumbnailer hatari higan mame mame-data mame-extra mame-tools mednafen mednaffe mess-desktop-entries mgba-common mgba-qt mgba-sdl mupen64plus-audio-all mupen64plus-data mupen64plus-input-all mupen64plus-qt mupen64plus-rsp-all mupen64plus-rsp-hle mupen64plus-rsp-z64 mupen64plus-ui-console mupen64plus-video-all mupen64plus-video-arachnoid mupen64plus-video-glide64 mupen64plus-video-glide64mk2 mupen64plus-video-rice mupen64plus-video-z64 nestopia osmose-emulator pcsxr stella vice virtualjaguar visualboyadvance xmms2-plugin-gme yabause yabause-common yabause-gtk yabause-qt yakuake

Objective: Install retro console emulators.

Video support

apt install xserver-xorg-video-all libva-drm2 libva-glx2 libva-wayland2 libva-x11-2 libva2

Objective: Install basic video driver support, usually built-in.

Audio support

apt install alsa-firmware-loaders alsa-oss alsa-tools alsa-utils alsamixergui volumeicon-alsa paprefs pavumeter pulseaudio-utils ffmpeg2theora sound-icons

apt install lame libdvdnav4 libdvdread4 libfaac0 libmad0 libmp3lame0 libquicktime2 libstdc++5 libxvidcore4 twolame vorbis-tools x264

apt install gstreamer1.0-x gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-alsa gstreamer1.0-pulseaudio gstreamer1.0-tools

Objective: Install the basic support of audio drivers, usually integrated. And other applications, accessories and libraries necessary for the management of audio and sound on computers.

Support for printing and scanning devices

apt install cups cups-client cups-bsd cups-filters cups-pdf cups-ppdc

apt install foomatic-db-compressed-ppds foomatic-db-engine ghostscript-x ghostscript-cups gocr-tk gutenprint-locales hannah-foo2zjs hpijs-ppds hplip openprinting-ppds printer-driver-all printer-driver-cups-pdf printer-driver-foo2zjs printer-driver-hpcups printer-driver-hpijs

apt install avahi-utils colord flex g++ libtool python-dev sane sane-utils system-config-printer system-config-printer-udev unpaper xsane xsltproc zlibc

Objective: Install the basic support of drivers, applications, add-ons and libraries necessary for managing printing and scanning devices.

Support for office applications

apt install fonts-arabeyes fonts-cantarell fonts-freefarsi fonts-liberation fonts-lyx fonts-mathjax fonts-oflb-asana-math fonts-opensymbol fonts-sil-gentium fonts-stix myspell-es ooo-thumbnailer xfonts-intl-arabic xfonts-intl-asian xfonts-intl-chinese xfonts-intl-chinese-big xfonts-intl-european xfonts-intl-japanese xfonts-intl-japanese-big ttf-bitstream-vera ttf-dejavu ttf-summersby

apt install libreoffice libreoffice-base libreoffice-gnome libreoffice-gtk3 libreoffice-help-es libreoffice-java-common libreoffice-l10n-es libreoffice-ogltrans libreoffice-pdfimport libreoffice-report-builder-bin libreoffice-style-breeze libreoffice-style-elementary libreoffice-style-sifr

apt install pdfarranger pdfshuffler pdftk

Objective: Install basic support for office applications, add-ons and fonts.

Support for Windows HW and SW compatibility

apt install cifs-utils disk-manager dosfstools exfat-fuse exfat-utils fuse gvfs-fuse hfsplus hfsutils icoutils ideviceinstaller ipheth-utils libsmbclient mtools mtp-tools ntfs-3g python-smbc smbclient samba-common smbnetfs samba samba-common-bin

apt install cabextract fonts-wine mscompress playonlinux q4wine ttf-mscorefonts-installer winetricks

apt install ndiswrapper

Objective: Install basic support for compatibility with the HW and SW of other Operating Systems, mainly MS Windows.

Support for Computer HW

apt install acpi acpitool acpi-support fancontrol firmware-linux-free hardinfo hwdata hwinfo irqbalance iucode-tool laptop-detect lm-sensors lshw lsscsi smartmontools xsensors

Objective: Install the basic support for compatibility with the generic HW of computers.

apt install intel-microcode

apt install amd64-microcode

Objective: Install basic CPU instruction set support for compatibility with Intel and AMD processors.

sensors-detect
chmod u+s /usr/sbin/hddtemp
hddtemp /dev/sda

Objective: Install the basic support of tools and drivers for the management of temperatures, voltage of the elements of the computer, including the management of the fans.

Support for wireless connection devices

apt install wifi-radar wireless-tools wpagui wpasupplicant

Objective: Install basic application support for managing wireless devices on a computer.

apt install firmware-atheros

apt install firmware-b43-installer firmware-b43legacy-installer firmware-bnx2 firmware-bnx2x firmware-brcm80211

apt install firmware-intelwimax firmware-iwlwifi

apt install firmware-ralink firmware-realtek

Objective: Install basic driver support for managing wireless devices (WiFi) on a computer.

Support for bluetooth connection devices

apt install bluetooth bluez bluez-cups bluez-firmware bluez-tools btscanner gnome-bluetooth python-bluez pulseaudio-module-bluetooth

Objective: Install the basic driver support for the management of wireless connection devices (bluetooth) of a computer.

Support for USB internet connection devices

apt install mobile-broadband-provider-info ppp pppconfig modemmanager modem-manager-gui modem-manager-gui-help usb-modeswitch usb-modeswitch-data wvdial

Objective: Install basic application and driver support for managing USB Internet connection devices connected to a computer.

Support for mobile multimedia devices

apt install gammu gtkpod libgammu-i18n libgpod-common libgpod-cil libgpod4 libmtp-runtime mtp-tools wammu

Objective: Install the basic support of applications and libraries for the management of multimedia devices connected to a computer.

Debian 10

Conclusion

We hope that this "useful little post" about what extra applications can be installed on GNU / Linux Distros «DEBIAN y MX-Linux», in its most recent and current versions for the year 2020, to achieve «actualizarlas y optimizarlas», is of great interest and utility, for the entire «Comunidad de Software Libre y Código Abierto» and of great contribution to the diffusion of the wonderful, gigantic and growing ecosystem of applications of and for «GNU/Linux».

And for more information, always do not hesitate to visit any Online library as OpenLibra y JedIT to read books (PDFs) on this topic or others knowledge areas. For now, if you liked this «publicación», don't stop sharing it with others, in your Favorite websites, channels, groups, or communities of social networks, preferably free and open as Mastodon, or secure and private like Telegram.

Or simply visit our home page at FromLinux or join the official Channel Telegram from DesdeLinux to read and vote for this or other interesting publications on «Software Libre», «Código Abierto», «GNU/Linux» and other topics related to «Informática y la Computación», And the «Actualidad tecnológica».


The content of the article adheres to our principles of editorial ethics. To report an error click here!.

10 comments, leave yours

Leave a Comment

Your email address will not be published. Required fields are marked with *

*

*

  1. Responsible for the data: Miguel Ángel Gatón
  2. Purpose of the data: Control SPAM, comment management.
  3. Legitimation: Your consent
  4. Communication of the data: The data will not be communicated to third parties except by legal obligation.
  5. Data storage: Database hosted by Occentus Networks (EU)
  6. Rights: At any time you can limit, recover and delete your information.

  1.   Alberto Guerra said

    The pdftk has been very useful for me to concatenate several pdf files in a single document through the command line.
    Example:
    pdftk file_0001.pdf file_0002.pdf file_0003.pdf cat output file_123.pdf

    1.    Linux Post Install said

      Thanks Alberto. For your contribution. I included it in the Support for office applications section of the article, since I realized that I did not put applications (packages) for advanced management of PDF files.

      Insert this line: apt install pdfarranger pdfshuffler pdftk

      The other 2 are for the same but from the graphical user interface (GUI).

  2.   Fran said

    Thanks is a very important contribution for many of us who just want to start in the Debian world

    1.    Linux Post Install said

      Greetings, Fran! Thank you for your positive comment on the article.

  3.   RubenMTL said

    Hello!. Thank you very much for this post, it was very useful to me since I just switched to Debian 10, plasma KDE. I installed the vast majority without problems. although now I detail the problems I had with some that were not installed.
    With the alsa-firmware-loaders package I got:

    E: The alsa-firmware-loaders package could not be located

    And the same happened with these other packages: libfaac0, amd64-microcode, firmware-atheros, firmware-b43-installer, firmware-b43legacy-installer, firmware-bnx2, firmware-bnx2x, firmware-brcm80211, firmware-intelwimax, firmware- iwlwifi, firmware-ralink, firmware-realtek, bluez-firmware.

    1.    Linux Post Install said

      Greetings RubenMTL! Thank you for your comment and observation. I will try to install a DEBIAN 10.3 very soon to retest each package and revalidate each currently existing package.

      1.    RubenMTL said

        You're welcome!. Great !!. Thanks to you for your time, greetings. !!

  4.   RubenMTL said

    Another poster that came out was with the hannah-foo2zjs package:

    The hannah-foo2zjs package is not available, but some other package references it. This may mean that the package is missing, out of date, or only available from some other source.

    E: The hannah-foo2zjs package has no candidate for installation.

    This also comes out with the packages: ttf-mscorefonts-installer, winetricks, playonlinux, iucode-tool

    Finally, when I wanted to restart from the terminal, I was ticked and I had to turn off the notebook from the power button, because it did not respond. And once started the program returned I tried to restart it this time from the desktop and it is also checked ... so again I have to do it from the button on the notebook. At no time can I restart or shut down from the desktop, I have to do it if or if pressing the button.

    I hope you can help me solve these problems, thanks for your time, greetings!

    1.    Linux Post Install said

      Greetings RubenMTL! I couldn't tell you exactly. Something must have changed related to energy management (ACPI). 🙁

      1.    RubenMTL said

        No drama, thanks anyway for the help! Cheers!!