Si të instaloni AceStream në Linux dhe të mos vdisni duke provuar

Ata prej nesh që e duan sportin dhe nuk kanë qasje në të gjitha kanalet aktuale sportive, në përgjithësi përballen me problemin që për ta shijuar atë duhet të përdorim faqe të ndryshme që transmetojnë ndeshje në internet, shumica e tyre kërkojnë instaloni AceStream, i cili tenton të jetë pak kompleks për tu instaluar në Linux.

Në këtë udhëzues do të mësojmë se si instaloni AceStream në Linux pa vdekur në përpjekje, duke u dhënë zgjidhje problemeve më të zakonshme sot. Përdorimi i tij dhe përmbajtja në të cilën keni qasje janë përgjegjësia juaj totale.

Çfarë është AceStream?

AceStream është një platformë multimediale mjaft inovative, e cila e ka çuar riprodhimin e audiovizualëve në Internet në një nivel më të lartë. Për ta bërë këtë, ai ka implementuar një menaxher universal për ngarkimin e skedarëve multimedial, i cili përdor teknologjitë më të përparuara P2P, duke garantuar një proces efikas të ruajtjes dhe transmetimit të të dhënave.

Softueri Ace Stream na ofron një sërë përfitimesh në të cilat mund të nxjerrim në pah:

  • Mundësia e shikimit të transmetimeve në internet (TV, transmetime të personalizuara, filma, karikatura, etj.), Me cilësi të lartë audio dhe imazhi.
  • Dëgjoni muzikë në internet në një format që nuk humbet asnjë cilësi.
  • Shikoni torrentet në internet, nuk ka nevojë të prisni që ai të shkarkohet plotësisht.
  • Shikoni përmbajtje në pajisjet e largëta (Apple TV, Chromecast, etj.) Mbi protokollet e komunikimit si AirPlay, Google Cast dhe të tjerët.
  • Lejon integrimin me aplikacione të ndryshme. Instaloni AceStream në Linux

Si të instaloni AceStream në Linux

Për të instaluar AceStream në Linux duhet të ndjekim hapa të ndryshëm në varësi të distro-së që përdorni, ne do të përqendrohemi në Arch Linux dhe Ubuntu, por shpresojmë që në të ardhmen të jemi në gjendje ta instalojmë atë në distro të tjera.

Instaloni AceStream në Arch Linux dhe derivatet e tij

Arsyeja kryesore që kam bërë këtë artikull është sepse shumë kanë pasur probleme në instalimin e AceStream në Arch Linux, Antergos, Manjaros dhe derivatet, shkaku kryesor është që pkgbuild i shtojcës shtojca acestream-mozilla Jep një gabim gjatë instalimit, zgjidhja është jashtëzakonisht e thjeshtë.

Ne do të instalojmë shtojca acestream-mozilla i cili gjithashtu do të na instalojë motori i rrymës y të dhënat e lojtarit të rrymës cilat janë paketat e nevojshme për të riprodhuar AceStream nga firefox.

Para së gjithash ne duhet të hapim një terminal dhe të ekzekutojmë komandën e mëposhtme:
gpg --keyserver pgp.mit.edu --recv-keys FCF986EA15E6E293A5644F10B4322F04D67658D8

Do të rregullojë problemin e verifikimit që parandalon instalimin e varësisë që është e nevojshme për t'u instaluar shtojca acestream-mozilla.

Pastaj ekzekutojmë komandën e mëposhtme

yaourt -S acestream-mozilla-plugin

Në raste të përsëritura do të pyetemi nëse duam të instalojmë varësi të ndryshme, duhet t'u themi po të gjithëve.

Instaloni AceStream në Ubuntu dhe derivatet

Instaloni AceStream në Ubuntu 14.04 dhe derivatet

Për përdoruesit e ubuntu dhe derivateve deri në versionin 14.04, instalimi i AceStream do të jetë mjaft i thjeshtë, ata vetëm duhet të ekzekutojnë komandat e mëposhtme nga terminali:

echo 'deb http://repo.acestream.org/ubuntu/ kryesore e besueshme' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get instalo akestream-plotë

Instaloni AceStream në Ubuntu 16.04 dhe derivatet

Ata që do të duhet të luftojnë pak më shumë janë përdoruesit e Ubuntu 16.04 dhe derivateve pasi acestream nuk ka mbështetje për këtë version, por falë këtij artikull, Arrita ta instaloj.

Gjëja e parë që do të bëjmë është të shkarkojmë dhe instalojmë disa varësi që nuk do të jeni në gjendje t'i shkarkoni nga depot zyrtare, sigurohuni që të instaloni ato të përshtatshme për arkitekturën e distroit tuaj:

Arkitektura 64bit:

  1. Shkarkoni dhe instaloni libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb mund ta bëni nga lidhja e mëposhtme: http://launchpadlibrarian.net/216005292/libgnutls-deb0-28_3.3.15-5ubuntu2_amd64.deb
  2. Shkarkoni dhe instaloni në rendin në të cilin paraqiten varësitë e mëposhtme:  acestream-player-compat_3.0.2-1.1_amd64.deb; acestream-engine_3.0.3-0.2_amd64.deb; acestream-player-data_3.0.2-1.1_amd64.deb; acestream-player_3.0.2-1.1_amd64.deb Secilin mund ta shkarkoni nga lidhja vijuese: https://drive.google.com/folderview?id= … e_web#list

Arkitektura 32bit:

  1. Shkarkoni dhe instaloni libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb mund ta bëni nga lidhja e mëposhtme: http://launchpadlibrarian.net/216005191/libgnutls-deb0-28_3.3.15-5ubuntu2_i386.deb
  2. Shkarkoni dhe instaloni në rendin në të cilin paraqiten varësitë e mëposhtme: acestream-player-compat_3.0.2-1.1_i386.deb; acestream-engine_3.0.3-0.2_i386.deb; acestream-player-data_3.0.2-1.1_i386.deb; acestream-player_3.0.2-1.1_i386.deb Secilin mund ta shkarkoni nga lidhja vijuese: https://drive.google.com/folderview?id= … e_web#list

Tjetra duhet të vazhdojmë me instalimin e zakonshëm të AceStream siç bëmë për versionin 14.04, të hapim një terminal dhe të ekzekutojmë:

echo 'deb http://repo.acestream.org/ubuntu/ kryesore e besueshme' | sudo tee /etc/apt/sources.list.d/acestream.list sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add - sudo apt-get update sudo apt-get instalo akestream-plotë

Në disa raste është e nevojshme të filloni shërbimin acestream-engine.service, për këtë ne ekzekutojmë komandat e mëposhtme nga terminali:

systemctl start acestream-motor.service systemctl mundëson acestream-motor.service

Me këtë manual, shpresojmë të mund të shijoni këtë protokoll të shkëlqyeshëm të transmetimit multimedial që përdor të gjithë kapacitetin e teknologjisë P2P.


41 komente, lini tuajën

Lini komentin tuaj

Adresa juaj e emailit nuk do të publikohet. Fusha e kërkuar janë shënuar me *

*

*

  1. Përgjegjës për të dhënat: Miguel Ángel Gatón
  2. Qëllimi i të dhënave: Kontrolloni SPAM, menaxhimin e komenteve.
  3. Legjitimimi: Pëlqimi juaj
  4. Komunikimi i të dhënave: Të dhënat nuk do t'u komunikohen palëve të treta përveç me detyrim ligjor.
  5. Ruajtja e të dhënave: Baza e të dhënave e organizuar nga Occentus Networks (BE)
  6. Të drejtat: Në çdo kohë mund të kufizoni, rikuperoni dhe fshini informacionin tuaj.

  1.   Julio Cesar Campos dijo

    Epo postimi, por të paktën në archlinux dhe ky ishte rasti im që ju nevojitet: "systemctl start acestream-engine.service" dhe "systemctl mundësojnë acestream-engine.service" që ajo të funksionojë.

    1.    hardhucë dijo

      Po e provonit nga firefox, apo po përdorni një shfletues tjetër?

  2.   PërdoruesDebian dijo

    A di dikush se si ta shtyjë atë të punojë në Debian 9?

  3.   Julio Cesar Campos dijo

    Firefox në archlinux

  4.   gecoxx dijo

    Nuk e di nëse është botuar komenti im i mëparshëm ... E përsëris! Duhet që unë nuk e di se sa orë ekzekuton komandën e dreq në terminal, dhe që unë vendos -noconfirm, dhe në fund të fundit nuk funksionon !!
    një postim tjetër që është i padobishëm!

    përpjekje për instalim në Manjaro

    1.    hardhucë dijo

      I dashur që nuk funksionoi për ju, funksionoi në mënyrë perfekte për mua, gjithsesi provoni të ekzekutoni këto 2 komanda:
      "Systemctl start acestream-engine.service" dhe "systemctl mundëson acestream-engine.service"

  5.   José dijo

    mirë

    Kam arritur të bëj të gjitha hapat pa ndonjë problem. Por kur përpiqesha të filloja shërbimin nga terminali më dha dy dështime;
    systemctl start acestream-motor.shërbim
    Dështoi të nisë motorin e rrymës. Shërbimi: Shërbimi i motorit të rrymës nuk u gjet.
    systemctl mundëson motorin e rrymës.servis
    Ekzekutimi i funksionimit dështoi: Asnjë skedar apo direktori e tillë

    1.    Gustavo dijo

      E njëjta gjë e saktë më ndodhi mua. terminali më kthen ato komanda me ato dështime.

  6.   John M dijo

    Faleminderit shumë për postimin! Nëse përdorni Ubuntu 16.10 64 bit nuk do të jeni në gjendje të instaloni "acestream-player-data_3.0.2-1.1_amd64.deb". Ata së pari duhet të shkarkojnë dhe instalojnë këto paketa:

    libavcodec-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    liblivemedia50_2016.02.09-1_amd64.deb
    libswresample-ffmpeg1_2.8.6-1ubuntu2_amd64.deb
    libavformat-ffmpeg56_2.8.6-1ubuntu2_amd64.deb
    libpng12-0_1.2.54-1ubuntu1_amd64.deb
    libswscale-ffmpeg3_2.8.6-1ubuntu2_amd64.deb
    libavutil-ffmpeg54_2.8.6-1ubuntu2_amd64.deb
    libpostproc-ffmpeg53_2.8.6-1ubuntu2_amd64.deb
    libwebp5_0.4.4-1.1_amd64.deb

    Ndoshta nevojitet një varësi tjetër që është në repos.
    Përshëndetje!

  7.   Miles dijo

    Të mirë.
    Shtojca acestream-mozilla ka ndaluar së punuari në Firefox 52, si shumë shtojca të tjera NPAPI.

  8.   darko dijo

    Një tjetër mundësi shumë e mirë dhe e thjeshtë është të përdorni docker dhe të bëheni agnostik i sistemit tuaj operativ. Duke përdorur aceproksinë, mund ta riprodhoni atë-

    Unë kam shkruar një mësim të vogël dhe një skenar, për të lehtësuar ekzekutimin.
    https://gist.github.com/alex-left/7967dac44f2d2e31eabba2fae318a402

  9.   David Martin dijo

    Në pjesën e instalimit të tij nga Ubuntu 16.04, kur thoni shkarkoni dhe instaloni ato skedarë, si i instaloni ato? Kur i shkarkoj dhe i nxjerr, disa janë vetëm një skedar libreoffice dhe të tjerët, nuk di si t'i "instaloj" ato.
    Faleminderit paraprakisht dhe përshëndetje.
    David.

  10.   Uau dijo

    Ose çelësat nuk punojnë përsëri, ose ka ndonjë gabim në pako, por në arch dhe manjaro është e pamundur ta instaloni.
    Kur përpiqeni të instaloni një varësi (qwebquit) ose diçka të tillë ajo kalon në një lak dhe nuk ka asnjë mënyrë.
    A e ka gjetur dikush zgjidhjen?
    Falënderim

    1.    Alexander dijo

      Përshëndetje, për instalimin në arch linux duhet të bëni sa më poshtë:
      -Instaloni paketën 'acestream-launcher' nga yaourt me 'yaourt -S acestream-launcher' (paketa që do të mundësojmë më poshtë shkarkohet automatikisht tek ju)
      -Enable acestream-motor.service, ne hyjmë në terminal dhe në mënyrën ROOT vendosim sa vijon
      -systemctl start acestream-motor.shërbim
      -systemctl mundëson acestream-motor.service
      Unë rifillova kompjuterin pas kësaj, nuk e di nëse do të jetë e nevojshme, por për çdo rast
      -Kjo duhet të jetë e mjaftueshme, por në azhurnimet e fundit të Arch ata kanë kapur diçka dhe nuk funksionon, kështu që ata kanë kërkuar një zgjidhje të përkohshme, e cila është të shkarkoni një skedar, është si vijon:
      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz
      Fuente: https://aur.archlinux.org/packages/acestream-launcher/ (mbi komentet)
      pasi të shkarkohen, ne shkojmë në terminal dhe shkojmë në dosjen ku e kemi shkarkuar,
      Ne vazhdojmë ta instalojmë me 'sudo pacman -U python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz' dhe kaq, duhet të shkojë, hera e parë që nuk shkon kurrë, kështu që klikoj për herë të dytë, herën e parë gjithmonë jep gabim, kjo është e gjitha

      PS: sqaroni se sudo pacman -U dhe jo -S sepse është një paketë lokale e marrë nga makepkg

      1.    Uau dijo

        Ju faleminderit shumë për interesin tuaj.
        Unë kam provuar kaq shumë herë saqë tashmë i njoh varësitë dhe komentet e paketave në instalim me zemrën tënde. Unë do të ndjek këshillat tuaja me lëshuesin dhe të shoh nëse jam me fat. Unë do të ju them.
        Unë përsëris falënderimet e mia

        Felipe

        1.    Uau dijo

          Në një mënyrë apo në një tjetër nuk funksionon. Kam provuar me lidhjen qe vendosni ne komente, por nuk e zgjidh, njeh lidhjen, me jep mundesine te zgjedh programin, zgjedh akestream-launcher por VLC nuk hapet.
          Në tastierë më jep përgjigjen vijuese.

          Skedari «/usr/lib/python3.6/site-packages/psutil/INIT.py », rreshti 1231, në _dërgo_shenjë
          os.kill (vetë. pid, sig)

          Do të duhet të presim për azhurnime të reja.
          Faleminderit për ndihmën tuaj.

  11.   Uau dijo

    Pas azhurnimit të ri, përgjigjja në tastierë është si më poshtë.

    acestream-launcher acestream://0cec6c0299c99f45c1859398d150c3a48e6d8b2e
    Aktivizimi i motorit në rrymë.
    2017-07-28 18: 16: 59,615 | MainThread | acestream | gabim gjatë fillimit
    Gjurmimi (thirrja më e fundit e fundit):
    Dosja «core.c», rreshti 1590, në
    Dosja «core.c», rreshti 144, në
    Dosja «core.c», rreshti 2, në
    ImportError: nuk mund të importojë emrin __m2crypto
    Gabim gjatë vërtetimit në Acestream!
    Media Player nuk po ekzekutohet ...

    Ne jemi duke u përmirësuar, tani ajo njeh rrjedhën e hollësishme, por libcrypto vazhdon të luftojë.

    1.    Uau dijo

      Unë kam provuar të instaloj paketën që ju rekomandoni në lidhjen që më keni dërguar.

      - https://archive.archlinux.org/packages/p/python2-m2crypto/python2-m2crypto-0.23.0-2-x86_64.pkg.tar.xz

      Dhe rregullon në mënyrë efektive problemin, hapet vlc dhe punon Acestream.
      Ju falënderoj shumë për ndihmën tuaj-

      1.    Alexander dijo

        Përshëndetje, më falni për vonesën, ishte shumë e çuditshme që nuk funksionoi për ju kur bëri, unë jam në Arch plasma, jam i kënaqur që ju ka ndihmuar, për këtë jemi

        Në shpërndarjen tjetër që unë kam, e cila është Fedora, ajo që unë kam është Wine emuting rrjedhë për windows xD, në rast se shkoni në një distro tjetër ose vetë Arch, ajo që më habit është se as në Debian nuk i kanë këto pako ...

      2.    prodhues i ëmbëlsirave01 dijo

        Përshëndetje dhe skedari është se si është instaluar Unë jam ende një newbie, një përshëndetje

        1.    Uau dijo

          sudo pacman -U python2-m2kript-0.23.0-2-x86_64.pkg.tar.xz

          Ai e vë atë në komentin e mësipërm

  12.   kimabet dijo

    Dje e instalova atë si një paketë të parakohshme në Kde Neon 5.8 dhe u habita nga sa e thjeshtë dhe e shpejtë funksionoi për mua. Do të ishte mirë nëse azhurnoni artikullin sepse nuk ka krahasim, procesi është shumë i thjeshtë.

    sudo apt install snapd → instalo sistemin e menaxhimit të paketës snap (nëse nuk e ke të instaluar)
    snap find acestream → për të kontrolluar që e kemi programin në depo (të gjithë derivatet e ubuntu duhet ta kenë)
    sudo snap instalo akestreamplayer

    të fala

    1.    Antonio Manzano dijo

      Ke te drejte. Sapo e instalova në kubuntu 17.10, pasi metoda që shfaqet këtu është plotësisht e parealizueshme. Faleminderit shumë

      1.    Babi dijo

        nuk është e vlefshme për arkitekturën i386

    2.    sie9k dijo

      Ka qenë mënyra e vetme për ta instaluar atë në Lubuntu 16.04.4, por nuk ka asnjë mënyrë që unë të ruaj skedarin konfigurues dhe më duhet të konfiguroj një parametër për të punuar së bashku me Serviio. Ndonjë ide për ta rregulluar?

  13.   José Antonio dijo

    Postim shumë i mirë. Një faqe në internet që duhet të lexohet për të sapoardhurit në Linux.

  14.   peter rishtar dijo

    Si do ta instalonit për AntiX 16 (është një shpërndarje linux)?

    Unë kam provuar si Arch Linux dhe derivatet, por jam një fillestar i ri, duhet ta kuptoj gabim

  15.   Alexander dijo

    Përshëndetje, me paketat sna, të cilat kolegu i mësipërm i komenton në një koment është bërë më e lehtë jo vetëm për këto shpërndarje por për shumë. Shpërndarjet e përputhshme me këto paketa janë këtu:
    https://snapcraft.io/

    Në Debian do të ishte si më poshtë:
    -sudo apt instalo snapd
    -Sudo snap install the core
    -sudo snap install akestreamplayer
    Në Arch dhe derivatet:
    -sudo pacman -S këput
    -sudo systemctl mundëson - tani snapd.socket
    -sudo snap install akestreamplayer

    Në Arch (plazma) unë duhej të rinisja në mënyrë që të shfaqen paketat e instaluara, nëse nuk shfaqet, ju tashmë dini se çfarë të bëni.

    Në ubuntu dhe derivatet mendoj se do të jetë si partneri që e instaloi atë më lart në komentet me KDE neon.

    Curshtë kurioze që në Gnome me Debian duket mjaft e shëmtuar dhe nuk integrohet mirë me GTK por në Arch plasma integrohet mjaft mirë, e rëndësishme është që ajo të shihet jashtë estetikës.

    1.    william dijo

      ju instalon kjo motor i rrymës?
      Jo une

      1.    Alexander dijo

        Përshëndetje, jo, nuk e instalon atë, dhe as nuk ka nevojë për të, me paketat e parakohshme të gjitha varësitë e mbuluara tashmë vijnë, ajo duhet të punojë po ose po.

    2.    txuber dijo

      Përshëndetje Alejandro, shiko nëse mund të më ndihmosh
      [txuber @ manjaro] $ sudo systemctl mundëson - tani snapd.socket
      Aktivizimi i dështuar i njësisë: Skedari i njësisë \ xe2 \ x80 \ x93now.service nuk ekziston.
      në manjaro Manjaro XFCE Edition (17.0.4) x64

      1.    Alexander dijo

        Përshëndetje, Manjaro është se nuk është Arch i pastër dhe gjërat mund të ndryshojnë pak, ai tashmë mund të jetë i aktivizuar dhe nuk është e nevojshme ta bëjmë këtë, unë supozoj se ju tashmë keni provuar ta kaloni atë hap ...

  16.   Debian dijo

    Pasi të keni instaluar çfarë të bëni? Për shkak se ace-player nuk është i instaluar, unë nuk di se si ta bëj atë të funksionojë.
    Dikush të më ndihmojë ju lutem?

    1.    Uau dijo

      Nëse ajo që keni instaluar është lëshuesi i acestream, kur klikoni në një lidhje, akestream do t'ju pyesë me cilin aplikacion dëshironi të hapni lidhjen, ju i tregoni se me VLC, dhe ky është ai që do të bëjë funksionet e ace-player

      1.    Debian dijo

        Pershendetje Së pari, shumë faleminderit për ndihmën tuaj. Komentoj Unë kam instaluar paketën acestream snap në Debian 9 me gnome. Kur jam në arenavisión, për të cilën e dëshiroj, unë klikoj në një lidhje acestream dhe shfaqet një dritare që më jep dy mundësi, e para është motori i rrymës që nëse klikoj në këtë nuk bën asgjë dhe e dyta zgjedh një aplikacion tjetër, i jap për të zgjedhur, por aplikacionet e instaluara nuk hapen, dosja ime e shtëpisë hapet, kështu që unë nuk di se si të zgjedh vlc.

        Një përshëndetje.

        1.    Alexander dijo

          Me lansuesin e acestream nuk po shkon aspak mirë, më mirë të instalohet me paketën Snap siç e shpjegoj në komentin tim më lart.

  17.   peter rishtar dijo

    Mundohem të instaloj paketën e parakohshme, por nuk më lejon:

    sudo apt instalo snapd
    Leximi i listës së paketës ... U krye
    Krijimi i pemës së varësisë
    Leximi i informacionit të statusit ... U krye
    E: Paketa e parakohshme nuk mund të gjendej

    cfare bej une

  18.   Alf dijo

    Faleminderit shumë, është një nga programet që kam përdorur në dritare dhe doja ta kisha në linux

  19.   Oscar dijo

    Faleminderit Chemabs dhe Alejandro! E përsosur me Ubuntu 17.10
    sudo apt instalo snapd
    parakohshme gjeni rrymë
    sudo snap instalo akestreamplayer
    Dhe kjo eshte!
    Gjëja e pabesueshme është që ju të shkoni në faqen zyrtare të internetit dhe ata t'ju dërgojnë një postim në forumin e tyre nga 2014! Dhe në të cilën ata përmendin vetëm deri në Ubuntu 13.04!

  20.   Marco Barria dijo

    mirë, siç thonë ata në komentet e mëparshme funksionon perfekt me snapd në hark:

    sudo pacman -S këput
    sudo systemctl mundëson snapd.socket
    reboot
    sudo snap instalo akestreamplayer
    reboot

    dhe gati:

  21.   mchavez dijo

    pershendetje, dhe a ka ndonje menyre per te instaluar rrjedhen ace pa qene nevoja te jesh programues ... sic behet me windows